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LESSON 1
Using Pivot Tables

Topics Covered

 Analyzing data with pivot tables.

 Editing pivot tables.

 Formatting pivot tables.

 Inserting pivot charts.

 Using Slicers.

Introduction

A pivot table is an interactive table that can be used to analyze, organize, and summarize
large amounts of data. Pivot tables make it easy to rearrange data, quickly displaying it
in different ways. Pivot tables usually have four types of fields:

1. Page field (Report Filter). Use the Page field to filter data by a specific field.

2. Column field (Column Labels). Use the Column field to display a field from the
source data as column headings.

3. Row field (Row Labels). Use the Row field to display a field from the source data
as row headings.

4. Data field (Values). The Data field is the field from the source data that you want
to summarize or analyze.

In the following image, the pivot table shows the average price of homes in different towns
based on the number of bedrooms. At the top is a Page field which can be used to show
only houses with a specific number of bathrooms:
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❋

1.1. Creating Pivot Tables

 1.1.1. Preparing Your Data

Before inserting a pivot table, make sure the data you want to analyze is in an organized
table. Things to consider include:

1. Header row. Make sure your data includes a header row because the top row of
your table will serve as the field names in your pivot table.

2. No empty rows or columns. If your data includes empty rows or columns, Excel
will not treat all your data as one table.

3. No subtotals. Remove all subtotals before creating your pivot table.

 1.1.2. Inserting a Pivot Table

To insert a pivot table in Microsoft Excel:

1. Select any cell in the set of data you want to analyze.

2. On the Insert tab, in the Tables group, click the PivotTable command (and in
Excel 2007 and 2010, then select PivotTable):
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3. In the Create PivotTable dialog box, verify that Excel has selected the correct
range, select where you want the pivot table to show up (you will almost always
want to select New Worksheet), and click OK:

4. In the PivotTable Field List, which opens up on the right (left in Excel 2007/2010)
of the worksheet in which your pivot table will be located, drag and drop fields
from your data into the Report Filter (Page fields go here), Column Labels
(Column fields go here), Row Labels (Row fields go here), and Values (Data
fields go here) boxes:
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A. In the image below, fields have been dragged into the boxes as the first
step in creating the report shown at the beginning of this lesson:

5. Excel assumes you want to sum the values of the Data field (the field in the Values
box). To perform a different calculation such as Count or Average:

A. Click the field name and select Value Field Settings:
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B. Select the calculation you want to perform and click OK:

6. To change the format of the numbers in the pivot table:

A. Click the field name and select Value Field Settings:
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B. Click Number Format:

C. In the Format Cells dialog box, select the number format category, the
number of decimal places to show and whether or not to display a comma
(if applicable), and then click OK:
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D. In the Value Field Settings dialog box, click OK:

❋

1.2. Inserting Slicers

Slicers make it really easy to filter data in a pivot table. Adding a Slicer is similar to adding
a second Page field (Report Filter), but it’s even easier to use.
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To add a Slicer to a pivot table:

1. Select any cell in the pivot table.

2. On the PivotTable Tools Analyze tab (PivotTable Tools Options tab in Excel
2007/2010), in the Filter group (Sort & Filter group in Excel 2007/2010), click the
Insert Slicer command (and then select Insert Slicer in Excel 2007/2010):

3. In the Insert Slicers dialog box, check the field or fields (Yes, you can create
multiple slicers at once!) to use to “slice” your data and click OK:

4. To use the Slicer, simply select one of the fields in the Slicer to filter your data by
that field:
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❋

1.3. Working with Pivot Tables

 1.3.1. Grouping Data

You can group data in a Pivot Table to show a subset of your data

To group data:

1. In the Pivot Table, select the data you want to group.

2. Right-click and select Group.

3. The data appears as a new group.
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 1.3.2. Using PowerPivot

PowerPivot is an add-on that you can use in Excel to perform more powerful data analysis.

To add PowerPivot:

1. Select the File menu tab, and then select Options.

2. In the Excel Options dialog box, on the right, select Add-Ins.

3. From the Manage drop-down list, select COM Add-ins and then click Go.
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4. Check the Microsoft Office PowerPivot for Excel  check box and click OK.

5. The PowerPivot tab now appears on the Ribbon.

Once PowerPivot is installed, you can launch the PowerPivot window by selecting Manage
from the PowerPivot tab. Here you can import and manage external data.

 1.3.3. Managing Relationships

A feature that was new with Excel is the Relationships option on the Data tab, in the Data
Tools group.

To manage relationships in Pivot Tables, you must have at least two tables (both of which
must be formatted at Tables, or else the "Relationships command will be grayed out) in
your worksheet. Then, to create a relationship:

1. From the Data tab, select Relationships.
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2. In the Manage Relationships dialog box, select New.

3. In the Create Relationship dialog box, enter the tables and columns you want to
be related, and click OK.

4. The information now appears in the Manage Relationships dialog box.
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❋

1.4. Inserting Pivot Charts

Pivot charts are simply charts that use the data in your pivot table. Pivot charts make it
easy to visualize your data.

To insert a pivot chart:

1. Select any cell in the pivot table.

2. On the PivotTable Tools Analyze tab (PivotTable Tools Options tab in Excel
2007/2010), in the Tools group, click the PivotChart command:

3. In the Insert Chart dialog box, select the type of chart to insert and click OK:
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Take a Few Minutes

Take a few minutes to experiment with some of the functionality of pivot charts using
the PivotTable Demo.xlsx file in your Excel2016.3/Demos folder. Note that as changes
are made to pivot charts, the pivot table on which the chart is based is automatically
updated.

❋

1.5. More Pivot Table Functionality

Pivot tables are one of the most powerful and useful tools in Excel. Additional pivot table
functionality is available, including:

1. How to Sort, Filter, Move, Remove, and format fields by right-clicking them:
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2. How to change or update the data source.

3. How to Refresh the pivot table.

4. How to filter the data in the pivot table using the filter drop-down arrows:

5. Some of things you can do from the PivotTable Tools Analyze tab:

6. Some of things you can do from the PivotTable Tools Design tab:
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 Exercise 1: Working with Pivot Tables
 15 to 25 minutes

In this exercise, you will practice using pivot tables, pivot charts, and Slicers.

1. Open PivotTables.xlsx from your Excel2016.3/Exercises folder.

2. Insert a pivot table in a new worksheet showing total sales by company. Format
the numbers as Currency and show zero decimal places. The pivot table should
look like the following image:

3. Insert a pivot chart that looks like the chart below:

4. Insert a pivot table in a new worksheet showing total sales in each calendar year
by industry. Format the numbers as Currency and show zero decimal places. The
pivot table should look like the following image:
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5. Insert Slicers to analyze sales by salesperson and product in addition to industry.
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Solution

1. To insert a pivot table showing total sales by company and to format the numbers
as Currency and show zero decimal places:

A. Select any cell in the table (cells A1:H62).

B. On the Insert tab, in the Tables group, click the PivotTable command
(and then select PivotTable in Excel 2007/2010):

C. In the Create PivotTable dialog box, verify that Excel has selected the
correct range, select where you want the pivot table to show up (select
New Worksheet), and then click OK:

D. In the PivotTable Field List, drag and drop Company into the Row Labels
box and Sale Amount into the Values box:
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E. Click Sum of Sale Amount and select Value Field Settings:

F. Click Number Format:
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G. In the Format Cells dialog box, select Currency, change the number of
decimal places to “0”, and click OK:

H. In the Value Field Settings dialog box, click OK:
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2. To insert the pivot chart showing total sales by company:

A. Select any cell in the pivot table.

B. On the PivotTable Tools Analyze tab (PivotTable Tools Options tab
in Excel 2007/2010), in the Tools group, click the PivotChart command:

C. In the Insert Chart dialog box, select Pie charts, select the first pie chart,
and then click OK:
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3. To insert a pivot chart that looks like the chart below:

A. Select any cell within the PivotTable.

B. On the PivotTable Tools > Analyze tab, in the Tools group, click
PivotChart.
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C. In the Insert Chart dialog box, click Pie from the list of chart types, and
then click OK.PivotChart.

4. To insert a pivot table showing total sales in each calendar year by industry and
to format the numbers as Currency and show zero decimal places:

A. Select the sheet named Data and then select any cell in the table (cells
A1:H62).

B. On the Insert tab, in the Tables group, click the PivotTable command
(and then select PivotTable in Excel 2007/2010):
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C. In the Create PivotTable dialog box, verify that Excel has selected the
correct range, select where you want the pivot table to show up (select
New Worksheet), and click OK:

D. In the PivotTable Field List, drag and drop Industry into the ROW box
(Row Labels box in Excel 2007/2010), Calendar Year into the COLUMN
box (Column Labels box in Excel 2007/2010), and Sale Amount into the
VALUES box:
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E. Click Sum of Sale Amount and select Value Field Settings:

F. Click Number Format:
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G. In the Format Cells dialog box, select Currency, change the number of
decimal places to “0”, and click OK:

H. In the Value Field Settings dialog box, click OK:
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5. To insert Slicers to analyze sales by salesperson and product in addition to industry:

A. Select any cell in the pivot table.

B. On the PivotTable Tools Analyze tab (PivotTable Tools Options tab
in Excel 2007/2010), in the Filter group (Sort & Filter group in Excel
2007/2010), click the Insert Slicer command (and select Insert Slicer in
Excel 2007/2010):

C. In the Insert Slicers dialog box, check the Product and Salesperson
check boxes and click OK:
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D. To use the Slicer, simply select one of the fields in either Slicer to filter
your data by that field.

Conclusion

In this lesson, you learned to use pivot tables to analyze data, to edit pivot tables, to format
pivot tables, to insert pivot charts, and to use Slicers.
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LESSON 2
Auditing Worksheets

Topics Covered

 Auditing formulas.

Tracing precedents.

Tracing dependents.

 Removing precedent and dependent arrows.

 Showing formulas.

 Checking for common formula errors.

Introduction

Large spreadsheets are often very complicated with formulas referring to many cells each
of which contain their own formulas referring to other cells that might be contained in other
worksheets or even other workbooks. Excel’s Formula Auditing commands are very
helpful when working in large worksheets.

The two most common uses of the Formula Auditing commands are:

1. To locate the cause of errors. Often an error appearing in one cell is caused by
an error in another cell. The Formula Auditing commands can help you find the
cell causing the error.

2. To better understand worksheets and information in specific cells. In a
complex worksheet, it can be difficult to ascertain where results come from. The
Formula Auditing commands can help you understand how different cells in the
worksheet relate to each other.

Detailed instructions for using the most commonly used Formula Auditing commands
follow.

❋
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2.1. Tracing Precedents

Tracing precedents in Microsoft Excel allows you to visually see which cells impact a given
cell. To trace precedents:

1. Select the cell to trace precedents for.

2. On the Formulas tab, in the Formula Auditing group, click the Trace Precedents
command:

3. The following screenshot shows the precedents for cell B11:

4. By clicking Trace Precedents a second time, we see another level of precedents
(the precedents for the cells directly preceding the first cell):
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5. Clicking Trace Precedents subsequent times shows additional levels of
precedents. If one of the preceding cells is on another sheet, Excel will add an
arrow pointing to an image of another sheet:

6. By double-clicking the small circle next to the image of the sheet, you can open
the Go To dialog box to see which sheet the cell refers to:

7. Select the sheet and click OK to go to the specific cell in the other sheet:
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8. To remove the arrows showing precedents, click Remove Arrows:
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 Exercise 2: Tracing Precedents
 5 to 15 minutes

In this exercise, you will practice tracing precedents.

1. Open Auditing Formulas.xlsx from your Excel2016.3/Exercises folder.

2. What are the first-level precedents for cell B5?

3. What are the second-level precedents for cell B5?

4. What are the first-level precedents for cell B11?

5. What are the second-level precedents for cell B11?
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Solution

1. The first-level precedents for cell B5 are cells B3 and B4. To figure this out:

A. Select cell B5.

B. On the FORMULAS tab, in the Formula Auditing group, click the Trace
Precedents command:

C. The preceding cells are indicated by the arrow:

2. The second-level precedents for cell B5 are cells B12 and B13 in the sheet named
“Revenue”. To figure this out:

A. Click Trace Precedents again.

B. Double-click the small circles next to the images of the sheets in order to
open the Go To dialog box showing the sheets and cells:

3. Remove the arrows showing the precedents for cell B5 by clicking Remove
Arrows:
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4. The first-level precedents for cell B11 are cells B5 and B10. To figure this out:

A. Select cell B11.

B. On the FORMULAS tab, in the Formula Auditing group, click the Trace
Precedents command:

C. The preceding cells are indicated by the arrow:

5. The second-level precedents for cell B11 are cells B3:B4 and cells B7:B9. To
figure this out:

A. Click Trace Precedents again.

B. The preceding cells are indicated by the arrows pointing to B5 and B10:
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❋

2.2. Tracing Dependents

Tracing dependents in Microsoft Excel allows you to visually see which cells are impacted
by a given cell. To trace dependents:

1. Select the cell to trace dependents for.

2. On the Formulas tab, in the Formula Auditing group, click the Trace Dependents
command:

3. The following screenshot shows the dependents for cell C3:

4. By clicking Trace Dependents a second time, we see another level of dependents
(the dependents for the cells directly dependent upon the first cell):
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5. As with precedents, clicking Trace Dependents subsequent times shows additional
levels of dependents. If one of the dependent cells is on another sheet, Excel will
add an arrow pointing to an image of another sheet.

6. To remove the arrows showing dependents, click Remove Arrows:
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 Exercise 3: Tracing Dependents
 5 to 10 minutes

In this exercise, you will practice tracing dependents.

1. Open Auditing Formulas.xlsx from your Excel2016.3/Exercises folder.

2. What are the first-level dependents for cell B4?

3. What are the second-level dependents for cell B4?
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Solution

1. The first-level dependent for cell B4 is cell B5. To figure this out:

A. Select cell B4.

B. On the Formulas tab, in the Formula Auditing group, click the Trace
Dependents command:

C. The dependent cells are indicated by the arrow:

2. The second-level dependents for cell B4 are cells B8:E8 and cells B9 and B11.
To figure this out:

A. Click Trace Dependents again.

B. The dependent cells are indicated by the arrows:

3. Remove the arrows by clicking Remove Arrows:
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❋

2.3. Showing Formulas

Sometimes it is useful to see the formulas in all the cells in a worksheet rather than the
values. To show formulas:

1. Select any cell in the worksheet in which you want to show the formulas.

2. On the Formulas tab, in the Formula Auditing group, click the Show Formulas
command:

3. Instead of values, you can now see the formulas in each cell:

4. To go back to showing values, simply click the Show Formulas command again.

Conclusion

In this lesson, you learned to audit formulas, to trace precedents and dependents to
determine how cells are impacted by other cells, to remove precedent and dependent
arrows, and to show formulas.
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LESSON 3
Data Tools

Topics Covered

 Converting text to columns.

 Data validation.

 Consolidating data from different ranges.

 Goal Seek.

Introduction

Data Tools in Microsoft Excel are simply tools which make it easy to manipulate data.
Some of them are intended to save you time by extracting or joining data and others
perform complex calculations. This lesson covers the most commonly used Data Tools.

❋

3.1. Converting Text to Columns

If you have a list of data in which all the information appears in one column, you can use
the Text to Columns command to convert the data to multiple columns. This is generally
much easier than retyping the data!

To convert text to columns in Microsoft Excel:

1. Select the column that holds the text you want to convert into multiple columns.

2. On the Data tab, in the Data Tools group, click the Text to Columns command:

3. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select either
Delimited (if your data is separated by commas, tabs, or spaces) or Fixed Width

LESSON 3: Data Tools | 45



(if your data contains a certain number of characters in each field).You will almost
always select Delimited in this step. Click Next:

4. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, select the
Delimiters (assuming you selected Delimited in the prior step). If you aren’t sure
what to select, you can select and deselect the options and see the results in the
Data preview. After making your selection(s), click Next:

5. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, you can select
the data format for each column or you can elect not to import a column. Simply
select the column under Data preview and then select the Column data format
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above. In this step, you also specify where you want the data to show up. After
you make your selections, click Finish:
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 Exercise 4: Converting Text to Columns
 10 to 20 minutes

In this exercise, you will practice converting text to columns.

1. Open Text to Columns.xlsx from your Excel2016.3/Exercises folder.

2. In the sheet named Presidents, convert the text in column A to three columns:
first name, last name, dates in office.

3. In the sheet named Capitols, convert the text in column A to two columns: city
and state. Put the converted data into columns C and D.

4. In the sheet named Contact Information, convert the text in column A to five
columns: name, address, city, state, and zip code. (Hint: You will need to do this
in two steps.)

5. In the sheet named Phone Numbers, separate the area codes by converting the
text in column A to three columns.
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Solution

1. To convert the text in column A of the sheet named “Presidents” to three columns:

A. Select column A.

B. On the Data tab, in the Data Tools group, click the Text to Columns
command:

C. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select
Delimited and click Next:

D. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, check
Space and click Next:
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E. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, click
Finish:

2. To convert the text in column A of the sheet named “Capitols” to two columns:

A. Select column A.

B. On the Data tab, in the Data Tools group, click the Text to Columns
command:
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C. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select
Delimited and click Next:

D. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, select
Comma and click Next:
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E. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, set the
Destination to cell C1 and click Finish:

3. To convert the text in column A of the sheet named “Contact Information” to five
columns:

A. Select column A.

B. On the Data tab, in the Data Tools group, click the Text to Columns
command:

C. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select
Delimited and click Next:
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D. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, select
Comma and click Next:

E. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, click
Finish:
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F. Select column D.

G. Click the Text to Columns command.

H. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select
Delimited and click Next.

I. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, select
Space and click Next.

J. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, click
Finish.

4. To convert the text in column A of the sheet named “Phone Numbers” to three
columns:

A. Select column A.

B. On the Data tab, in the Data Tools group, click the Text to Columns
command:

C. In the Convert Text to Columns Wizard - Step 1 of 3 dialog box, select
Delimited and click Next:
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D. In the Convert Text to Columns Wizard - Step 2 of 3 dialog box, select
Other, enter a dash (“-”), and click Next:

E. In the Convert Text to Columns Wizard - Step 3 of 3 dialog box, click
Finish:
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❋

3.2. Linking to External Data

In Excel 2016 (and Excel 2013), you can use the options in the Get External Data group
of the Data tab to link to data in different sources, such as text files, Microsoft Access,
and the Internet.

❋

3.3. Controlling Calculation Options

In Excel, calculation refers to Excel’s ability to automatically compute formulas and display
the results.You can alter the calculation options.
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To control calculation options:

1. From the File menu tab, select Options.

2. In the Excel Options dialog box, select Formulas on the left.

3. Set options under Calculation options and click OK to save the changes.
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❋

3.4. Data Validation

To protect against incorrect data entry, you can use data validation to restrict the type of
data that can be entered into a cell. You can choose to allow only certain types of data,
such as whole numbers or dates, or you can allow only items from a specified list.

To apply data entry restrictions:

1. Select the cells for which to verify data.

2. On the Data tab, in the Data Tools group, click the Data Validation command:

3. Click Data Validation:
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4. In the Data Validation dialog box:

A. On the Settings tab, choose which types of values to allow:

B. Note that when you select a type of value to allow, the Data options change
accordingly. Set the criteria (between, greater or less than, equal to,
Source, etc.) for those values. You can type the criteria or select it by
clicking the red arrows to the right of the data entry boxes. If you are only
allowing values from a list, you must click the red arrow and select the
source:
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C. If you want to, you can enter a message telling the person entering the
data what the restrictions are. They will see this message when selecting
any of the cells for which the restriction has been set. To enter this
message, select the Input Message tab, make sure that Show input
message when cell is selected is checked, and enter the Title and Input
message:

D. You also have the option of entering an error alert that pops up when
invalid data is entered. To enter an error alert, select the Error Alert tab,
make sure that Show error alert after invalid data is entered is checked,
and enter the Style (choose to stop the person from entering the data,
warn them that this data does not meet the criteria, or simply let them
know), Title, and Input message:
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E. Click OK.
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 Exercise 5: Using Data Validation
 15 to 25 minutes

In this exercise, you will practice using Data Validation to restrict the data that can be
entered in specific cells in a worksheet.

1. Open Data Validation.xlsx from your Excel2016.3/Exercises folder.

2. Use the Data Validation command to restrict the data that can be entered into
cells C2:C17 to the list of salespeople on the sheet named “Salespeople”.

3. Use Data Validation to restrict the data that can be entered into cells D2:D17 to
a date in 2012.

4. Use Data Validation to restrict the data that can be entered into cells E2:E17 to
the list of territories on the sheet named “Territories”. Enter an Input Message
and an Error Alert to help the person entering data.
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Solution

1. To restrict the data that can be entered into cells C2:C17 to the list of salespeople
on the sheet named “Salespeople”:

A. Select cells C2:C17.

B. On the Data tab, in the Data Tools group, click the Data Validation
command:

C. Click Data Validation:

D. In the Data Validation dialog box, on the Settings tab, under Allow, select
List:

E. Click the red arrow to the right of the Source data entry box to collapse
the Data Validation dialog box:
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F. Navigate to the sheet named Salespeople, select cells A2:A6, and then
click the red arrow at the right of the collapsed Data Validation dialog box
to restore it:

G. Back in the main Data Validation dialog box, click OK:

H. Note that selecting any of cells C2:C17 in the sheet named “Sales” opens
a drop-down list from which you can select one of the allowed entries:
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2. To restrict the data that can be entered into cells D2:D17 to a date in 2012:

A. Select cells D2:D17.

B. On the Data tab, in the Data Tools group, click the Data Validation
command:

C. Click Data Validation:

D. In the Data Validation dialog box, on the Settings tab, under Allow, select
Date:

66 | LESSON 3: Data Tools

EVALUATION COPY: Not to be used in class.



E. Under Data, select between. Under Start date, enter “1/1/12” and under
End date, enter “12/31/12”. Click OK:

F. Only dates in 2012 are allowed in cells D2:D17 now. Entering another
date will result in an error message:

3. To restrict the data that can be entered into cells E2:E17 to the list of territories
on the sheet named “Territories”, and to enter an Input Message and an Error
Alert to help the person entering data:

A. Select cells E2:E17.

B. On the Data tab, in the Data Tools group, click the Data Validation
command:
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C. Click Data Validation:

D. In the Data Validation dialog box, on the Settings tab, under Allow, select
List:

E. Click the red arrow to the right of the Source data entry box to collapse
the Data Validation dialog box:
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F. Navigate to the sheet named Territories and select cells A2:A6:

G. Click the red arrow at the right of the Data Validation dialog box to restore
it:

H. Select the Input Message tab and enter a Title and an Input message:
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I. Select the Error Alert tab, enter a Title and an Error message, and then
click OK:

J. Note that selecting any of the cells E2:E17 in the sheet named “Sales”
opens a drop-down list from which you can select one of the allowed
entries. In addition, your Input Message is displayed and entering an
invalid entry results in your Error Message popping up:
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❋

3.5. Consolidating Data

Use the Consolidate command to join values from a number of different ranges into one
new range.You can use Consolidate to sum the values in other ranges, to get an average
of the values, to find the min or max value, and more.

To consolidate data from different ranges:

1. On the Data tab, in the Data Tools group, click the Consolidate command:

2. In the Consolidate dialog box:

A. Select the Function to use.

B. Click the red arrow to the right of the Reference data entry box.

C. Select the first series of cells you want to consolidate and then click the
red arrow in the Consolidate - Reference dialog box to return to the
Consolidate dialog box.

D. Click Add to add the series of cells to the All references box.
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E. Repeat steps B, C, and D until you have selected all series of cells that
you want to consolidate.

F. Click OK:
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 Exercise 6: Consolidating Data
 15 to 25 minutes

In this exercise, you will consolidate students’ grades on four different exams to show their
average, lowest, and highest grades on a summary sheet.

1. Open Consolidate.xlsx from your Excel2016.3/Exercises folder.

2. Students’ grades on four exams are stored on the first four sheets in this workbook.
Use the Consolidate command to show the average, lowest, and highest grade
for each student on the sheet named Consolidate.
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Solution

1. To show the average grade for each student:

A. On the sheet named Consolidate, select cells B2:B11.

B. On the Data tab, in the Data Tools group, click the Consolidate command:

C. In the Consolidate dialog box, set the Function to Average and then
click the red arrow to the right of the Reference data entry box:

D. Navigate to the sheet named Exam 1 and select cells B2:B11 and then
click the red arrow at the right of the Consolidate - Reference dialog box:
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E. Back in the Consolidate dialog box, click Add:

F. Repeat steps C, D, and E, selecting cells B2:B11 on the sheets named
Exam 2, Exam 3, and Exam 4.

G. Now that all four series of data have been added to the All references
box, click OK:

2. To show the lowest grade for each student:

A. On the sheet named Consolidate, select cells C2:C11.

B. On the Data tab, in the Data Tools group, click the Consolidate command:
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C. In the Consolidate dialog box, set the Function to Min. Note that the
series of data from the prior exercise already appears in the All references
box. Were we using different data, you could delete these references and
add others. As we are using the same data in this exercise, simply click
OK:

3. To show the highest grade for each student:

A. On the sheet named Consolidate, select cells D2:D11.

B. On the Data tab, in the Data Tools group, click the Consolidate command:

C. In the Consolidate dialog box, set the Function to Max. Once again, as
we are using the same data as in the prior exercises and it already appears
in the All references box, simply click OK:
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❋

3.6. Goal Seek

If you know the result of a formula but not the value of a specific variable on which the
formula depends, you can use Goal Seek to adjust the variable to display the desired
value. Goal Seek can only adjust one variable in a formula, so if a formula depends on
more than one variable, you will need to decide which variable to adjust.

To use Goal Seek:

1. On the Data tab, in the Forecast group (the Data Tools group in Excel 2013),
click the What-If-Analysis command:

2. Click Goal Seek:
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3. In the Goal Seek dialog box:

A. In the Set cell box, enter the cell for which you know the result (if you
selected this cell before clicking Goal Seek, then it is already filled in).

B. In the To value box, enter the value for the cell above.

C. In the By changing cell box, enter the cell to adjust in order to obtain the
value. (Remember, this cell must be related via a formula to the cell above
or else changing one won’t impact the other.)

D. Click OK:

4. In the Goal Seek Status dialog box, after the calculation has completed, click OK
to accept the change or Cancel to reject it:
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 Exercise 7: Using Goal Seek
 15 to 25 minutes

In this exercise, you will practice using Goal Seek to adjust the number of periods it will
take to pay off a loan based on varied payments and to figure out what grade a student
needs on their final exam to achieve a target grade for a course.

1. Open Goal Seek.xlsx from your Excel2016.3/Exercises folder.

2. The worksheet named Loans contains information on four loans. The Payment
is calculated via the PMT formula. Use Goal Seek to determine:

A. How many months (periods) it will take to pay off your boat if you can only
pay $100 per month.

B. How many months (periods) it will take to pay off your first car if you can
only pay $250 per month.

C. How many months (periods) it will take to pay off your second car if you
can pay $200 per month.

D. How many months (periods) it will take to pay off your house if you can
pay $1,000 per month.

3. The worksheet named Grades contains scores for a number of students on four
exams, an empty column where the score for the fifth exam will go, and a column
showing the average score on all exams. Use Goal Seek to figure out:

A. What grade Babe Ruth needs to get on the last exam to raise his final
grade to 90.

B. What grade Barry Bonds needs to get on the last exam to achieve a
passing grade (65).

C. What the lowest grade Cal Ripken can get on the last exam to finish with
a final grade of 90.
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Solution

1. To determine how many months it will take to pay off your boat if you can only pay
$100 per month:

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:

B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell B2.

ii. In the To value box, enter -100.

iii. In the By changing cell box, enter D2:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. The correct result is 63 months.

2. To determine how many months it will take to pay off your first car if you can only
pay $250 per month:
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On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:

A.

B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell B3.

ii. In the To value box, enter -250.

iii. In the By changing cell box, enter D3:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. The correct result is 148 months.

3. To determine how many months it will take to pay off your second car if you can
pay $200 per month:

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:
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B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell B4.

ii. In the To value box, enter -200.

iii. In the By changing cell box, enter D4:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. The correct result is 42 months.

4. To determine how many months it will take to pay off your house if you can pay
$1,000 per month:

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:
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B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell B5.

ii. In the To value box, enter -1000.

iii. In the By changing cell box, enter D5:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. The correct result is 252 months.

5. To figure out what grade Babe Ruth needs to get to raise his final grade to 90, go
to the sheet named Grades and then:

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:
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B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell G2.

ii. In the To value box, enter 90.

iii. In the By changing cell box, enter F2:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. Babe Ruth needs a 100 on the final exam to raise his average to 90.

6. To figure out what grade Barry Bonds needs to get on the last exam to achieve a
passing grade (65):

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:
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B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell G8.

ii. In the To value box, enter 65.

iii. In the By changing cell box, enter F8:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. Barry Bonds needs a 133 on the final exam to achieve a passing grade.
Poor Barry Bonds.

7. To figure out the lowest grade Cal Ripken can get on the last exam to finish with
a final grade of 90:

A. On the Data tab, in the Forecast group (the Data Tools group in Excel
2013), click the What-If-Analysis command and then click Goal Seek:
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B. In the Goal Seek dialog box:

i. In the Set cell box, enter cell G9.

ii. In the To value box, enter 90.

iii. In the By changing cell box, enter F9:

iv. Click OK:

C. In the Goal Seek Status dialog box, after the calculation has completed,
click OK to accept the change:

D. Cal Ripken needs at least a 79 on the final exam to finish with a final grade
of 90.

Conclusion

In this lesson, you learned to convert text to columns, to use Data Validation to restrict
the type of data that can be entered into a cell, to consolidate data from a number of
different ranges into one new range, and to use Goal Seek to figure out the value to input
to obtain a specific result.
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LESSON 4
Working with Others

Topics Covered

 Password protection.

Tracking changes.

 Accepting and rejecting changes.

 Listing all changes on a new sheet.

Introduction

In this lesson, you will learn to password protect a workbook, a worksheet, and specific
ranges in a worksheet, to track changes, to accept and reject changes, and to list all
changes on a new sheet.

❋

4.1. Protecting Worksheets and Workbooks

By default, any person who can access a workbook can open it, and if you can open a
workbook, you can edit it. Fortunately, Excel offers numerous levels of protection for
workbooks and worksheets. The three most common ways to protect data in Excel are:

1. Password protect a workbook.You can protect your workbook with a password,
thereby preventing people who do not know the password from opening or
modifying (your choice) the workbook.

2. Password protect a worksheet. You can protect individual worksheets with a
password. Others can view the sheet, but you determine what, if any, changes
they can make without a password.

3. Password protect ranges in a worksheet. If you want to allow people to edit
some cells in a worksheet, but not others, you can protect the worksheet but leave
those cells you want people to edit “unlocked” and, therefore, editable.

LESSON 4: Working with Others | 87



 4.1.1. Password Protecting a Workbook

To protect your workbook with a password to prevent people who do not know the password
from opening or modifying it:

1. Click File > Save As and navigate to where you want to save the file (this step is
not necessary in Excel 2007 and 2010):

2. Select where you want to save the file, and in the Save As dialog box, click Tools
> General Options:
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3. Depending on whether you want to prevent others from opening the workbook or
just from modifying it, enter a password in either the Password to open box or
the Password to modify box and then click OK:

4. In the Confirm Password dialog box, reenter the password and then click OK:
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5. Back in the Save As dialog box, click Save:

6. If you previously saved the workbook, the Confirm Save As dialog box pops up
asking if you want to replace the existing workbook. Click Yes:
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 4.1.2. Removing Workbook Metadata

Before you share a workbook with others, you may want to remove its metadata, which
can include sensitive information.

To remove document metadata:

1. Select the File menu tab, and from the Info section, in the Inspect Workbook
section, select Check for Issues.

2. Select Inspect Document from the drop-down list.

3. Set options in the Document Inspector dialog box, and then click Inspect.
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4. Use the information that is returned to clean up your workbook.
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 Exercise 8: Password Protecting a
Workbook

 5 to 10 minutes

In this exercise, you will password protect a workbook to prevent people who do not know
the password from opening it.

1. Open Password Protect.xlsx from your Excel2016.3/Exercises folder.

2. Save the workbook so that others cannot open it without entering the password
“OpenMe!”.
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Solution

1. Click File > Save As:

2. In the Save As dialog box, click Tools > General Options:
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3. Since the purpose of the password is to prevent others from opening the workbook,
enter the password in the Password to open box and click OK:

4. In the Confirm Password dialog box, reenter the password and click OK:

5. Back in the Save As dialog box, click Save:
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6. In the Confirm Save As dialog box, click Yes:

❋

4.2. Password Protecting a Worksheet

To protect a worksheet within a workbook and to determine exactly which changes others
can make without a password:

1. Select any cell in the worksheet you want to protect.

2. On the Review tab, in the Changes group, click the Protect Sheet command:

3. In the Allow all users of this worksheet to list, check the boxes for all actions
you want users to be able to perform without a password. Note that by default
users can select locked and unlocked cells, meaning users can select cells to see
the formulas within, but cannot change them. If you uncheck these boxes, users
will see the worksheet in the same way they would see a picture. After making
your selections, enter a password and click OK:
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4. In the Confirm Password dialog box, reenter the password and click OK:

5. To unprotect the worksheet:

A. On the Review tab, in the Changes group, click the Unprotect Sheet
command (note that this has replaced the Protect Sheet command on
the toolbar):

B. In the Unprotect Sheet dialog box, enter the password and click OK:
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 Exercise 9: Password Protecting a
Worksheet
 5 to 10 minutes

In this exercise, you will password protect a worksheet to prevent people who do not know
the password from editing it.

1. Open Protecting Worksheets.xlsx from your Excel2016.3/Exercises folder.

2. Protect the worksheet named Loans with the password NoEdits. Allow users to:

A. Select locked and unlocked cells.

B. Format cells, rows, and columns.

C. Use AutoFilter.
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Solution

1. Select any cell in the worksheet named Loans.

2. On the Review tab, in the Changes group, click the Protect Sheet command:

3. In the Allow all users of this worksheet to list, verify that Select locked cells
and Select unlocked cells are both checked. Check the Format cells, Format
columns, Format rows, and Use AutoFilter boxes. After making your selections,
enter the password “NoEdits” and click OK:

4. In the Confirm Password dialog box, reenter the password and click OK:
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5. Note that while you can’t edit any of the data without unprotecting the sheet, you
can change the formatting and use AutoFilter. Also note that the sheet named
“Grades” is not protected, and thus is fully editable.

❋

4.3. Password Protecting Ranges in a Worksheet

By default, when you protect a worksheet, all cells in the worksheet are “locked,” meaning
they cannot be edited. However, you can “unlock” some cells in a worksheet before
protecting it, thus allowing users to edit those, and only those, cells. This is a two step
process:

1. Unlock cells you want people to be able to edit without a password. To do so:

A. Select the cells you want to "unlock."

B. On the Home tab, in the Cells group, click the Format command:

C. Note that the image of a lock is highlighted. Click Lock Cell to unlock the
cells:
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i. Click the Format command again and note that the image of a
lock is no longer highlighted, indicating that the selected cells are
now unlocked:

ii. Press Escape.
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2. Protect the worksheet (see instructions provided earlier in this lesson).
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 Exercise 10: Password Protecting Ranges
in a Worksheet

 10 to 15 minutes

In this exercise, you will unlock cells in a worksheet before protecting it, thus allowing
users to edit much of the worksheet, but protecting the formulas and structure of the
worksheet.

1. Open Protecting Ranges in a Worksheet.xlsx from your Excel2016.3/Exercises
folder.

2. Protect the worksheet so that users can edit cells D2:D5 (Periods), but cannot
edit anything else.
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Solution

1. Select cells D2:D5.

2. On the Home tab, in the Cells group, click the Format command:

3. Click Lock Cell to unlock the cells:

4. On the REVIEW tab, in the Changes group, click the Protect Sheet command:

5. In the Allow all users of this worksheet to list, verify that Select locked cells
and Select unlocked cells are both checked and click OK:
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6. In the Confirm Password dialog box, reenter the password and click OK:

❋

4.4. Marking a Workbook as Final

You can mark a workbook as final to discourage others from editing it.

To mark a workbook as final:

1. Select the File menu tab, and from the Info section, in the Protect Workbook
section, click Protect Workbook.
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2. Select Mark as Final from the drop-down list.

3. Click OK in the dialog box.

4. Click OK in the next box that appears.

5. The workbook is now read-only and the following appears:
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Conclusion

In this lesson, you learned to password protect a workbook, to password protect a
worksheet, to password protect ranges in a worksheet, to track changes in an Excel
workbook, to accept and reject changes, and to list all the changes on a new sheet.
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LESSON 5
Recording and Using Macros

Topics Covered

 Recording macros.

 Running macros.

 Editing macros (kind of).

 Adding macros to the Quick Access Toolbar.

Introduction

As you work with Excel, you may find that you repeat certain operations frequently. Instead
of performing each step of the operation, you can create a macro that stores these steps.
You can then run the macro, or let Excel perform the steps for you, saving you both time
and effort.

❋

5.1. Recording Macros

To record a macro in Microsoft Excel:

1. On the View tab, in the Macros group, click the Macros command:

2. Click Record Macro:
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3. In the Record Macro dialog box:

A. Enter a Macro name. Choose a name that clearly identifies the macro.
You cannot use spaces.

B. Enter a Shortcut key.You will be able to run the macro using this shortcut
key.

C. Choose where to store the macro. You will normally accept the default
(This Workbook).

D. Enter a Description. Briefly explain what the macro does.

E. Click OK.

4. After clicking OK, every keystroke is recorded.

5. To stop recording, on the View tab, in the Macros group, click the Macros
command and then click Stop Recording:
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 5.1.1. Copy a Macro from Workbook to Workbook

You can copy macros to different workbooks. First you need to ensure the Developer tab
is active on the Ribbon. To add it:

1. Right-click the Ribbon and select Customize the Ribbon.

2. Select Customize Ribbon, and on the right, select the Developer check box and
click OK.
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Now you need to enable and copy the macros:

1. Select the Developer tab, and select Macro Security from the Code group.

2. Under Macro Settings, select Enable all macros and click OK.

3. Open both the source and destination workbook.

4. Select the Developer tab, and select Visual Basic from the Code group.

5. From the Project Explorer pane, press Ctrl and drag the module from the source
to the destination workbook.
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6. Close the Visual Basic window and save the workbook.
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 Exercise 11: Recording a Macro
 10 to 20 minutes

In this exercise, you will record a macro that adds a custom header and footer to a Microsoft
Excel workbook.

1. Open Macros.xlsx from your Excel2016.3/Exercises folder.

2. Record a macro named CustomHF to add a custom header and footer to your
workbook. Specifically, the macro should:

A. Add the word “CONFIDENTIAL” in the center of the header.

B. Add the date on the right side of the header.

C. Add the page number to the center of the footer.
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Solution

1. On the View tab, in the Macros group, click the Macros command:

2. Click Record Macro:

3. In the Record Macro dialog box:

A. Enter the Macro name of “CustomHF”.

B. Enter a Shortcut key.

C. Accept the default to store the macro in this workbook.

D. Enter a Description such as “Custom header and footer.”

E. Click OK.

4. After clicking OK, every keystroke is recorded. Following are specific instructions:
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Click File, then Print, and then Page Setup:A.

B. Select the Header/Footer tab and then click Custom Header:

C. Tab to or click in the Center section and type “CONFIDENTIAL”. Then
tab to or click in the Right section, click the Insert Date icon, and then
click OK:
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D. Click Custom Footer:

E. Tab to or click in the Center section, click the Insert Page Number icon,
and then click OK:

F. You are now back in the Page Setup dialog box. Click OK:
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G. On the View tab, in the Macros group, click the Macros command and
then click Stop Recording:

❋

5.2. Running Macros

To run a macro in Microsoft Excel:

1. On the View tab, in the Macros group, click the Macros command:

2. Click View Macros:
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3. In the Macro dialog box, choose the macro you want to run and click Run:

Unless they are very large, macros run very fast, meaning that almost immediately after
clicking Run the macro will finish executing. If the macro doesn’t change anything that is
readily visible, it may seem as if nothing has happened.

❋

5.3. Editing Macros

If you need to make simple changes to a macro, you can do so using Microsoft Visual
Basic for Applications (VBA). The steps below briefly describe how to do this. For most
Excel users, however, it is easier to record a new macro than to edit an existing macro.
To learn how to write and edit complicated macros, you should take a course on VBA.

To edit a macro in Microsoft Excel:

1. On the View tab, in the Macros group, click the Macros command:
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2. Click View Macros:

3. In the Macro dialog box, choose the macro you want to change and click Edit to
open the macro in the Microsoft Visual Basic for Applications window:

4. You can see and edit your code in the Microsoft Visual Basic for Applications
window:
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Microsoft Visual Basic for Applications is a powerful programming language that can be
used to make major customizations to Microsoft Excel and other Microsoft Office
applications. Editing code is far beyond the scope of this class, but it’s fun to think about
just how powerful Microsoft Excel is.

❋

5.4. Adding Macros to the Quick Access Toolbar

The reason to create a macro is to make it easier to complete a set of operations that you
regularly perform. Given this, it is likely that you need to run the macro frequently.To make
it easy to do so, you can add the macro to the Quick Access Toolbar.

To add a macro to the Quick Access Toolbar:

1. Click the Customize Quick Access Toolbar drop-down arrow:

2. Select More Commands:

124 | LESSON 5: Recording and Using Macros

EVALUATION COPY: Not to be used in class.



3. In the Excel Options dialog box on the Quick Access Toolbar tab, from the
Choose commands from drop-down list, select Macros:

4. Select the macro you want to add to the Quick Access Toolbar and click Add
and then OK:
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5. You can now see and run the macro on the Quick Access Toolbar:

 5.4.1. Managing Macro Security

When working with macros, it is important to maintain security, that is, ensure that no
dangerous code is going to be run.

To enable security when working with macros in Excel 2016:
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1. Enter Backstage view by selecting File > Options.

2. In the Excel Options dialog box, select Customize Ribbon.

3. Under Customize Ribbon, on the right, check the Developer check box and then
click OK.
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4. Now, on the Developer tab, in the Code group, select Macro Security.

5. Use the options in the Trust Center dialog box to set security options.
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 Exercise 12: Adding a Macro to the Quick
Access Toolbar

 5 to 10 minutes

In this exercise, you will add a macro to the Quick Access Toolbar.

1. Open Add Macros to QAT.xlsm from your Excel2016.3/Exercises folder.

2. Add the macro named CustomHF to the Quick Access Toolbar.
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Solution

1. Click the Customize Quick Access Toolbar drop-down arrow:

2. Select More Commands:

3. In the Excel Options dialog box on the Quick Access Toolbar tab, from the
Choose commands from drop-down list, select Macros:
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4. Select the macro named “CustomHF” to add it to the Quick Access Toolbar and
click Add and then OK:

5. You can now see and run the macro on the Quick Access Toolbar:
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Conclusion

In this lesson, you learned to record and run macros and how to add a macro to the Quick
Access Toolbar.
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LESSON 6
Random Useful Items

Topics Covered

 Inserting sparklines.

 Customizing sparklines.

 Internationalization, accessibility, and compatibility.

 Importing text files.

 Copying data into into Microsoft Word.

 Copying a chart into Microsoft Word.

Introduction

In this lesson, you will learn to insert and customize sparklines, to prepare a workbook for
internationalization, accessibility, and compatibility, to import text files into Excel, and to
copy data and charts from Excel into Microsoft Word.

❋

6.1. Sparklines

Sparklines make it easy to visualize data in a worksheet. They are essentially miniature
charts that appear in a cell representing data in the worksheet. (Sparklines are not available
in Excel 2007.) Here are some examples:

1. Revenue from the local pizza joint:
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2. Daily stock prices:

3. The win-loss records for the last 10 games for four baseball teams:

Here are some things to know about sparklines:

1. Unlike charts, which float above the grids in worksheets, sparklines live in a cell.
To make a sparkline bigger or smaller, just make the cell bigger or smaller.

2. Sparklines are great for spotting trends.

3. Hidden cells don’t show up on sparklines.

4. You can autofill sparklines.

5. Sparklines are just plain cool.

 6.1.1. Inserting Sparklines

To insert a sparkline in a cell:

1. Select the cell you want to insert a sparkline in.

2. On the Insert tab, in the Sparklines group, depending on the type of sparkline
you want to create, click either the Line, Column, or Win/Loss command. You
can always change the type of sparkline later:
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3. In the Create Sparklines dialog box, enter the Data Range (the range of cells
the sparkline will chart), the Location Range (if necessary), and click OK:

 6.1.2. Customizing Sparklines

When you insert sparklines into a cell or select a cell that already has sparklines, the
Sparkline Tools Design tab appears:

There are many ways to customize sparklines, including:

1. Change the type. You can always change the type of the sparkline by selecting
a different type in the Type group:

2. Highlight key points.You can draw attention to key (high, low, first, last, negative)
points by selecting them in the Show group:

3. Colors.You can change the color of the sparkline or of any of the key points using
the Sparkline Color and Marker Color drop-down menus:
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4. Change the axis.You can change the axis using the Axis drop-down menu:
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 Exercise 13: Inserting and Customizing
Sparklines

 10 to 20 minutes

In this exercise, you will practice using sparklines by creating sparklines similar to the
examples above.

1. Open Sparklines.xlsx from your Excel2016.3/Exercises folder.

2. On the sheet named Revenue, insert sparklines that look like the following:

A. Note that:

i. The Vertical Axis Minimum Value Option has a Custom Value
of zero (0).

ii. The High Point is highlighted in a different color.

3. On the sheet named “Stocks”, insert sparklines that look like the following:

4. On the sheet named “WinLoss”, insert sparklines that look like the following:
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Solution

1. To insert column sparklines on the sheet named Revenue:

A. Select cell C3.

B. On the Insert tab, in the Sparklines group, click the Column command:

C. In the Create Sparklines dialog box, enter D3:O3 in the Data Range and
then click OK:

D. On the Sparkline Tools Design tab, in the Show group, click the High
Point command:

E. On the Sparkline Tools Design tab, in the Group group, click the Axis
command:

F. Under Vertical Axis Minimum Value Options, click Custom Value:
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G. In the Sparkline Vertical Axis Setting dialog box, accept the default value
of “0.0” and click OK:

H. Copy cell C3 to cells C4:C6.

2. To insert line sparklines on the sheet named Stocks:

A. Select cell B2.

B. On the Insert tab, in the Sparklines group, click the Line command:

C. In the Create Sparklines dialog box, enter C2:G2 in the Data Range and
then click OK:
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D. Copy cell B2 to cells B3:B6.

3. To insert win/loss sparklines on the sheet named “WinLoss”:

A. Select cell D2.

B. On the Insert tab, in the Sparklines group, click the Win/Loss command:

C. In the Create Sparklines dialog box, enter E2:N2 in the Data Range and
then click OK:

D. Copy cell D2 to cells D3:D5.

❋
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6.2. Preparing a Workbook for Internationalization and
Accessibility

You may need your workbook to be able to be available to an international audience or
an audience of disabled users, and if so you may need to make certain adaptations to it.

 6.2.1. Display Data in Multiple International Formats

To display data in multiple international formats:

1. From the Home tab, select Format in the Cells group, and then select Format
Cells.

2. Select Date or Time from the Category list.

3. From the Locale drop-down list, select a location and click OK.
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 6.2.2. Modify Worksheets for Use with Accessibility Tools

To check and modify worksheets for accessibility:

1. Select the File menu tab, and from the Info section, select Check for Issues.

2. From the drop-down list, select Check Compatibility.

3. The Accessibility Checker pane will launch, with any issues listed.

142 | LESSON 6: Random Useful Items

EVALUATION COPY: Not to be used in class.



4. To correct an issue, select it and view information about how to fix it.

Inspect a Workbook for Compatibility Issues

You can check a workbook for compatibility with previous versions of Excel:

1. Select the File menu tab, and from the Info section, select Check for Issues.
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2. From the drop-down list, select Check Compatibility.

3. The Compatibility Checker will launch if any compatibility issues exist.

 6.2.3. Use International Symbols

To use international symbols in a workbook:

1. From the Home tab, select Format in the Cells group, and then select Format
Cells.
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2. On the Number tab, select Currency.

3. From the Symbol drop-down list, select a unit of currency and click OK.

 6.2.4. Manage Multiple Options for +Body and +Heading Fonts

To manage multiple options for +Body and +Heading fonts:

1. Select the Home tab of the Ribbon.

2. In the Styles group, select Cell Styles.
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3. From the drop-down list, select a body or heading option.

❋

6.3. Importing and Exporting Files

 6.3.1. Importing Delimited Text Files

It is often necessary to import data from other applications. Data can be imported from
other spreadsheet applications and from database applications, but most of the time when
you need to import data into Excel, it will be from a delimited text file. When you do need
to import data from another application, it is usually easiest to first convert it from the other
application to a text file and then import it into Excel as a text file.

The process of importing text files is very similar to the process of converting text to
columns. To import a text file into Microsoft Excel:

1. From the File menu, select Open:
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2. Navigate to the location of the file and in the Open dialog box, in the file type
drop-down box, select Text Files:

3. Select the text file you want to import and click Open:
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4. In Step 1 of the Text Import Wizard, select either Delimited (if your data is
separated by commas, tabs, or spaces) or Fixed Width (if your data contains a
certain number of characters in each field). You will usually select Delimited in
this step. Click Next:

5. In Step 2 of the Text Import Wizard, select the Delimiters (assuming you selected
Delimited in the prior step). If you aren’t sure what to select, you can select and
deselect the options and see the results in the Data preview. After making your
selection(s), click Next.
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6. In Step 3 of the Text Import Wizard, select the data format for each column or
you can elect not to import a column. Simply select the column under Data preview
and then select the Column data format above.When you are done, click Finish:
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 Exercise 14: Importing Text Files
 5 to 15 minutes

In this exercise, you will practice importing text files into a Microsoft Excel workbook.

1. Use Microsoft Excel to import Contact Information.txt from your Excel2016.3/Ex
ercises folder.

2. Use Microsoft Excel to import Capitals.txt from your Excel2013.3/Exercises
folder.
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Solution

1. To import Contact Information.txt from your Excel2016.3/Exercises folder:

A. Open Microsoft Excel.

B. From the File menu, select Open:

C. In the Open dialog box, navigate to your Excel2013.3/Exercises folder
and in the file type drop-down box, select Text Files:

D. Select Contact Information.txt and click Open:
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E. In Step 1 of the Text Import Wizard, select Delimited and click Next:

F. In Step 2 of the Text Import Wizard, select Tab and click Next:
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G. In Step 3 of the Text Import Wizard, click Finish:

2. To import Capitals.txt from your Excel2016.3/Exercises folder:

A. From the File menu, select Open:
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B. In the Open dialog box, navigate to your Excel2013.3/Exercises folder
and in the file type drop-down box, select Text Files (if it isn’t already
selected):

C. Select Capitals.txt and click Open:
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D. In Step 1 of the Text Import Wizard, select Delimited and click Next:

E. In Step 2 of the Text Import Wizard, select Comma and click Next:
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F. In Step 3 of the Text Import Wizard, click Finish:

LESSON 6: Random Useful Items | 157



 Exercise 15: Copying Data from Excel to
Word

 5 to 10 minutes

In this exercise, you will copy data from Microsoft Excel to Microsoft Word.

1. Open Copy to Word.xlsx and Pizza and Wings.docx from your Excel2016.3/Ex
ercises folder.

2. In Copy to Word.xlsx, copy cells A1:M7 and paste them into Pizza and Wings.docx
between the two paragraphs such that the formatting is the same as in Excel and
the data is linked to the Excel worksheet.
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Solution

1. Select cells A1:M7 in Copy to Word.xlsx.

2. On the Home tab, in the Clipboard group, click the Copy command:

3. In Pizza and Wings.docx, place your cursor between the two paragraphs.

4. On the Home tab, in the Clipboard group, click the drop-down arrow below the
Paste command:

5. Click the Link & Keep Source Formatting icon:

6. Note that when you change the numbers in Copy to Word.xlsx, they change in
Pizza and Wings.docx as well.
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 Exercise 16: Copying Charts from Excel
to Word

 5 to 10 minutes

In this exercise, you will copy a chart from Microsoft Excel to Microsoft Word.

1. If they aren’t already open, open Copy to Word.xlsx and Pizza and Wings.docx

from your Excel2016.3/Exercises folder.

2. In Copy to Word.xlsx, copy the chart and paste it as a picture into Pizza and

Wings.docx below the second paragraph.
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Solution

1. Select the chart in Copy to Word.xlsx.

2. On the Home tab, in the Clipboard group, click the Copy command:

3. In Pizza and Wings.docx, place your cursor below the second paragraph.

4. On the Home tab, in the Clipboard group, click the drop-down arrow below the
Paste command:

5. Click the Picture icon:

Conclusion

In this lesson, you learned to insert sparklines into worksheets and to customize sparklines
by changing the type, highlighting key points on the sparkline, changing the color of the
sparkline and highlighted points, and changing the axis.You then learned how to prepare
a workbook for internationalization and accessibility. You also learned to import text files
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into Microsoft Excel, to copy cells from a worksheet into Microsoft Word, and to copy and
paste a chart into Microsoft Word.
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LESSON 7
Features New in Excel 2013

Topics Covered

 Slicers to filter data.

 PivotTable timeline.

 Standalone PivotChart.

Introduction

Excel 2013 provided a number of new features to help you efficiently and effectively create
and edit workbooks.

❋

7.1. Using Slicers to Filter Data

Slicers was a new feature added to Excel 2010, which allows users to filter PivotTable
data. Starting in Excel 2016, you can use slicers to filter table data.

To filter data using slicers:

1. Click in the table.

2. From the Table Tools Design tab, from the Tools group, select Insert Slicer.

3. In the Insert Slicers dialog box, check the check boxes of the desired slicers.
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4. Click OK.
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5. The slicers are now displayed in the worksheet.
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 Exercise 17: Filtering Data with Slicers
 05 to 10 minutes

In this exercise, you will use slicers to filter data.

1. Open Filtering with Slicers.xlsx from your Excel2016.3/Exercises folder.

2. Create slicers for the data for the months of January, February, and March.
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Solution

1. Click in the table.

2. From the Table Tools Design tab, from the Tools group, select Insert Slicer.

3. In the Insert Slicers dialog box, check the Jan, Feb, and Mar check boxes and
click OK.

4. View the slicers in your worksheet.
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❋

7.2. Creating a PivotTable Timeline

You can now use the PivotTable Timeline feature to filter your data by time.

To create a PivotTable Timeline:

1. Click the PivotTable.

2. From the PivotTable Tools Analyze tab, in the Filter group, select Insert
Timeline.

3. In the Insert Timeline dialog box, check the check box of the date fields you want
in the timeline.
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4. The timeline is displayed. To filter by date, click the arrow next to the time section
and make a selection.

5. Drag the scrollbar to see the filtered data.

6. To see a specific time period, click and drag the timeline handles.

7. Click the Clear Filter button to clear the timeline.
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 Exercise 18: Creating a Timeline
 05 to 10 minutes

In this exercise, you will create a PivotTable timeline.

1. Open PivotTables Timeline.xlsx from your Excel2016.3/Exercises folder.

2. Create a PivotTable Timeline based on the PivotTable showing all periods.
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Solution

1. Open the PivotTable and click it to select it.

2. From the PivotTable Tools Analyze tab, in the Filter group, select Insert
Timeline.

❋

7.3. Creating a Standalone PivotChart

In previous versions of Excel, a PivotChart needed to be associated with a PivotTable;
however, starting with Excel 2013 and continuing with 2016 you can create a standalone
PivotChart.

To create a standalone PivotChart:

1. Click in your data.

2. Select the Insert tab and, in the Charts group, select Recommended Charts.
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3. On the Recommended Charts tab, select a chart with the PivotChart icon and
view the preview.

4. When you find a chart you would like to select, click OK.
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5. The PivotChart is displayed.

❋

7.4. Workspaces in Excel 2013

One of the features of previous versions of Excel was the ability to create workspaces.
This command is no longer available starting with Excel 2013; however, if you have a
previous workspaces file (ending with the file extension .xlw), you can open it in Excel
2013 and 2016.
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Conclusion

In this lesson, you have learned:

1. How to use slicers to filter data.

2. How to create a PivotTable timeline.

3. How to create a standalone PivotChart.
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LESSON 8
New Features in Excel 2016

Topics Covered

 Enhancements to PivotTables.

The Ink Equation feature.

The Multi-Select option in slicers.

 Quick Shape formatting.

 Sharing workbooks.

Introduction

Excel 2016 provides a number of new features.

❋

8.1. PivotTable Updates

Excel 2016 provides PivotTable enhancements to make working with data easier. These
include:
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Searchable PivotTable fields: You can use the PivotTable Fields navigation

pane to search for fields within the table.

Custom measures: You can use the PivotTable fields navigation pane to create
and edit custom measures.

PivotChart drill-down menu: You can use the drill-down menu in PivotCharts to

more easily work with your data.

❋

8.2. Ink Equations

If you are using a tablet device, you can now “write” equations using a stylus or your finger
and Excel will convert it to text. If you are not using a touchscreen device, you can do the
same using your mouse.

To use Ink Equations, from the Insert tab of the Ribbon, in the Symbols group, select
Equation.
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From the drop-down, select Ink Equations.

A dialog box opens where you can insert your equation and then click Insert to add it to
the worksheet.

❋

8.3. Multi-Select Option in Slicers

Another thing you can now do on a touch device is select multiple items in a slicer, using
the Multi-Select option.
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❋

8.4. Quick Shape Formatting

There are now preset Quick Shape styles available in Excel from the Drawing Tools
Format tab.

❋

8.5. Sharing

You can share your Excel workbooks with others using the Share option on the File menu.
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First you need to save the workbook to SharePoint or OneDrive. Then, select the Share
with People option.

In the Share pane, you can invite people to share or edit the workbook.
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 Exercise 19: Sharing a Workbook
 10 to 15 minutes

In this exercise, you will share a workbook with someone else.

1. Open the Sharing.xlsx from your Excel2016.3/Exercises folder.

2. Save the file to OneDrive.

3. Share the file with someone who needs to access it.
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Solution

1. Open the file and select File, and then select Share.

2. Select Save to Cloud and navigate to a location to which to save the file.

3. When the file is saved, on the Share screen you will see the Share with People

option.

4. The Share pane launches. Enter the recipient’s email in the Invite people field.

5. Select whether the person will have access to editing or just viewing the file using

the drop-down list.

6. If you were going to send the file, you would click Share. Close the file without

sharing it.

Conclusion

In this lesson, you have learned:
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1. About the enhancements to PivotTables.

2. About the Ink Equation feature.

3. About the Multi-Select option in slicers.

4. About Quick Shape formatting.

5. About sharing workbooks.
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LESSON 9
Cloud

Topics Covered

 Using the cloud.

Introduction

One of the new features that was introduced in the Microsoft Office 2013 suite and is also
available in the 2016 edition is the ability to save, share, and collaborate with others using
the cloud. You can save, share, and access your Excel workbooks on SharePoint or
OneDrive.

❋

9.1. Using the Cloud

OneDrive (formerly called SkyDrive) provides account holders with a certain amount of
free cloud storage.

You will need a OneDrive account to perform the following. If you do not have one, go to
https://onedrive.live.com to sign up.

To save and share a document to OneDrive:

1. Add OneDrive to your list of Places in Excel, by selecting the File menu, and then
clicking Save As.
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2. Click Add a Place.

3. In the Add a Place section, select OneDrive.

4. In the Add a service dialog box, enter your email address and click Next.
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5. Enter your password and click Sign in.

6. To save your document to the cloud and share it, select the File menu and click
Share.
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7. Click Save To Cloud.

8. In the Save As section, click your OneDrive account.
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9. Click Browse and navigate to the OneDrive folder you want to use, and then name
your document and click Save.

10. Log in to your OneDrive account in a web browser at: https://onedrive.live.com/.

11. Navigate to your workbook and select the check box.

12. Select Share.
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13. Type the recipient’s email address and a message, if desired. Select the Recipients
can edit option if you want to give the recipient read-only access. When done
selecting options, click Share.

14. Your recipient can now view and change (if you did not uncheck the Recipients
can edit check box) your document.

196 | LESSON 9: Cloud

EVALUATION COPY: Not to be used in class.



 Exercise 20: Using the Cloud
 10 to 15 minutes

In this exercise, you will save an Excel workbook to OneDrive. (To perform this activity,
you must have a OneDrive account. To obtain a OneDrive account, go to
https://skydrive.live.com.)

1. Navigate to the Excel2016.3/Exercises folder and open Interview Schedule.

2. Save the document to a folder in your OneDrive.
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Solution

1. Add OneDrive to your list of Places in Excel, by selecting the File menu, and then
clicking Save As.

2. Click Add a Place.

3. In the Add a Place section, select OneDrive.
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4. In the Add a service dialog box, enter your email address and click Next.

5. Enter your password and click Sign in.
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6. To save your document to the cloud and share it, select the File menu and click
Share.

7. Click Save To Cloud.
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8. In the Save As section, click your OneDrive account.

9. Click Browse and navigate to the OneDrive folder you want to use, and then name
your document and click Save.
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Conclusion

In this lesson, you have learned how to use the cloud in Excel 2013.
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