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LESSON 1
A Quick Overview of Web Development

Topics Covered

 Client-side web development languages.

 Server-side web development languages.

Introduction

Learning HTML is the first step to becoming a web developer. But it is just one of several languages
you will need to know to create websites and web applications. In this lesson, you will learn where
HTML fits in the ecosystem of web development.

❋

1.1. HTML is Part of a Team

Before you get started writing HTML code, it’s important to understand where HTML fits in the
ecosystem of web development. Let’s first consider what happens when you visit a website. When you
type in a URL in the location bar of your browser (e.g., https://www.runners-home.com), the
browser makes a request from the web server for a web page. If you don’t specify the name of the file
you want (e.g., contact.html or about.html), the web server will send a default page, which is most
likely called index.html, index.php, index.cfm, or something similar. The web server returns that
web page to the browser for display. The web page may include references to other files:

Images to display on the page.
Style sheets to add formatting to the page.
Scripts to add interactivity to the page.

The browser will download these referenced files as well. To get a better feel for this, do the following
in Google Chrome:

1. As illustrated below…

A. Click the three-vertical-dot icon in the upper right of Google Chrome:
B. Then select More tools.
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C. Then select Developer tools. This will open Chrome’s Developer tools.

2. In Developer tools, select the Network tab:

3. If Developer tools isn’t docked on the bottom of the browser, move it to the bottom to make
it easier to see the Network tab information:

Developer tools should now be at the bottom of the browser:
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4. Now, in the location bar of your browser, enter https://www.runners-home.com and
press Enter:

5. After the page loads, take a look at the Network tab. You should see something like this:

LESSON 1: A Quick Overview of Web Development | 3



A. www.runners-home.com – Although it doesn’t specify the page, this represents the
main page you requested: the HTML page (usually called index).

B. toggle.js – A JavaScript page used for adding interactivity to the HTML page.
Notice in the fourth column that the initiator for this page is (index). That means
that the HTML code instructed the browser to download this page.

C. Style sheets ending with .css – CSS pages used for adding style and formatting to
the HTML page. Like the JavaScript page, these pages were also requested by the
HTML code.

D. Images ending with .png and .jpg – Images to display on the page. The images
were also requested by the HTML code.

E. Font files ending with .woff2 – Web fonts for adding custom fonts to your web
page.

F. Though not shown in the screenshot above, you may also see favicon.ico – An
icon used to identify the website on the browser tab:

Note that favicon.ico only gets delivered when pages are sent from a web server. When you open
files in a browser directly from your file system, the favicon will not show up.

As you can see, HTML, while essential, is just a piece of the puzzle. Web development involves a
combination of client-side-programming and server-side-programming languages. We will now introduce
the most common languages, but don’t worry if you don’t fully understand the role of each one. At
this point, the most important takeaway is that HTML is just one of many languages used in web
development.

❋

1.2. Client-side Programming

Client-side programming involves writing code that is interpreted by a browser, such as Google Chrome
or Safari, whether it be on your desktop or mobile device. The most common languages and technologies
used in client-side programming are HTML, Cascading Style Sheets (CSS), and JavaScript.
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 1.2.1. HTML

Hypertext Markup Language (HTML) is the language behind most web pages. The language is made
up of elements that describe the structure of the content on a web page.

 1.2.2. Cascading Style Sheets

Cascading Style Sheets (CSS) are used in HTML pages to format and lay out the content. CSS rules
defining color, size, positioning, and other display aspects of elements are mixed within the HTML
code or in linked external style sheets.

 1.2.3. JavaScript1

JavaScript is used to make HTML pages more dynamic and interactive. It can be used to validate forms,
pop up new windows, create audio and video controls, and create dynamic effects such as drop-down
menus and modal dialogs.

 1.2.4. Ajax

The term Ajax was originally a pseudo-acronym for “Asynchronous JavaScript and XML,” but is now
used much more broadly to cover all methods of communicating with a server using JavaScript.

The main purpose of Ajax is to provide a simple and standard means for a web page to communicate
with the server without a complete page refresh.

 1.2.5. JavaScript Frameworks

JavaScript frameworks are frameworks written in JavaScript that create a different approach to web
application design. Popular frameworks include Angular (https://angular.io), React
(https://reactjs.org), Vue.js (https://vuejs.org), and jQuery (https://jquery.com). You
should learn JavaScript before beginning to work with a JavaScript framework.

 1.2.6. CSS Frameworks

CSS frameworks are frameworks that allow you to quickly design HTML pages with a predefined set
of CSS classes. The most popular CSS framework is Bootstrap (https://getbootstrap.com/),
which comes with a library of stylish components that you can easily incorporate into your website.

1. The word “JavaScript” is a trademark of Oracle. Microsoft’s version of this language is called JScript.
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Tailwind CSS (https://tailwindcss.com/) is a newer CSS framework that allows for more
customization, but requires a better understanding of CSS.

❋

1.3. Server-side Programming

Server-side programming involves writing code that connects web pages with databases, XML pages,
email servers, file systems, and other systems and software accessible from the web server. The most
common server-side languages and programming frameworks are PHP, Java Enterprise Edition,
ASP.NET, ColdFusion, Node.js, and Python.

 1.3.1. PHP

PHP (https://www.php.net) is open source. It is the language behind WordPress and has long been
a popular alternative to proprietary languages such as ColdFusion and ASP.NET. PHP is lightweight
and relatively simple to learn.

 1.3.2. Java EE

Java EE (https://docs.oracle.com/javaee) is used in large web projects. With its power and
robustness comes a steep learning curve.

 1.3.3. ASP.NET

Microsoft’s ASP.NET (https://docs.microsoft.com/aspnet) is not a language, but a framework
for writing websites and software. ASP.NET pages can be written in many languages, but the most
popular are C# (pronounced C-sharp) and Visual Basic .NET (VB.NET).

 1.3.4. ColdFusion

ColdFusion (https://coldfusion.adobe.com), created by Allaire (now owned by Adobe), is arguably
the simplest of all server-side languages. It is tag-based, which makes it look a lot like HTML and easier
for client-side programmers to understand than some of the other choices.
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 1.3.5. Node.js

Node.js (https://nodejs.org) is a JavaScript runtime that can run on the server, allowing developers
to use JavaScript for server-side scripting as well as client-side scripting.

 1.3.6. Python

Python (https://www.python.org) has been a popular open-source programming language for a
long time. There are many web frameworks based on Python, the most popular of which is Django
(https://www.djangoproject.com).

Conclusion

This lesson has provided a general overview of the different languages and frameworks commonly used
in web development. Again, don’t worry if you don’t remember all the different technologies and their
specific roles. Take it one step at a time. The first step is to learn HTML.
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LESSON 2
Getting Started with Dreamweaver

Topics Covered

 The role of Dreamweaver in web development.

 The Dreamweaver interface.

 A simple web page.

 Previewing your web page in the browser.

 Setting up a website in Dreamweaver.

Introduction

Dreamweaver is an integrated development environment (IDE) for creating web pages and websites.
It was first introduced in 1997 by Macromedia, which was taken over by Adobe in 2005. Adobe has
since released many versions. In this lesson, we’ll introduce you to the Dreamweaver interface and get
you started with your first website.

❋

2.1. The Role of Dreamweaver

Experienced web developers need to know many different languages. For example, a really good
client-side programmer needs to know HTML, CSS, and JavaScript - three very different languages.
Dreamweaver makes it possible to develop websites without knowing these languages; however, as
you’ll see in this course, it helps to have some understanding of how the different languages work.

Dreamweaver also has a Code View that can be used for writing many different client-side and server-side
languages.

❋
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2.2. Start Screen

Very First Time Opening Dreamwweaver

The very first time you open Dreamweaver, it may ask you to choose your workspace and a
theme. You should choose Standard Workspace and any color theme that you like. It may then
ask you how you want to get started. You should choose to start with a new or existing folder,
and then navigate to the dreamweaver-cc folder that you unzipped as part of the course setup.

When you open Dreamweaver, it presents you with a Start Screen with some quick links for opening
recent items, creating new documents, and viewing video tutorials.

If you would prefer not to see the Start Screen each time Dreamweaver opens, you can remove it by
going to Edit > Preferences… (Windows) or Dreamweaver > Preferences… (Mac) and removing
the check mark from Show Start Screen in the General category:
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Then, click Apply and Close. The next time you open Dreamweaver, the Start Screen will not appear.
But you might prefer to keep it for the time being.

❋

2.3. Dreamweaver Workspaces

Dreamweaver comes with predesigned Workspace Layout options, listed below:

Developer
Standard

You can switch between workspace layouts using the drop-down on the upper right of the application
bar:
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In this course, we will be using the Standard layout, which you can reset at any time by selecting 'Reset
Standard'.

❋

2.4. Creating HTML Pages

There are several ways to create new HTML pages in Dreamweaver:

1. Click HTML Document under Quick Start on the Start Screen.

2. Select New… from the File menu.

3. Press CTRL+N on the keyboard.

The Start Screen option will create an HTML document using your default settings, which you can
change (we will see how later in the course). The other two options will pop up the following dialog:
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To create an HTML page using the default settings, simply click the Create button. We will look more
into the other options later in the course.

❋

2.5. Code View vs. Design View

There are three main views for editing documents, plus an additional option:

1. Code View – you work directly in the code.

2. Split View – you easily toggle back and forth between working in Code and Design View
and see your changes in both places.

3. Design View – you work in the WYSIWYG (What You See Is What You Get) interface that
feels like a word processor.

4. Live View – you can preview and edit within Dreamweaver.

Use the buttons in the center, below the toolbar to switch views:

LESSON 2: Getting Started with Dreamweaver | 13



.

In this course, we will generally be working in Design View. You might, however, want to switch to
Split View from time to time if you are interested in seeing the code that Dreamweaver is creating as
you work.
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 Exercise 1: Creating a Web Page
 10 to 15 minutes

In this exercise, you will create and view a simple web page.

1. Create a new HTML page using any of the methods previously described.

2. Place the cursor on the page and type “Hello world!”.

3. Save the page (File > Save) as hello-world.html in your dreamweaver-cc/Exercises
folder.

4. When you are done, your page should look something like this:
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Solution

1. Select New… from the File menu.

2. In the New Document dialog that pops up, click Create.

3. Type “Hello world!” in the document.

4. Save the document as hello-world.html in your dreamweaver-cc/Exercises folder.

❋

2.6. The Dreamweaver Interface

 2.6.1. Panels

All of Dreamweaver’s tools are contained in various windows and panels. Panels are divided and
organized into a series of Panel Groups based on the functions they contain. You can control which
of these panel groups is visible by selecting and deselecting them in the Window menu. The checked
items indicate the windows/panels that are currently showing:
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 2.6.2. Insert Panel

The Insert panel (shown below) allows you to insert various “objects” (such as tables, forms, and
images) into your page. You can format or set attributes for these objects as you insert them:
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The Dreamweaver Insert panel has several groupings of related objects:
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1. HTML - for most commonly used objects.

2. Form - for form components.

3. Bootstrap Components - for adding Bootstrap components to the page.

4. Templates - for creating template regions within pages.

5. Favorites - can be customized to display just the options that you use most often.

Bootstrap

Bootstrap (https://getbootstrap.com/) is a free, open source CSS framework, which
includes a library of stylish components that you can easily incorporate into your website.

jQuery Mobile and jQuery UI

Although Dreamweaver continues to offer jQuery Mobile and jQuery UI support, those libraries
are no longer in use, so you can ignore those options.

You can drag the Insert panel below the Application bar:

This will give it a tabbed horizontal layout:
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To drag it back to the original location, click and hold the handle on the left of the panel and drag:

And remember that you can always reset the Standard layout by selecting Reset 'Standard' from the
Standard menu in the top right of Dreamweaver.

We will discuss many of the elements available in the Insert panel in detail throughout the course.

Collapse All Panels

To collapse all the panels in the right column, click the double-arrow icon shown in the image below:

Click the double-arrow icon again to re-open the panels.

You can also open and close panels individually by clicking the panel name: once to open and twice
to close.

Hiding All Panels

To completely hide all panels, press F4. Press F4 again to reshow them.

 2.6.3. Property Inspector

The Property Inspector is used to customize elements on the page. It is context-based, meaning it will
change depending on what type of object is selected. For example, if text is selected, text properties
will be visible; if an image is selected, image properties will be visible, and so on. If the Property
Inspector is not showing, select Properties from the Windows menu. It may open as a floating panel.
You can dock it at the bottom of Dreamweaver by clicking and holding the top of the panel and
dragging it to the bottom of Dreamweaver until you see a blue line:
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The screenshot below shows the options given in the Property Inspector when text is selected:

Every page element can be customized via the Property Inspector. For example, text can have a specified
font, size, and style. Images can have a specified height, width, and source. To customize an element,
select it within the Document Window (the main editing area) and make alterations via the Property
Inspector.

The Property Inspector is split into two sections: HTML and CSS. Click the HTML or CSS icons
on the left side of the inspector to switch between the two:

Note

When the CSS icon is selected and you attempt to change properties of text, Dreamweaver will
automatically create a new inline CSS rule. These rules will all be covered later in the course.

 2.6.4. Files Panel

The Files panel (shown below) keeps track of all of the files and folders within your site. It can also be
used to view and access files on a remote server:
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Right now, our Files panel is showing the Desktop, but we’ll change that soon to show the folder
containing the class files used in this course.

❋

2.7. Previewing Your Page

While you are editing a page in Design View, Dreamweaver attempts to give you a good reflection of
how the page will appear in a browser, but that’s not always possible (or even desirable). Dreamweaver
does make it easy to view your page as it will appear in the browser either from within Dreamweaver
itself or directly in one or more browsers. Live View uses Chromium Embedded Framework (CEF)
to allow you to edit and make changes while getting a live view.

 2.7.1. Real-time Preview

Before previewing a page in a browser, you must first set up your Real-time Preview preferences in
Dreamweaver:

1. Select Edit > Preferences… (Windows) or Dreamweaver > Preferences… (Mac).

2. From the Category list, click Real-time Preview:
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You may already see one or more browsers in the Browsers list.

3. To add a new browser to the list:

A. Click the plus icon ( ).
B. Fill out the resulting dialog. For example:
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4. Repeat for every browser you want to be able to test. You can add as many as you like. Your
primary and secondary browsers can be accessed with shortcut keys:

Preview in primary browser: F12 (Win) / Opt+F12 (Mac)
Preview in secondary browser: CTRL+F12 (Win) / Cmd+F12 (Mac)

5. To edit an existing browser in the list, select it and click the Edit… button.

6. To remove a browser from the list, select it and click the minus icon ( ).

7. Notice that you can change your primary and secondary browsers by checking or unchecking
the Defaults:

When you are done, your list will be exactly as you need it. You can access it from the browser icon in
the bottom right of the main window:
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Clicking one of the browser options will launch your page in that browser.

Note that each time you click one of the browser options, it will open a new browser tab. As an
alternative, you may wish to keep the page open in the browser. With Real-time Preview, the page
will update as you save changes.

There is also an option to preview your page using a temporary file instead of the actual file that you
are working on. We prefer to leave this option unchecked.

 2.7.2. Live View

Live View makes it possible to view your page as it will appear in a browser from within Dreamweaver
itself. Simply click the Live button. For simple pages, you will not see much difference between Design
View and Live View:
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Although you can make edits in Live View, most of the time, you will find it more practical to edit in
Design View.
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 Exercise 2: Previewing a Web Page
 5 to 10 minutes

In this exercise, you will modify your Real-time Preview settings (if you wish) and preview a page in
different browsers.

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. Preview the page in Live View.

3. Preview the page in one or more browsers.

4. Make some small modification to the page, save, and preview again.

❋

2.8. Setting Up a Website

Follow these steps to set up your website for this course:

1. From the Site menu, select New Site… to open the Site Setup dialog:

2. Enter “dw-class” for the Site Name and browse to the dreamweaver-cc folder within the
class files for the Local Site Folder:
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Note

You may have unzipped your class files in a different location. That is okay. Simply
select the folder path in which you saved them.

3. Click Save.

Your Files panel should now look like this:
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Open up the Exercises folder and you should see the hello-world.html file you created in the
last exercise:

 2.8.1. Pointing to Websites

When you point your browser to a website (e.g., www.google.com), the browser fetches a page from
a web server somewhere on the internet. That web server is simply a computer with some special
software on it for serving web pages and associated files (e.g., images). The server can deliver pages to
many different clients (browsers) at the same time as shown below:
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As a web developer, you may be responsible for putting your pages onto the web server. Different
organizations handle this in different ways, but one common way is via File Transfer Protocol (FTP).
We will show you how to set this up in Dreamweaver; however, in this course, we will simply view the
files locally.

To point your website to the computer hosting the web server:

1. Click the Define Servers button on the Files panel:

2. The Site Setup dialog with the Servers options open. Click the + button to add a new server:
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3. The options will change depending on how you connect to your website (e.g., FTP,
Local/Network, WebDAV, RDS):

4. Normally, you would click Save to save the configuration. You would then be able to send
files back and forth between your computer and the server. But for our purposes, you can
cancel out of these dialog boxes as we will not need to connect to a web server for this course.

LESSON 2: Getting Started with Dreamweaver | 31



Connect to a Publishing Server

For detailed information on connecting to a web server, see Adobe Help: Connect to a
publishing server (https://helpx.adobe.com/dreamweaver/using/connect-remote-
server.html).

❋

2.9. Edit Preferences

As we saw when setting our preview browsers, you can edit preferences in Dreamweaver through Edit
> Preferences… (Windows) or Dreamweaver > Preferences… (Mac). Most of the preference settings
have to do with how the code is handled behind the scenes. If you’re working in Code View, you may
find you want to make some changes. That’s fine, but our recommendation is to leave the defaults in
place until you have a clear reason to make a change.

Conclusion

In this lesson, you have been introduced to the Dreamweaver interface, set up a website, and created
and previewed your first web page.
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LESSON 3
Creating HTML Pages

Topics Covered

 HTML DOCTYPEs.

 Adding a document title.

 Headings, paragraphs, and blockquotes.

 Line breaks.

 Special characters.

Introduction

In this lesson, you will begin adding simple content to an HTML page.

❋

3.1. Creating a New Page

When you choose to create a new HTML document via CTRL+N or File > New…, you get the
following New Document dialog:
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To start with a basic blank HTML page, you should select HTML for the Document Type and enter
whatever title you want for you page (more on the title soon). For the Doc Type, you should stick
with HTML5, unless otherwise instructed by a manager or site administrator.

❋

3.2. Adding a Title to Your Page

The title of an HTML page does not show up on the page itself, but it is important to include for a
few reasons:

1. The title shows up on the browser tab as shown below making it easy for users to navigate
between tabs:
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2. Search engines often present the document title (also known as the page title) as the heading
of a search result:

3. The title could play a factor in the search results themselves as it gives Google and other search
engines a good idea of what the page is about.

In Dreamweaver, you can add or change the document title in the Document Title field on the
Property Inspector:

Don’t ever leave “Untitled Document” as your document title.

Let’s add a title to dreamweaver-cc/Exercises/hello-world.html:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. Place your cursor in the Document Title field in the Property Inspector and type “Hello
World”:

3. Save your page.
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4. Preview the page in your browser (File > Real-time Preview). You should see the title on the
tab heading:

❋

3.3. Paragraphs, Headings, and Blockquotes

 3.3.1. Paragraphs

The paragraph is the default format for a block of text. Just like in a word processor, when you press
Enter at the end of one paragraph, Dreamweaver begins a new paragraph.

To illustrate let’s add a paragraph to dreamweaver-cc/Exercises/hello-world.html:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. Place your cursor at the end of the first line of text and press Enter (Return on a Mac2).

3. Type the following:

The text "Hello world!" is very often used in the first exercise of programming
classes.

4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). It should appear as follows:

2. If you’re using a Mac, when the instructions say “press Enter”, you should press Return.
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 3.3.2. Headings

HTML supports six levels of headings. Heading 1 is the most important and Heading 6 is the least
important. Like paragraphs, headings are block-level elements, meaning that they affect the whole line
of text (or multiple lines if the heading is long enough to wrap). Later in the course, we’ll see how you
can control the look of headings, but by default, they are bold and the size of the text changes based
on the heading level:
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There are several ways to add headings in Dreamweaver, but the most common is to use the Property
Inspector. To illustrate:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. Place your cursor anywhere in the first paragraph (i.e., the “Hello World!” paragraph).

3. Select “Heading 1” for the Format in the Property Inspector:

4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). It should appear as follows:

Paragraphs after Headings

To add a new paragraph after a heading, place the cursor at the end of the heading text and press
Enter.
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 3.3.3. Blockquotes

Blockquotes are used to designate quoted blocks of text. In Dreamweaver, blockquotes are added by
clicking the Blockquote icon in the Property Inspector:

To remove the blockquote, click the Remove Blockquote icon to the left of the Blockquote icon:

To illustrate let’s add a blockquote to dreamweaver-cc/Exercises/hello-world.html:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. At the end of the first paragraph under the heading, type “According to wikipedia:”

3. Press Enter to add a new paragraph.

4. Open dreamweaver-cc/Exercises/hello-world-blockquote.txt in Dreamweaver
from the Files panel and copy all the text by selecting it all, right-clicking, and selecting Copy:

5. Switch back to the hello-world.html file and paste the text into the new paragraph you
added.
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6. With the cursor in the new paragraph, click the Blockquote icon in the Property Inspector.

7. Save your page.

8. Preview the page in your browser (File > Real-time Preview). It should appear as follows:

Blockquotes are for Quotes

Dreamweaver users often use blockquotes incorrectly as a quick and dirty way of indenting
paragraphs. You should not do this. Blockquotes should only be used to indicate that the content
is taken from another source. The proper way to indent paragraphs for formatting purposes is
to use CSS, which we will get to later in the course.
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 Exercise 3: Adding Content to Your Page
 15 to 25 minutes

In this exercise, you will add content to your web page.

1. Create a new HTML page and save it as index.html in your Exercises folder.

2. Add content so that your web page will look like this in the browser:

3. Save your page and open it in the browser. Does it look like the screenshot above? If not, go
back to Dreamweaver and fix it.

❋

3.4. Breaks

As we have discussed, when you press Enter in Dreamweaver, a new paragraph gets added. In some
cases, you may want a new line to appear within a paragraph. In HTML, this is called a break. In
Dreamweaver, you can add a break by pressing Shift+Enter.
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Use Breaks Sparingly

Breaks should be used only for content such as poems or addresses. They are very often mistakenly
used for formatting purposes only, use CSS alternatives to layout your basic content.

❋

3.5. Special Characters

Special characters (i.e., characters that do not show up on your keyboard) can be added to your pages
by choosing Insert > HTML> Character . If you do not see the character you are looking for - Insert
> HTML> Character > Other… will allow you to choose more symbols:
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 Exercise 4: Adding Breaks
 10 to 15 minutes

In this exercise, you will make some modifications to the index.html page.

1. Open dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s not already open.

2. Modify the page so it will look like this in the browser:

3. Save your page and open it in the browser. Does it look like the screenshot above? If not, go
back to Dreamweaver and fix it.

Conclusion

In this lesson, you have learned to add paragraphs, headings, blockquotes, and line breaks to your pages.
You have also learned to add special characters.
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LESSON 4
Links

Topics Covered

 Text links.

 Absolute and relative paths.

 Targeting new windows with your links.

 Email links.

 Naming locations on a page.

Introduction

The “HT” in HTML stands for HyperText. HyperText is text that, when clicked, can take the user
to other content. So, what makes HTML HTML is the fact that the pages can contain links. In this
lesson, you will learn how to create them.

❋

4.1. Adding Links

Dreamweaver makes adding links easy. Simply highlight the text that you want to turn into a link and
enter the link URL into the Link field in the Property Inspector.

To illustrate let’s add a link to dreamweaver-cc/Exercises/hello-world.html:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver if it’s not already
open.

2. Highlight the text “wikipedia”.

3. In the Link field in the Property Inspector, enter:

https://en.wikipedia.org/wiki/Hello_World_program
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4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). The page should look like this:

6. Notice that when you hover over the link, the cursor turns to a pointer and the browser shows
the URL to which the link points.
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7. Click the wikipedia link. It should take you to Wikipedia’s page entitled "Hello, World!"
program.

❋

4.2. Absolute vs. Relative Paths

Read Carefully!

Read this section slowly. It’s important to understand absolute and relative paths, not just for
links, but for images and for CSS pages as well.

 4.2.1. Absolute Paths

An absolute path shows the complete path to a file starting from the web root. What does this mean?
Consider the following directory tree:

Assume that the wwwroot folder is the web root on the example.com website. This means that when
a user navigates to https://www.example.com/index.html, the index.html page within the
wwwroot folder will be downloaded to the browser. The absolute path to the web root from a page on
the same domain (meaning another page on example.com) is simply a forward slash (/).

Using an absolute path, a link to company.html would include the about directory, like this:
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<a href="/about/company.html">About Our Company</a>

This same link could be placed on any page in any folder below the wwwroot folder or on any page in
the wwwroot folder itself.

External Links

When linking to a page on a different website you must identify the location of the domain using the
domain name (or IP address) of the site. To illustrate, assume that the directory structure shown above
is found at https://www.example.com. The path of a link to company.html from another site would
be written like this: https://www.example.com/about/company.html.

 4.2.2. Relative Paths

Relative paths can only be used to link to other files under the same web root, meaning you cannot
use a relative path to link to a page on another website. A relative path indicates where a file is relative
to the file that contains the link. The folder (also called a directory) that contains the file being worked
on is called the current directory. The relative path to another file that is also in the current directory is
just the name of that file. For example, since company.html and contact.html are found in the same
directory, they can link to each other simply by specifying the file name.

The relative path to a file in a subdirectory of the current directory must include the name of the
subdirectory. For example, to link to company.html from index.html you must first point to the
about directory, like so: about/company.html.

The relative path to a file in a directory above the current directory should begin with ../. For example,
the following shows the path of a link to index.html from company.html: ../index.html. In an
HTML link, that would look like this:

<a href="../index.html">Home</a>

This says “Go up one folder and then look in that folder for index.html.

 4.2.3. Default Pages

The web server administrator can set up default page names to look for when a path ends with a
directory name without specifying a file. Often these files are called index.html. In this case, the
following URLs would be identical, all loading index.html:
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https://www.example.com

https://www.example.com/

https://www.example.com/index.html

You can give this a try by visiting those pages at example.com, which is an actual website used for
demonstrating just this sort of thing:

❋

4.3. Quick Tricks for Adding Links in Dreamweaver

Dreamweaver provides some neat tools for quickly adding links.

 4.3.1. Point to File

1. Highlight the text that will become a link.

2. Click and hold the Point to File icon in the Property Inspector.

3. Drag the mouse over to the Files panel and point to the file you want to link to.
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 4.3.2. Browse for File

1. Highlight the text that will become a link.

2. In the Property Inspector, click the folder icon:

3. The Select File dialog will open. Navigate to and select the file you want to link to. The dialog
includes a Site Root button, which will take you directly to your website root:

 4.3.3. Right-click

Right-click the text you want to turn into a link and select Make Link:
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Then, navigate to and select the file you want to link to.
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 Exercise 5: Adding Links to Your Page
 15 to 25 minutes

In this exercise, you will create new pages and add links to them from the home page. The site structure
is shown below:

1. Create the following new pages and save them in dreamweaver-cc/Exercises. Add titles
and level-one headings to each page:

A. Races as Races.html

B. Calculator as Calculator.html

C. Running Log as RunningLog.html

D. My Account as MyAccount.html

E. Log out as Logout.html

2. Open dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s not already open.

3. Add the following links:

A. Home: index.html
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B. Races: Races.html

C. Resources: Resources.html

D. Calculator: Calculator.html

E. Running Log: RunningLog.html

F. My Account: MyAccount.html

G. Log out: Logout.html

4. Save your page and open it in the browser.

5. Test your links. Do they work?

If everything worked and you have more time, link the content below “Runners Home is dedicated to
providing you with:”:

1. the most up-to-date information on running races: Races.html

2. the best resources for runners: Resources.html

❋

4.4. Targeting New Tabs

Sometimes it is desirable for a link to open in a new tab or window, so that the page with the link does
not get replaced. Dreamweaver provides a Target field in the Property Inspector for this purpose.
This Target field remains inactive until the Link field is filled in, at which point it gives you the options
shown in the screenshot below:

The _parent, _self, and _top values apply to framesets and should not be used (unless you are
designing with framesets, which you probably shouldn’t be).
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The _blank and new values will both direct the linked page to open in a new window. The difference
is that all links that target _blank will spawn new windows, whereas a link targeting new will open a
new window and name it “new.” As long as that window remains open, all future links targeting new
will open in that same window. In fact, new is an arbitrary target name. You will get the same behavior
with any target name other than the four reserved names: _blank, _parent, _self, and _top.

Warning

As a rule of thumb, if you’re going to have links open in new tabs, we would use a named target
rather than the generic _blank, so that the user doesn’t get inundated with new tabs.

As an even more important rule of thumb, we would avoid targeting new tabs/windows altogether.
Some websites do this so that the linked page will not replace their web page, but it is bad design.
Generally, you do not want to surprise your users, who are accustomed to clicking the Back
button to get back to a page they were just on. When a link opens in a new tab or window, users
cannot click the Back button to get back to your page. Instead, they have to know to go back
to the tab that your page is on, making it even more difficult to get back to your page. An
exception would be when you are quite certain that the user wants to stay on your page because
they are following a setup guide or a tutorial. In this case, it can be helpful to target new tabs,
so that the user can easily toggle back and forth between the instructions they are following and
the linked pages.

❋

4.5. Email Links

Email links are used to open an email client to start a new email message. The value you enter in the
Link field must begin with mailto: and end with an email address. For example:
mailto:paul@example.com. If you add that via the Property Inspector, you would do it like this:

You can also add an email link by selecting Insert > HTML> Email Link, and then filling out the
resulting dialog:
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Here you do not need to include the mailto: prefix. Dreamweaver knows it’s an email link, so it will
add it for you.

If you select the text you want to turn into an email link before selecting Insert > HTML > Email
Link then that text will show up in the Email Link dialog. Otherwise, you must type in the text in
the dialog and Dreamweaver will add it to the page at the point where the cursor is.

It is good practice to include the email address as the text of the link, so that people who are printing
the page or whose setup does not support email links can see the actual email address. For example:
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 Exercise 6: More on Links
 10 to 15 minutes

In this exercise, you will add an email link and change a link to open in a new window.

1. Open dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s not already open.

2. Change the link to Calculator.html so that page opens in a new window.

3. Add text to the footer that reads “Contact us at info@runners-home.com.” Make
info@runners-home.com an email link.

4. Save your page and open it in the browser.

5. Test your links. Do they work?

❋

4.6. Targeting a Specific Location on the Page

Sometimes, it’s nice to provide links directly to spots on a page. You can do so by targeting an element
by its id.

Every HTML element can take an id attribute, which uniquely identifies that element on the page.
You can add an id to an element in the Property Inspector:

The value of the id attribute must not contain any whitespace.

To target a specific element on the page, the link’s href value should point to that element’s id attribute
prefaced with a number sign (also known as a hash mark).

For example, assume you have an <h2> tag with the id of “john”:
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<h2 id="john">John Lennon</h2>

Here is what that would look like in the Property Inspector:

To target that location, the link would look like this:

<a href="#john">Read about John</a>

Here is what that would look like in the Property Inspector:

You can also link to locations on other pages:

<a href="about.html#john">Read about John</a>

Here is what that would look like in the Property Inspector:

You can event target locations on pages on other websites:

<a href="https://www.example.com/about.html#john">Read about John</a>

In this case, you would enter https://www.example.com/about.html#john as the Link value in
the Property Inspector.
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The “top” Keyword

To link back to the top of a page, you can use #top. You do not have to give any element an id of
“top” for this to work. Browsers know that “top” references the top of the page.
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 Exercise 7: Adding Anchors
 15 to 25 minutes

In this exercise, you will add named locations to Anchors.html.

1. Before starting, open dreamweaver-cc/Solutions/Anchors.html in your browser and
test the links to see how the page should work.

2. Now open dreamweaver-cc/Exercises/Anchors.html in Dreamweaver.

3. Add ids to each story title heading:

A. POOH GOES VISITING
B. A MAD TEA-PARTY
C. THE NAUGHTY BOY

4. Make the story names at the top of the page link to the stories.

5. At the bottom of the page, you’ll see the following text: “The link element.” Make that text
a link to the “the-link-element” id on https://www.w3.org/TR/html52/document-
metadata.html.

6. Save your page and open it in the browser.

7. Test your links. Do they work?

Conclusion

In this lesson you have learned to create text links, to work with absolute and relative paths, to target
new windows, to create email links, and to create and link to named locations.
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LESSON 5
Images

Topics Covered

 Adding images to a page.

 Image links.

 Accessibility attributes.

Introduction

Modern browsers support several types of images, including:

Graphics Interchange Format (GIF)
Joint Photographic Expert Group image (JPEG)
Portable Network Graphics (PNG)
Scalable Vector Graphics (SVG)
Web Picture format (WebP)

WebP is generally the best choice for both image quality and compression and is supported by Chrome,
Edge, Firefox, Opera, and Safari. However, they are not supported by Internet Explorer and there are
fewer tools available for creating and editing them. So, it is still common to use JPEG for photographs
and PNG for drawings.

❋

5.1. Inserting Images

To add an image place the cursor where you want the image to appear and do one of the following:

Select Insert > Image:
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Click the image icon in the Insert panel. Depending on where that panel is docked, the image
icon may be followed by “Image”:

The Select Image Source dialog will open so you can navigate to the image you want to insert.

As with links, this dialog gives you the option of jumping right to your website root by clicking the
Site Root button:

As an alternative to browsing to the image, you can drag an image from the Files panel to the location
on your page where you want the image to appear:
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 5.1.1. Alternate Text

Images should always include alternate text describing the image. The alternate text is displayed…

1. When the user’s browser does not support images.

2. As the image is downloading.

3. When the user hovers over the image with the mouse (in some browsers).

Most importantly, alternate text is used by screen readers to describe an image for the visually impaired.

You add alternate text in the Alt field in the Property Inspector:

In addition to the Alt field, the Property Inspector for images includes fields for setting and changing
the image source (Src), link URL (Link), title (Title), and width (W) and height (H).

When you insert an image, Dreamweaver automatically sets the width and height to the actual
dimensions of the image (in pixels). In most cases, you should not change this setting. If one of the
values is different from the actual dimension, a Reset icon appears:

Click that icon to reset the image dimensions.
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The Title field is used to set a title for the image. Including a title results in a tooltip in many browsers:

The Ps icon will open the image in Photoshop if you have it installed. You can change the tool
Dreamweaver will use to edit images by going to Edit > Preferences (Windows) or Dreamweaver >
Preferences (Mac) and setting the editors for different file types in the File Types / Editors category.

We will discuss ID and Class when we discuss CSS later in the course.

 5.1.2. Preview in Code View

When you are in Code View, you may want to get a quick preview of an image without switching to
a different view. To do so, hover over the source of the image and the preview will pop up:

❋
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5.2. Image Links

Turning an image into a link is simple:

1. Select the image.

2. Add the link in the same way you would with text selected.

Some browsers will place a blue border around a linked image to indicate that the image is a link. Using
CSS you may remove this border.
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 Exercise 8: Adding Images to Your Page
 15 to 25 minutes

In this exercise, you will add images to your page.

1. Open dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s not already open.

2. Add dreamweaver-cc/Images/RunnersHome.png to the home page after the level-one
heading and set the alternate text to “Logo”.

3. Replace “Contact us at info@runners-home.com.” in the footer with the dreamweaver-
cc/Images/Email.png image. Make the image an email link to info@runners-home.com
and set the alternate text to “Email info@runners-home.com.”

4. Save your page and open it in the browser.

When you are done, your page should look like this:

Make sure your email link works.
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Also, as an extra little challenge, add a trademark symbol (TM) after the “Welcome to Runners Home”
heading. This is a special character.

Conclusion

In this lesson, you have learned to add images to your pages and to link those images to other pages as
simple links.
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LESSON 6
Lists

Topics Covered

 Unordered lists.

 Ordered lists.

 Nested lists.

 Definition lists.

Introduction

HTML provides three types of lists:

1. Unordered Lists – used to create lists in which the order of the list items is not important
(e.g., a grocery list or a list of people in a group).

2. Ordered Lists – used to create lists in which the order is important (e.g., a recipe or setup
instructions).

3. Definition Lists – used to create lists containing terms and definitions (e.g., a dictionary or
glossary).

In this lesson, we will learn how to create all three.

❋

6.1. Ordered and Unordered Lists

Creating ordered and unordered lists in Dreamweaver is simple using the list icons in the Property
Inspector:
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To see how lists are added:

1. Open dreamweaver-cc/Exercises/Anchors-list.html in Dreamweaver.

2. Place the cursor on the line with the three linked story titles.

3. Click the Unordered List icon in the Property Inspector. Your page should appear as follows:

4. Place the cursor at the end of “Pooh Goes Visiting” and delete the dividing bar (called a pipe)
and the spaces around it:

5. Press Enter:
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6. Place the cursor at the end of “A Mad Tea-Party,” delete the dividing bar and surrounding
spaces and press Enter:

7. To add another bullet at the end of the list, place the cursor at the end of “The Naughty Boy”
and press Enter and type a story name:

8. You can add additional bullets by typing story names and pressing Enter just as you would
in a typical Word processing tool.

You create ordered (or numbered) lists in the same way. In step 3 above, you would click the Ordered
List icon instead of the Unordered List icon.

Creating a List from Scratch

To create an ordered or unordered list from scratch, simply start a new paragraph and press the
appropriate list icon in the Property Inspector.

 6.1.1. Nesting Lists

Unordered and ordered lists may be nested any number of levels deep. To see how to add a nested list:

1. Open dreamweaver-cc/Exercises/nested-list.html in Dreamweaver.

2. The page is currently empty. Type “Grocery List” and make it a Heading 1.
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3. With the cursor below the heading, begin an unordered list by clicking the Unordered List
icon in the Property Inspector.

4. Type “Fruit” and press Enter:

5. To create your nested list, press Tab (or click the Indent icon on the Property Inspector)
and type “Apples”, Enter, “Pears”, Enter, “Bananas”, Enter:

6. There are multiple ways to get back to the parent list:

A. Press Enter again.
B. Press Shift+Tab.
C. Click the Outdent icon in the Property Inspector.

7. Type “Meat” and press Enter:
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8. Continue with your list until it looks like this:

9. To get out of a list, make sure the cursor is at the very end of the last item in the list and press
Enter twice.
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 6.1.2. Converting Lists

To convert an unordered list to an ordered list (or vice versa), click somewhere within the list (or sublist)
and then click the appropriate list icon in the Property Inspector.

❋

6.2. Definition Lists

Definition lists, which are used less frequently than unordered and ordered lists, are used to create lists
containing terms and definitions. Dreamweaver does not provide a way to create them using the
Property Inspector.

In Dreamweaver:

1. Select the location to place the list.

2. Select Edit > List > Definition List.

3. Enter the list items. Press Enter after the term, then type the definition. Repeat as needed
until all terms and definitions are entered.

To see how a definition list is added to a page:

1. Open dreamweaver-cc/Exercises/definition-list.html in Dreamweaver.

2. The page is currently empty. Type “Abbreviations” and make it a Heading 1.

3. With the cursor below the heading, begin a definition list choose Edit > List > Definition
List. You will not notice any change on the page, but if you look at the Tag Inspector on the
bottom left, you will see this:

This indicates that you are in a definition term (dt) within the definition list (dl).

4. You will create a list of definitions of the different HTML list types (ol, ul, and dl:

Type ol and press Enter.

Type Ordered List and press Enter.
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Type ul and press Enter.

Type Unordered List and press Enter.

Type dl and press Enter.

Type Definition List and press Enter .
Press Enter again to exit the list.

The page should look like this:

The display of definition lists is a little odd, but, if you learn CSS well, you will be able to change the
display to look like the page below (or however else you like):

dreamweaver/Demos/definition-list-styles.html
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 Exercise 9: Creating Lists
 15 to 25 minutes

In this exercise you will create a new page that looks like this:

1. Create a new page and save it as RunningTerms.html in dreamweaver-cc/Exercises.

2. Add the title and heading level 1.

3. Create the list of links at the top. Here are the links:

Home: index.html

Races: Races.html

Resources: Resources.html

Calculator: Calculator.html

Running Log: RunningLog.html

My Account: MyAccount.html

Log out: Logout.html
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4. Add the definition list below the navigation menu.If you do not want to type the whole list
out, you can grab the content from dreamweaver-cc/Exercises/RunningTerms.txt;
however, do not copy and paste the whole thing at once as that will add a bunch of unwanted
paragraphs. Rather, copy and paste each term and definition as needed.

5. Save your page and open it in the browser. Does it look right?

❋

6.3. Converting Existing Content to Lists

Converting existing content to lists in Dreamweaver can be tricky. The easiest way to see this is to
illustrate with an example. Our end goal is a list that looks like this:

1. Open dreamweaver-cc/Exercises/groceries.html in Dreamweaver.

2. Open dreamweaver-cc/Exercises/groceries.txt and copy and paste its entire content
into groceries.html:
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3. Highlight everything you just pasted in and click the Ordered List icon in the Property
Inspector:

4. Now we want to turn the actual food items into sublists. Select the three fruit items like this:
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And press Tab.

5. That didn’t work, did it? Your list probably looks like this:

6. Undo using Edit > Undo Indent or by pressing CTRL/CMD+Z.

Here’s the problem: those breaks that move the names of the food items to the next lines are line
breaks not new paragraphs. The content that comes after them (i.e, the fruit item names) are considered
part of the “Fruit” list item. So you cannot indent the individual items without indenting the “Fruit”
list item as well.

The solution is to delete the line breaks:

1. Place the cursor immediately before the letter “A” in “Apples” and press Backspace until
“Apples” is on the same line as “Fruit”:

2. Press Enter to create a new list item:
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3. Do the same thing with “Pears” and “Bananas” and then select all three fruit:

4. Press Tab. That should have worked:

5. Now we can covert the sublist to an unordered list by highlighting all three fruit names and
clicking the Unordered List icon in the Property Inspector:

Try fixing the other two sublists as well.
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Fixing Lists

When working with nested lists, if things get messed up, usually the easiest thing is to get rid of
the list and start over. To remove a list, highlight the whole thing and click the outdent icon in
the Property Inspector repeatedly until all lines are nested against the left border.
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 Exercise 10: Converting Content to a List
 15 to 25 minutes

In this exercise you will modify Resources.html, which currently looks like this:

Notice that it contains a list of resources. Although the order may not matter, it would be nice to be
able to refer to a resource by number, so let’s make the list a numbered (i.e., ordered) list. Each resource
has some related information, which could be represented in a nested list:

The date it was posted.
A description.

Modify the page to look like this:
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1. Open dreamweaver-cc/Exercises/Resources.html in Dreamweaver.

2. Modify the page so that it appears as shown in the second screenshot above.

3. Save your work and open your new page in a browser to test it.

Conclusion

In this lesson, you have learned to create and work with unordered, ordered and definition lists.
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LESSON 7
Tables

Topics Covered

 Creating and Modifying tables.

 Merging cells horizontally and vertically.

 Sorting tables.

 Importing data into tables from spreadsheets.

Introduction

HTML Tables are quite cumbersome to hand code, but Dreamweaver makes it easy to add and modify
them. In this lesson, you will learn how.

❋

7.1. Adding a Table to Your Page

To add a table to your page, place the cursor where you want the table to appear and do one of the
following:

Select Insert > Table:

Select Table from the Insert panel. Depending on where that panel is docked, the table icon
may be followed by “Table”:
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Either option will open the Table dialog:

In the Table dialog, you enter:

1. Rows and Columns. The number of rows and columns you want for your initial table. Rows
and columns can be added to and removed from the table later.
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2. Header: Whether you want a header row, header column, or both.

3. Caption: The caption, if you want one. This is unformatted by default, but can be formatted
with CSS.

You should leave all of the following fields blank as they are no longer part of the HTML specification.
Most of them were used for formatting purposes, and formatting should always be done with CSS:

1. Table width

2. Border thickness

3. Cell padding

4. Cell spacing

5. Summary

Let’s add a table to a page:

1. Open dreamweaver-cc/Exercises/table.html in Dreamweaver.

2. Place the cursor in the empty paragraph after the “Employees” heading.

3. Select Insert > Table.

4. Fill out the Table dialog as shown below:
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5. Click OK. Your page should look like this:

In Design View, when the table is selected, Dreamweaver provides table menus (the green
lines, arrows, and text above the table) to help you understand and modify the table. These
will not appear on the page when viewed in the browser.
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6. If you have trouble placing the cursor in the small cells, you can enter Expanded Tables Mode
by right-clicking the table and selecting Table > Expanded Tables Mode:

The table will then look like this:
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To exit Expanded Tables Mode, click the [exit] button at the top.

7. Now fill out the table as shown below. You can use Tab, Shift+Tab, and the arrow keys to
navigate between cells:

Note that this screenshot is not in Expanded Tables Mode.

8. Save the page and leave it open.

Heading Rows

Notice that the data in the first row is bold and centered. That’s because it is a heading row. You
can change any cell to or from a heading row in the Property Inspector by checking or
unchecking the Header field:
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Do NOT change cells to table headers for formatting purposes alone. Only actual headers should be
marked as headers.

❋

7.2. Sorting Tables

Dreamweaver allows you to sort tables as long as they do not have merged cells. To sort a table:

1. Place the cursor anywhere within the table to be sorted.

2. Select Edit > Table > Sort Table:

3. The Sort Table dialog will pop up:
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4. Select the first column you want to sort by, the sort method (Alphabetically or Numerically),
and the sort direction (Ascending or Descending).

5. If you want a secondary sort, fill out the Then by fields as well.

6. Check the appropriate Options. Generally, you will leave them all unchecked.

7. Click OK.
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 Exercise 11: Table Sorting
 5 to 10 minutes

In this exercise, you will practice sorting a table.

1. Open dreamweaver-cc/Exercises/table.html in Dreamweaver if it is not already open.

2. Sort the table by Name.

3. Now sort the table by Phone to get it back to the way it was.

❋

7.3. Modifying Tables

After inserting the table, it is likely that you will want to make changes. Dreamweaver makes it easy to
do so.

 7.3.1. Inserting Rows

There are several methods of inserting rows into a table.

Method 1: Right-click

1. Right-click in any cell in the row below which you want to insert a new row.

2. Select Table > Insert Row:
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Method 2: Edit Menu

1. Place the cursor in any cell in any row in the table.

2. From the Edit menu, select Table > Insert Row:

Method 3: Keyboard Shortcut

1. Place the cursor in any cell in the row above which you want to insert a new row.

2. Press CTRL+M.

Method 4: Tab

To insert a row at the very bottom of the table:
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1. Place the cursor in the last cell of the bottom row.

2. Press Tab.

 7.3.2. Inserting Columns

Some of the same methods are available for inserting columns:

1. Right-click – Right-click in any cell in the column after which you want to insert a new
column. Select Table > Insert Column.

2. Edit Menu – Place the cursor in any cell in any column in the table. From the Edit menu,
select Table > Insert Column.

3. Keyboard Shortcut – Place the cursor in any cell in the column before which you want to
insert a new column. Press Ctrl+Shift+A (Windows) / Cmd+Shift+A (Mac).

The Column Header Menus

Another way to insert columns is to use the column header menus:

1. Click the Table Column menu above any column.

2. Select Insert Column Left or Insert Column Right:

 7.3.3. Inserting Multiple Rows or Columns at One Time

1. Right-click in any cell in the table before or after which you want to insert columns or rows.

2. Select Table > Insert Rows or Columns…:
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3. Fill out the Insert Rows or Columns dialog and click OK:

 7.3.4. Merging Cells

There are several methods of merging cells in Dreamweaver. Each method begins by selecting the cells
you would like to merge by clicking one cell and dragging the mouse over additional cells.

Method 1: Right-click

1. After selecting the cells to merge, right-click and select Table > Merge Cells:
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2. Note that the content of the merged cells also merges, so in this case, we would delete the
second number (assuming that Daffy is now sharing Tweety’s number):

Method 2: Property Inspector

1. Make sure that the Property Inspector is expanded. The arrow in the bottom right of the
Property Inspector should be pointing up. If is pointing down, click it:

2. After selecting the cells to merge, click the Merge Cells icon in the Property Inspector:

Method 3: Keyboard Shortcut

1. After selecting the cells to merge, press Ctrl+Alt+M (Windows) / Cmd+Option+M (Mac).

 7.3.5. Splitting Cells

There are several methods of splitting a cell in Dreamweaver. Note that the last step for each method
is to fill out the Split Cell dialog and click OK:
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Method 1: Right-click

1. Place the cursor in the cell to split, right-click, and select Table > Split Cell…:

Method 2: Property Inspector

1. Make sure that the Property Inspector is expanded.

2. Place the cursor in the cell to split, click the Split Cells icon in the Property Inspector:

Method 3: Keyboard Shortcut

1. Place the cursor in the cell to split and press Ctrl+Alt+S (Windows) / Cmd+Option+S (Mac).
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 Exercise 12: Converting a List to a Table
 15 to 25 minutes

In this exercise, you will change the list on Resources.html to a table that looks like this:

1. Open dreamweaver-cc/Exercises/Resources.html in Dreamweaver.

2. Modify the page so that it appears as shown in the screenshot above. A couple of notes:

A. You will modify some of the content in the first column.
B. The first cell under the Date heading is merged across two rows.

3. To style the table, you will attach a CSS file to this page. This will give you a feel for the power
of CSS.

A. From the top Tools menu, select CSS > Insert Style Sheet…

B. The Attach Existing CSS File dialog will open:

Click the Browse button and browser to styles.css in the Solutions folder.
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C. Leave Link selected.
D. Click OK:

4. Save your work and open your new page in a browser to test it.

❋

7.4. Importing Data into Tables

Dreamweaver makes it possible to import data from external files saved as CSVs (comma-separated
values). Such data most often comes from spreadsheets.

Let’s give it a try:

1. Open dreamweaver-cc/Exercises/sales-report.html in Dreamweaver.

2. Place the cursor in the empty paragraph after the “Sales Report” heading.

3. Select File > Import >Tabular Data:
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4. Fill in the Import Tabular Data dialog as shown below:

Data file: Browse to the Sales_Report.csv file, which is in the same directory as
the sales-report.html file you are working on.
Delimiter: Leave as Comma.
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Table width: Fit to data.
Format top row: [No Formatting]

Clear the following fields as they are all deprecated in HTML, meaning that they
are not supposed to be used anymore:

1. Cell padding

2. Cell spacing

3. Border

5. Select the top row of the table by hovering over its left-most border until the cursor changes
to a solid right arrow and then clicking:

6. Click the Header check box in the Property Inspector:

7. Save your file and preview it in the browser. Your table should look like this:
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Don’t worry that it is unstyled. We will get to that.

❋

7.5. Dreamweaver and Styling Tables

Dreamweaver provides options for formatting tables using the Property Inspector. It lets you:

1. Set background colors for the table rows and cells.
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2. Set the width and height of columns and rows.

3. Change the horizontal and vertical alignment of cells.

However, behind the scenes, Dreamweaver uses deprecated (removed from the HTML language)
attributes to do all these things, which is really too bad. While some browsers still support these
deprecated attributes, not all do, and in the future they may not. So, you should avoid using the
Property Inspector to format tables. We will show you how to format tables with CSS soon.

Conclusion

In this lesson, you have learned to create and modify HTML tables.
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LESSON 8
Styling Content

Topics Covered

 CSS.

 The CSS Styles panel.

 Creating and editing CSS rules.

 Applying CSS rules to elements on the page.

 External style sheets.

Introduction

While HTML is a language for structuring web pages, Cascading Style Sheets (CSS) is the language
used for styling and laying out web pages. Although Dreamweaver provides a nice interface for working
with CSS, to use it effectively, you must understand the different ways CSS styles can be applied to
elements and pages. In this lesson, you will learn how CSS works in general and how Dreamweaver
implements it.

❋

8.1. HTML Structure

Before learning CSS, it is important to understand how HTML is structured. HTML is made up of
elements that describe the structure of the content on a web page.

 8.1.1. HTML Elements

HTML elements describe the structure and content of a web page. Tags are used to indicate the
beginning and end of elements. The syntax is as follows:

<tagname>Element content</tagname>

For example, a paragraph would be marked up as follows:
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<p>This is a paragraph.</p>

 8.1.2. Attributes

Tags often have attributes for further defining the element. Attributes come in name-value pairs:

<tagname att1="value" att2="value">Element content</tagname>

For example, an important paragraph might be marked up as follows:

<p class="important">This is an important paragraph.</p>

 8.1.3. Blocks and Inline Elements

Block-level Elements

Block elements are elements that separate a block of content. For example, a paragraph (<p>) element
is a block element. Other block elements include:

Lists (<ul> and <ol>)

Tables (<table>)

Forms (<form>)

Divs (<div>)

Inline Elements

Inline elements are elements that affect only snippets of content and do not block off a section of a
page. Examples of inline elements include:

Links (<a>)

Images (<img>)

Phrase elements (<em>, <strong>, <code>, etc.)

Spans (<span>)

106 | LESSON 8: Styling Content

EVALUATION COPY: Not to be used in class.



Strong knowledge of HTML makes working with CSS much easier, but with the basic knowledge
covered above, you should be able to get a good start with CSS.

❋

8.2. CSS Rules

CSS rules are statements that define the style of an element or group of elements. The syntax is as
follows:

selector {
property: value;
property: value;
property: value;

}

Each property: value pair is a declaration. Declarations are separated by semi-colons, and usually
put on a new line. The selector defines which elements are affected by the rule. Take a look at the
following rule:

p {
color: darkgreen;
font-family: Verdana;
font-size: 10pt;

}

This rule specifies that all paragraph text should be dark green and use a 10-point Verdana font.

Adding Your First Rule

To see how to add rules in Dreamweaver:

1. Open dreamweaver-cc/Exercises/hello-world.html in Dreamweaver in Design View.
This is a file you created earlier in the course. If you don’t have it still, you can use
dreamweaver-cc/Exercises/hello-world-css.html instead.

2. Place the cursor in the first paragraph under the heading.

3. Open the CSS Styles panel if it is not already open (Window > CSS Designer):
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4. Add a new source by clicking the + button to the left of Sources and selecting Create a New
CSS File:

This will create a link from the HTML page to a new CSS file, in which you can define CSS
rules that style the HTML page.
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5. Name the source styles.css and click OK:

This will put the CSS file in the same folder as the HTML file. If you want to put it somewhere
else, you can use the Browse button to browse to a different location. styles.css is a
common name for a general CSS file. Sometimes, site designers like to have several different
CSS files that each serves it’s own purpose, but for starters, we recommend putting all your
rules in a single CSS file to keep things simple. You can always separate them into different
files later if you have a reason to do so.

6. Switch to Split View:
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Notice this tag:

<link href="styles.css" rel="stylesheet" type="text/css">

That is the tag that got added when you created a new CSS file by adding a source in the CSS
Designer. It tells the browser that this HTML page should be styled according to the CSS
rules defined in styles.css.

7. Switch back to Design View.

8. Make sure the new .css file is selected and add a new selector:

9. In the selector field, type p and then select p:

This creates a new rule for styling paragraphs.

10. Now, you need to define the properties for the new rule:
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A. Make sure the p selector is selected under Selectors.
B. If Show Set is checked, uncheck it.
C. Click the bordered T icon to show just text properties.
D. Set whatever text properties you like. We’ve chosen a font family and set the color

to a shade of blue.
E. Notice the paragraphs on the page change as you add, change, and remove properties.

11. Save your file and preview it in the browser. If you get an alert like this one, it’s because your
CSS file did not get saved:

Click Yes to save the file.
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That is the basics of creating CSS rules in Dreamweaver. Now, let’s get a better understanding of how
those rules work.

❋

8.3. Selectors

The are several different types of selectors. The most common ones are listed below:

Type
Descendant
Class
ID

Selectors identify the element(s) affected by the CSS rule.

 8.3.1. Type Selectors

Type selectors specify elements by tag name and affect every instance of that element type. Looking
again at a previous example:

p {
color: darkgreen;
font-family: Verdana;
font-size: 10pt;

}

This rule specifies that the text of every <p> element should be dark green and use a 10-point Verdana
font.

 8.3.2. Descendant Selectors

Descendant selectors specify elements by ancestry. Each “generation” is separated by a space. For
example, the following rule states that <strong> tags within <p> tags should have red text.

p strong {
color:red;

}
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With descendant selectors, generations can be skipped. In other words, the code above does not require
that the <strong> tag is a direct child of the <p> tag.

To illustrate:

1. Return to dreamweaver-cc/Exercises/hello-world.html.

2. Place the cursor in the “wikipedia” link.

3. In the CSS Designer panel, click the Add Selector icon in the Selectors section.

4. Dreamweaver will then provide you with a descendant selector starting with the body tag:

This means that this rule will affect every a element (a elements are links) within a p element
within the body element. It will not affect a elements that are not nested somewhere within
p elements.

5. Define the selector in the Properties area. For example, make it red:

6. Now, select the word “World” in the header and make it a link to
https://en.wikipedia.org/wiki/World.

7. Notice that the link is not red. That’s because the link is not nested within a paragraph tag:
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 8.3.3. Class Selectors

In HTML, almost all elements can take the class attribute, which assigns a class name to an element.
The names given to classes are arbitrary, but should be descriptive of the purpose of the class. In CSS,
class selectors begin with a dot (.). For example, the following rule creates a class called “warning” that
makes the text of all elements of that class red, bold, and large:

.warning
{

color: #FF0000;
font-family: Impact, Haettenschweiler, "Franklin Gothic Bold", "Arial Black", sans-

serif;
font-weight: bold;
font-size: large;

}

Following are a couple of examples of elements of the warning class:

<h1 class="warning">WARNING</h1>
<p class="warning">Don’t go there!</p>

To create class selectors in Dreamweaver, you must include the dot in the name of the selector.

To illustrate how to add a class selector in Dreamweaver:

1. Return to dreamweaver-cc/Exercises/hello-world.html in Dreamweaver.

2. Place the cursor at the end of the blockquote and press Enter.

3. Click the Outdent icon in the Property Inspector to get out of the blockquote.

4. Type “Don’t forget to save your work!”
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5. In the CSS Designer panel, click the Add Selector icon in the Selectors section and type in
.warning:

6. Set color, font-family, font-weight, and font-size for the rule:

The warning class will now be available to every HTML page that has the styles.css file attached
to it. Let’s apply the class to the paragraph we just added:

1. Place the cursor in the warning paragraph you typed under the blockquote.

2. Select warning from the Class drop-down in the Property Inspector:
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3. Open the page in your browser by pressing F12. If you prompted to save, click Yes. This saves
the HTML and CSS files if they have unsaved changes.

4. The page should look like this:

It’s not beautiful, but it shows you how CSS works.
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 8.3.4. ID Selectors

As with the class attribute, in HTML, almost all elements can take the id attribute, which is used
to uniquely identify an element on the page. In CSS, ID selectors begin with a number sign (#) and
have arbitrary names. The following rule will indent the element with the “maintext” id 20 pixels from
the left and right.

#maintext
{

margin-left:20px;
margin-right:20px;

}

Here’s what the HTML element might look like:

<p id="maintext"> This is the main text of the page… </p>

To create ID selectors in Dreamweaver, you must include the number sign in the name of the selector:

 8.3.5. ID vs. Class

Again, the id attribute is used to uniquely identify an element on a page, so no two elements may use
same id.

Classes, on the other hand, can be applied to many elements on the page.

❋
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8.4. Modifying the Rule

Sometimes you will want to modify the rule after you have created it. For example, that warning class
we created is a little too standout-ish. Let’s make it less so, by changing the font-family:

1. Return to dreamweaver-cc/Exercises/hello-world.html in Dreamweaver.

2. Place the cursor anywhere in the warning paragraph.

3. In the CSS Designer panel, make sure .warning is selected in the Selectors area.

4. Check the Show Set checkbox to just show the properties already assigned to the .warning
class.

5. Click the font-family value, and from the dropdown, select the new font:

6. The page should update.
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 8.4.1. Making Sure the CSS File Saves

Beneath the file name at the top of the Document Window, you will see a line that begins with the
words “Source Code.” This line lists the source files associated with the HTML file:

Notice above that there is an asterisk next to both the hello-world.html and the styles.css file
names. That’s because the files have been changed and not saved. When you close the HTML file, you
will be prompted to save the associated files that have been changed; however, you can save them earlier
by selecting File > Save All Related Files:

The asterisks should disappear.

❋

8.5. CSS Properties

There are many CSS properties and it is beyond the scope of this course to cover each in detail. However,
we will go over them quickly and you will be able to learn a lot more on your own by exploring the
CSS Designer Properties area.

Dreamweaver breaks CSS properties into the following categories:

1. Layout – for margins, padding, height and width:
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2. Text – for styles that effect text and fonts:
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3. Border – for border size, styles, and color:
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4. Background – for background colors and images:
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5. More – for entering additional properties by hand:
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 Exercise 13: Styling a Table
 20 to 30 minutes

In this exercise, you will style some pages.

1. Open dreamweaver-cc/Exercises/table.html in Dreamweaver.

2. If you have any of the deprecated HTML properties set, you should clear them as shown in
the following screenshot:

3. Link the page to the styles.css stylesheet in the same folder by clicking the Add CSS
Source icon and choosing Attach Existing CSS File:

Or, if you don’t have that file, create a new stylesheet called styles.css by choosing Create
A New CSS File.

4. Create rules for the following:

A. All caption elements should be bold and left-aligned with white text and a dark
blue background.

B. All table headers (th) should have dark blue text and should have 4 pixels of padding
on all sides.

C. All table data cells (td) should have 4 pixels of padding on all sides.
D. All odd rows starting with the one under the table header, should have a light gray

background color (#ccc).

E. The heading 1 (h1) should be centered.

124 | LESSON 8: Styling Content

EVALUATION COPY: Not to be used in class.



F. The table should be centered. To center the table, you will need to change the left
and right margins to “auto”.

5. When you’re finished, open the page in your browser. It should look like this:
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Solution

There are different ways to accomplish this look. To compare how you did it with our solution, look
at the CSS Styles panel. In the Selectors area, you will see the selectors. Ours look like this:

And here are the properties for the different selectors:

caption
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th
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td

.odd
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h1

table

You will also need to select the odd rows in the table and set the class property to odd in the Property
Inspector.

 E13.1. Applying the Same Style Sheet to Other Pages

Style sheets that are saved as separate files can be used over and over again. To illustrate this:
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1. Open dreamweaver-cc/Exercises/sales-report.html in Dreamweaver.

2. Click somewhere in the table and then clear the deprecated HTML properties.

3. In the CSS Designer panel, click the Add CSS Source icon and choose Attach Existing CSS
File:

4. In the Attach External Style Sheet dialog, browse to styles.css in the dreamweaver-
cc/Exercises folder and click OK.

5. That should style the table. Now, let’s add an additional style. Select the last table row showing
the Grand Total and enter an id of “summaryrow”:

6. Create a rule using an ID selector that sets the background color to dark green and the font
to white and bold:
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7. View the page in the browser. The bottom row should look like this:

❋

8.6. The Cascade

Web designers can define style rules in three different places:

Where Styles are Set

1. In an external (or linked or imported) style sheet.

2. In an embedded style sheet.

3. Inline in an element.

In the examples thus far, we have been using external style sheets. This is generally the best approach
as it allows you to apply a single style sheet to an unlimited number of HTML files.

 8.6.1. Embedded Style Sheets

To create an embedded style in Dreamweaver, select Define in Page when adding a source:
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 8.6.2. Inline Styles

Inline styles are applied directly to an element within the HTML code using the style attribute. The
value of the style attribute is a list of one or more property-value pairs separated by semi-colons. The
code snippet below illustrates how inline styles are used:

<p style="color:red; font-weight:bold;">Hello, world!</p>

To illustrate how to add inline styles:

1. Open dreamweaver-cc/Exercises/sales-report.html in Dreamweaver if it’s not open
already.

2. Place the cursor in the heading 1.

3. Make sure the whole header is selected by clicking h1 in the Tag Selector in the bottom left
of the main window:

4. In the Property Inspector, click CSS, and from the Targeted Rule menu, select <New Inline
Style>:
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5. Style the heading however you want using the other options in the CSS area of the Property
Inspector. The styles will take precedence over the styles defined in the h1 rule.

Generally, you should avoid using inline styles as you will not be able to reuse them in the same
document or in others.

❋

8.7. Units of Measurement

CSS allows for the use of many different units when specifying property values such as font size, border
size, margins, etc. However, standards have been established for what units to use for different media
types. In these lessons, except where specifically stated, you will be designing for screen.

Note that units of measurement and sizing will be covered throughout these lessons. In this section,
we provide a general overview of the different units of measurement.

 8.7.1. Absolute vs. Relative Units

Absolute units have a basis in the physical world; however, their actual size on the screen depends on
the resolution and size of the user’s device. When designing for screen, it is standard to use pixels for
absolute units.

Relative units are relative to the size of other things (e.g., window size, font size, container element
size, etc.). When designing for screen, it is standard to use ems, rems, and percentages for relative units.
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 8.7.2. Pixels

Pixels are the only recommended absolute unit to be used when designing for screen. A common
practice is to use pixels to set root font sizes for different screen and window sizes. Root font sizes are
font sizes set on the html or body element. This allows for designs using mostly ems and rems to adjust
between different screen and window sizes because ems and rems are relative to font size.

 8.7.3. Ems and Rems

You should use ems and rems for almost everything when building responsive designs for screens. The
exception to this rule is height and width, which are more often defined in pixels (for absolute values)
and percentages or viewport units (for relative values). An em is the size of the font size for the current
element or the parent element. For example, if the font-size of the html element is set to 14px, then
for all elements within that html element, 1em is 14px.

Rems are similar to ems, except for one key difference. The ‘r’ in rem stands for ‘root’ because 1rem is
always equal to the root font size (the font size set for the html element) regardless of what element it
is in. This means 1rem is consistent throughout the page, while 1em is not. Both ems and rems can be
used to accomplish the same things.

The code below illustrates the difference between ems and rems:
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Demo 8.1: dreamweaver-cc/Demos/ems-vs-rems.html

<!DOCTYPE HTML>1.
<html lang="en">2.
<head>3.
<meta charset="UTF-8">4.
<meta name="viewport" content="width=device-width,initial-scale=1">5.
<link href="../normalize.css" rel="stylesheet">6.
<style>7.
/* Tighten vertical spacing of headings. */8.
h1,9.
h2,10.
h3 {11.
margin-bottom: .2rem;12.
margin-top: .2rem;13.

}14.
</style>15.
<title>Ems vs Rems</title>16.
</head>17.
<body class="webucator">18.
<h1>Using em</h1>19.
<h2 style="margin-left: 2em;">Subtitle 1</h2>20.
<h3 style="margin-left: 2em;">Subtitle 2</h3>21.

22.
<hr>23.

24.
<h1>Using rem</h1>25.
<h2 style="margin-left: 2rem;">Subtitle 1</h2>26.
<h3 style="margin-left: 2rem;">Subtitle 2</h3>27.

</body>28.
</html>29.

The code above will render the following:
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Notice that “Subtitle 1” and “Subtitle 2” do not line up in the Using em section, but do line up in the
Using rem section. This is because the ems are relative to the font sizes of their h2 and h3 elements,
while the rems are not:

2em = twice the size of the inherited font.

2rem = twice the size of the base font.

 8.7.4. Percentages

Percentages are most often used to create flexible layouts that change to fit the size of the browser
window. When specifying a value such as width or height in percentages, the percentage is relative
to the size of the containing element. For font-size, percentages work the same as ems. 100% is equal
to the inherited font size, so 100% is essentially 1em when specifying font size. It is most common to
use percentages to specify values like width and height to create “fluid” boxes that grow and shrink
to fit within the browser window.

 8.7.5. Other Units

Inches (in), centimeters (cm), millimeters (mm), points (pt), and picas (pc) are all absolute units that
are most often used when designing for print.
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You might also run into viewport units, which are relative units based on the size of the viewport (the
browser window). vw and vh specify sizes relative to the user’s viewport width and height, respectively.

1. vw is 1/100th of the viewport’s width.

2. vh is 1/100th of the viewport’s height.

3. vmax specifies size relative to whichever dimension is larger: width or height.

4. vmin specifies size relative to whichever dimension is smaller: width or height.

Viewport units are used for designing for screen, but they are not as commonly used as other screen
units, in part because the specification is not clear on how they should behave on mobile3. There are
newer units called dynamic viewport units coming, but major browsers do not yet support them4.

If you would like to play with the different CSS units to see how they compare on a screen, open
dreamweaver-cc//Demos/units-of-measurement.html (shown below) in your browser:

3. https://www.bram.us/2021/07/08/the-large-small-and-dynamic-viewports/
4. https://caniuse.com/?search=viewport%20units
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CSS Values and Units

For even more detailed information on CSS values and units see https://developer.mozil
la.org/en-US/docs/Learn/CSS/Building_blocks/Values_and_units.
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 Exercise 14: CSS Play
 15 to 60 minutes

This is an optional exercise if time allows.

1. Style the following files however you like:

A. dreamweaver-cc/Exercises/index.html

B. dreamweaver-cc/Exercises/Resources.html

C. dreamweaver-cc/Exercises/RunningTerms.html

Conclusion

In this lesson, you have learned to style your HTML pages using CSS.
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