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LESSON 1
A Quick Overview of Web Development

Topics Covered

 Client-side web development languages.

 Server-side web development languages.

Introduction

Learning HTML is the first step to becoming a web developer. But it is just one of several
languages you will need to know to create websites and web applications. In this lesson,
you will learn where HTML fits in the ecosystem of web development.

❋

1.1. HTML is Part of a Team

Before you get started writing HTML code, it’s important to understand where HTML fits
in the ecosystem of web development. Let’s first consider what happens when you visit a
website. When you type in a URL in the location bar of your browser (e.g.,
https://www.runners-home.com), the browser makes a request from the web server for a
web page. If you don’t specify the name of the file you want (e.g., contact.html or
about.html), the web server will send a default page, which is most likely called index.html,
index.php, index.cfm, or something similar. The web server returns that web page to the
browser for display. The web page may include references to other files:

Images to display on the page.

Style sheets to add formatting to the page.

Scripts to add interactivity to the page.

The browser will download these referenced files as well. To get a better feel for this, do
the following in Google Chrome:

1. As illustrated below…

A. Click the three-vertical-dot icon in the upper right of Google Chrome:
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B. Then select More tools.

C. Then select Developer tools. This will open Chrome’s Developer tools.

2. In Developer tools, select the Network tab:

3. If Developer tools isn’t docked on the bottom of the browser, move it to the bottom
to make it easier to see the Network tab information:

Developer tools should now be at the bottom of the browser:
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4. Now, in the location bar of your browser, enter https://www.runners-home.com
and press Enter:

5. After the page loads, take a look at the Network tab. You should see something
like this:
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A. www.runners-home.com – Although it doesn’t specify the page, this
represents the main page you requested: the HTML page (usually called
index).

B. toggle.js – A JavaScript page used for adding interactivity to the HTML
page. Notice in the fourth column that the initiator for this page is (index).
That means that the HTML code instructed the browser to download this
page.

C. Style sheets ending with .css – CSS pages used for adding style and
formatting to the HTML page. Like the JavaScript page, these pages were
also requested by the HTML code.

D. Images ending with .png and .jpg – Images to display on the page. The
images were also requested by the HTML code.

E. Font files ending with .woff2 – Web fonts for adding custom fonts to your
web page.

F. Though not shown in the screenshot above, you may also see favicon.ico
– An icon used to identify the website on the browser tab:
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Note that favicon.ico only gets delivered when pages are sent from a web server. When
you open files in a browser directly from your file system, the favicon will not show up.

As you can see, HTML, while essential, is just a piece of the puzzle. Web development
involves a combination of client-side-programming and server-side-programming languages.
We will now introduce the most common languages, but don’t worry if you don’t fully
understand the role of each one. At this point, the most important takeaway is that HTML
is just one of many languages used in web development.

❋

1.2. Client-side Programming

Client-side programming involves writing code that is interpreted by a browser, such as
Google Chrome or Safari, whether it be on your desktop or mobile device. The most
common languages and technologies used in client-side programming are HTML,
Cascading Style Sheets (CSS), and JavaScript.

 1.2.1. HTML

Hypertext Markup Language (HTML) is the language behind most web pages.The language
is made up of elements that describe the structure of the content on a web page.

 1.2.2. Cascading Style Sheets

Cascading Style Sheets (CSS) are used in HTML pages to format and lay out the content.
CSS rules defining color, size, positioning, and other display aspects of elements are
mixed within the HTML code or in linked external style sheets.
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 1.2.3. JavaScript1

JavaScript is used to make HTML pages more dynamic and interactive. It can be used to
validate forms, pop up new windows, create audio and video controls, and create dynamic
effects such as drop-down menus and modal dialogs.

 1.2.4. Ajax

The term Ajax was originally a pseudo-acronym for “Asynchronous JavaScript and XML,”
but is now used much more broadly to cover all methods of communicating with a server
using JavaScript.

The main purpose of Ajax is to provide a simple and standard means for a web page to
communicate with the server without a complete page refresh.

 1.2.5. JavaScript Frameworks

JavaScript frameworks are frameworks written in JavaScript that create a different approach
to web application design. Popular frameworks include Angular (https://angular.io),
React (https://reactjs.org), Vue.js (https://vuejs.org), and jQuery
(https://jquery.com). You should learn JavaScript before beginning to work with a
JavaScript framework.

❋

1.3. Server-side Programming

Server-side programming involves writing code that connects web pages with databases,
XML pages, email servers, file systems, and other systems and software accessible from
the web server. The most common server-side languages and programming frameworks
are PHP, Java Enterprise Edition, ASP.NET, ColdFusion, Node.js, and Python.

 1.3.1. PHP

PHP (https://www.php.net) is open source. It is the language behind WordPress and has
long been a popular alternative to proprietary languages such as ColdFusion and ASP.NET.
PHP is lightweight and relatively simple to learn.

1. The word “JavaScript” is a trademark of Oracle. Microsoft’s version of this language is called JScript.
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 1.3.2. Java EE

Java EE (https://docs.oracle.com/javaee) is used in large web projects. With its power
and robustness comes a steep learning curve.

 1.3.3. ASP.NET

Microsoft’s ASP.NET (https://docs.microsoft.com/aspnet) is not a language, but a
framework for writing websites and software. ASP.NET pages can be written in many
languages, but the most popular are C# (pronounced C-sharp) and Visual Basic .NET
(VB.NET).

 1.3.4. ColdFusion

ColdFusion (https://coldfusion.adobe.com), created by Allaire (now owned by Adobe),
is arguably the simplest of all server-side languages. It is tag-based, which makes it look
a lot like HTML and easier for client-side programmers to understand than some of the
other choices.

 1.3.5. Node.js

Node.js (https://nodejs.org) is a JavaScript framework that runs on the server, allowing
developers to use JavaScript for server-side scripting as well as client-side scripting.

 1.3.6. Python

Python (https://www.python.org) has been a popular open-source programming language
for a long time. There are many web frameworks based on Python, the most popular of
which is Django (https://www.djangoproject.com).

Conclusion

This lesson has provided a general overview of the different languages and frameworks
commonly used in web development. Again, don’t worry if you don’t remember all the
different technologies and their specific roles. Take it one step at a time. The first step is
to learn HTML.
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LESSON 2
Getting Started with Dreamweaver

Topics Covered

The role of Dreamweaver in web development.

The Dreamweaver interface.

 A simple web page.

 Previewing your web page in the browser.

 Setting up a website in Dreamweaver.

Introduction

Dreamweaver is an integrated development environment (IDE) for creating web pages
and websites. It was first introduced in 1997 by Macromedia, which was taken over by
Adobe in 2005. Adobe has since released several versions. In this lesson, we’ll introduce
you to the Dreamweaver interface and get you started with your first website.

❋

2.1. The Role of Dreamweaver

Experienced web developers need to know many different languages. For example, a
really good client-side programmer needs to know HTML, CSS, and JavaScript - three
very different languages. Dreamweaver makes it possible to develop websites without
knowing these languages; however, as you’ll see in this course, it helps to have some
understanding of how the different languages work.

Dreamweaver also has a Code View that can be used for writing many different client-side
and server-side languages.

❋

LESSON 2: Getting Started with Dreamweaver | 9



2.2. Start Screen

When you first open Dreamweaver, it presents you with a Start Screen with some quick
links for opening recent items, creating new documents, and viewing video tutorials.

You may need to click Edit > Preferences... and remove the check mark from Show Start
Screen in the General category if you wish to stop the screen from opening each time you
open Dreamweaver.

❋

2.3. Dreamweaver Workspaces

Dreamweaver comes with predesigned Workspace Layout options, listed below:

Developer

Standard

You can switch between workspace layouts using the drop-down on the upper right of the
application bar:
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In this course, we will be using the Standard layout, which you can reset at any time by
selecting Reset Standard.

❋

2.4. Creating HTML Pages

There are several ways to create new HTML pages in Dreamweaver:

1. Click HTML Document under Quick Start on the Start Screen.

2. Select New... from the File menu.

3. Press CTRL+N on the keyboard.

The Start Screen option will create an HTML document using your default settings, which
you can change (we will see how later in the course). The other two options will pop up
the following dialog box:
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To create an HTML page using the default settings, simply click the Create button. We
will look more into the other options later in the course.

❋

2.5. Code View vs. Design View

There are three main views for editing documents, plus an additional option:

1. Code View - you work directly in the code.

2. Split View - you easily toggle back and forth between working in Code and Design
View and see your changes in both places.

3. Design View - you work in the WYSIWYG (What You See Is What You Get)
interface that feels like a word processor.

4. Live View - you can preview and edit within Dreamweaver.

Use the buttons in the center, below the toolbar to switch views:

.
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In this course, we will generally be working in Design view. You might, however, want to
switch to Split view from time to time if you are interested in seeing the code that
Dreamweaver is creating as you work.
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 Exercise 1: Creating a Web Page
 10 to 15 minutes

In this exercise, you will create and view a simple web page.

1. Create a new HTML page using any of the methods described above.

2. Place the cursor on the page and type “Hello world!”.

3. Save the page (File > Save) as hello-world.html in your ClassFiles/dreamweaver-
cc/Exercises folder.

4. When you are done, your page should look something like this:
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Solution

1. Select New... from the File menu.

2. In the New Document dialog box that pops up, click Create.

3. Type “Hello world!” in the document.

4. Save the document as hello-world.html in your ClassFiles/dreamweaver-
cc/Exercises folder.

❋

2.6. The Dreamweaver Interface

 2.6.1. Panels

All of Dreamweaver’s tools are contained in various windows and panels. Panels are
divided and organized into a series of Panel Groups based on the functions they contain.
You can control which of these panel groups is visible by selecting and deselecting them
in the Window menu. The checked items are currently showing:
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 2.6.2. Insert Panel

The Insert panel (shown below) allows you to insert various “objects” (such as tables,
forms, and images) into your page. You can format or set attributes for these objects as
you insert them.
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The Dreamweaver Insert panel has several groupings of related objects, here are a few:

Common (shown above HTML) - for most commonly used objects.

Structure - for divs, and lists.

Media - for media elements.

Form - for form components.

jQuery Mobile - for building jQuery Mobile pages.

jQuery UI- for building jQuery User Interface.

Templates - for creating template regions within pages.

Favorites - can be customized to display just the options that you use most often.

You can switch between these groups using the drop-down at the top left of the Insert
panel:

The group options are shown below:
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You can also drag the Insert panel below the Application Bar to give it a tabbed horizontal
layout:

Many of the elements available in the Insert panel will be discussed in detail throughout
the course.

Collapse All Panels

To collapse all the panels in the right column, click the arrow icon shown in the image
below (in red square):

Click the arrow again to re-open the panels.

You can also open and close panels individually by clicking the panel name: once to open
and twice to close.

Hiding All Panels

To completely hide all panels, press F4. Press F4 again to reshow them.

LESSON 2: Getting Started with Dreamweaver | 19



 2.6.3. Properties Inspector

The Properties Inspector (shown below), which appears at the bottom of Dreamweaver
in the Designer workspace, is context-based, meaning it will change depending on what
type of object is selected. For example, if text is selected, text properties will be visible; if
an image is selected, image properties will be visible, and so on:

Every page element can be customized via the Properties Inspector. For example, text
can have a specified font, size, and style. Images can have a specified height, width, and
source.To customize an element, select it within the Document Window (the main editing
area) and make alterations via the Properties Inspector.

The Properties Inspector is split into two sections: HTML and CSS. Click the HTML or
CSS icons on the left side of the inspector to switch between the two.

Note

When the CSS icon is selected and you attempt to change properties of text,
Dreamweaver will automatically create a new inline CSS rule. These rules will all be
covered later in the course.

 2.6.4. CSS Styles Panel

The CSS Designer panel shows up by default in the workspace. We will cover CSS later
in the course. For now, you can collapse it by double-clicking the panel name.
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 2.6.5. Files Panel

The Files panel (shown below) keeps track of all of the files and folders within your site.
It can also be used to browse the files on a computer or network just as Windows Explorer
can be used to browse files.
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❋

2.7. Previewing Your Page

While you are editing a page in Design View, Dreamweaver attempts to give you a good
reflection of how the page will appear in a browser, but that’s not always possible (or even
desirable). Dreamweaver does make it easy to view your page as it will appear in the
browser either from within Dreamweaver itself or directly in one or more browsers.  Live
View uses Chromium Embedded Framework (CEF) to allow you to edit and make changes
while getting a live view.

 2.7.1. Real-time Preview

Before previewing a page in a browser, you must first set up you Real-time Preview
preferences in Dreamweaver:

1. Select Preferences... from the Edit menu.

2. From the Category list, click Real-time Preview:
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You may already see one or more browsers in the Browsers list.

3. To add a new browser to the list:

A. Click the  icon.

B. Fill out the resulting dialog box. For example:
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4. Repeat for every browser you want to be able to test. You can add as many as
you like. Your primary and secondary browsers can be accessed with shortcut
keys:

Preview in primary browser: F12 (Win) / Option+F12 (Mac)

Preview in secondary browser: CTRL+F12 (Win) / Command+F12 (Mac)

5. To edit an existing browser in the list, select it and click the Edit... button.

6. When you are done, your list will be exactly as you need it.

Notice that you can change your primary and secondary browsers by
checking or unchecking the Defaults.

 2.7.2. Live

Live view makes it possible to view your page as it will appear in a browser from within
Dreamweaver itself. Simply click the Live button. For simple pages, you will not see much
difference between Design view and Live view. In Live view, however, you will be able to
edit the page.

 2.7.3. Device Preview

Device Preview allows you to not only connect using WiFi to multiple devices, but also
preview in real time so you get a good feel for how your project is coming along without
having to use a test environment.

To use Device Preview, you must have the following setup:

1. Put all of your devices on the same WiFi network.

2. Log in using your Adobe ID.
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3. Click Real-time Preview in the lower-right corner.

4. Scan, type, or copy/paste the path.

Once that is accomplished, you may enjoy real-time edits and previews in all of your
compatible devices.

 2.7.4. Preview in Code View

You may now see a preview of an image in code view, taking the guess work out of what
the image looks like and saving you time form switching back and forth from view to view.
Simply hover over the reference and the preview will pop up.
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 Exercise 2: Previewing a Web Page
 5 to 10 minutes

In this exercise, you will modify your Real-time Preview settings (if you wish) and preview
a page in different browsers.

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.

2. Preview the page in Live View.

3. Preview the page in one or more browsers.

4. Make some small modification to the page and preview again.

❋

2.8. Setting Up a Website

Follow these steps to set up your website for this course:

1. From the Site menu, select New Site... to open the Site Setup dialog box:

2. Enter “dw-class” for the Site Name and browse to the Dreamweaver folder within
the course class files for the Local Site Folder:
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Note

You may have stored your class files in a different location. That is okay.
Simply refer to your location in Local Site Folder.

3. Click Save.

Your Files panel should now look like this:
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Open up the Exercises folder and you should see the hello-world.html file you created
in the last exercise.

 2.8.1. Pointing to Websites

When you point your browser to a website (e.g., www.google.com), the browser fetches
a page from a web server somewhere on the internet.That web server is simply a computer
with some special software on it for serving web pages and associated files (e.g., images).
The server can deliver pages to many different clients (browsers) at the same time as
shown below:

As a web developer, you may be responsible for putting your pages onto the web server.
Different organizations handle this in different ways, but one common way is via File
Transfer Protocol (FTP). We will show you how to set this up in Dreamweaver; however,
in this course, we will simply view the files locally.
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1. To reopen the Manage Sites dialog box, select Manage Sites... from the Site
menu.

2. Select “dw-class” from the site list and click the pencil icon.

3. Click Servers on the left, and then click the plus symbol as shown below.

LESSON 2: Getting Started with Dreamweaver | 29



4. The options will change depending on how you connect to your website (e.g., FTP,
Local/Network, WebDAV, RDS).
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5. For our purposes, you can cancel out of these dialog boxes as we will not need
to connect to a web server for this course.

❋

2.9. Edit Preferences

As we saw when setting our preview browsers, you can edit preferences in Dreamweaver
through Edit > Preferences...

As you become more familiar with Dreamweaver, you will want to come back to these
options to see if you want to make changes to your preferences.

Conclusion

In this lesson, you have been introduced to the Dreamweaver interface, set up a website
and created and previewed your first web page.
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LESSON 3
Creating HTML Pages

Topics Covered

 HTML DOCTYPEs.

 Adding a page title.

 Headings, paragraphs, and blockquotes.

 Line breaks.

 Special characters.

Introduction

In this lesson, you will begin adding simple content to an HTML page.

❋

3.1. Understanding HTML Doctypes

When you choose to create a new HTML document via CTRL+N or File > New..., you get
the following New Document dialog box:
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To start with a basic blank HTML page, you should select HTML for the Page Type. But
what about the Doc Type? The DOCTYPE is used to specify the “flavor” of HTML you
want to use.

It used to be pretty important to understand the different DOCTYPEs, but with the
introduction of HTML5, there is an easy way out, which we highly recommend as it is both
simpler and backward compatible. DOCTYPEs differ, so just go with the new HTML5
DOCTYPE as it’s easier to remember.

It is possible that you are working on a development team or project that has standardized
around one of the other DOCTYPEs. If so, you may want to stick with that one. However,
unless otherwise instructed by a manager or site administrator, you should choose the
HTML5 DOCTYPE.

❋

3.2. Adding a Title to Your Page

The title of an HTML page does not show up on the page itself, but it is important to include
for a couple of reasons:
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1. The title shows up on the browser tab as shown below making it easy for users
to navigate between tabs:

2. Search engines present the page title as the heading of a search result:

3. The title plays a significant factor in the search results themselves. The page title
gives Google and other search engines a good idea of what the page is about.

In Dreamweaver, you enter the page title in the Document Title field on the Properties
panel:

To illustrate, let’s add a title to ClassFiles/dreamweaver-cc/Exercises/hello-world.html:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.

2. Place your cursor in the Document Title field on the Properties panel and type
“Hello World”

3. Save your page.
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4. Preview the page in your browser (File > Real-time Preview). You should see
the title on the tab heading:

❋

3.3. Paragraphs, Headings, and Blockquotes

 3.3.1. Paragraphs

The paragraph is the default format for a block of text. Just like in a word processor, when
you press Enter at the end of one paragraph, Dreamweaver begins a new paragraph.

To illustrate let’s add a paragraph to ClassFiles/dreamweaver-cc/Exercises/hello-
world.html:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.

2. Place your cursor at the end of the first line of text and press Enter (Return on a
Mac2).

3. Type the following:

The text “Hello world!” is very often used in the first exercise of
programming classes.

4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). It should appear
as follows:

2. If you’re using a Mac, when the instructions say “press Enter”, you should press Return.

36 | LESSON 3: Creating HTML Pages

EVALUATION COPY: Not to be used in class.



 3.3.2. Headings

HTML supports six levels of headings. Heading 1 is the most important and Heading 6
is the least important. Like paragraphs, headings are block-level elements, meaning that
they affect the whole line of text (or multiple lines if the heading is long enough to wrap).
Later in the course, we’ll see how you can control the look of headings, but by default,
they are bold and the size of the text changes based on the heading level:
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There are several ways to add headings in Dreamweaver, but the most common is to use
the Properties panel. To illustrate:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.

2. Place your cursor anywhere in the first paragraph (i.e., the “Hello world!”
paragraph).

3. Select “Heading 1” for the Format in the Properties Inspector:
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4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). It should appear
as follows:

Paragraphs after Headings

To add a new paragraph after a heading, place the cursor at the end of the heading
text and press Enter.

 3.3.3. Blockquotes

Blockquotes are used to designate quoted blocks of text. In Dreamweaver, blockquotes
are added by clicking the Blockquote icon in the Properties:

To remove the blockquote, click the Remove Blockquote icon ( ) to the left of the
Blockquote icon.

To illustrate let’s add a blockquote to ClassFiles/dreamweaver-cc/Exercises/hello-
world.html:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.
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2. At the end of the first paragraph under the heading, type “According to wikipedia:”

3. Press Enter to add a new paragraph.

4. Open ClassFiles/dreamweaver-cc/Exercises/hello-world-blockquote.txt and
copy all the text.

5. Switch back to hello-world.html and paste the text into the new paragraph you
added.

6. In the Properties Inspector click the Blockquote icon ( ).

7. Save your page.

8. Preview the page in your browser (File > Real-time Preview). It should appear
as follows:

Blockquotes are for Quotes

Dreamweaver users often use blockquotes incorrectly as a quick and dirty way of
indenting paragraphs. You should not do this. Blockquotes should only be used to
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indicate that the content is taken from another source. The proper way to indent
paragraphs for formatting purposes is to use CSS.
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 Exercise 3: Adding Content to Your Page
 15 to 25 minutes

In this exercise, you will add content to your web page.

1. Create a new HTML page and save it as index.html in your Exercises folder.

2. Add content so that your web page will look like this in the browser:

3. Save your page and open it in the browser. Does it look like the screenshot above?
If not, go back to Dreamweaver and fix it.

❋

3.4. Breaks

As we have discussed, when you press Enter in Dreamweaver, a new paragraph gets
added. Sometimes it is desirable to have a hard return appear within a paragraph. In
HTML, this is called a break. In Dreamweaver, you can add a break by pressing
Shift+Enter.
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Use Breaks and Horizontal Rules Sparingly

Breaks should be used only for content such as poems or addresses. They are very
often mistakenly used for formatting purposes only, use CSS alternatives to layout
your basic content.

❋

3.5. Special Characters

Special characters (i.e., characters that do not show up on your keyboard) can be added
to your pages by choosing Insert > HTML> Character . If you do not see the character
you are looking for - Insert > HTML> Character > Other... will allow you to choose more
symbols.
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 Exercise 4: Adding Breaks
 10 to 15 minutes

In this exercise, you will make some modifications to /index.html.

1. Open ClassFiles/dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s
not already open.

2. Modify the page so it will look like this in the browser:

3. Save your page and open it in the browser. Does it look like the screenshot above?
If not, go back to Dreamweaver and fix it.

Conclusion

In this lesson, you have learned to add paragraphs, headings, blockquotes, and line breaks
to your pages.You have also learned to add special characters.
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LESSON 4
Links

Topics Covered

Text links.

 Absolute and relative paths.

Targeting new windows with your links.

 Email links.

 Naming locations on a page.

Introduction

The “HT” in HTML stands for HyperText. HyperText is text that, when clicked, can take
the user to other content. So, what makes HTML HTML is the fact that the pages can
contain links. In this lesson, you will learn how to create them.

❋

4.1. Adding Links

Dreamweaver makes adding links easy. Simply highlight the text that you want to turn into
a link and enter the link URL into the Link field in the Properties.

To illustrate let’s add a link to ClassFiles/dreamweaver-cc/Exercises/hello-world.html:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
if it’s not already open.

2. Highlight the text “wikipedia”.

3. I n  t h e  L i n k  f i e l d  i n  t h e  P r o p e r t i e s ,  e n t e r
“http://en.wikipedia.org/wiki/Hello_world_program”:
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4. Save your page.

5. Preview the page in your browser (File > Real-time Preview). The page should
look like this:

6. Notice that when you hover over the link, the cursor turns to a pointer and the
browser shows the URL to which the link points.

7. Click the “wikipedia” link. It should take you to Wikipedia’s page entitled “Hello
world program.”

❋

4.2. Absolute vs. Relative Paths

 4.2.1. Absolute Paths

An absolute path shows the complete path to a file starting from the web root. To illustrate
this, see the following directory tree:
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Assume that the wwwroot folder is the web root. This means that when a user types
http://www.servername.com/index.html, the index.html page within the wwwroot folder
will be downloaded to the browser. The absolute path to the web root from a page on the
same domain is simply a forward slash (/).

The same link could be placed on any page in any folder below the wwwroot folder or on
any page in the wwwroot folder itself.

Using an absolute path, a link to Company.html would include the about directory, like this:
/about/Company.html

External Links

When linking to a page on a different website you must identify the location of the domain
using the domain name (or IP address) of the site. To illustrate, assume that the directory
structure shown above is found at http://www.beatles.com. The path of a link to Compa
ny.html from another site would be written like this: http://www.beatles.com/about/Com
pany.html

 4.2.2. Relative Paths

Relative paths can only be used to link to other files under the same web root. A relative
path indicates where a file is relative to the file that contains the link.The folder (or directory)
that contains the file being worked on is called the current directory. The relative path to
another file that is also in the current directory is just the name of that file. For example,
since Company.html and Contact.html are found in the same directory, they can link to
each other simply by specifying the file name.
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The relative path to a file in a subdirectory of the current directory must include the name
of the subdirectory. For example, to link to Company.html from index.html you must first
point to the about directory, like so: about/Company.html.

The relative path to a file in a directory above the current directory should begin with ../
For example, the following shows the path of a link to index.html from Company.html:
../index.html

 4.2.3. Default Pages

The web server administrator can set up default page names to look for when a path ends
with a directory name without specifying a file. Often these files are named index.html or
Default.htm. In this case, the following two URLs would be identical, both loading in
dex.html.

http://www.beatles.com/

http://www.beatles.com/index.html

❋

4.3. Quick Tricks for Adding Links in Dreamweaver

Dreamweaver provides some neat tools for quickly adding links described below.

 4.3.1. Point to File

1. Highlight the text that will become a link.

2. Click down on the Point to File icon in the Properties.

3. Drag the mouse over to the Files panel and point to the file.
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 4.3.2. Browse for File

1. Highlight the text that will become a link.

2. Click the folder icon (if you hover over the folder icon, it will shown Browse for
files) in the Properties:

3. In the Select File dialog that appears, click the Site Root button to quickly navigate
to your website root:
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A. Alternatively, you can type the URL into the URL field.

4. Navigate to the file and click OK.

 4.3.3. Drag File from Files Panel

1. Highlight the text that will become a link.

2. In the Files panel click down on the file to which you want to link.

3. Click down on the Point to File icon in the Properties.

4. Drag the mouse over to the Properties Inspector and point to the Link field.
Although the “no-drop” cursor might show up, Dreamweaver allows you to drop
the file path into the field.
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 Exercise 5: Adding Links to Your Page
 15 to 25 minutes

In this exercise, you will add links to your page.

1. Create the following new pages and save them in ClassFiles/dreamweaver-
cc/Exercises. Add titles and level-one headings to each page:

A. Races as Races.html

B. Calculator as Calculator.html

C. Running Log as RunningLog.html

D. My Account as MyAccount.html

E. Log out as Logout.html

2. Open ClassFiles/dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s
not already open.

3. Add the following links:

Home: index.html

Races: Races.html

Resources: Resources.html

Calculator: Calculator.html

Running Log: RunningLog.html

My Account: MyAccount.html

Log out: Logout.html

the most up-to-date information on running races: Races.html

the best resources for runners: Resources.html

4. Save your page and open it in the browser.

5. Test your links. Do they work?

❋
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4.4. Targeting New Windows

Sometimes it is desirable for a link to open in a new tab or window, so that the page with
the link does not get replaced. Dreamweaver provides a Target field in the Properties
Inspector for this purpose. This Target field remains inactive until the Link field is filled
in, at which point it gives you the options shown in the screenshot below:

The _parent, _self, and _top values apply to framesets and should not be used (unless
you are designing with framesets, which you probably shouldn’t be).

The _blank and new values will both direct the linked page to open in a new window. The
difference is that all links that target _blank will spawn new windows, whereas a link
targeting new will open a new window and name it “new”. As long as that window remains
open, all future links targeting new will open in that same window. In fact, new is an arbitrary
target name. You will get the same behavior with any target name other than the four
reserved names: _blank, _parent, _self, and _top.

Warning

Be careful not to overuse targeting new windows. A best practice in web design is
to give users what they expect and users generally expect links to replace the current
page.They also know that they can get back to the original page using the browser’s
Back button. However, when creating a link that opens in a new window, the user
will not be able to use the Back button in that new window to get back to your page.
Reserve the open a new window for links that take the user away from your site, so
any links to other sites work well in a new window as your site will still be available
when they close that window.

❋
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4.5. Email Links

Email links are used to open an email client to start a new email message. The value you
enter in the Link field must begin with mailto: and ends with an email address. For
example: mailto:paul@beatles.com

You can also add an email link by selecting Insert > HTML> Email Link, and then filling
out the resulting dialog:

If you select the text you want to turn into an email link before selecting Insert > HTML >
Email Link then that text will show up in the Email Link dialog. Otherwise, you must type
in the text in the dialog box and Dreamweaver will add it to the page at the point where
the cursor is.
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 Exercise 6: More on Links
 10 to 15 minutes

In this exercise, you will add an email link and change a link to open in a new window.

1. Open ClassFiles/dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s
not already open.

2. Change the link to Calculator.html so that page opens in a new window.

3. Add text to the footer that reads “Contact us at info@runnershome.com.” Make
info@runnershome.com an email link.

4. Save your page and open it in the browser.

5. Test your links. Do they work?

❋

4.6. Naming a Location on a Page

Named locations to which a link can point are helpful on pages with many topics. Linking
to a specific location on a page can be most helpful. This is no longer a built in feature,
however, still available by following the directions below.

To add a named location in Dreamweaver CC:

1. In Design view, highlight the text where you want to add the anchor.

2. Right-click and choose Wrap Tag...

3. Type span to choose <span>, press Enter twice to commit.

4. Use the ID field in then properties to name the area.

5. Create the link to the new named area.

A. Highlight the text you want to turn into a link.

B. Do one of the following:
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i. Enter the name of the id you just entered preceded by a number
sign (#).

ii. Hover over the Point to File icon in the Properties panel and
drag it to the text to which you just added an id:
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 Exercise 7: Adding Anchors
 15 to 25 minutes

In this exercise, you will add more named locations to Anchors.html.

1. Before starting, open ClassFiles/dreamweaver-cc/Solutions/Anchors.html in
your browser and test the links to see how the page should work.

2. Now open ClassFiles/dreamweaver-cc/Exercises/Anchors.html in Dreamweaver
if it’s not already open.

3. Add anchors before each story title heading:

POOH GOES VISITING

A MAD TEA-PARTY

THE NAUGHTY BOY

4. Make the story names at the top of the page link to your new anchors.

5. At the bottom of the page, you’ll see the following text: “W3C anchors |
Dreamweaver Class Schedule.”

A. Make “The link element” a link to the “the-link-element” id on
https://www.w3.org/TR/html52/document-metadata.html.

B. Make “Did not finish” a link to the “dnf” id on https://www.runners-
home.com/resources/terms.html.

6. Save your page and open it in the browser.

7. Test your links. Do they work?

Conclusion

In this lesson you have learned to create text links, to work with absolute and relative
paths, to target new windows, to create email links and to create and link to named
locations.
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LESSON 5
Images

Topics Covered

 Adding images to a page.

 Image links.

 Accessibility attributes.

 PSD images.

Introduction

Modern browsers generally support three types of images: GIFs, JPEGs, and PNGs. The
PNG and GIF are generally used for simple images such as drawings, whereas the JPEG
format is used for more complicated images such as photographs. Dreamweaver makes
it simple to add images to your page.

❋

5.1. Inserting Images

To add an image place the cursor where you want the image to appear and do one of the
following:

Select Insert > Image:

Select Images > Image from the Common Insert panel:
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You will then be presented with the Select Image Source dialog box, which allows you
to navigate to your image:

As with links, this dialog box gives you the option of jumping right to your website root by
clicking the Site Root button.

Rather than browsing to the image in the Select Image Source dialog box, you can drag
it from the Files panel to the location on your page where you want the image to appear.

 5.1.1. Accessibility Attributes

After selecting the image, make sure to set the Image Tag Accessibility Attributes:
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Alternate Text

Screen readers will use the Alternate text value when announcing the presence of the
image. You should either write descriptive text or select “<empty>” from the drop-down.
Here are some guidelines:

1. If the only purpose of the image is to provide a design impact, you should select
“<empty>”.

2. If the image contains instructive text (e.g., “Enter Store” or “Go”), you should write
that text as the value.

Long Description

The long description is used with images that tell a story (e.g., graphs and charts). The
value for the Long description, if included, should be a URL pointing to a page that
provides text telling the same story as the image.

To edit the source of the Long Description:

1. Open the Quick Tag Editor for the IMG tag.
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2. Begin to type a “lo” and see the longdesc choice.

3. Press the Enter key and type the source path.

 5.1.2. Image Properties

You can use the Properties to modify the properties of the image:

1. You can change the source, link URL, and alternate text using the Src, Link and
Alt fields.

2. W and H stand for width and height.

3. When you insert an image, Dreamweaver automatically sets the width and height
to the actual dimensions of the image (in pixels). In most cases, you should not
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change this setting. If one of the values is different from the actual dimension, the
value becomes bold and a Reset icon appears:

Click that icon to reset the image dimensions.

4. We will discuss ID and Class when we discuss CSS later in the course.

5. (e.g., Photoshop).

Editing Images Directly in Dreamweaver

The Edit Image Settings button allows for a small amount of image editing to be done
without use of an external graphics program such as Adobe Photoshop.

Images can be cropped and brightness and contrast may be edited. Be aware, however,
that if you change an image using Dreamweaver, you are changing the actual image file.
If the image is used on any other pages, your changes will affect those pages.

Editing Images

In general, if you need to make changes to images, it is better to do so by going back
to the original image in your graphics program.

❋
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5.2. Image Links

Turning an image into a link is simple:

1. Select the image.

2. Add the link in the same way you would with text selected.

Some browsers will place a blue border around a linked image to indicate that the image
is a link. Using CSS you may remove this border.
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 Exercise 8: Adding Images to Your Page
 15 to 25 minutes

In this exercise, you will add images to your page.

1. Open ClassFiles/dreamweaver-cc/Exercises/index.html in Dreamweaver if it’s
not already open.

2. Add ClassFiles/dreamweaver-cc/Images/RunnersHome.gif to the home page after
the level-one heading.

3. Replace “Contact us at info@runnershome.com.” in the footer with the Class
Files/dreamweaver-cc/Images/Email.gif image. Make the image an email link
to info@runnershome.com.

4. Save your page and open it in the browser.
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Solution

When you are done, your page should look like this:

You should have set the alternate text of the Runners Home image to “<empty>” and of
the Email image to something like “Contact us at info@runnershome.com.”

Make sure your email link works.

❋

5.3. Inserting Photoshop .psd documents directly - Photoshop
Smart Objects

Dreamweaver allows you to insert Photoshop PSD files directly into a page. Dreamweaver
will watch the original document for changes. To illustrate:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world-with-psd.html in
Dreamweaver.
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2. Insert ClassFiles/dreamweaver-cc/Images/world.psd beneath the “Hello world!”
heading. The Image Optimization dialog box will come up, Click OK:

3. Choose a place and a name for the imported image.

4. The image will show up like this:
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If the original PSD file is changed, right-click the image and select Update from Original
to have the changes applied to the JPEG as well.

Conclusion

In this lesson, you have learned to add images to your pages and to link those images to
other pages as simple links.You have also learned to add a PSD file to a page from within
Dreamweaver.
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LESSON 6
Lists

Topics Covered

 Unordered lists.

 Ordered lists.

 Nested lists.

 Definition lists.

Introduction

HTML provides three types of lists:

1. Unordered Lists - used to create lists in which the order of the list items is not
important (e.g., a grocery list or a list of people in a group).

2. Ordered Lists - used to create lists in which the order is important (e.g., a recipe
or setup instructions).

3. Definition Lists - used to create lists containing terms and definitions (e.g., a
dictionary or glossary).

In this lesson, we will learn how to create all three.

❋

6.1. Ordered and Unordered Lists

Creating ordered and unordered lists in Dreamweaver is simple using the list icons in the
Properties:

To illustrate:
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1. Open ClassFiles/dreamweaver-cc/Exercises/Anchors-list.html in Dreamweaver.

2. Place the cursor on the line with the three linked story titles.

3. Click the Unordered List icon in the Properties. Your page should appear as
follows:

4. Place the cursor at the end of “Pooh Goes Visiting” and delete the dividing bar:

5. Press Enter:

6. Place the cursor at the end of “A Mad Tea-Party,” delete the dividing bar and press
Enter:

7. To add another bullet at the end of the list, place the cursor at the end of “The
Naughty Boy” and press Enter and type a story name:
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8. You can add additional bullets by typing story names and pressing Enter just as
you would in a typical Word processing tool.

You create ordered (or numbered) lists in the same way. In step 3 above, you would click
the Ordered List icon instead of the Unordered List icon.

Creating a List from Scratch

To create an ordered or unordered list from scratch, simply start a new paragraph
and press the appropriate list icon on the Properties.

 6.1.1. Nesting Lists

Unordered and ordered lists may be nested any number of levels deep. To illustrate:

1. Open ClassFiles/dreamweaver-cc/Exercises/nested-list.html in Dreamweaver.

2. The page is currently empty. Type “Grocery List” and make it a Heading 1.

3. With the cursor below the heading, begin an unordered list by clicking the
Unordered List icon in the Properties.

4. Type “Fruit” and press Enter:

5. To create your nested list, press Tab (or click the Indent icon  on the Properties)
and type “Apples” Enter, “Pears” Enter, “Bananas” Enter:

6. There are multiple ways to get back to the parent list:
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Press Enter again.A.

B. Press Shift+Tab.

C. Click the Indent icon  on the Properties.

7. Type “Meat” and press Enter:

8. Continue with your list until it looks like this:

9. To get out of a list, make sure the cursor is at the very end of the last item in the
list and press Enter twice.

 6.1.2. Converting Lists

To convert an unordered list to an ordered list (or vice versa), click somewhere within the
list (or sublist) and then click the appropriate list icon on the Properties.

❋
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6.2. Definition Lists

Definition lists, which are used less frequently than unordered and ordered lists, are used
to create lists containing terms and definitions. Dreamweaver does not provide a way to
create them using the Properties.

In Dreamweaver:

1. Select the location to place the list.

2. Choose Edit > List > Definition List.

3. Enter the list items. Press enter after the term, then type the definition. Repeat as
needed until all terms and definitions are entered.

To illustrate how a definition list is added to a page:

1. Open ClassFiles/dreamweaver-cc/Exercises/definition-list.html in
Dreamweaver.

2. The page is currently empty. Type “Abbreviations” and make it a Heading 1.

3. With the cursor below the heading, begin a definition list choose Edit > List >
Definition List.You will not notice any change on the page, but if you look at the
Tag Inspector on the bottom left, you will see this:

This indicates that you are in a definition term (dt) within the definition list (dl).

4. Type the following:

ol Enter

Ordered List Enter

ul Enter

Unordered List Enter

dl Enter

Definition List Enter Enter

5. After pressing Enter twice at the end of the list, you should no longer be in the
definition list and your page should look as follows:
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The display of definition lists is a little odd, but, if you learn CSS well, you will be able to
change the display to look like the page below (or however else you like):
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 Exercise 9: Creating Lists
 15 to 25 minutes

In this exercise you will create a new page that looks like this:

1. Create a new page and save it as RunningTerms.html in ClassFiles/dreamweaver-
cc/Exercises.

2. Add the title and heading level 1.

3. Create the list of links at the top. Here are the links:

Home: index.html
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Races: Races.html

Resources: Resources.html

Calculator: Calculator.html

Running Log: RunningLog.html

My Account: MyAccount.html

Log out: Logout.html

4. Add the definition list below the navigation menu.

If you do not want to type the whole list out, you can grab the content from
ClassFiles/dreamweaver-cc/Exercises/RunningTerms.txt; however, do
not copy and paste the whole thing at once as that will add a bunch of
unwanted paragraphs. Rather, copy and paste each term and definition
as needed.

5. Save your page and open it in the browser. Does it look right?

❋

6.3. Converting Existing Content to Lists

Converting existing content to lists in Dreamweaver can be tricky. The easiest way to see
this is to illustrate with an example. Our end goal is a list that looks like this:

1. Open ClassFiles/dreamweaver-cc/Exercises/groceries.html in Dreamweaver.

2. Open ClassFiles/dreamweaver-cc/Exercises/groceries.txt and copy and paste
its entire content into groceries.html:
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3. Highlight everything you just pasted in and click the Ordered List icon in the
Properties:

4. Now we want to turn the actual food items into sublists. Highlight the three fruit
items like this:

And press Tab.

5. That didn’t work, did it? Your list probably looks like this:
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6. Undo using Edit > Undo Indent or by pressing CTRL+Z.

Here’s the problem: those breaks that move the names of the food items to the next lines
are line breaks not new paragraphs. The content that comes after them (i.e, the fruit item
names) are considered part of the “Fruit” list item. So you cannot indent the individual
items without indenting the “Fruit” list item as well.

The solution is to delete the line breaks:

1. Place the cursor immediately before the letter “A” in “Apples” and press Backspace
until “Apples” is on the same line as “Fruit”:

2. Press Enter to create a new list item:

3. Do the same thing with “Pears” and “Bananas” and then highlight all three fruit:

4. Press Tab. That should have worked:
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5. Now we can covert the sublist to an unordered list by highlighting all three fruit
names and clicking the Unordered List icon in the Properties:

Follow Along

When working with nested lists, if things get messed up, usually the easiest thing is
to get rid of the list and start over. To remove a list, highlight the whole thing and
click the relevant list icon in the Properties.
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 Exercise 10: Converting Content to a List
 15 to 25 minutes

In this exercise you will modify Resources.html, which currently looks like this:

Notice that it contains a list of resources. Although the order may not matter, it would be
nice to be able to refer to a resource by number, so that the list could be represented as
an ordered (or numbered) list. Each resource has some related information, which could
be represented in a nested list:

The date it was posted.

A description.

Modify the page to look like this:

80 | LESSON 6: Lists

EVALUATION COPY: Not to be used in class.



1. Open ClassFiles/dreamweaver-cc/Exercises/Resources.html in Dreamweaver.

2. Modify the page so that it appears as shown in the second screenshot above.

3. Save your work and open your new page in a browser to test it.

Conclusion

In this lesson, you have learned to create and work with unordered, ordered and definition
lists.
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LESSON 7
Tables

Topics Covered

 Creating and Modifying tables.

 Merging cells horizontally and vertically.

 Sorting tables.

 Importing data into tables from spreadsheets.

Introduction

HTML Tables are quite cumbersome to hand code, but Dreamweaver makes it easy to
add and modify them. In this lesson, you will learn how.

❋

7.1. Adding a Table to Your Page

To add a table to your page, place the cursor where you want the table to appear and do
one of the following:

Select Insert > Table:

Select Table from the Common Insert panel:
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You will then be presented with the Table dialog box:

In the Table dialog box, you enter:

Rows and Columns. The number of rows and columns you want for your initial
table. Rows and columns can be added to and removed from the table later.

Table width: The width of the table in pixels or percent. Percent applies to the
containing area. For example, if you nest a table with a width set at 50% within a
table cell of another table, the nested table will take up 50% of the cell.

Border thickness: The border width in pixels. The border will be applied to all
cells of the table in a grid format. Enter “0” if you don’t want a border.
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Cell padding: The amount of space in pixels that will separate the cell content
from the cell border.

Cell spacing:The amount of space in pixels that will separate each cell from each
other cell.

Header: Whether you want a header row, header column, or both.

Caption: The caption you want to appear above the table. This is unformatted by
default, but can be formatted with CSS.

Summary: The text used by screen readers to describe the table.

To illustrate, let’s add a table to a page:

1. Open ClassFiles/dreamweaver-cc/Exercises/table.html in Dreamweaver.

2. Place the cursor in the empty paragraph after the “Employees” heading.

3. Select Insert > Table.

4. Fill out the Table dialog box as shown below:

5. Click OK.Your page should look like this:
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In Design View, when the table is selected, Dreamweaver provides table menus
(the green lines, arrows, and text above the table) to help you understand and
modify the table. These will not appear on the page when viewed in the browser.

6. Click the Live  button to see what the page will look like in the browser:

7. Now fill out the table as shown below.You can use Tab, Shift+Tab, and the arrow
keys to navigate between cells.

8. Save the page and leave it open.

Heading Rows

Notice that the data in the first row is bold and centered.That’s because it is a heading
row.You can change any cell to or from a heading row in the Properties Inspector
by checking or unchecking the Header field:
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Do NOT use this for formatting purposes. Only actual headers should be marked as
headers.

❋

7.2. Sorting Tables

Dreamweaver allows you to sort tables as long as they do not have merged cells. To sort
a table:

1. Place the cursor anywhere within the table to be sorted.

2. Select Edit > Table > Sort Table:

3. The following dialog box will pop up:

A. Select the first column you want to sort by, the sort method (Alphabetically
or Numerically), and the sort direction (Ascending or Descending).

B. If you want a secondary sort, fill out the Then by fields as well.

C. Check the appropriate Options.

D. Click OK.
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 Exercise 11: Table Sorting
 5 to 10 minutes

In this exercise, you will practice sorting a table.

1. Open or go to ClassFiles/dreamweaver-cc/Exercises/table.html in Dreamweaver.

2. Sort the table by Name.

3. Now sort the table by Phone to get it back to the way it was.

❋

7.3. Modifying Tables

After inserting the table, it is likely that you will want to make changes. Dreamweaver
makes it easy to do so.

 7.3.1. Inserting Rows

There are several methods of inserting rows into a table.

Method 1: Right-click

1. Right-click in any cell in the row below which you want to insert a new row.

2. Select Table > Insert Row:

Method 2: Edit Menu

1. Place the cursor in any cell in any row in the table.
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2. From the Edit menu, select Table > Insert Row:

Method 3: Keyboard Shortcut

1. Place the cursor in any cell in the row above which you want to insert a new row.

2. Press CTRL+M.

Method 4: Tab

To insert a row at the very bottom of the table:

1. Place the cursor in the last cell of the bottom row.

2. Press Tab.

 7.3.2. Inserting Columns

There are several methods of inserting columns into a table.

Method 1: Right-click

1. Right-click in any cell in the column after which you want to insert a new column.

2. Select Table > Insert Column:

Method 2: Edit Menu

1. Place the cursor in any cell in any column in the table.

2. From the Edit menu, select Table > Insert Column:
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Method 3: The Column Header Menus

1. Click the Table Column menu above any column.

2. Select Insert Column Left or Insert Column Right:

Method 4: Keyboard Shortcut

1. Place the cursor in any cell in the column before which you want to insert a new
column.

2. Press CTRL+SHIFT+A.

 7.3.3. Inserting Multiple Rows or Columns at One Time

1. Right-click in any cell in the table before or after which you want to insert columns
or rows.

2. Select Table > Insert Rows or Columns...:

3. Fill out the Insert Rows or Columns dialog box and click OK:
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 7.3.4. Merging Cells

There are several methods of merging cells in Dreamweaver. Each method begins by
selecting the cells you would like to merge by clicking one cell and dragging the mouse
over additional cells:

Method 1: Right-click

1. After selecting the cells to merge, right-click and select Table > Merge Cells:

2. Note that the content of the merged cells also merges, so in this case, we would
delete the repetitive content:
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Method 2: Properties Inspector

1. Make sure that the Properties Inspector is expanded. The arrow in the bottom
right of the Properties Inspector should be pointing up ( ). If is pointing down, click
it.

2. After selecting the cells to merge, click the Merge Cells icon in the Properties
Inspector:

Method 3: Keyboard Shortcut

1. After selecting the cells to merge, press CTRL+ALT+M.

 7.3.5. Splitting Cells

There are several methods of splitting a cell in Dreamweaver. Note that the last step for
each method is to fill out the Split Cell dialog box and click OK.

Method 1: Right-click

1. Place the cursor in the cell to split, right-click, and select Table > Split Cell...:
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Method 2: Properties Inspector

1. Make sure that the Properties Inspector is expanded. The arrow in the bottom
right of the Properties Inspector should be pointing up ( ). If is pointing down, click
it.

2. Place the cursor in the cell to split, click the Split Cells icon in the Properties
Inspector:

Method 3: Keyboard Shortcut

1. Place the cursor in the cell to split and press CTRL+ALT+S.
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 Exercise 12: Converting a List to a Table
 15 to 25 minutes

In this exercise, you will change the list on Resources.html to a table that looks like this:

1. Open ClassFiles/dreamweaver-cc/Exercises/Resources.html in Dreamweaver.

2. Modify the page so that it appears as shown in the screenshot above. Note that
the first cell under the Date  heading is merged across two rows.

3. Save your work and open your new page in a browser to test it.

❋

7.4. Importing Data into Tables

Dreamweaver makes it possible to import data from external files saved as CSVs
(comma-separated values). Such data most often comes from spreadsheets.

To illustrate in Dreamweaver:
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1. Open ClassFiles/dreamweaver-cc/Exercises/sales-report.html in Dreamweaver.

2. Place the cursor in the empty paragraph after the “Sales Report” heading.

3. Select File > Import >Tabular Data:

4. Fill in the Import Tabular Data dialog box as shown below:

Data file: Browse to the Sales_Report.csv file, which is in the same
directory as the sales-report.html file you are working on.

Delimiter: Leave as Comma.

Table width: Fit to data.
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Cell padding: 2

Cell spacing: 2

Format top row: [No Formatting]

Border: 1

5. Select the top row of the table by hovering over its left-most border until the cursor
changes to a solid right arrow and then clicking:

6. Click the Header check box in the Properties Inspector:

7. Your table should look like this:

❋

96 | LESSON 7: Tables

EVALUATION COPY: Not to be used in class.



7.5. Dreamweaver and Styling Tables

Dreamweaver makes it easy to format tables. Using the Properties (shown below), you
can:

1. Set background colors for the table rows and cells.

2. Set the width and height of columns and rows.

3. Change the horizontal and vertical alignment of cells.

However, behind the scenes, Dreamweaver uses deprecated attributes to do all these
things, which is really too bad. Browsers still support the deprecated attributes, so you
can use the Properties Inspector to format tables in this way, but your HTML5 pages will
not be valid. We will show you how to format tables with CSS later in the course.

Conclusion

In this lesson, you have learned to create and modify HTML tables.
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LESSON 8
Styling Content

Topics Covered

 CSS.

The CSS Styles panel.

 Creating and editing CSS rules.

 Applying CSS rules to elements on the page.

 External style sheets.

Introduction

While HTML is a language for structuring web pages, Cascading Style Sheets (CSS) is
the language used for styling and laying out web pages. Although Dreamweaver provides
a nice interface for working with CSS, to use it effectively, you must understand the different
ways CSS styles can be applied to elements and pages. In this lesson, you will learn how
CSS works in general and how Dreamweaver implements it.

❋

8.1. HTML Structure

Before learning CSS, it is important to understand how HTML is structured. HTML is made
up of elements that describe the structure of the content on a web page.

 8.1.1. HTML Elements

HTML elements describe the structure and content of a web page. Tags are used to
indicate the beginning and end of elements. The syntax is as follows:

<tagname>Element content</tagname>

For example, a paragraph would be marked up as follows:
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<p>This is a paragraph.</p>

 8.1.2. Attributes

Tags often have attributes for further defining the element. Attributes come in name-value
pairs:

<tagname att1="value" att2="value">Element content</tagname>

For example, an important paragraph might be marked up as follows:

<p class="important">This is an important paragraph.</p>

 8.1.3. Blocks and Inline Elements

Block-level Elements

Block elements are elements that separate a block of content. For example, a paragraph
(<p>) element is a block element. Other block elements include:

Lists (<ul> and <ol>)

Tables (<table>)

Forms (<form>)

Divs (<div>)

Inline Elements

Inline elements are elements that affect only snippets of content and do not block off a
section of a page. Examples of inline elements include:

Links (<a>)

Images (<img>)

Formatting tags (<b>, <i>, <tt>, etc.)

Phrase elements (<em>, <strong>, <code>, etc.)

Spans (<span>)
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Strong knowledge of HTML makes working with CSS much easier, but with the basic
knowledge covered above, you should be able to get a good start with CSS.

❋

8.2. CSS Rules

CSS rules are statements that define the style of an element or group of elements. The
syntax is as follows:

selector {
property: value;
property: value;
property: value;

}

Each property: value pair is a declaration. Multiple declarations are separated by
semi-colons. The selector defines which elements are affected by the rule. Take a look at
the following rule.

p {
color: darkgreen;
font-family: Verdana;
font-size: 10pt;

}

This rule specifies that all paragraph text should be dark green and use a 10-point Verdana
font.

Adding Your First Rule

To illustrate how to add rules in Dreamweaver:

1. Open ClassFiles/dreamweaver-cc/Exercises/hello-world.html in Dreamweaver
in Design View.

2. Place the cursor in the first paragraph under the heading.

3. Open the CSS Styles panel if it is not already open (Window > CSS Designer):

4. Add a new source:
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5. Name the source and click OK:

6. Make sure the new .css file is selected and add a new Selector:

7. Click the new Selector, then click the Text choice. Set the text properties:
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❋

8.3. Selectors

The are several different types of selectors. The most common ones are listed below:

Type

Descendant

Class

ID

Selectors identify the element(s) affected by the CSS rule.

 8.3.1. Type Selectors

Type selectors specify elements by tag name and affect every instance of that element
type. Looking again at a previous example:
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p {
color: darkgreen;
font-family: Verdana;
font-size: 10pt;

}

This rule specifies that the text of every <p> element should be dark green and use a
10-point Verdana font.

Class and ID Selectors

In Dreamweaver, you must type the beginning “.” or “#” to note a Class or ID type
selector.

 8.3.2. Descendant Selectors

Descendant selectors specify elements by ancestry. Each “generation” is separated by a
space. For example, the following rule states that <strong> tags within <p> tags should
have red text.

p strong {
color:red;

}

With descendant selectors generations can be skipped. In other words, the code above
does not require that the <strong> tag is a direct child of the <p> tag.

To illustrate:

1. Return to ClassFiles/dreamweaver-cc/Exercises/hello-world.html.

2. Place the cursor in the “wikipedia” link.
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3. In the CSS Designer panel, click the Add Selector icon ( ) in the Selectors
section.

4. Dreamweaver will then provide you with a descendant selector starting with the
body tag:

This means that this rule will affect every ‘a’ element within a ‘p’ element within
the ‘body’ element. It will not affect ‘a’ elements that are not nested somewhere
within ‘p’ elements.

5. Define the selector in the Properties area.

 8.3.3. Class Selectors

In HTML, almost all elements can take the class attribute, which assigns a class name to
an element. The names given to classes are arbitrary, but should be descriptive of the
purpose of the class. In CSS, class selectors begin with a dot. For example, the following
rule creates a class called “warning” that makes the text of all elements of that class bold
and red:

.warning {
font-family: Impact;
font-size: large;
font-weight: bold;
color: #F00;

}

Following are a couple of examples of elements of the warning class:

<h1 class="warning">WARNING</h1>
<p class="warning">Don’t go there!</p>

To create class selectors in Dreamweaver, you type “.warning” as the name of the Selector:
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To illustrate how to add a class selector in Dreamweaver:

1. Return to ClassFiles/dreamweaver-cc/Exercises/hello-world.html in
Dreamweaver.

2. Place the cursor at the end of the blockquote and press Enter.

3. Click the Outdent icon ( ) in the Properties to get out of the blockquote.

4. Type “Don’t forget to save your work!”

5. In the CSS Designer panel, click the Add Selector icon ( ) in the Selectors
section.

6. Type in .warning:

7. Define the selector in the Properties area.

Now we have to apply the class to an element on the page:

1. Place the cursor in the warning paragraph you typed under the blockquote.

2. Select “warning” from the Class drop-down in the Properties:

3. Open the page in your browser by pressing F12. If you get the following prompt,
click Yes. This saves the CSS file.
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4. The page should look like this:

 8.3.4. ID Selectors

As with the class attribute, in HTML, almost all elements can take the id attribute, which
is used to uniquely identify an element on the page. In CSS, ID selectors begin with a
pound sign (#) and have arbitrary names. The following rule will indent the element with
the “maintext” id 20 pixels from the left and right.

#mainText {
margin-left:20px;
margin-right:20px;
]

<div id="mainText">
This is the main text of the page...
</div>

To create id selectors in Dreamweaver, you type “#mainText” as the name of the Selector:
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 8.3.5. ID vs. Class

Again, the id attribute is used to uniquely identify an element on a page, so no two elements
may use same id.

Classes, on the other hand, can be applied to many elements on the page.

❋

8.4. Modifying the Rule

Sometimes you will want to modify the rule after you have created it. For example, that
warning class we created is a little too standout-ish. Let’s make it less so, by changing the
font-family from Impact to Arial:

1. Return to ClassFiles/dreamweaver-cc/Exercises/hello-world.html in
Dreamweaver.

2. Place the cursor anywhere in the warning paragraph.

3. In the CSS Designer panel, make sure “.warning” is selected in the Selectors part
of the window. Then next to font-family, replace the existing font by typing “Arial”
over it and press Enter.
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4. The page should update.

 8.4.1. Making Sure the CSS File Saves

Beneath the file name at the top of the Document Window, you will see a line that begins
with the words “Source Code.” This line lists the source files associated with the HTML
file:

Notice above that there is an asterisk next to the test.css file name. That’s because the
file has been changed and not saved.When you close the HTML file, you will be prompted
to save the associated files that have been changed; however, you can save them earlier
by selecting File > Save All Related Files:

LESSON 8: Styling Content | 109



The asterisk should disappear.

❋

8.5. CSS Properties

There are many CSS properties and it is beyond the scope of this course to cover each
in detail. However, we will go over them quickly and you will be able to learn a lot more
on your own by exploring the CSS Designer Properties area.

Dreamweaver breaks CSS properties into the following categories:

Layout- for margins, padding, height and width.

Text - for styles that effect text and fonts.

Border - for border size, styles, and color.

Background - for background colors and images.

More - for other choices.
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 8.5.1. Layout
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 8.5.2. Text
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 8.5.3. Border
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 8.5.4. Background

 8.5.5. More
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 Exercise 13: Styling a Table
 20 to 30 minutes

In this exercise, you will style some pages.

1. Open ClassFiles/dreamweaver-cc/Exercises/table.html in Dreamweaver.

2. Click somewhere in the table and then clear the deprecated HTML properties
shown in the screenshot below:

3. Add a stylesheet called styles.css in the same folder.

4. Create rules for the following:

A. All caption elements should be bold and left-aligned with white text and
a dark blue background.

B. All table headers (th) should have dark blue text and should have 4 pixels
of padding on all sides.

C. All table data cells (td) should have 4 pixels of padding on all sides.

D. All odd rows starting with the one under the table header, should have a
light gray background color (#ccc).

E. The heading 1 (h1) should be centered.

F. The table should be centered.To center the table, you will need to change
the left and right margins to “auto”.

5. When you’re finished, open the page in your browser. It should look like this:
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Solution

There are different ways to accomplish this look. To compare how you did it with our
solution, look at the CSS Styles panel. In the Selectors part, you will see the selectors.
Ours look like this:

Style sheets that are saved as separate files can be used over and over again.To illustrate
this:

1. Open ClassFiles/dreamweaver-cc/Exercises/sales-report.html in Dreamweaver.

2. Click somewhere in the table and then clear the deprecated HTML properties
shown in the screenshot below:

3. In the CSS Designer panel, click the Add CSS Source and choose Attach
Existing Style Sheet icon:
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4. In the Attach External Style Sheet dialog box, browse to styles.css in the
ClassFiles/dreamweaver-cc/Exercises folder:

5. Click OK.

6. Select the last table row showing the Grand Total and enter an id of “summaryrow”:

7. Create a rule using an ID selector that sets the background color to dark green
and the font to white and bold. The page should look like this:
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❋

8.6. The Cascade

Web designers can define style rules in three different places:
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Where Styles are Set

1. In an external (or linked or imported) style sheet.

2. In an embedded style sheet.

3. Inline in an element.

In the examples above, we have been using external style sheets. This is generally the
best approach as it allows you to apply a single style sheet to an unlimited number of
HTML files.

 8.6.1. Embedded Style Sheets

To create and embedded style in Dreamweaver, select “(Define in Page)” for the Rule
Definition:

 8.6.2. Inline Styles

Inline styles are applied directly to an element within the HTML code using the style
attribute. The value of the style attribute is a list of one or more property-value pairs
separated by semi-colons. The code snippet below illustrates how inline styles are used:

<p style="color:red; font-weight:bold;">Hello, world!</p>

To illustrate how to add inline styles:

1. Open ClassFiles/dreamweaver-cc/Exercises/sales-report.html in Dreamweaver
if it’s not open already.

2. Place the cursor in the heading 1.

3. In the Properties, click CSS.
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4. Select <New Inline Style> from the Targeted Rule menu:

5. Click the Edit Rule button.

6. Style the heading however you want.

Generally, you should avoid using inline styles as you will not be able to reuse them in the
same document or in others.

❋
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8.7. Units of Measurement

CSS allows you to specify font size, border size, margins, padding, etc. using many different
units of measurement. The table below shows the units available.
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ExampleUnitName

margin-top: 10px;pxPixels

Pixel is the measurement unit most often used for designing web pages is
pixels. A pixel is not an absolute measurement like, for example, an inch or
a point. The actual size of a pixel depends on the resolution and size of a
user’s monitor. Consider an image that is 900 pixels wide. If the monitor
resolution is set to 800 by 600 pixels, then the image will not fit on the screen.
However, if the monitor resolution on the same computer is set to 1024 by
768 pixels, the image will fit with room to spare.

font-size: 12pt;ptPoints

Points should be reserved for print. There are 72 points in an inch.

padding-top: .5in;inInches

Although inches are one of the most common units of measurement in life,
they should be avoided in web design.

top: 5cm;cmCentimeters

Although centimeters are one of the most common units of measurement
in life, they should be avoided in web design.

left: 45mm;mmMillimeters

Although millimeters are one of the most common units of measurement in
life, they should be avoided in web design.

bottom: 12pc;pcPicas

Picas should be reserved for print. There are 6 picas in an inch.

font-size: 1.5em;emEms

An em (or Mutt) is a relative unit that refers to the size of the letter “M” in a
font. Because em is a relative rather than absolute measurement, it is often
used in web design, especially for font sizes.

font-size: 1.5ex;exExs

The “x-height” is the height of font’s lowercase “x”. Exs are used to set the
size of content based on the size of the surrounding font.

width: 80%;%Percentage

The percentage is based on the default size had no value been specified.
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 Exercise 14: CSS Play
 15 to 60 minutes

This is an optional exercise if time allows.

1. Style the following files however you like:

A. ClassFiles/dreamweaver-cc/Exercises/index.html

B. ClassFiles/dreamweaver-cc/Exercises/Resources.html

C. ClassFiles/dreamweaver-cc/Exercises/RunningTerms.html
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Solution

There is no right answer. Just have fun.

Conclusion

In this lesson, you have learned to style your HTML pages using CSS.

126 | LESSON 8: Styling Content

EVALUATION COPY: Not to be used in class.


	A Quick Overview of Web Development
	HTML is Part of a Team
	Client-side Programming
	Server-side Programming

	Getting Started with Dreamweaver
	The Role of Dreamweaver
	Start Screen
	Dreamweaver Workspaces
	Creating HTML Pages
	Code View vs. Design View
	Exercise 1: Creating a Web Page
	The Dreamweaver Interface
	Previewing Your Page
	Exercise 2: Previewing a Web Page
	Setting Up a Website
	Edit Preferences

	Creating HTML Pages
	Understanding HTML Doctypes
	Adding a Title to Your Page
	Paragraphs, Headings, and Blockquotes
	Exercise 3: Adding Content to Your Page
	Breaks
	Special Characters
	Exercise 4: Adding Breaks

	Links
	Adding Links
	Absolute vs. Relative Paths
	Quick Tricks for Adding Links in Dreamweaver
	Exercise 5: Adding Links to Your Page
	Targeting New Windows
	Email Links
	Exercise 6: More on Links
	Naming a Location on a Page
	Exercise 7: Adding Anchors

	Images
	Inserting Images
	Image Links
	Exercise 8: Adding Images to Your Page
	Inserting Photoshop .psd documents directly - Photoshop Smart Objects

	Lists
	Ordered and Unordered Lists
	Definition Lists
	Exercise 9: Creating Lists
	Converting Existing Content to Lists
	Exercise 10: Converting Content to a List

	Tables
	Adding a Table to Your Page
	Sorting Tables
	Exercise 11: Table Sorting
	Modifying Tables
	Exercise 12: Converting a List to a Table
	Importing Data into Tables
	Dreamweaver and Styling Tables

	Styling Content
	HTML Structure
	CSS Rules
	Selectors
	Modifying the Rule
	CSS Properties
	Exercise 13: Styling a Table
	The Cascade
	Units of Measurement
	Exercise 14: CSS Play


