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LESSON 1
Crystal Reports Review

Topics Covered

 Review exercise.

Introduction

Before we introduce new topics, let’s review the topics covered in the introductory course
by building a practice report that reinforces the following:

Creating a connection.

Organizing fields into the report sections.

Controlling sections using the section expert.

Creating groups and group summaries.

Using formulas to create content.
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 Exercise 1: Creating a Report
 45 to 60 minutes

In this exercise, you will create a new report about the sales people of Adventure Works
Cycles.

1. Show the following information for each sales person:

A. Full name (using a formula)

B. Phone number

C. Date of birth

D. Last year’s sales

2. Total all sales figures.

3. Group sales people by sales territory and region (North America, Europe, and
Pacific).

Note

There will be two groups based on a conditional formula that represents the
regions and then the sales territories. For the US territories, show the specific
territory name followed by “United States”.

4. Include a chart of Sales by Territory.

5. Name the report SalesReport.rpt and save it to your ClassFiles\cry2011-re
view\Exercises folder.

2 | LESSON 1: Crystal Reports Review

EVALUATION COPY: Not to be used in class.



LESSON 1: Crystal Reports Review | 3



Solution

The following steps represent one possible solution to the exercise:

1. From the menu, select File > New > Blank Report.

2. In the Database Expert  d ialog box, expand to the
C:\ClassFiles\Data\AdventureWorks.mdb node. (If you have not already
established this connection, see the appendix.)
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3. Double-click the Employee, Contact, CountryRegion, SalesPerson, and
SalesTerritory nodes.

4. Select the Links tab.

5. Click the Clear Links button. Click Yes to confirm that you want to clear the links.
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6. Create the following links between the tables:

A. Link the ContactID field of the Contact table to the ContactID field of the
Employee table.

B. Link the EmployeeID field of the Employee table with the SalesPersonID
field of the SalesPerson table.

C. Link the TerritoryID field of the SalesPerson table with the TerritoryID
field of the SalesTerritory table.

D. Link the CountryRegionCode field of the SalesTerritory table with the
CountryRegionCode field of the CountryRegion table.

7. Click OK.

8. From the menu, select View > Field Explorer to show the Field Explorer pane.

9. In the Field Explorer, select the Formula Fields node and click the New icon in
the Field Explorer toolbar.

10. In the Formula Name dialog box, type “Name” and click OK.
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11. In the Formula Workshop - Formula Editor - Name dialog box, type the following
in the formula editor:

{Contact.FirstName} & (If IsNull({Contact.MiddleName}) Then "" Else " " & {Con  ↵↵
tact.MiddleName})& " " &{Contact.LastName}

12. Click the Check icon to verify the formula.

13. Click Save and close.

14. Click and drag the following fields, in the order indicated, from the Field Explorer
to the Details section of the report. Use the text in parentheses as the field title:

A. Name formula field (“Sales Person”)

B. Contact.Phone (“Phone”)

C. Employee.BirthDate (“Date of Birth”)

D. SalesPerson.SalesLastYear (“Sales Last Year”)

15. Right-click the BirthDate field and select Format Field.

16. In the Format Editor dialog box, on the Date and Time tab, click March 01, 1999.
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17. Click OK to close the dialog box.

18. Adjust the widths of the fields as needed.

19. In the Field Explorer, select the Formula Fields node and click the New icon in
the Field Explorer toolbar.

20. In the Formula Name dialog box, type “SalesTerritory” and click OK.

8 | LESSON 1: Crystal Reports Review

EVALUATION COPY: Not to be used in class.



21. In the Formula Workshop - Formula Editor - Sales Territory dialog box, type
the following in the formula editor:

{SalesTerritory.Name} & (If {SalesTerritory.CountryRegionCode} = "US" Then "
United States" Else "")

22. Verify the formula and click Save and close.

23. In the Experts toolbar, click the Group Expert icon.

24. In the Group Expert dialog box, locate and expand the SalesTerritory node and
then double-click the Group field.

25. Locate and double-click the Sales Territory formula field.
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26. Click OK.

27. Move the Group #2 Name over.

28. Click the Section Expert icon.

29. In the Section Expert dialog box, in the Sections list box, select Group Header
#2 and click Insert. Click OK.
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30. Select all field titles, move them to the Group Header #2b and click the Bold icon
in the Formatting toolbar.

31. Adjust the width of any fields along with their corresponding field titles as needed.

32. Move all of the fields to the right, adjusting them accordingly.

33. Right-click the Sales Last Year field and select Insert > Summary.
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34. In the Insert Summary dialog box, verify that “Sum” is selected in the Calculate
this summary drop-down list, and then in the Summary location section mark
the Add to all group levels checkbox.

35. Click OK.
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36. Increase the height of Group Footer #1, Group Footer #2, and the Report Footer.
Move each summary down to the bottom of the section.

37. Click the Insert Line icon. In the Group Footer #1 and the Group Footer #2
section, draw a line just above each summary field.

38. Format each line to suit you by right-clicking the line object and select Format
Line.

39. In the Format Editor dialog box, change the width to 2 pt and click OK.
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40. Draw a box around the Report Footer Summary.

41. Create labels for each summary by doing the following:

A. Click the Insert Text Object icon. Move the cursor to the Group Footer
#2 section near the middle of the report and click.

B. In the text object, type “Sales for”.

C. In the Field Explorer, expand the Group Name Fields node, drag the
Group #2 Name field into the text object, and then type a colon (“:”) at the
end.

D. Right-click the summary field in the Group Footer #2 section and select
Cut.

E. Right-click the text object and select Edit Text. Go to the end of the text,
add a space, and then right-click and select Paste. Click outside of the
text object.

F. Expand the text object to the far right side of the Group Footer #2 section.

G. With the text object still selected, click the Bold and Align Right icons.

H. Repeat for each remaining summary.
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42. Click the Insert Text Object icon. Move the cursor to the top left corner of the
Report Header section and click.

43. Type “Adventure Works Cycles Sales People Report” inside the text object. Click
outside of the text object.

44. Move the text object into the upper-left corner of the Report Header section and
expand the text object to the other end of the Report Header section.

45. Click the Bold and Align Center icons.

46. From the Font Size drop-down list, select “20”.

47. Expand the text object vertically to ensure that the text is completely visible. Also
adjust the height of the Report Header section to ensure that the text object is
not too close to the field titles.

48. Save the report as “SalesReport.rpt”.

49. Preview the report.

After some formatting adjustments, the report should look similar to the following:
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Conclusion

In this lesson, you completed a review exercise covering introductory topics.
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LESSON 2
Using Parameters

Topics Covered

 Creating a parameter.

 Using parameters in reports.

 Optional parameters.

 Lists of values to set a parameter value.

 Dynamic lists of values.

 Cascading lists of values.

 Multivalue parameters.

 Ranges of values.

Introduction

Flexibility can be important when creating reports. Rather than change a report to
accommodate various user requests, it can be helpful to put that choice in the user’s
control. This is where the parameter field in Crystal Reports becomes useful. We can
create parameters in our reports that can be set by the report user. This greatly reduces
the amount of work required to satisfy user requests while also providing the user with a
report that is interactive.

Parameter fields serve as a placeholders for real data to be entered by the report user.
Parameter fields must match in data type in order to serve as a placeholder for the fields
they are replacing.These fields can be static, dynamic, cascading, and entered as ranges.
All of these techniques will be explored.

❋
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2.1. Creating Parameters

To create a parameter field in Crystal Reports, we start in the Field Explorer. Among its
nodes, you will find the Parameter Fields node. Selecting this node and clicking the New
icon in the Field Explorer toolbar opens the following dialog box:

 2.1.1. Adding a Parameter Field

Using a Customer report developed for your use, we will demonstrate how to add a
parameter field so that users can filter the report using the customer’s country.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer.rpt and select the
Design tab.

2. In the Field Explorer, select the Parameter Fields node and click the New icon
in the Field Explorer toolbar.
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3. In the Create New Parameter dialog box, replace the text in the Name field with
“p_territory”.

4. Verify that "String" is selected in the Type drop-down list and that "Static" is
selected in the List of Values drop-down list. In the Value Options area, locate
the Prompt Text and replace it with "Enter the Territory" and then click OK.

5. Click the Select Expert icon.

6. In the Choose Field dialog box, double-click SalesTerritory.Group. Click OK.
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7. In the Select Expert -- Record dialog box, select "is equal to" from the drop-down
list of conditions.

8. In the second drop-down list, select the "{?p_territory}" option, which represents
the SalesTerritory.Group parameter field.

9. Click OK.

10. Preview the report.The Enter Values dialog box prompts you for a territory name.

11. In the Enter p_territory field, type “Europe” and then click OK.
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12. Review the report. Notice that only customers in Europe appear on the report.

13. To change the parameter, press F5 or click the Refresh button.

14. In the Refresh Report Data dialog box, select Prompt for new parameter values
and click OK.
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15. In the Enter Values dialog box, replace “Europe” in the Enter p_territory field
with “North America” and click OK.

16. After previewing the report with the territory of North America as the filter value,
press F5.

17. In the Refresh Report Data dialog box, select Prompt for new parameter values
and click OK.

18. In the Enter Values dialog box, replace “North America” with “South America”
and click OK.

19. Observe that the report contains no records since there are no customers in South
America.

20. Select the Design tab and save the report.

❋
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2.2. Optional Parameters

We’ve demonstrated how to use parameters to give report users more control over the
content of their reports. What about the instances when the report user wants to see all
the data in the report? In other words, how can the user view the report unfiltered? In
previous versions of Crystal Reports, report developers would typically create another
parameter to provide this option.The problem with this approach is that a parameter would
be needed to turn off the filter for each parameter in the report. In Crystal Reports 2011,
we can define parameters as optional, ensuring no further action from the report developer.

 2.2.1. Making a Parameter Optional

In order to reuse the Customers report and allow for all records to be shown, we will make
the p_territory parameter optional.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_1.rpt or you may
continue to use your own. Select the Design tab.

2. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field and click the Edit icon in the Field Explorer toolbar.

3. In the Edit Parameter: p_territory dialog box, in the Value Options table, find
“Optional Prompt” in the Option column. Change the value in the Setting column
to “True”. You are warned that your action could break existing formulas. Click
OK 2 times.

LESSON 2: Using Parameters | 23



4. Preview the report. The Enter Values dialog box opens with the Enter the
Territory field empty. Click OK. The following message is returned:

5. Click OK. The Formula Workshop - Record Selection Formula Editor dialog
box opens. Since the parameter was not originally defined as an optional
parameter, we need to change it manually.

6. In the formula editor, edit the formula to match the following:

(Not HasValue({?p_territory})) Or {SalesTerritory.Group} = {?p_territory}
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7. Verify the formula and then click Save and close. The report should now be
unfiltered.

8. Press F5. In the Refresh Report Data dialog box, select Prompt for new
parameter values and click OK.

9. In the Enter Values dialog box, type “Europe” in the Enter p_territory field and
click OK.

10. Select the Design tab and save the report.

❋
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2.3. Using a List of Parameter Values

We can manually add a list of values when we define a parameter, but the most expedient
method for creating a list of values is by using data from our database. This is a one-time
connection to the database and we must manually sync the list each time the database
is updated. The “disconnect” can be a positive as the report will not slow down at all using
this type of parameter list.

 2.3.1. Creating a Parameter Value List

In this demonstration, we will edit the parameter to filter the report by territory, but give
the report users a list to choose from.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_2.rpt or you may
continue to use your own. Select the Design tab.

2. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field, and click the Edit icon in the Field Explorer toolbar.

3. In the Edit Parameter: p_territory dialog box, in the Value Field, choose
SalesTerritory.Group in the drop-down.
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4. From the Actions drop-down list, select Append all database values.

Append all database values

Under certain conditions, the Append all database values selection does
not work correctly. If this occurs, you can add the values manually.

5. All of the territories should be listed in the Value table below.
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6. Click OK.

7. Preview the report. (press F5 if needed). The Enter Values dialog box prompts
you for a sales territory.

8. From the Enter the Territory drop-down list, select “North America” and click OK.

9. Select the Design tab.

10. Select the report title and then expand it to the right up to the logo image. Also
expand its height so that the report title is completely visible.

11. Right-click the report title text object and select Edit Text.

12. Move the cursor to the end of the text and type “from”.

13. In the Field Explorer, click and drag the Sales Territory parameter field to the
end of the text in the text object. Click outside of the text object.
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14. Preview and save the report.
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 Exercise 2: Using Parameters
 30 to 45 minutes

In this exercise, we will add filters based on report parameters to the Sales Order report,
which was developed for your use. Open C:\ClassFiles\cry2011-parameters\Exercis
es\SalesOrder.rpt.

1. Add a parameter for selecting specific sales territories that is based on the
SalesTerritory.Group field.

2. Using the new parameter field, filter the report based on the SalesTerritory.Group
field.

3. Change the report header to indicate the filter in use. (Use Europe as an example.)
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Solution

The following steps represent one possible solution to the exercise:

1. Open C:\ClassFiles\cry2011-parameters\Exercises\SalesOrder.rpt and select
the Design tab.

2. In the Field Explorer, select the Parameter Fields node and click the New icon
in the Field Explorer toolbar.

3. In the Create New Parameter dialog box, replace the text in the Name field with
“p_territory”.

4. Verify that "String" is selected in the Type drop-down list and that "Static" is
selected in the List of Values drop-down list. In the Value Options area, locate
the Prompt Text and replace it with "Enter the Territory" and then click OK.
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5. Click the Select Expert icon.

6. In the Select Expert -- Record dialog box you will change the existing filter to use
the p_territory paramater.

7. Confirm in the Select Expert -- Record dialog box, that select "is equal to" is
choosen from the drop-down list of conditions.

8. In the second drop-down list, select the "{?p_territory}" option, which represents
the SalesTerritory.Group parameter field.

9. Click OK.

10. Preview the report.The Enter Values dialog box prompts you for a territory name.

11. In the Enter the Territory field, type “Europe” and then click OK.

12. Review the report. Notice that only customers in Europe appear on the report.

13. Select the Design tab.

14. Select the report title and then expand it to the right side of the report if needed.
Also expand its height so that the report title is completely visible if needed.

15. Right-click the report title text object and select Edit Text.

16. Move the cursor to the end of the text and type “from”.
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17. In the Field Explorer, click and drag the Sales Territory parameter field to the
end of the text in the text object. Click outside of the text object.

18. Preview the report.

19. Select the Design tab and save the report.

❋

2.4. Dynamic List of Values

Creating a dynamic list of values has the benefit of updating each time the reports runs
and communicates directly with the database.The price we pay for this level of interactivity
is speed. The report may be a bit slower to process and run as the time to communicate
with the database can be lengthy if we have a large database.
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 2.4.1. Creating a Dynamic Value List

In this demonstration, we will edit the parameter to filter the report by territory, but give
the report users a list to choose from that stays up to date.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_3.rpt or you may
continue to use your own. Select the Design tab..

2. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field and click the Edit icon in the Field Explorer toolbar.

3. In the Edit Parameter: p_territory dialog box, in the List of Value, choose
Dynamic in the drop-down. In the Choose a Data Source area, click the Click
here to add item. Choose SalesTerritory.Group. Click OK.
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4. Preview the report. Choose “Pacific” from the drop-down.

5. Click OK.

6. Save the report.

❋

2.5. Cascading List of Values

Creating a dynamic list of values has the benefit of updating each time the reports runs
and communicates directly with the database. When we have a complex relationship
between the data, a cascading list may be the solution. Cascading list values become
useful when we have hundreds of countries to choose from. Instead of having such large
dynamic lists, we may use the natural hierarchy of the data to pullout first the territory,
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then the countries within each territory, leaving just what we need to choose from and not
others cluttering the parameter dialog box.

 2.5.1. Creating a Cascading Value List

In this demonstration, we will edit the parameter to filter the report by country, but give the
report users a list to choose from that isolates the drop-down to show just one territory at
a time.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_4.rpt or you may
continue to use your own. Select the Design tab.

2. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field and click the Edit icon in the Field Explorer toolbar.

3. In the Edit Parameter: p_territory dialog box, in the List of Value, choose
Dynamic from the drop-down. In the Choose a Data Source area click the New
radio button, click the Click here to add item. Choose SalesTerritory.Group
and click below on the Click here to add item. Choose CountryRegion.Name.
Click OK.

LESSON 2: Using Parameters | 37



4. Click the Select Expert icon.

5. Delete the SalesTerritory.Group filter by clicking Delete.

6. Click New button.

7. Choose CountryRegion.Name, Click OK.
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8. Choose "is equal to“ from the first drop-down box. Choose ”{p_territory}" from
the second drop-down box.

9. Click OK.

10. Preview the report. Choose "Europe“ and then choose ”France".
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11. Click OK.

12. The report should only be showing France customers.

13. Save the report.

❋

2.6. Multivalue Parameters

Often in a report, we want a multiple items, not a single, nor all, but a nice mix of exactly
what we want. Crystal Reports has a parameter setting to assist you.
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 2.6.1. Creating a Dynamic Value List

In this demonstration, we will edit the parameter to filter the report by territory, but give
the report users a list to choose from that will allow them to choose more than one territory.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_3.rpt. Select the
Design tab.

2. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field, and click the Edit icon in the Field Explorer toolbar.

3. In the Edit Parameter: p_territory dialog box, in the Value Options, locate the
Allow Multiple Values and choose True. Click OK.

4. Preview the report. Choose "Europe“ and ”North America" by double-clicking
each one to move it to the Selected Values area.
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5. Click OK.

6. The report should show both countries in Europe and North America.

7. Save the report.

❋

2.7. Range Parameter

Often in a report we want a range of dates. Crystal Reports has a parameter setting to
assist you.
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 2.7.1. Creating a Range Parameter

In this demonstration, we will edit the parameter to filter the report by date, but give the
report users a range to choose from.

1. Open C:\ClassFiles\cry2011-parameters\Demos\Customer_6.rpt. Select the
Design tab.

2. In the Field Explorer, select the Parameter Fields node and click the New icon
in the Field Explorer toolbar.

3. In the Create New Parameter dialog box, replace the text in the Name field with
“p_DateRange”.

4. Verify that "Date Time" is selected in the Type drop-down list and that "Static" is
selected in the List of Values drop-down list. In the Value Options area, locate
the Prompt Text and replace it with "Enter the dates“. Locate the ”Allow range
values" and choose True and then click OK.
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5. Click the Select Expert icon.

6. Delete the SalesTerritory.Group filter by clicking Delete.

7. Click New, Choose Individual.DateFirstPurchase and click OK.
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8. Choose "is equal to“ from the first drop-down box. Choose ”{?p_DateRange}"
from the second drop-down box. Click OK.

9. Preview the report. Choose Start of Range; 1/1/2003 00:00:00 and End of Range:
12/31/2003 23:59:59. Click OK.
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10. The report should only show items form the year 2003.

11. Save and close the report.
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 Exercise 3: Special Parameter Options
 15 to 25 minutes

In this exercise, we will edit report parameters in the Sales Order report, which was
developed for your use. Open C:\ClassFiles\cry2011-parameters\Exercises\SalesOr
der_1.rpt.

1. Edit the parameter for the SalesTerritory.Group field so that it pulls in all of the
accounts in a territory.

2. Using the parameter field, filter the report based on the
SalesOrderHeader.AccountNumber field.

3. Allow for multiple accounts to be chosen at a time.
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Solution

The following steps represent one possible solution to the exercise:

1. Open C:\ClassFiles\cry2011-parameters\Exercises\SalesOrder_1.rpt.

2. Select the Design tab.

3. In the Field Explorer, expand the Parameter Fields node, select the p_territory
parameter field and click the Edit icon in the Field Explorer toolbar.

4. In the Edit Parameter: p_territory dialog box, in the List of Value, choose
Dynamic from the drop-down. In the Choose a Data Source area click New, click
the Click here to add item. Choose SalesTerritory.Group, click below on the
Click here to add item. Choose SalesOrderHeader.AccountNumber. Click OK.
In the Edit Parameter: p_territory dialog box, in the Value Options, locate the
Allow Multiple Values and choose True. Click OK.
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5. Click the Select Expert icon.

6. Delete the SalesTerritory.Group filter by clicking Delete.

7. Click New button.

8. Choose SalesOrderHeader.AccountNumber, Click OK.

9. Choose "is equal to“ from the first drop-down box. Choose ”{p_territory}" from
the second drop-down box. Click OK.
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10. Preview the report and choose any two account numbers.

11. The report shows the 2 accounts.
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12. Save and close the report.

Conclusion

In this lesson, you learned:

To create a parameter in Crystal Reports.

To use parameters in reports.

How to use optional parameters.

How to use a list of values to set a parameter value.

How to create a dynamic list of values.

How to use a cascading list of values.

How to use multivalue parameters.

How to use a range of values.
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LESSON 3
Using Subreports

Topics Covered

 Subreports within a main report.

 Linking subreports to the main report.

Introduction

Subreports may be used to include additional information in your report, that may or may
not have a direct linkage between the data already contained in the report. Subreports
are used in both situations, and based on section location, may repeat or appear once.

❋

3.1. Unlinked Subreports

To include information which has no relationship with the data already contained in a
report, you can use an unlinked subreport. For example, suppose your report is a letter
that pulls in data from your database, but you also need to include a list of the board of
directors of your organization in the letter.You could use an unlinked subreport to include
the list of board members in a non-repeat section such as the Report Footer.

 3.1.1. Creating an Unlinked Subreport

For this demonstration, we have been asked to include last year’s sales by sales region
in the Customer report.

1. Open C:/ClassFiles/cry2011-subreports/Demos/Customer.rpt and select the
Design tab.

2. On the Insert toolbar, click the Insert Subreport icon.
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3. In the Insert Subreport dialog box, ensure that the Create a subreport with the
Report Wizard option is selected. In the New report name field, type “Last Year’s
Sales” and then click the Report Wizard button.

4. In the Standard Report Creation Wizard dialog box on the Data page, expand
the C:\ClassFiles\Data\AdventureWorks.mdb node and double-click the
SalesTerritory table.
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5. Click Next.

6. On the Fields page, double-click the Name and SalesLastYear fields.
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7. Click Finish.

8. In the Insert Subreport dialog box, click OK.

9. Move the mouse cursor to the far-left side of the Report Header section and click.

10. Right-click the Report Header section and select Insert Section.

11. Move and resize the subreport box to fit in the Report Header b section. Adjust
the placement of the fields to maximize the width of the subreport.
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12. Right-click the subreport box and select Edit Subreport.

13. Notice that a Last Year’s Sales tab has been added.

14. In the subreport, remove the Print Date field and the field titles.

15. Right-click the Report Header a section and select Delete Section.

16. Right-click the Report Footer b section and select Delete Section.

17. Right-click in the Report Footer section and select Suppress (No Drill-Down).

18. Expand the height of the Details section.

19. Add a new guideline along the vertical ruler near the bottom of the Details section.

20. Move the SalesLastYear field down until its bottom edge is linked to the new
horizontal guideline and then move it to the left using its vertical guideline.

21. Preview the subreport.

22. Expand the SalesLastYear field to ensure that the field values are visible and not
masked.

23. Select the Last Year’s Sales tab.

24. In the Field Explorer, right-click the Formula Fields node and select New.

25. In the Formula Name dialog box, type “salesRegion” and click OK.
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26. In the Formula Workshop - Formula Editor - salesRegion dialog box, type the
following in the formula editor:

{SalesTerritory.Name} & (If {SalesTerritory.CountryRegionCode} = "US" Then "
USA" Else "")

27. Verify the formula and then click Save and close.

28. Remove the Name field from the subreport and replace it with the Sales Region
formula field. Remove the new field title.

29. Click the Insert Text Object icon, move the cursor near the upper-left corner of
the Report Header section, and click.

30. Inside the text object, type “Sales for Last Year by Region”. Click outside of the
text object.

31. Move the text object to the far left and then expand its width to the width of the
subreport.

32. Select the text object and change the font size to 11.

33. Click the Bold and Align Center icons.

34. Increase the height of the text object by expanding it from the bottom edge until
all the text is clearly visible.

35. Change the height of the Report Header, leaving a little space at the bottom.

36. Preview the subreport.
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37. Preview the report.

38. Select the Design tab.

39. Right-click the Report Header b section and select Section Expert.

40. In the Section Expert dialog box, ensure that Report Header b is selected in the
Sections list. On the Common tab, mark the Underlay Following Sections
checkbox.
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41. Click OK.

42. Preview the report.
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43. Save the report.

❋

3.2. Linked Subreports

Sometimes including all the data we want to present in a report would mean adding
numerous tables. Including a large number of tables as data sources for a report can result
in performance issues. An alternative solution is the linked subreport.

By linking subreports to a main report, we can minimize the number of tables that we need
to add for the main report while still getting a good set of data for the report. Linked
subreports can be very handy when you need to present additional information that is
associated with the data in the main report.

 3.2.1. Adding a Linked Subreport

We will add the sales people for each of our regions to the Customer report.

1. Open C:/ClassFiles/cry2011-subreports/Demos/Customer_2.rpt and select the
Design tab.

2. On the Insert toolbar, click the Insert Subreport icon.
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3. In the Insert Subreport dialog box, ensure that the Create a subreport with the
Report Wizard option is selected. In the New report name field, type “salesPeople”
and then click the Report Wizard button.

4. In the Standard Report Creation Wizard dialog box on the Data page, expand
the C:\ClassFiles\Data\AdventureWorks.mdb node.

5. Double-click the Contact, CountryRegion, Employee, SalesPerson and
SalesTerritory tables.
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6. Click Next.

7. On the Link page, verify the link between the tables, remove links and fix if needed.

8. Click Next.
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9. On the Fields page, expand the Contact node and double-click
Contact.Firstname, Contact.LastName, and CountryRegion.Name.

10. Click Finish.

11. Back in the Insert Subreport dialog box, select the Link tab.

12. In the Available Fields list, locate and expand the CountryRegion table node
and then double-click Name. Note that the Subreport parameter field to use
drop-down option is now set to "?PmCountryRegion.Name" and the Select data
in subreport based on field checkbox is marked and the drop-down option is
set to "CountryRegion.Name".
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13. Click OK. If the Subreport Preview message box appears, click OK.

14. Move the mouse cursor to the Group Footer 1 section to the left and click.

15. Right-click the salesReport subreport and select Edit Subreport.

16. In the salesReport design view, remove the Print Date field.

17. Right-click the Report Header a section and select Delete Section.

18. Right-click the Report Footer b section and select Delete Section.

19. Right-click the Report Footer section and select Suppress (No Drill-Down).
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20. Preview the subreport.

21. Select the Design tab.

22. Right-click the subreport object and select Format Subreport....

23. In the Format Editor dialog box, on the Common tab, confirm that the Can Grow
checkbox is active.

24. Click OK.
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25. Preview and save the report.
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 Exercise 4: Using Subreports
 20 to 30 minutes

Add the billing address to the right of the order number on the Sales Order report.

1. Add a subreport using the Address, StateProvince, and CountryRegion tables
to present the billing address.

2. Use the BillToAddress field in the SalesOrderHeader table as the linked field
for the subreport.
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Solution

The following steps represent one possible solution to the exercise:

1. Open C:/ClassFiles/cry2011-subreports/Exercises/SalesOrder.rpt and select
the Design tab.

2. Click the Insert Subreport icon.

3. In the Insert Subreport dialog box, ensure the Create a subreport with the
Report Wizard option is selected, type “AcctAddress” in the New report name
field, and then click the Report Wizard button.

4. In the Standard Report Creation Wizard dialog box, expand the
C:\ClassFiles\Data\adventureWorks.mdb node, and then double-click the
Address, CountryRegion, and StateProvince tables.
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5. Click Next.

6. On the Link page, verify the links between the tables.

7. Click Next.

8. On the Fields page, add the AddressLine1, AddressLine2, City, and PostalCode
fields from the Address table, the Name field from the CountryRegion table, and
the StateProvinceCode field from the StateProvince table.
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9. Click Finish.

10. In the Insert Subreport dialog box, select the Link tab.

11. In the Available Fields list box, locate and expand the SalesOrderHeader node
and double-click the BillToAddressID field. Ensure that “Address.AddressID” is
selected in the drop-down list below the Select data in subreport based on field
checkbox.
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12. Click OK.

13. Move the mouse cursor to the right of the Account Title formula field in the Group
Header #1a section and click. Size to fit.

14. Right-click the AcctAddress subreport and select Edit Subreport. The
AcctAddress tab should now be in focus.

15. Remove the Print Date and the field titles from the subreport.

16. Right-click the Report Header a section and select Delete Section.

17. Right-click the Report Footer b section and select Delete Section.

18. Move the AddressID to the Report Header section.

19. Right-click the Report Header section and select Suppress (No Drill-Down).
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20. Move the AddressLine2 field below the AddressLine1 field. Remove the orphaned
guideline.

21. Move the City, PostalCode, Name, and StateProvinceCode fields into a new
text object, make sure to arrange with proper spacing.

22. Select the Design tab.

23. Preview the report.
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24. Save the report.

Conclusion

In this lesson, you learned:

To use subreports within a main report.

To link subreports to the main report.
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LESSON 4
Charts

Topics Covered

 Adding charts to reports.

Introduction

Pages of data simply do not have the same impact on some people as a visual
representation of that data. Crystal Reports provides the tools to create charts for displaying
your data visually.

❋

4.1. Adding a Chart to a Report

To add a chart to a report, go to the Insert toolbar and click the Insert Chart icon. To
open up the Chart Expert, move the mouse to the location where you want to put the
chart and click:
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A variety of charts can be created using the Chart Expert. The following table describes
the types of charts available:
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Chart DescriptionChart Type

The bar chart is useful in presenting comparative data.

The line chart is useful for presenting data over time.

The area chart is similar to the line chart in function, but it fills in the area
below the line.

The pie chart is useful in presenting data as percentages.

The dough nut chart is similar to the pie chart, except it provides the grand
total in the open center.

The riser chart is a three-dimensional representation of the line chart. This
chart is useful when using multiple groups of data.

The surface chart is a three-dimensional representation of the area chart.

The scatter chart is useful in looking for visual correlation patterns within
the data.

The radar chart is useful in displaying data patterns among groups of data.

The bubble chart compares data in a way similar to the scatter chart, except
it provides for an additional set of data to compare with by using the size
of the individual plotted points.

The stock chart presents a set of data as a bar that displays the range of
data from its low point to its high point.

The numeric axis chart is an alternative to the bar, line, and area charts
that uses a numeric/date axis along the bottom of the chart.

The gauge chart provides a different means of displaying data as an
alternative to many of the traditional charts.

The Gantt chart allows for data to be presented based on start and end
dates.
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Chart DescriptionChart Type

The funnel chart is useful for displaying the data associated with the flow
patterns of a process.

The histogram chart is useful in displaying the frequencies in a set of data.

Crystal Report charts can provide useful information in a very powerful way. Often a chart
can provide a meaningful, succinct summary of the information in your report.

 4.1.1. Adding a Chart

We will add a bar chart based on the the number of customer in each region to the
Customer report.

1. Open C:\ClassFiles\cry2011-charts\Demos\Customer.rpt and select the Design
tab.

2. Click the Insert Chart icon. Move the mouse cursor to the far left side of the Group
Header 1b and click.

3. A chart is placed in your Group Header 1b, you may need to right-click and choose
Chart Expert if it does not open on its own.

4. In the Chart Expert dialog box, select the Type tab. In the Choose your chart
type list box, select Bar.
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5. Select the Data tab.

6. Confirm that the CountryRegion.Name field is listed in the On change of
drop-down and that the Show drop-down has Count of
Customer.AccountNumber is listed.
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7. Click OK.

8. Resize the chart object to fit in the subreport.
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9. Preview and save the report.
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 Exercise 5: Adding a Chart
 20 to 30 minutes

In this exercise, we will add a chart to the Sales Order report.

1. Add a chart to the group header 1c that displays total color by product.

2. Format as you like.
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Solution

The following steps represent one possible solution to the exercise:

1. Open C:ClassFiles\cry2011-charts\Exercises\SalesOrder.rpt and select the
Design tab.

2. Click the Insert Chart icon. Move the mouse cursor to the far left side of the Group
Header 1c and click.

3. A chart is placed in your Group Header 1c, you may need to right-click and choose
Chart Expert if it does not open on its own.

4. In the Chart Expert dialog box, select the Type tab. In the Choose your chart
type list box, select Bar.

5. Select the Data tab.

6. Confirm that the Product.Color field is listed in the On change of drop-down and
that the Show drop-down has Count of Product.Name is listed.
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7. Click OK.

8. Resize the chart object to fit in the subreport.

9. Preview and save the report.
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Conclusion

In this lesson, you learned:

How to add a chart to a report.
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LESSON 5
Cross-Tabulation Reports

Topics Covered

 How to use a cross-tabulation object in a report.

Introduction

A strictly columnar report is not always the best way to present information. When you’re
working with data with at least two groupings where those groups are somehow correlated,
using a cross-tab report, may be a better approach.

A cross-tab report presents data in rows and columns rather than in traditional columnar
format. Within the cross-tab, data is presented as summary information in a cross-section
grid between two (or more) groups.

❋

5.1. Creating a Cross-Tab Report

Crystal Reports provides two ways to create cross-tab reports:

Using the Cross-Tab Report Wizard which is available by selecting File > New
> Cross-Tab Report from the menu.
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Adding a cross-tab object to an existing report.

A cross-tab report presents data in rows and columns rather than in traditional columnar
format. Within the cross-tab, data is presented as summary information in a cross-section
grid between two (or more) groups.
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 5.1.1. Creating a Cross-Tab Subreport

Let’s add a cross-tab subreport to the Customer report that presents total sales by region
and product line.

1. Open C:\ClassFiles\cry2011-cross-tab-reports\Demos\Customer.rpt and select
the Design tab.

2. Right-click in the Report Header section and select Insert Section Below.

3. From the menu, select File > New > Cross-Tab Report.

4. In the Cross-Tab Report Creation Wizard dialog box, expand the
C:\ClassFiles\Data\AdventureWorks.mdb node.

5. Double-click the Product, Individual, SalesOrderDetail, SalesOrderHeader,
and SalesTerritory tables to add them to the Selected Tables pane.

6. Click Next.

7. On the Link page, click Clear Links.

8. Link the Product and SalesOrderDetail tables using the ProductID field.

9. Link the SalesOrderDetail and SalesOrderHeader tables using the SalesOrderID
field.

10. Link the SalesOrderHeader and Individual tables using the CustomerID field.
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11. Link the SalesOrderHeader and SalesTerritory tables using the TerritoryID field.

12. Click Next.

13. On the Cross-tab page, expand the Product table node, select ProductLine,
and add it to the Columns list box.

14. Expand the SalesTerritory table node, select Name, and add it to the Rows list
box.

15. Expand the SalesOrderDetail table node, select LineTotal, and add it to the
Summary Fields list box.

Summary Fields

Note that the item added to the Summary Fields list box is actually the sum
of the SalesOrderDetail.LineTotal field.
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16. Click Finish.You should see the preview of the cross-tab report.

17. Select the Design tab.

18. Remove the Print Date and Page Number fields along with their horizontal
guideline markers.

19. Suppress all blank sections.
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20. Expand all of the fields in the bottom row. Check the Preview tab to ensure that
the field values are completely visible.

21. Preview the report.

22. Select the Design tab.

23. In the Field Explorer, right-click the Formula Fields node and select New.

24. In the Formula Name dialog box, type “CycleProductLine” and click OK.

25. In the Formula Workshop - Formula Editor - Cycle Product Line dialog box,
type the following in the formula editor:

If IsNull({Product.ProductLine}) Then "Non-Cycle"
Else If {Product.ProductLine} = "M" Then "Mountain"
Else If {Product.ProductLine} = "R" Then "Road"
Else If {Product.ProductLine} = "S" Then "Standard"
Else If {Product.ProductLine} = "T" Then "Touring"
Else ""
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26. Verify the formula and click Save.

27. In the Formula Workshop tree, right-click the Formula Fields node and select
New.

28. In the Formula Name dialog box, type “SalesRegion” and click OK.

29. Type the following in the formula editor:

{SalesTerritory.Name} + (If {SalesTerritory.CountryRegionCode} = "US" Then "
USA" Else "")
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30. Verify the formula and click Save and close.

31. Right-click the upper-left corner of the cross-tab object and select Cross-Tab
Expert.

32. In the Cross-Tab Expert dialog box, remove the SalesTerritory.Name field from
the Rows list box and replace it with the Sales Region formula field.

33. Remove the Product.ProductLine field from the Columns list box and replace
it with the Cycle Product Line formula field.

34. Click OK.

35. Preview the report. Ensure that all field values are completely visible.

36. Save the report, naming it “Cross-Tab Subreport.rpt”. Close its tab.
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37. Switch to the Customer.rpt tab.

38. Click the Insert Subreport icon.

39. In the Insert Subreport dialog box, select Choose an existing report, then click
the Browse button.

40. In the Open dialog box, select the Cross-Tab Subreport.rpt and click Open.

41. Back in the Insert Subreport dialog box, click OK.

42. Move the mouse cursor to the Report Header b and click.

43. Preview the report.You may need to widen the subreport container in design view
in order to see the entire report.
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44. Select the Cross-Tab Subreport.rpt tab.

45. Select all of the Sum of SalesOrderDetail.LineTotal fields in the cross-tab table.

46. From the menu, select Format > Format Field.

47. In the Format Editor, select the Font tab and select 9 in the Size box.

48. Click OK.

49. Click the Insert Text Object icon. Move the mouse cursor to the upper-left corner
of the Report Header b section and click. You may need to move the Cross-Tab
Subreport down a bit.

50. Inside the text object, type “Sales Total by Sales Region and Product Line”. Click
outside of the text object.

51. Expand the width of the text object to the full width of the subreport.

52. Select the text object and click the Bold and Align Center icons.

53. Change the font size to 14.
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54. Adjust the height of the text object to ensure that it is completely visible.

55. Using the Cross-Tab Subreport.rpt preview, adjust the field values so that the
values are completely visible and on a single page. Change font size, if necessary.

56. Preview and save the main report.
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 Exercise 6: Using Cross-Tab Objects
 20 to 30 minutes

In the Sales Order report, use a cross-tab report to summarize sales totals based on
product categories and sales regions.

1. Add a subreport to the Report Footer that contains a cross-tab report which
presents sales totals by product categories and sales regions. Note that:

You will need to create a new cross-tab report and add it as a subreport
of the existing Sales Order report.

The cross-tab report will require all the existing tables from the Sales Order
report.
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Solution

The following steps represent one possible solution to the exercise:

1. Open C:\ClassFiles\cry2011-cross-tab-reports\Exercises\SalesOrder.rpt
and select the Design tab.

2. From the menu, select File > New > Cross-tab Report.

3. In the Cross-tab Report Creation Wizard dialog box, on the Data page, expand
the C:\ClassFiles\Data\AdventureWorks.mdb node and double-click Product,
ProductCategory,ProductSubcategory, SalesOrderDetail, SalesOrderHeader,
and SalesTerritory.

4. Click Next.

5. On the Link page, click Clear Links.

6. Link the tables as follows:

A. Link the Product table to the ProductSubcategory table using the
ProductSubcategoryID field.

B. Link the ProductSubcategory table to the ProductCategory table using
the ProductCategoryID field.

C. Link the Product table to the SalesOrderDetail table using the ProductID
field.
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D. Link the SalesOrderDetail table to the SalesOrderHeader table using
the SalesOrderID field.

E. Link the SalesOrderHeader table to the SalesTerritory table using the
TerritoryID field.

7. Click Next.

8. On the Cross-Tab page, expand the ProductCategory node, select Name, and
add it to the Columns list box.

9. Expand the SalesTerritory node, select Name, and add it to the Rows list box.

10. Expand the SalesOrderDetail node, select the LineTotal field, and add it to the
Summary fields list box.

Sum of SalesOrderDetail.LineTotal

Note that the Sum of SalesOrderDetail.LineTotal has been added to this
list box.
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11. Click Finish.

12. In the new report tab, select the Design tab.

13. Remove the Print Date and Page Number fields along with their horizontal
guideline markers.

14. Suppress all blank sections.

15. In the Field Explorer, right-click the Formula Fields node and select New.

16. In the Formula Name dialog box, type “LineTotal” and click OK.

17. In the Formula Workshop - Formula Editor - Line Total dialog box, type the
following in the formula editor:

{SalesOrderDetail.OrderQty} * {SalesOrderDetail.UnitPrice}
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18. Verify the formula and then click Save.

19. Right-click the Formula Fields node in the Formula Workshop field tree and
select New.

20. In the Formula Name dialog box, type “salesRegion” and click OK.

21. In the formula editor, type the following:

{SalesTerritory.Name} & (If {SalesTerritory.CountryRegionCode} = "US" Then "
USA" Else "")

22. Verify the formula and then click Save and close.

23. Right-click the cross-tab object and select Cross-Tab Expert.
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24. In the Cross-Tab Expert dialog box, on the Cross-Tab tab, remove the
SalesTerritory.Name field from the Rows list box and replace it with the
SalesRegion formula field.

25. Remove the Sum of SalesOrderDetail.LineTotal field from the Summarized
Fields list box and replace it with the Line Total formula field.

26. Click OK.

27. Select the Preview tab and adjust the cross-tab fields so that they are all completely
visible.
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28. Save the cross-tab report as “SalesOrderTotalCT.rpt” and then close the report
tab.

29. Switch to the SalesOrder.rpt tab.

30. Click the Insert Subreport icon.

31. In the Insert Subreport dialog box, select Choose an existing report and then
click the Browse button.

32. In the Open dialog box, find and select the C:\ClassFiles\cry2011-cross-tab-
reports\Exercises\SalesOrderTotalCT.rpt file and then click Open.

33. Back in the Insert Subreport dialog box, click OK. Move the mouse cursor to the
top left corner of the Report Header b section and click.

34. Expand the subreport object so that it stretches across the Report Footer b
section.

35. Preview the report.
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36. Save the report.

Conclusion

In this lesson, you learned:

How to use a cross-tabulation object in a report.
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LESSON 6
Advanced Techniques

Topics Covered

 Special Fields.

The If statement.

The Select Case statement.

 Conditional formatting.

 Alternating row formatting.

Introduction

In this lesson, you will learn to work with Special Fields, to write conditional statements
with If and Select Case, to apply conditional formatting, and to alternate row formatting.

❋

6.1. Special Fields

Features such as page numbers and the date and time when a report was lasted printed
add value to reports are Special Fields. While we could use formulas to produce these
items, Crystal Reports provides many of these out of the box in a set of fields called Special
Fields. Special Fields capture data associated with the processing of the report as well as
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useful information that is included within the report file itself. The following table presents
the Special Fields available in Crystal Reports:

Special Field DescriptionSpecial Field Name

Displays the date the data in the report was last refreshed.Data Date

Displays the time the data in the report was last refreshed.Data Time

Displays the time zone associated with the last time the report
was refreshed.

Data Time Zone

Displays the name of the author as set in the Document
Properties of the report.

File Author

Displays the date when the report was created.File Creation Date

Displays the name of the report and its full path.File Path and Name

Displays the current group count.Group Number

Displays the formula field that is used to select the group.Group Selection Formula

Displays the date the report was last modified.Modification Date

Displays the time the report was last modified.Modification Time

Displays the current page number along with the total number
of pages in the report output.

Page N of M

Displays the current page number.Page Number

Displays the date when the report was printed.Print Date

Displays the time when the report was printed.Print Time

Displays the time zone associated with the print time.Print Time Zone

Displays a sequential number based on the counting of the
records.

Record Number

Displays the formula field on which the selection of the records
is based.

Record Selection Formula

Displays the comments as set in the Document Properties.Report Comments

Displays the title as set in the Document Properties.Report Title

Displays the total number of pages of report output.Total Page Count

In the next demo, we’ll add some of these Special Fields to the Customer report.

 6.1.1. Adding Special Fields to a Report

Let’s add page numbering to the Customer report.
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1. Open C:\ClassFiles\cry2011-advanced-techniques\Demos\Customer.rpt and
select the Design tab.

2. Right-click the Page Footer section and select Don’t Suppress.

3. In the Field Explorer, expand the Special Fields node.

4. Click and drag the Page Number Special Field to the left of the Page Footer.

5. Select the Page Number Special Field and click the Align Left icon.
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6. Preview the report.

Special Fields

Please take some time and explore the Special Fields and add others to parts of
your report.

❋

6.2. Using the If Statement

One of the most common and useful ways to test for a condition and then feed directions
based on the result is to use the If Statement. The basic logic is as follows: If TEST Then
ACTION WHEN TRUE Else ACTION WHEN FALSE.
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If {fieldName} = "value1" Then {fieldName} * 1.5 Else {fieldName} * 1.1

 6.2.1. Using the If Statement

In this demo we will test for empty middle names as we build a "CustomerFullName"
field.

1. Open C:\ClassFiles\cry2011-advanced-techniques\Demos\Customer_1.rpt and
select the Design tab.

2. In the Field Explorer, select the Formula Fields node and click the New icon in
the Field Explorer toolbar.

3. In the Formula Name dialog box, type "CustomerFullName" and click OK.

4. In the Formula Workshop - Formula Editor - DateTitle dialog box, in the formula
text pane, type

{Contact.FirstName} & (If IsNull({Contact.MiddleName}) Then "" Else " " &
{Contact.MiddleName})& " " & {Contact.LastName}

5. The text in the Formula Editor should look like this:
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6. Click the Check icon  in the toolbar. Crystal Reports should report no errors.
Click OK.

7. Click Save and close.

8. In the report, replace the Customer Name fields in the Detail Section with the
new formula field.

9. Preview the report. Adjust the various fields and objects so that they are completely
visible.
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10. Save the report.

❋

6.3. Using the Select Case Statement

As we have already demonstrated, If statements are very useful for handling conditional
situations. Still, as the number of conditional options expands, so does the complexity of
the formula. For this reason, Crystal Reports provides a conditional statement for situations
in which we are dealing with multiple options based on a single value. This statement is
the Select Case statement.

 6.3.1. Using the Select Case Statement

Let’s show the marital status for all customers on the Customer report.

1. Open C:\ClassFiles\cry2011-advanced-techniques\Demos\Customer_2.rpt and
select the Design tab.

2. Move the fields in the Details section to the right if needed.

3. In the Field Explorer, right-click the Formula Fields node and select New.

4. In the Formula Name dialog box, type “MaritalStatus” and click OK.
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5. In the Formula Workshop - Formula Editor - MaritalStatus dialog box, type the
following in the formula editor:

Select {Individual.MaritalStatus} Case "M": "Married" Case "S": "Single"

6. Verify the formula and then click Save and close.

7. Click and drag the Marital Status formula field to the Details section, placing it
after the @CustomerFullName formula field.

8. Move the field title from the Page Header section to the Group Header #3b
section.

9. Select the Marital Status field title and click the Bold and Underline icons. Adjust
the width of the field to ensure that the field values as well as the field title are
completely visible.
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10. Preview and save the report.

❋
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6.4. Conditional Formatting

While the data in a report is always important since it provides the report with its purpose,
if the presentation is poor, then the report will likely not convey the message that was
intended.Therefore, it is equally important to format our data well. In some cases, we may
want to highlight information in our report based on its value. While the Highlighting
Expert provides the means to do this for a specific field in a report, it is limited in its scope.
Crystal Reports provides the means to format a variety of elements on a conditional basis.
In the various dialog boxes we have already seen, you may have noticed a certain button
that is available in many places. This is the Conditional Formula button:

With this feature, you can base the visibility or color of a report element on a specific value.

 6.4.1. Using Conditional Formatting

In the Customer report, we will use conditional formatting to shade customers’ anniversary
months.

1. Open C:\ClassFiles\cry2011-advanced-techniques\Demos\Customer_3.rpt and
select the Design tab.

2. Right-click the Anniversary Month formula field and select Format Field.

3. In the Format Editor dialog box, select the Border tab.

4. In the Color section, click the Conditional Formula button for Background.

118 | LESSON 6: Advanced Techniques

EVALUATION COPY: Not to be used in class.



LESSON 6: Advanced Techniques | 119



5. In the Formula Workshop - Format Formula Editor - Background Color dialog
box, note the list of Color Constants in the formula editor. Modify the text in the
formula editor so that it looks as follows:

Select {@AnniversaryMonth}
Case "January":
Color(128, 128, 128)

Case "February":
Color(144, 144, 144)

Case "March":
Color(160, 160, 160)

Case "April":
Color(176, 176, 176)

Case "May":
Color(192, 192, 192)

Case "June":
Color(200, 200, 200)

Case "July":
Color(216, 216, 216)

Case "August":
Color(224, 224, 224)

Case "September":
Color(232, 232, 232)

Case "October":
Color(240, 240, 240)

Case "November":
Color(248, 248, 248)

Case "December":
Color(250, 250, 250)
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6. Verify the formula and then click Save and close.
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Conditional Formula

Note that the Conditional Formula button has changed:

7. Click OK.

8. Preview the main report.
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Shades of Gray

Note the months are now in subtle shades of gray.

❋

6.5. Alternating Row Formatting

When there are many records within a report it can be difficult to distinguish one record
from the next. A common technique for improving readability uses conditional formatting
to alternate the color of rows.

 6.5.1. Formatting Rows by Alternating the Colors

To improve the readability of the Customer report, we will employ the alternating row color
technique.

1. Open C:ClassFiles\cry2011-advanced-techniques\Demos\Customer_4.rpt and
select the Design tab.
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2. Click the Section Expert icon.

3. In the Section Expert dialog box, in the Sections list box, select Details and then
select the Color tab.

4. Click the Conditional Formula button.

5. In the Formula Workshop - Format Formula Editor - Background Color dialog
box, replace the text in the formula editor with the following:

If RecordNumber Mod 2 = 0 Then crAqua Else crWhite
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6. Verify the formula and then click Save and close.

7. Click OK to close the Section Expert dialog box.

8. Preview the report. Note that the Anniversary Month is not affected by the new
formatting.
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 Exercise 7: Advanced Techniques
 30 to 45 minutes

We will add page numbering and highlighting to the Sales Order report.

1. Add page numbering to the report in the form of (Page #) of (Total # of Pages).
(Hint: Use the Page N of M special field.)

2. Add color highlighting to the product names of the bicycles based on the product
line.
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Solution

The following steps represent one possible solution for the exercise:

1. Open C:\ClassFiles\cry2011-advanced-techniques\Exercises\SalesOrder.rpt
and select the Design tab.

2. In the Field Explorer, expand the Special Fields node.

3. Click and drag the Page N of M special field to the left of the Page Footer.

4. Select the Page N of M special field and click the Align Left icon and Bold Icon.

5. Preview the report.

6. Select the Design tab.

7. Right-click the Product.Name field in the Details section and select Format Field.

8. In the Format Editor dialog box, select the Border tab.

9. In the Color section, click the Conditional Formatting button for Background.
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10. In the Formula Workshop - Format Editor - Background Color dialog box, type
the following in the formula editor:

Select {Product.ProductLine}
Case "R":
crRed
Case "M":
crMaroon
Case "T":
crTeal
Case "S":
crSilver
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11. Verify the formula and then click Save and close.

12. Click OK.

13. Preview the report.

14. Save the report.
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Conclusion

In this lesson, you learned:

To use Special Fields.

To use If Statement.

To use the Select Case statement.

To use conditional formatting.

To use alternating row formatting.
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LESSON 7
Report Alerts

Topics Covered

 Report alerts.

Introduction

In cases where you have several conditions you are looking for in your report, you could
put together several filters triggered using parameters; however, Crystal Reports can
produce a quick filtered report by using report alerts.

❋

7.1. Using Report Alerts

A report alert is a customized message in your report that is set up to be triggered based
on a given condition. Report alerts can be useful when you are dealing with fairly complex
scenarios when you review your report.

In our Customer report, we are interested in sales that are greater than $3500 or are less
than $100. We will investigate these using report alerts.

1. Open C:\ClassFiles\cry2011-report-alerts\Demos\Customer.rpt and select
the Design tab.

2. From the menu, select Report > Alerts > Create or Modify Alerts.

3. In the Create Alerts dialog box, click the New button.
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4. In the Create Alert dialog box, type “Sales Over $3500” in the Name field and
type “Big Sales!!” in the Message field.

5. Click the Condition button.

6. In the Formula Workshop - Alert Condition Formula Editor dialog box, type
the following in the formula editor:

{@LineTotal} > 3500
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7. Verify the formula and then click Save and close.

8. Back in the Create Alert dialog box, verify that the Enabled checkbox is marked.
Click OK.

9. Back in the Create Alerts dialog box, click the New button again.

10. In the Create Alert dialog box, type “Sales Under $100” in the Name field and
type “We need to sell them more...” in the Message field.

11. Click the Condition button.

12. In the Formula Workshop - Alert Condition Formula Editor dialog box, type
the following in the formula editor:

{@LineTotal} < 100
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13. Verify the formula and then click Save and close.

14. Back in the Create Alert dialog box, verify that the Enabled checkbox is marked.
Click OK.

15. In the Create Alerts dialog box, click Close.

16. Preview the report.

17. Press F5.

18. Note that a Report Alerts dialog box appears, indicating that both conditions have
been triggered.

19. In the Report Alerts list, select “Sales Over $3500” and click View Records. Note
that you now have a new report tab labeled “Sales Over $3500” that lists all sales
over $3500 for the given parameter values.

20. Select the Preview tab. The Report Alerts dialog box reappears.

21. Select the “Sales Under $100” alert and click View Records. Note that a new tab
for this alert is now present.
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22. Select the Preview tab. Click the Close button in the Report Alerts dialog box.

23. Save the report.
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 Exercise 8: Using Report Alerts
 10 to 20 minutes

We will add a report alert to the Sales Order report to help identify Style sales.

1. Create a report alert based on sales of “U” Style items. (Hint: Use the
Product.Style field.)

138 | LESSON 7: Report Alerts

EVALUATION COPY: Not to be used in class.



LESSON 7: Report Alerts | 139



Solution

The following steps represent one possible solution to the exercise:

1. Open C:\ClassFiles\cry2011-report-alerts\Exercises\SalesOrder.rpt and
select the Design tab.

2. From the menu, select Report > Alerts > Create or Modify Alerts.

3. In the Create Alerts dialog box, click New.

4. In the Create Alert dialog box, type “Accessory Sales” in the Name field.

5. In the Message field, type “Sales of Accessories”.

6. Click the Condition button.

7. In the Formula Workshop - Alert Condition Formula Editor dialog box, type
the following in the formula editor:

{Product.Style}="U"
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8. Verify the formula and then click Save and close.

9. In the Create Alert dialog box, click OK.

10. In the Create Alerts dialog box, click Close.

11. Press F5.

12. In the Refresh Report Data dialog box, click OK. The Report Alerts dialog box
opens.

13. Click View Records. The Style Sales tab opens containing a partial report.

14. Save the report.

Conclusion

In this lesson, you learned:

How to use report alerts in a report.

LESSON 7: Report Alerts | 141



142 | LESSON 7: Report Alerts

EVALUATION COPY: Not to be used in class.



LESSON 8
Establishing a Database Connection

Topics Covered

 Creating a new database connection.

Introduction

In this lesson we will learn to create a new database connection to the AdventureWorks
database.

❋

8.1. Connecting to the AdventureWorks Database

1. From the menu, select File > New > Blank Report.

2. In the Database Expert dialog box, expand the Create New Connection >
Access/Excel (DAO) node.
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3. Select the Make New Connection node.The Access/Excel (DAO) wizard starts.

4. Click the Open icon.

5. Locate and select C:\ClassFiles\Data\AdventureWorks.mdb.
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6. Click Open.

7. Click Finish.

8. Choose the tables you need and proceed.
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Conclusion

In this lesson, you learned how to create a new database connection.
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