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LESSON 1
Getting Acquainted with Crystal Reports

Topics Covered

What Crystal Reports is.

 Opening Crystal Reports.

Toolbars.

 Creating a basic report with the Database Expert.

 Report sections.

The Field Explorer.

Introduction

Crystal Reports is a full-featured presentation system, providing numerous ways to present
data from a variety of data sources. A query tool in a database management system
(DBMS) can easily produce raw data; however, Crystal Reports helps you customize data
presentation to individual needs. The ability to provide your customers, both internal and
external, with data presented in the format most useful to them is powerful indeed. In fact,
with Crystal Reports you can often output an entire set of reports in many formats from a
single report file.

❋

1.1. Report Writing Process

When building a report throughout this course, we will be following a few simple steps.

1. Choose your source and know your data. Make sure you know each table for the
data source that you plan to use, and how they work together.

2. Filter out what is needed. Make sure you know the requirements of your report
audience to ensure proper results. Only provide the records needed.

3. Organize the report. We will be sorting, grouping, and performing summary
calculations on the detailed data in each group.
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4. Enhance with custom formulas. Make sure we create the missing pieces of data
with a variety of custom formula fields that we build and add to the report.

5. Generate the output. Once we have the perfect report, send it out to the audience
in their favorite format. We will have many to choose from and can create them
all from the original report definition.

Every report will have room for improvement, and if we do not capture the right data in the
right format the first time around, we can always go back and edit the original report
definition.

❋

1.2. Opening Crystal Reports

For the purposes of this training, it is assumed that Crystal Reports is installed and ready
to use on your computer.

To start Crystal Reports, go to Start > All Programs > Crystal Reports 2011 > Crystal
Reports 2011.

Once Crystal Reports is up and running, it should look similar to the image below:

Crystal Reports opens on the Start Page. You can open and create reports directly from
this page. In addition, when connected to the Internet, you will see a set of tabs in the
lower portion of the Start Page. From these tabs, you can access a variety of SAP/Crystal
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Reports resources on the Internet, including up-to-date information about any software
updates for Crystal Reports.

❋

1.3. The Database Expert

When creating a new report in Crystal Reports, we are first presented with the Database
Expert dialog box:

The Database Expert helps you connect to any data source that is available in a Windows
environment. While these sources are typically databases such as Microsoft Access,
Microsoft SQL Server, Oracle, MySQL, etc., other sources such as network file systems,
event logs, Internet log files, and XML files can be used with Crystal Reports.

Let’s use the Database Expert to add a table for a new report.

Demo - Creating Our First Report

1. From the Start Page, click Blank report.

2. In the Database Expert dialog box, expand Create New Connection.
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3. Click the plus sign next to Access/Excel (DAO).1

4. In the Access/Excel (DAO) wizard, Click the ... to choose the database to connect
to.

1. OLE = Object Linking and Embedding; DB = Database; DAO = Data Access Object.

4 | LESSON 1: Getting Acquainted with Crystal Reports

EVALUATION COPY: Not to be used in class.



5. The database is located at C:/ClassFiles/Data/AdventureWorks.mdb. Click
Open.

6. The rest of the choices are fine left as default. Click Finish.
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7. In the Database Expert dialog box below the Access/Excel (DA)) node, expand
C:/ClassFiles/Data/AdventureWorks.mdb.

8. Double-click Customer. The Customer table is added to the Selected Tables
pane.
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9. Click OK.

10. From the menu, select File > Save.

11. In the Save As dialog box, navigate to C:/ClassFiles/StudentReports/, type
“Customer.rpt” in the File name field, and click Save.

❋
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1.4. Review the Toolbars

Now that we have created a blank report, let’s look closer at the tools available with Crystal
Reports. Most tasks in Crystal Reports can be accomplished using commands available
on the toolbars. Let’s look at the toolbars and icons we will be using throughout this course.
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 1.4.1. The Standard Toolbar
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Shortcut keyMenu sequenceDescriptionIcon

Ctrl+NFile > New > Standard ReportCreates a new report using the
Standard Report Creation Wizard.

Ctrl+OFile > OpenOpens saved Crystal Report (.rpt)
files.

Ctrl+SFile > SaveSaves the current report to disk.

Ctrl+PFile > PrintPrints your report.

Ctrl+RView > Print PreviewOpens the Preview tab showing
what your report would look like
with your data.

View > HTML PreviewPresents your report in HTML.
(Crystal Reports must be
connected to a Web server for
this to work properly.)

File > Export > Export ReportExports your report output to a
file or another application.

Ctrl+XEdit > CutCuts an object from the report to
be pasted elsewhere.

Ctrl+CEdit > CopyCopies an object from the report
to be pasted elsewhere.

Ctrl+VEdit > PastePastes a cut or copied object
somewhere on the report.

Format > Format PainterAllows you to copy formatting
from one object to another.

Ctrl+ZEdit > UndoReverses the last change made
to your report.

Ctrl+YEdit > RedoRepeats the last change made to
your report.

View > Preview PanelToggles the Preview Panel on
and off. The Preview Panel is
found under the Preview tab.

View > Field ExplorerOpens the Field Explorer.

Ctrl+FEdit > FindAllows you to perform a search
in your report.
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 1.4.2. The Formatting Toolbar

Shortcut keyMenu sequenceDescriptionIcon

Increases the font size by one unit.

Decreases the font size by one unit.

Ctrl+BToggles the bold font style on and off.

Ctrl+IToggles the italics font style on and off.

Ctrl+UToggles the underline font style on and off.

Aligns selected text to the left.

Centers the selected text.

Aligns selected text to the right.

Aligns selected text on both the left and right
sides.

Changes the font color of the selected object.

Changes the borders on the selected object.

Suppresses visibility of the selected object in
report output.

Toggles the currency symbol on and off.

Toggles thousands formatting for numbers on
and off.

Toggles the percentage symbol on and off.

Adds a decimal place to a number.

Removes a decimal place from a number.

Additionally, there are two drop-down lists on the left side of the Formatting toolbar used
to set the font and its size.
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 1.4.3. The Insert Toolbar

Shortcut keyMenu sequenceDescriptionIcon

Insert > Text ObjectInserts a text object in your report.

Insert > GroupInserts a group in your report.

Insert > SummaryInserts a summary field in the report footer.

Insert > Cross-TabInserts a cross-tab object into your report.

Insert > SubreportInserts a subreport into your report.

Insert > LineInserts a line object into your report.

Insert > BoxInserts a box object into your report.

Insert > PictureInserts a picture object into your report.

Insert > ChartInserts a chart object into your report.
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 1.4.4. The Experts Toolbar

Menu sequenceDescriptionIcon

Database > Database ExpertOpens the Database Expert.

Report > Group ExpertOpens the Group Expert.

Report > Group Sort ExpertOpens the Group Sort Expert.

Report > Record Sort ExpertOpens the Record Sort Expert.

Report > Select ExpertOpens the Select Expert.

Report > Section ExpertOpens the Section Expert.

Report > Formula WorkshopOpens the Formula Workshop.

Format > Format <Object>Opens the Format Editor.

Format > Format <Highlight Expert>Opens the Highlighting Expert.
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 1.4.5. The Navigation Toolbar

Shortcut keyMenu sequenceDescriptionIcon

F5Report > Refresh Report DataRefreshes the report data from
your data source.

Stops gathering data from your
data source after clicking the
Refresh icon.

Shows the first page of your
report in the Preview tab.

Shows the previous page of your
report in the Preview tab.

Shows the next page of your
report in the Preview tab.

Shows the last page of your
report in the Preview tab.

Additionally, the Page Selector text box displays the current page being viewed along
with the total number of pages processed. The plus (+) sign indicates that there are more
pages to the report that have not been processed.

 1.4.6. The External Command Toolbar

The External Command toolbar provides access to third-party applications that have
been added on to your Crystal Reports installation.

❋

1.5. The Report Sections in the Design Tab

A report is divided into several sections, as indicated below:
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Let’s review each of these sections individually.

 1.5.1. Report Header

The Report Header is at the top of the report. Its purpose is to provide an area to display
information at the start of the report, such as a report title. This section does not repeat.

 1.5.2. Page Header

The Page Header appears at the top of each page in your report. It provides a place for
information that needs to be present at the top of each page. Field titles are commonly
used in the Page Header.We will look at field titles more in the next section of this lesson.
This section will repeat once per page.

 1.5.3. Details

The Details section holds the field data from your report data sources. This section will
repeat as needed to show all relevant records.

 1.5.4. Page Footer

The Page Footer appears at the end of each page in your report. It is normally used for
common elements that enhance your report and that need to appear on each page.
Examples of items that may appear in the Page Footer are page numbers and print dates.
This section will repeat once per page.
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 1.5.5. Report Footer

The Report Footer appears at the end of your report. Its most likely use is the collection
of summary data for the whole report. This section does not repeat.

❋

1.6. The Field Explorer

After selecting tables for your report using the Database Expert, you can access the
tables through the Field Explorer. For the Customer report, we added a single table called
“Customers” as you can see in the image below. If you do not see the Field Explorer and
then click View > Field Explorer. It usually appears on the right side of the screen.

If we expand the list of fields under the Customer table, we can use the Field Explorer
to place the fields on the report.
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To do so, click and drag a field from the Field Explorer onto the Details section of the
report. When you do, a field title based on the field name is created in the Page Header
section and a guideline marker is placed in the top horizontal ruler. You can use this
guideline marker to move the field and its field title left or right.

The end result is as follows:

Next, we will demonstrate how to use the Field Explorer to populate reports with data.

Demo - Adding Fields to the Report

1. Using Customer.rpt, go to the Field Explorer and expand the Database Fields
node and then the Customer node so that the field list for the Customer table
shows.

2. Click the CustomerID field in the Field Explorer and drag it to the Details section
of the report.

3. Repeat the previous step for the AccountNumber and CustomerType fields.

❋

LESSON 1: Getting Acquainted with Crystal Reports | 17



1.7. Preview the Report

Now that we have added some fields to our report, we can see what it will look like when
we print it. This is accomplished by previewing the report in the Crystal Reports
environment. We’ll use the Customer report we created to learn how to preview reports.

Demo - Previewing a Report

1. Select the Customer.rpt tab.

2. In the Standard toolbar, click the Print Preview icon.

3. The Preview tab displays, showing a preview of the Customer report.

❋

1.8. Adding Multiple Tables to Reports

Often the data for the report we need to create is not contained in a single table in our
database.With relational database systems, such as Microsoft Access, the data is divided
among multiple tables to improve the performance of the database and to reduce the
amount of redundant data.

In Crystal Reports, the Database Expert helps us work with multiple tables. When a
second table is added in the Database Expert, a new Links tab displays.This tab presents
a visual representation of the tables available to the report along with how the tables are
linked together.
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There are three main join types that are used to link the Fields.They are Inner, Left Outer,
and Right Outer. Double-click the join line to bring up the Link Options box.

Join Types
DescriptionJoin Type

The record must be present in both the Left and Right tables.Inner Join

All of the records from the Left table, and only those in the Right that
match based on the ID Field (also known as the linked fields).

Left Outer Join

All of the records from the Right table and only those in the Left that
match based on the ID Field (also known as the linked fields).

Right Outer Join

The next demonstration shows how we can use data from several tables in a single report.
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Demo - Adding Multiple Tables to a Report

The information currently in our Customer report does not represent the full picture. We
need to add more tables to the report that help display the full contact information using
inner joins.

1. Open C:/ClassFiles/StudentReports/Customer.rpt, if necessary.

2. Select the Design tab.

3. Move the objects already in the Details section to the left using their guideline
markers.

4. In the Experts toolbar, click the Database Expert icon.

5. In the Available Data Sources pane of the Database Expert dialog box, navigate
to C:/ClassFiles/Data/AdventureWorks.mdb.

6. Double-click Individual to add the table to the Selected Tables pane.

7. Double-click Contact to add the table to the Selected Tables pane.
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8. Still in the Database Expert dialog box, select the Links tab. (You may need to
resize the window.)

9. Confirm that the ID field link connections are correct.

10. Click OK.
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11. In the Refresh Report Data message box, click OK.

12. Select the Design tab.

13. In the Field Explorer, expand the Database Fields list and then the Contact
column list.

14. Add the following fields (with corresponding field titles) to the Details section of
the report:

A. FirstName

B. LastName

C. Phone (Note that this field does not fit on the report. We will fix this later.)
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15. Preview and save the report.
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 Exercise 1: Creating a Report
 10 to 20 minutes

In this exercise, we will create a simple report by accomplishing the following tasks:

1. Create a new report.

2. Add the following tables from the AdventureWorks database to the report:

A. Product

B. SalesOrderDetail

C. SalesOrderHeader

3. Add the following fields to the report:

A. From the Product table:

i. ProductID

ii. ProductNumber

iii. Name

B. From the SalesOrderHeader table:

i. SalesOrderID

ii. SalesOrderNumber

C. From the SalesOrderDetail table:

i. SalesOrderDetailID

4. Save the report as “SalesOrder.rpt” and preview it.
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Solution

1. From the Start Page, click Blank report.

2. In the Database Expert dialog box, in the Available Data Sources pane, navigate
to C:/ClassFiles/Data/AdventureWorks.mdb and double-click Product,
SalesOrderDetail, Sales Order Header.

3. Select the Links tab.

4. Confirm that the ID field link connections are correct.
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5. Click OK.

6. In the Field Explorer, expand the Product column list and then click and drag
the ProductID, ProductNumber, and Name fields to the Details section of the
report.

7. Expand the SalesOrderHeader column list and then click and drag the
SalesOrderID and SalesOrderNumber fields to the Details section.

8. Expand the SalesOrderDetail column list and then click and drag the
SalesOrderDetailID field to the Details section.

9. From the menu, select File > Save As.

10. In the Save As dialog box, navigate to C:/ClassFiles/StudentReports, type
“SalesOrder.rpt” in the File name field, and click Save.
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11. In the Standard toolbar, click the Print Preview icon.

Note

Be aware you added the SalesOrderID and the SalesOrderDetailID to experience
the relationship between the tables. Please note that you may try using other fields,
such as OrderQty and UnitPrice in their place once you see the relationships in
action.

Conclusion

In this lesson, you learned:

What Crystal Reports is.

How to open Crystal Reports.

About the toolbars used in Crystal Reports.

To create a basic report using the Database Expert.

About the different sections in a report.

About the Field Explorer.
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LESSON 2
Formatting Reports

Topics Covered

 Formatting fields.

The Format Painter.

Introduction

So far we have created a simple report that presents data from a few tables in the
AdventureWorks database. In the first lesson, we mentioned that Crystal Reports has the
potential to produce much more than a basic data listing. To harness that potential, we
need to know how the report can benefit the various consumers of our report information
and how to customize the output to suit their various needs. While data is essential to a
report, if it is not presented well, the message you intend to convey may be lost. In this
lesson, we will learn about the tools we can use to format the data meaningfully.

❋

2.1. Formatting Fields

When formatting a report, understanding the audience, the data, and the message you
want to send are critical in determining presentation.

To make formatting changes to a field in your report, you will use the Format Editor dialog
box which you can access by selecting a field in the report and then selecting Format >
Format Field from the menu.The options available in the Format Editor change depending
on the type of field object that is selected in the report.The following image shows options
for a number field.
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As we progress through the demos in this lesson and subsequent lessons, we will learn
a variety of options available with the Format Editor.

To achieve consistent formatting throughout a report, you can specify global settings using
the Options dialog box. To access the Options dialog box, select File > Options from
the menu and select the Fields tab.
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Clicking any of the buttons on the Fields tab opens the Format Editor dialog box showing
only the options that are global in nature and not specific to any particular report field
object.

Recall that each of the fields we added to the Customer report has a guideline marker on
the horizontal ruler at the top of the design region. These markers are associated with
guidelines in the report designer. By default, the guidelines do not appear in the report,
but you can turn them on by selecting View > Guidelines > Design from the menu.
Guidelines are useful in formatting because they allow you to move fields along with their
corresponding field titles. They also help line up the edges of several fields. Note that the
vertical ruler can also have guidelines.

Much of the basic work of formatting involves working with the fields in the report. Fields
can be resized and features from the Format Editor can be applied to enhance their
presentation.
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 2.1.1. The AdventureWorks Database

The demonstrations in this course will continue to build on the Customer report that we
started in the first lesson. Along the way we may introduce other reports to help illustrate
particular features of Crystal Reports, but our focus will be on the Customer report.

As we work to build a quality presentation report, we will consider the business requirements
that factor into report development as well as the technical aspects of report building. The
AdventureWorks database represents a business called Adventure Works Cycles, a bicycle
manufacturer and equipment retailer. Adventure Works builds and sells bicycles in several
multinational markets.

The Customer report should present information about Adventure Works’ customers that
can be used by various departments and upper management. As we proceed, we will
modify the Customer report to correspond with the material that we are learning.

Demo - Formatting the Report

Let’s make some changes to the Customer report to improve the presentation and make
it more useful.

1. Open C:/ClassFiles/cry2011-format-report/Customer.rpt. You may also opt
to use the one you had created C:ClassFiles/StudentReports/Customer.rpt.

2. Select the Design tab.

3. Preview the report. Note the following:

A. The CustomerID field values contain commas. Since these are ID values,
we want to format these values without any numeric-style formatting.

B. There is extra whitespace associated with the FirstName and LastName
fields.

C. Recall that the Phone field did not completely fit in the body of the report.

4. Return to the Design tab.

5. Right-click the CustomerID field and select Format Field.
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6. In the Format Editor dialog box, select the Number tab, if necessary.

7. In the Style list box, select (1123) and click OK.
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8. Select the FirstName field and hover over its right edge until the cursor changes
into a two-headed arrow.

9. Click and drag the edge to the left to resize the field. Notice that the field title
resizes along with the field.

10. To reduce the amount of whitespace between the FirstName and LastName
fields, click and drag the guideline marker for the LastName field to the left.

11. Resize the LastName field.

12. Move the Phone field to the left using its guideline marker.

13. Resize the Phone field.

14. Preview the report. Ensure that all field values and field titles are completely visible.
Make changes if necessary.

15. Save the report.
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❋

2.2. The Format Painter

When formatting fields in a report, you may find that several fields should be formatted in
a similar way. For example, you may want fields to have the same font style, font size,
and background color. To accomplish this quickly, you can use the Format Painter. The
following demo shows how the Format Painter works.

Demo - Format Painter

In this demo, we will use the Format Painter as a quick solution for making repeated
format changes to the fields in the Customer report.

1. Open C:/ClassFiles/cry2011-format-report/Customer_1.rpt or continue using
the one that you had created. Select the Design tab.

2. Right-click the CustomerID field and select Format Field.

3. In the Format Editor dialog box, select the Border tab.
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4. In the Color section, check the Background check box and then select “Yellow”
as the background color.
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5. Select the Font tab. Change the Style to “Bold Italic”. Please be mindful of choosing
a color on a color as we need to keep readability and stay Section 508 compliant.
See appendix A for details on Section 508.
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6. Click OK.

7. Right-click the CustomerID field and select Format Painter. Notice that your
cursor has changed into a paint brush.
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8. Click the Phone field. Notice that the Phone field now has all of the formatting
from the CustomerID field.

9. In order to remove the formatting from the two fields we had just changed, select
the AccountNumber field and double-click the Format Painter button in the
Standard toolbar to activate the Format Painter. Click the CustomerID field and
the Phone field.

10. Click again on the Format Painter button in the Standard toolbar to deactivate
the Format Painter.

Great time saver!

Select the field you wish to copy in the report, and double-click the Format
Painter button in the Standard toolbar to activate the Format Painter. Click
the fields you wish to apply the formatting. Then, click again on the Format
Painter button in the standard toolbar to deactivate the Format Painter.
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 Exercise 2: Formatting a Report
 15 to 30 minutes

 E2.1. The Sales Order Report

Just as the demonstrations throughout this course focus on the Customer report, the
exercises at the conclusion of each lesson will focus on the Sales Order report.

The purpose of the Sales Order report is to provide information on the orders that Adventure
Works’ customers have placed. In the first lesson, we created the report. In this exercise,
you will modify the Sales Order report using what you have learned about formatting and
the Format Painter.

Apply the following format changes to the Sales Order report:

1. Resize the ProductNumber and SalesOrderNumber fields.

2. Move fields to the left as needed to ensure that all fields fit in the body of the report.

3. Format the ProductID, SalesOrderID, and SalesOrderDetailID fields to remove
commas from the formatting.

4. Make adjustments as needed to ensure that all fields and their corresponding field
titles are completely visible.

5. Save the report and preview it.
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Solution

1. Open C:/ClassFiles/cry2011-format-report/SalesOrder.rpt or you may use
the one that you created C:/ClassFiles/StudentReports/SalesOrder.rpt. Select
the Design tab.

2. Right-click the ProductID field and select Format Field.

3. Select the Number tab, select (1123) in the Style list box, and click OK.

42 | LESSON 2: Formatting Reports

EVALUATION COPY: Not to be used in class.



4. Since we want to apply the same formatting that we applied to the ProductID field
to the SalesOrderID and SalesOrderDetailID fields, we can use the Format
Painter. To do so, right-click the ProductID field and select Format Painter, and
then click the SalesOrderID field. Repeat this action for the SalesOrderDetailID
field.

5. Select the ProductNumber field and then click and drag the right edge of the field
to the left to resize it.

6. Move the Name field to the left by clicking and dragging its guideline marker.

7. Move the SalesOrderID field to the left by clicking and dragging its guideline
marker.

8. Move the SalesOrderNumber field to the left by clicking and dragging its guideline
marker.

9. Select the SalesOrderNumber field and then click and drag the right edge of the
field to the left to resize it.
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10. Move the SalesOrderDetailID field to the left by clicking and dragging its guideline
marker.

11. Make any other adjustments to the report fields that you feel are needed.

12. Preview the report by clicking the Print Preview icon on the Standard toolbar.

13. Save the report by clicking the Save icon on the Standard toolbar.

Conclusion

In this lesson, you learned:

How to format fields.

How to use the Format Painter.
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LESSON 3
Working with Objects

Topics Covered

Text objects.

 Field titles.

 Incorporating fields in text objects.

 Image objects.

The Section Expert.

 Using images in reports.

Introduction

In the previous lesson, we looked at formatting the fields in a report. We can enhance our
report further with the use of text and image objects.

❋

3.1. Text Objects

Aside from report fields, the most common object we will use in a report is the text object.
Text objects help enhance the presentation quality of a report and have a variety of
applications. One of the most common uses of a text object is to create a report title. In
our next demonstration, we’ll add a title to the Customer report.

Demo - Using Text Objects

1. Open C:/ClassFiles/cry-2011-objects/Demos/Customer.rpt or use the one that
you had created C:/ClassFiles/StudentReports/Customer.rpt. Select the Design
tab.

2. On the Insert toolbar, click the Insert Text Object icon.The mouse cursor changes
to a large plus sign.
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3. Place the cursor near the upper-left-hand corner of the Report Header section
and click.

4. In the text object, type “Customers”. Click outside the text object.

5. Click the text object and drag it so the left edge aligns with the 1.5-inch mark on
the horizontal ruler.

6. Click and drag the right edge of the text object until it is about four inches long.
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7. Select the text and, using the Formatting toolbar, change the font size to 16, and
click the Bold and Align Center icons.

8. Right-click the report title and select Format Text.

9. In the Format Editor on the Common tab, check the Can Grow check box. The
Can Grow option automatically increases the size of the text object when the
formatted text is too large for the object box as currently defined.
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10. Select the Border tab and then set all sides in the Line style section to “Single”
and click OK.
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11. Select the text object and move it down so that it is away from the top of the Report
Header section. This will ensure that the entire border is visible.

12. Preview the report.
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❋

3.2. Field Titles

When you add a field to the Details section of a report, a special text object, the field title,
is created along with a vertical guideline. The field title mimics the field name, so it is
probably not the best label to use for your field. Due to this, we should look at each of our
field titles, edit their text to be more descriptive, and apply formatting as needed. In this
process, we may need to make other changes such as resizing the field title. A special
feature of the field titles is that, as long as their linkage is maintained with their
corresponding fields, you can resize and move the field titles as you resize and move the
fields.

The next demo will illustrate how we can work with field titles.

Demo - Editing Field Titles

At this point, the field titles in the Customer report simply mirror the field names and, except
for underlining, they tend to blend in with the report data. In this demo, we will edit the field
titles so they are more meaningful to our users and we will apply formatting to these text
objects to make them stand out.

1. Open C:/ClassFiles/cry2011-objects/Demos/Customer_1.rpt or continue using
the one you had created. Select the Design tab.

50 | LESSON 3: Working with Objects

EVALUATION COPY: Not to be used in class.



2. Using your mouse, click near (but not on) the CustomerID field title and drag to
draw a selection box over all the field titles (Rubber band Selection). Notice that
when you release the mouse button all the field titles are highlighted.

3. The field titles are currently underlined, so click the Underline icon in the
Formatting toolbar to turn underlining off.

4. Click the Bold icon in the Formatting toolbar to bold the field titles.

5. Click anywhere outside of the text objects in the Page Header section to deselect
them.

6. To edit a field title, double-click it. Once inside the text object, you can freely edit
the text. Edit the field titles as follows:

A. Change “CustomerID” to “Customer ID”.

B. Change “AccountNumber” to “Account #”.

C. Change “CustomerType” to “Customer Type”.

D. Change “FirstName” to“First Name”.

E. Change “LastName” to “Last Name”.
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7. Adjust the fields as needed by moving and resizing the fields to ensure that the
field values and field titles are completely visible.

8. Preview the report.

❋

3.3. Using Fields in Text Objects

So far we have only used text objects to hold regular text. However, it is also possible to
add fields to a text object. This means we can have a formatted text object with content
that changes based on the information coming from the fields we incorporate in it.

Demo - Adding Fields to Text Objects

In this demonstration, we’ll consolidate the FirstName and LastName fields to simulate
a single field that we’ll label “Customer Name”. In addition, we’ll combine the current
account number and the customer type to derive a new account number format.

1. Open C;/ClassFiles/cry2011-objects/Demos/Customer_2.rpt or continue using
the one that you had created. Select the Design tab.

2. Delete the following fields from the report by highlighting the field and pressing
Delete:

A. AccountNumber

B. CustomerType

C. FirstName
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D. LastName

3. Remove the guideline markers for the deleted fields by clicking and dragging them
off the horizontal ruler.

4. If any field titles remain, delete them.

5. On the Insert toolbar, click the Insert Text Object icon.

6. Place the cursor to the right of the CustomerID field and click.

7. Click outside the text object and then reselect it and drag its right edge to the right
to increase its width.

8. Using the Field Explorer, click and drag the AccountNumber field from the
Customer table node and place it inside the new text object. Then type a dash
(-).

9. Click and drag the CustomerType field from the Customer table node and place
it next to the dash (-).
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10. Click outside the text object.

11. Click the Insert Text Object icon, place the cursor in the Page Header directly
over the left edge of the account number text object, and click.

12. Type “Account #” in this new text object.

13. Click outside of the new text object and then select it again. Click the Bold icon
in the Formatting toolbar. Resize the text object to about the 2.5" mark.

14. Click the Insert Text Object icon, place the cursor to the right of account number
text object in the Details section, and click.
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15. Click outside the text object and then reselect it and drag its right edge to the right
to increase its width.

16. Using the Field Explorer, click and drag the FirstName field from the Contact
table node and place it inside the new text object. Type a space.

17. Click and drag the LastName field from the Contact table node and place it next
to the space in the text object.

18. Click outside the text object.

19. Click the Insert Text Object icon, place the cursor in the Page Header directly
over the left edge of the customer name text object, and click.
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20. Type “Customer Name” in this new text object.

21. Click outside of the text object and then select it again. Click the Bold icon.

22. Resize each of the fields with their corresponding field titles to ensure the field
titles are completely visible. Some of the surrounding objects may need to be
moved/expanded.

23. Preview and save the report.

Note

The alignment of the text objects and their field titles is not consistent. We will look
into that in the next section.

❋
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3.4. Aligning and Sizing Objects

It can be difficult to manually place objects on a report so that they line up with other
objects. Crystal Reports provides several features for adjusting the alignment and the
relative size of objects.

While guidelines and their markers are added automatically when we place fields inside
the Details section of a report, we can also manually add guidelines to a report. We have
already seen that one benefit of using guidelines is that we can use them to help line up
objects either vertically or horizontally. By using guidelines, we can also link two or more
objects together so that they can be moved together.

Tools in the Format menu also help us align two or more objects. In addition, the menu
has tools for setting the height or width (or both) of two or more objects to the same size.
These features can also be accessed from a shortcut menu by right-clicking an object
when two or more objects are selected.

Let’s take a look at how this works in our Customer report.

Demo - Aligning and Resizing Objects

On our Customer report, we want the field titles to align properly with each other. For the
new fields we created from text objects, we want the text objects and their corresponding
field titles to line up and have the same width.
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1. Open C:/ClassFiles/cry2011-objects/Demos/Customer_3.rpt or continue using
the report you had created. Select the Design tab.

2. Select the CustomerID field and then press Ctrl while clicking each of the
remaining objects in the Details section of the report.

3. From the menu, select Format > Align > Tops.

4. Select the CustomerID field title and then press Ctrl while clicking each of the
remaining objects in the Page Header section of the report.

5. Right-click the CustomerID field title and select Align > Middles.
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6. Click in the whitespace in the Page Header section to deselect the objects.

7. Add a vertical guideline over the account number object by clicking in the ruler
area around the 1" mark. Move the text object and its corresponding field title so
their left sides line up with the guideline.

8. Add another vertical guideline over the customer name object by clicking in the
ruler area around the 2.5" mark. Move the text objects and their corresponding
field titles to ensure that the left sides line up on the guideline.

9. Click below the account number object and drag the selection box (Rubber band
Selection) to include the account number text object and its corresponding field
title.

10. Right-click the text object and select Size > Same Width.
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11. Click below the customer name object and drag the selection box to include the
customer name text object and its corresponding field title.

12. Right-click the text object and select Size > Same Width.

13. Preview and save the report.

❋
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3.5. The Section Expert

We’ve seen how we can work with the different objects in our report. Next we’ll look at
how we can work with the different sections of the report. To work with sections, we use
the Section Expert.

The Section Expert includes a number of options that can be used to format the report
as a whole. The following demo will explore some of these features.

Demo - Using the Section Expert

We will make adjustments to some of the sections of the Customer report to improve
formatting.

1. Open C:/ClassFiles/cry2011-objects/Demos/Customer_4.rpt or continue to use
the report you created. Select the Design tab.

2. From the menu, select Report > Section Expert.
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3. In the Sections list box, select Page Footer.

4. On the Common tab, check the Suppress (No Drill-Down) check box.
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5. In the Sections list box, select Report Footer.

6. On the Common tab, check the Suppress (No Drill-Down) check box.

7. In the Sections list box, select Details.

8. Select the Color tab, check the Background Color check box, and select Silver
from the color palette.
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9. Click OK.

10. Preview the report.
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❋

3.6. Images

An image can be a simple enhancement to any report. This is especially true when you
want to brand your reports with your company logo. Let’s look at how to add an image to
a report.

Demo - Adding the Company Logo

For branding purposes, we will add the Adventure Works company logo to the top of the
Customer report.

1. Open C:/ClassFiles/cry2011-objects/Demos/Customer_5.rpt or you may continue
to use the report you had created. Select the Design tab.

2. In the Report Header section, drag the report title to the far left.
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3. On the Insert toolbar, click the Insert Picture icon.

4. In the Open dialog box, navigate to the Images folder C:/ClassFiles/Images/AWL
ogo.jpg.

5. Select the AWLogo.jpg file and click Open.

6. Position the mouse in the Report Header section so that the right edge of the
picture box is on the right edge of the report.
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7. Click and then select the image and the report title. Right-click the image and
select Align > Middles.

8. Preview the report.

When to Use an Image

Images should be used in a very purposeful manner. Use them to better describe, illustrate,
or clarify a point. Do not use them only for decorative purposes. Also, when used on a
series of reports, make sure to be consistent across all the reports. Keep art to a minimum
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because reports are all about data. Clean, professional layouts are the key to
easy-to-interpret the data.
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 Exercise 3: Working with Text Objects
 30 to 45 minutes

We will make changes to our Sales Order report to make it more useful and presentable.
Open C:/ClassFiles/cry2011-objects/Exercises/SalesOrder.rpt or continue using the
report that you had created C:/ClassFiles/StudentReports/SalesOrders.rpt.

1. Add the report title “Sales Orders”.

2. Remove the following fields from the report:

A. ProductID

B. SalesOrderID

C. SalesOrderDetailID

3. Add the following fields to the report from the SalesOrderDetail table:

A. OrderQty

B. UnitPrice

4. Rearrange the fields in the following order and edit their field titles as indicated:

A. SalesOrderNumber - “Order Number”

B. Name - “Name of Product”

C. ProductNumber - “Product #”

D. OrderQty - “Quantity”

E. UnitPrice - “Unit Price”

5. Change the style for all field titles to italicized and underlined.

6. Suppress the Report Footer.

7. Change the background color of the Page Footer to silver.

8. Save the report and preview it.
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Solution

The following describes one possible solution to the exercise.

1. Open C:/ClassFiles/cry2011-objects/Exercises/SalesOrder.rpt and select
the Design tab.

2. Click the Insert Text Object icon.

3. Position the mouse cursor on the left side of the Report Header section and click.

4. In the new text object, type “Sales Orders” and then click in the whitespace to
deselect it.

5. Select the text object and then press the left arrow key until the text object stops
moving.

6. Click and drag the right edge of the text object to the right side of the report.

7. Click the Bold icon.

8. Click the Align Center icon.

9. Change the font size to 16.
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10. Resize the box to a height that holds all of the text.

11. Delete the ProductID, SalesOrderID, and SalesOrderDetailID fields by selecting
them and pressing Delete. Ensure their titles are also deleted. Drag their guideline
markers off the horizontal ruler.

12. Move the remaining fields to the left.

13. Using the Field Explorer, drag the OrderQty and UnitPrice fields from the
SalesOrderDetail node to the Details section of the report.

14. Using the guidelines, move the fields so they are in the following order:

A. SalesOrderNumber

B. Name

C. ProductNumber

D. OrderQty

E. UnitPrice
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15. Select the field title of the SalesOrderNumber field, right-click, select Edit Text,
and type “Order Number”. Repeat for the remaining field titles using the following
labels:

A. Name - “Name of Product”

B. ProductNumber - “Product #”

C. OrderQty - “Quantity”

D. UnitPrice - “Unit Price”

16. In the Page Header section, click above the field title of the SalesOrderNumber
field and drag a selection box around all field titles to select them (Rubber band
Selection).

17. Click the Italics icon. (The field titles should already be underlined.)

18. Adjust and resize fields and their titles to ensure the titles are completely visible.

19. On the Experts toolbar, click the Section Expert icon.

20. In the Sections list box, select Report Footer.

21. On the Common tab, check the Suppress (No Drill-Down) check box.
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22. In the Sections list box, select Page Footer.

23. Select the Color tab, check the Background Color check box, and verify that
Silver is selected in the color palette. Click OK.

24. Save and preview the report.
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25. Your report may look similar to this.

Conclusion

In this lesson, you learned:

How to use text objects.

How to work with field titles.

How to incorporate fields in text objects.

How to add image objects.

About the various features available through the Section Expert.

How to use images in reports.
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LESSON 4
Filtering Reports

Topics Covered

The Select Expert.

 Building a filter based on a single field.

 Building a filter based on multiple criteria.

Introduction

When creating a report, you want to deliver the data that your users need. In some cases,
presenting all the data is not desirable and, in fact, can be overwhelming, especially when
the report is based on a large data set. To limit the data that is presented in your report,
you will need to use filters. In Crystal Reports, the tool you use to create filters is the Select
Expert. The Select Expert allows you to choose items to filter by. You can also use the
Formula Workshop and type in the code to create a filter.

❋

4.1. Create a Filter Based on a Single Criterion

To access the Select Expert, click the Select Expert icon in the Experts toolbar.

Initially, if you have no filters in place, you will see this dialog box:
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Once you select a field and click the OK button, you are taken to the Select Expert dialog
box:

The Formula Editor... opens the Formula Workshop, which allows for advanced work
with filters and other areas of Crystal Reports. You will have a chance to work with the
formula editor later on in this lesson. The Formula Workshop will be covered in more
detail later in the course.
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Let’s build a filter for the Customer report.

Demo - Adding a Filter on a Single Field

In our Customer report, we will limit the report to customers who are in North America.

1. Open C:ClassFiles/cry-2011-filter-report/Demos/Customer.rpt or you may
continue to use the report you already created C:ClassFiles/StudentReports/Cus
tomers.rpt. Select the Design tab.

2. On the Experts toolbar, click the Database Expert icon.

3. In  the Avai lable Data Sources  pane,  expand the
C:ClassFiles/Data/AdventureWorks.mdb node and select the following tables:

A. Address

B. CountryRegion

C. StateProvince

D. CustomerAddress

E. SalesTerritory
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4. Select the Links tab and confirm the connections.

5. Click OK. In the Refresh Report Data message box, click OK.

6. In the report, remove the CustomerID and Phone fields including their field titles
and guideline markers.

7. Move the remaining fields to the left.
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8. Using the Field Explorer, add the following fields:

A. From the Address table, add the City field and keep the field title “City”.

B. From the StateProvince table, add the Name field and change the field
title to “Region”.

C. From the CountryRegion table, add the Name field and change the field
title to “Country”.

9. Preview the report.

10. Return to the Design tab and adjust the widths of the fields so that all fields are
inside the body of the report.

11. Select the new field titles and then click the Bold icon to bold the titles and the
Underline icon to turn off underlining.

12. Select all field titles, right-click the AccountNumber field title, and select Align >
Middles.
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13. Click the Select Expert icon.

14. In the Choose Field dialog box, scroll down to the CountryRegion table and
expand it. Select the Name field and click OK.

15. In the Select Expert -- Record dialog box, on the CountryRegion.Name tab,
select “is one of” from the drop-down list. Then, in the drop-down list that appears
to the right, select “Canada” and “United States”. Click OK.
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16. Preview the report. The Change In Record Selection Formula message box
prompts you about which data to use. Click Refresh Data.

17. Review the data. Notice that the countries listed include only the United States
and Canada, countries in North America.
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❋

4.2. Create a Filter for Multiple Selection Criteria

Often we may need more complex filtering criteria to help get specific information from
the database. In the next demo, we will apply multiple filters to the Customer report.

Demo - Adding an Additional Filter

Let’s refine the selection in the Customer report to all North American customers who do
not reside in the West Coast states and provinces.

1. Open C:ClassFiles/cry-2011-filter-report/Demos/Customer.rpt or you may
continue to use the report you had created C:ClassFiles/StudentReports/Cus
tomers.rpt. Select the Design tab.

2. Click the Select Expert icon.

3. In the Select Expert -- Record dialog box, select the New tab.

82 | LESSON 4: Filtering Reports

EVALUATION COPY: Not to be used in class.



4. In the Choose Field dialog box, select the StateProvince.Name field and click
OK.

5. On the StateProvince.Name tab, select is not one of from the drop-down list.

6. In the new drop-down list, select the following:

A. British Columbia

B. California

C. Oregon

D. Washington
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7. Explore the Formula Editor... by clicking the  Formula Editor...
You will not be typing or making any changes just yet. Right now just explore the

options and then close the Formula Workshop by clicking the  red X. As
you progress in Crystal Reports, the Formula Workshop will be used more often
as needed.

8. Click OK to return to the report.

9. Preview the report. In the Change in Record Selection Formula message box,
click Refresh Data.

10. Review the report. Notice that the report now excludes customers in West Coast
states and provinces.

11. Save the report.
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 Exercise 4: Creating Filters
 15 to 30 minutes

In this exercise, we will filter the Sales Order report to show all orders placed in 2003 for
European customers.

1. Add the SalesTerritory table to the report and link it to the SalesOrderHeader
table.

2. Create a filter on the OrderDate field that shows only orders made in 2003.

3. Create a filter that includes only customers from Europe. Hint: Use the Formula
Workshop.

{SalesTerritory.Group}="Europe" and

4. Preview and save the report.
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Solution

The following describes one possible solution to the exercise.

1. Open C:/ClassFiles/cry2011-filter-report/Exercises/SalesOrder.rpt and
select the Design tab.

2. Click the Database Expert icon.

3. In the Available Data Sources pane, expand to the
C:/ClassFiles/Data/AdventureWorks.mdb node, double-click Sales Territory,
and click OK.

4. Select the Links tab, verify that the SalesOrderHeader table is linked to the
SalesTerritory table by the TerritoryID field, and then click OK.
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5. Click Cancel to close the Refresh Report Data message box.

6. Add the SalesTerritory.Group to the detail section.

7. Format to match.

8. Click the Select Expert icon.

9. In the Choose Field dialog box, scroll down to the SalesOrderHeader node,
expand it, select Order Date, and click OK.
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10. In the Select Expert -- Record dialog box on the SalesOrderHeader.OrderDate
tab, select “is between” from the drop-down list. Note that two combo boxes appear
to the right of the drop-down list.

11. In the top combo box, type “1/1/2003”. Type “12/31/2003” in the second combo
box.

12. Click Formula Editor....

13. In the Formula Workshop dialog box, type the following above the existing code.

{SalesTerritory.Group}="Europe" and

90 | LESSON 4: Filtering Reports

EVALUATION COPY: Not to be used in class.



14. click Save and close.

15. Preview the report. In the Change in Record Selection Formula message box,
click Refresh Data.
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16. Save the report.

Conclusion

In this lesson, you learned:

To use the Select Expert.

To build a filter based on a single field.

To build a filter based on multiple criteria.
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LESSON 5
Sorting and Grouping Reports

Topics Covered

The Sort Expert.

The Group Expert.

 Summarizing records within groups.

Introduction

Often, the data coming from the data source is not well organized; i.e., it is unsorted. Once
data is sorted, we may find data that is repetitious. In these instances, we may want to
group the data to reduce duplication.

Crystal Reports provides the tools we need to sort and group the data in our reports. The
Record Sort Expert is used to create the sort order. The Group Expert is used to group
the data and creates new sections in which we may organize summary data.

❋

5.1. Using the Sort Expert

To sort data in a report, we first need to determine which field to base the sort on. Once
this is decided, we can use the Record Sort Expert to proceed:
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You can choose any number of fields to sort on, including fields that are not used in your
report. In addition, once you select a field for sorting, you have the option to sort in either
ascending or descending order. We’ll see this in the next demo.

Demo - Sorting Records

Instead of filtering the Customer report by customers from different regions, let’s sort it by
country and region.

1. Open C:/ClassFiles/cry2011-sorting-grouping/Demos/Customer.rpt or use the
report that you already created C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. Click the Select Expert icon.

3. In the Select Expert -- Record dialog box, on the CountryRegion.Name tab,
click Delete. Do the same for the StateProvince.Name tab and then click OK.
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4. On the Experts toolbar, click the Record Sort Expert icon.

5. In the Record Sort Expert dialog box, expand the CustomerRegion node and
double-click the Name field.

6. Next, under the StateProvince node, double-click the Name field and click OK.

7. Preview the report. If the Change In Record Selection Formula message box
displays, click Refresh Data.
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8. Your report may look similar to this.

❋

5.2. Using the Group Expert

When we sort on some fields, we can end up with repeating data. Since these fields are
available for sorting, we can go a step further and group the report on these fields to
eliminate the duplication of values in the report layout.

To group data in the report, we will use the Group Expert:
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Demo - Grouping Records

We will now group the Customer report by country, region, and city.

1. Open C:/ClassFiles/cry2011-sorting-grouping/Demos/Customer_1.rpt or use
the report that you already created C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. On the Experts toolbar, click the Group Expert icon.

3. In the Group Expert dialog box, double-click the following fields in this order:

A. Individual.DateFirstPurchased

B. CountryRegion.Name

C. StateProvince.Name

D. Address.City
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4. Select the Individual.DateFirstPurchase - A in the Group By area and click
Options.

5. From The section will be printed: drop-down, choose for each quarter. Click
OK.

6. Click OK. You should see four sets of group headers and footers with a Group
Name field for each.
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7. Leave Group #1 Name alone. Stagger the other three Group Name fields to the
right. The left edge of each should be about a half an inch from the left edge of
the field above it.

8. Remove the Address.City, StateProvince.Name, and CountryRegion.Name
fields from the report including their field titles and guideline markers.

9. Use the guideline markers to move the remaining fields and their field titles to the
right.
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10. Click the Record Sort Expert icon.

11. In the Record Sort Expert dialog box, in the Sort Fields list box, double-click A
- CountryRegion.Name, and StateProvince.Name to remove them. (These fields
duplicate two of the grouping fields.) Click OK.

12. Preview the report.
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❋

5.3. Summarizing Records within Groups

To better organize a report, you may filter, sort, and group the data on a report. Within the
grouped data, you may go a step further and summarize the data at the group level. For
example, instead of manually counting the number of customers per country or per city,

we can let Crystal Reports do the work for us.To do this, we’ll use the Insert Summary
dialog box:
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Demo - Adding Group Summary Counts

We will count the number of customers in each country on the Customer report and show
those counts on the report.

1. Open C:/ClassFiles/cry2011-sorting-grouping/Demos/Customer_2.rpt or use
the report that you already created C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. On the Insert toolbar, click the Insert Summary icon.

3. In the Insert Summary dialog box, verify that the Customer.AccountNumber
field is selected in the Choose the field to summarize drop-down list.

4. From the Calculate this summary drop-down list, select Count.

5. In the Summary location section, check the Add to all group levels check box
and then click OK.
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6. The summary fields are added to the Group Footer section. Move them so that
they are under the AccountNumber field.

7. Preview the report. Review the last page of the report.

8. Save the report.
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 Exercise 5: Sorting and Grouping
 15 to 30 minutes

In the Sales Order report, group the data by sales order and sort by the product number
within each order.

1. Remove all filters.

2. Group on the SalesOrderNumber field.

3. Sort on the ProductNumber field.

4. Count the number of line items per order.

5. Save the report and preview it.
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Solution

The following describes one possible solution to the exercise.

1. Open C:/ClassFiles/cry2011-sorting-grouping/Exercises/SalesOrder.rpt or
use the report that you already created C:/ClassFiles/StudentReports/salesOr
der.rpt. Select the Design tab.

2. Click the Select Expert icon.

3. In the Select Expert -- Record dialog box, on the SalesTerritory.Group tab, click
Delete. Do the same for the SalesOrderHeader.OrderDate tab and then click
OK.

4. Click the Group Expert icon.

5. In the Group Expert dialog box, under the report fields, double-click the
SalesOrderHeader.SalesOrderNumber field and then click OK.

106 | LESSON 5: Sorting and Grouping Reports

EVALUATION COPY: Not to be used in class.



6. Delete the SalesOrderNumber field from the report including its field title and
guideline marker. Adjust the remaining fields as necessary.

7. Click the Record Sort Expert icon.

8. In the Record Sort Expert dialog box, double-click the Product.ProductNumber
field and then click OK.
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9. On the report, right-click the ProductNumber field and select Insert > Summary.

10. In the Insert Summary dialog box, from the Calculate this summary drop-down
list, select Count.

11. From the Summary location drop-down list, select Group #1:
SalesOrderHeader.SalesOrderNumber - A and then click OK.
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12. Preview the report. If the Change in Record Selection Formula message box
opens, click Refresh Data.

Note this is an inner page to show more detail.
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Conclusion

In this lesson, you learned:

To use the Sort Expert.

To use the Group Expert.

How to summarize records within groups.
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LESSON 6
Using Basic Formulas

Topics Covered

 Formulas for various data types.

 Running totals.

 Conditional formulas.

Introduction

While the ability to add fields to text objects is useful, its application is limited. The ability
to create formulas in Crystal Reports is much more robust. You can use formulas to
combine (concatenate) first and last names and fields of different data types and apply
special formatting. Data based on the report itself may also be presented using formulas..

To create a formula, use the Formula Workshop:
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The Formula Workshop is used for all types of formulas. You can access it by selecting

Report > Formula Workshop from the menu or by clicking the Formula Workshop
icon in the Experts toolbar.

❋

6.1. String Formulas

Often fields in a database are closely related to one another. For example, address fields.
A database may have separate fields for the street name, the city, the state/region, etc.
From the perspective of the database, it may be preferable to split these entries in order
to maintain efficiency. However, from the reporting perspective, this does not always
present well in the layout.

To resolve this difference, Crystal Reports provides the means to combine fields together
using string formulas. The next demo explores how to use string formulas.

Demo - Adding String Formulas

We will improve the group headers in the Customer report.

1. Open C:/ClassFiles/cry2011-formulas/Demos/Customer.rpt or you may use the
report that you already built C:/ClassFiles/StudentReports/Customers.rpt. Select
the Design tab.

2. To create a formula for showing the Date explanation:

A. In the Field Explorer, select the Formula Fields node and click the New
icon in the Field Explorer toolbar.
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B. In the Formula Name dialog box, type “DateTitle” and click OK.

C. In the Formula Workshop - Formula Editor - DateTitle dialog box, in
the formula text pane, type “Date Range - ” (include the quotes) followed
by an ampersand (&).

D. In the Report Fields pane, expand the Report Fields node and
double-click the Individual.DateFirstPurchase field.
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E. The text in the Formula Editor should look like this:

"Date Range - " & GroupName ({Individual.DateFirstPurchase}, "quarterly")

F. Click the Check icon  in the toolbar. Crystal Reports should report no
errors. Click OK.

G. Click Save and close.

3. To create a formula for the country description:

A. In the Field Explorer, right-click the Formula Fields node and select New
from the menu.

B. In the Formula Name dialog box, type “CountryDescription” and click OK.

C. In the formula text pane, type “Country - ” (include the quotes) followed
by an ampersand (&).

D. In the Report Fields pane, double-click the CountryRegion.Name field.
The text in the Formula Editor should look like this:

"Country - " & {CountryRegion.Name}

E. Click the Check icon to verify the formula. Crystal Reports should report
no errors. Click OK.

F. Click Save.

4. To create a formula for the region description:

A. In the Formula Workshop tree, right-click Formula Fields and select
New.

B. In the Formula Name dialog box, type “RegionDescription” and click OK.
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C. In the formula text pane, type “Region - ” (include the quotes) followed by
an ampersand (&).

D. In the Report Fields pane, double-click the StateProvince.Name field.
The text in the Formula Editor should look like this:

"Region - " & {StateProvince.Name}

E. Click the Check icon. No errors should be reported. Click OK.

F. Click Save.

5. To create a formula for the city description:

A. In the Formula Workshop tree, right-click Formula Fields and select
New.

B. In the Formula Name dialog box, type “CityDescription” and click OK.

C. In the formula text pane, type “City - ” (include the quotes) followed by an
ampersand (&).

D. In the Report Fields pane, double-click the Address.City field. The text
in the Formula Editor should look like this:

"City - " & {Address.City}

E. Click the Check icon. No errors should be reported. Click OK.

F. Click Save.

6. In the report, replace the Group Name fields in the Group Header with their
corresponding formula fields. To do so, delete the Group Name field and then, in
the Field Explorer, expand the Formula Fields node, and click and drag the
corresponding field onto the report.
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7. Preview the report. Adjust the various fields and objects so that they are completely
visible.

8. Save the report.

❋
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6.2. Numeric Formulas

Database tables usually do not contain fields calculated from other fields. Crystal Reports
lets us perform these calculations using fields that are available in the report.

Demo - Using a Numeric Formula

Let’s modify the Customer report to look at what customers spent on their purchases.

1. Open C:/ClassFiles/cry2011-formulas/Demos/Customer_1.rpt or you may use
the report that you already built C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. Click the Database Expert icon.

3. I n  t he  Ava i lab le  Da ta  Sources  pane,  go  t o  t he
C:/ClassFiles/Data/AdventureWorks.mdb node and double-click
SalesOrderHeader to add it to the Selected Tables pane.

4. Select the Links tab and remove all links from the SalesOrderHeader table by
right-clicking the links and selecting Delete Link.
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5. Create a link between the Customer and SalesOrderHeader tables using the
CustomerID field.

6. Click OK. In the Refresh Report Data message box, click OK.

7. In the Field Explorer, right-click the Formula Fields node and select New.

8. In the Formula Name dialog box, type “LineTotal” and click OK.
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9. In the Formula Workshop - Formula Editor - LineTotal dialog box, expand the
C:/ClassFiles/Data/AdventureWorks.mdb node in the Report Fields pane.
Locate the SalesOrderHeader table node and expand it.

10. Double-click the SubTotal, TaxAmt, and Freight fields.

11. In the formula text pane, type plus signs between the fields. The formula should
look like this:

{SalesOrderHeader.SubTotal} + {SalesOrderHeader.TaxAmt} + {SalesOrderHead  ↵↵
er.Freight}

12. Click the Check icon. No errors should be reported. Click OK.

13. Click Save and close.

14. In the Field Explorer, expand the Database Fields > SalesOrderHeader node,
then click and drag the SalesOrderNumber field to the Details section of the
report.

15. From the Formula Fields node, click and drag the Line Total formula field to the
Details section.
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16. Change the SalesOrderNumber field title to “Order Number”.

17. Right-click the Account Number field title and select Format Painter. Move the
cursor to the SalesOrderNumber field title and click. Repeat for the Line Total
field title.

18. Select all field titles, then right-click in the AccountNumber field title and select
Align > Middles.

19. Adjust the fields so that all are contained inside the body of the report.

20. Preview the report.
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❋

6.3. Date/Time Formulas

When working with dates and times in a report, it is not always the actual date or time we
want. Instead, we may want to know the number of days between events, whether a
deadline was met, or in which month someone became a customer. Crystal Reports
provides many Date/Time functions to assist you.

Demo - Adding a Date-based Formula

We will modify the Customer report to display the anniversary month for each customer.

1. Open C:/ClassFiles/cry2011-formulas/Demos/Customer_2.rpt or you may use
the report that you already built C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. In the Field Explorer, select the Formula Fields node and click the New icon in
the Field Explorer toolbar.

3. In the Formula Name dialog box, type “AnniversaryMonth” and click OK.

4. In the Formula Workshop - Formula Editor - AnniversaryMonth dialog box,
go to the Functions pane and expand the Functions > Date and Time > DatePart
node.
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5. Double-click DatePart (intervalType, inputDateTime).

6. In the formula text pane, verify that the cursor is in front of the comma, then type
“m” (include the quotes) and move the cursor so that it is after the comma.

7. I n  t h e  R e p o r t  F i e l d s  p a n e ,  e x p a n d  t h e
C:/ClassFiles/Data/AdventureWorks.mdb>Individual node.

8. Double-click the DateFirstPurchase field.

9. Enclose the current expression in the MonthName function. The formula should
look like this:

MonthName(DatePart ("m",{Individual.DateFirstPurchase}))

10. Click the Check icon. No errors should be reported. Click Save and close.

11. In the Field Explorer, click and drag the Anniversary Month formula field to the
Details section next to the Line Total formula field.

12. Select the field title and then click the Bold and Underline icons.

13. Adjust the width of the Anniversary Month formula field so that it and its field title
are completely contained inside the report. Make other adjustments as needed.
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14. Preview and save the report.

❋

6.4. Running Totals

You can track the accumulation of a value throughout a report or simply produce
incremental values to display. Furthermore, you may want to track these values within
groups, resetting the value back to zero at the start of the each group. Crystal Reports
handles these calculations using running totals. To create a running total field, you will
use the Create Running Total Field dialog box:
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Demo - Adding Running Total Fields

In this demo, we will add a line number for each record in the report and a running total
based on the Line Total formula field.

1. Open C:/ClassFiles/cry2011-formulas/Demos/Customer_3.rpt or you may use
the report that you already built C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. Move fields to the right to make the AccountNumber Text Object wider.

3. In the Field Explorer, Right-click Running Total Fields and choose New.

4. In the Create Running Total Field dialog box, Confirm that
Customer.AccountNumber is the Field to summarize select "count" from the
Type of summary drop-down list. If not, choose the field.

5. In the Evaluate section, ensure the For each record radio button is selected.

6. In the Reset section, select On change of group and then select “Group #2:
CountryRegion.Name - A” from the drop-down list.
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7. Click OK.

8. Move the RTotal0 running total field to the right of the Account Number in the
Text Object.

9.

10. Preview the report. Make adjustments as necessary.
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❋

6.5. Conditional Formulas

Sometimes rather than display actual data, we may want to provide an indicator based
on the values in a field. We may also want to create formulas based on comparing two
fields or comparing the values in a field with a particular value. We can do this using
conditional statements in our formulas.The conditional statement we need, the If-Then-Else
clause, can be used to create indicator fields which display when certain conditions have
been met.

Demo - Adding a Conditional Formula

We will add a marker to the Customer report to the left of the LineTotal to indicate which
total is greater than $3,500.

1. Open C:/ClassFiles/cry2011-formulas/Demos/Customer_4.rpt or you may use
the report that you already built C:/ClassFiles/StudentReports/Customers.rpt.
Select the Design tab.

2. In the Field Explorer, select the Formula Fields node and click the New icon.

3. In the Formula Name dialog box, type “LT>3500” and click OK.

4. In the Formula Workshop - Formula Editor -LT>3500 dialog box, in the
Operators pane, expand the Operators > Control Structures node and
double-click “if x then y else z”.
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5. After verifying that the cursor in the formula text pane is between “if” and “then”,
go to the Report Fields pane and double-click the LineTotal field.

6. Following the LineTotal field, type " > 3500".

7. Move your cursor after “then” and type “X” (include the quotes). After “else”, type
"". The formula should look like this:

if {@LineTotal}>3500 then "X" else ""

8. Click the Check icon to verify that there are no errors.

9. Click OK and then click Save and close.

10. Move the the LineTotal field to the right a bit.

11. Click and drag the LT>3500 formula field to the left of the LineTotal running total
field in the Details section of the report and delete its field title.

12. Preview and save the report.
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 Exercise 6: Formulas in Reports
 15 to 30 minutes

For the Sales Order report, we will show the total sales amount and use a running total
for our sales total. We’ll also enhance the group fields.

1. Replace Group #1 Name in the Group Header with a formula field that better
describes the group. Confirm, or switch the group to
SalesOrderHeader.AccountNumber.

2. Create a formula for the total line amount for each line in the report. Add a summary
field for the sales order total to the Group Footer.

3. Create a running total field that accumulates the line totals per sales order.
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Solution

The following describes one possible solution to the exercise.

1. Open C:/ClassFiles/cry2011-formulas/Exercises/SalesOrder.rpt and select
the Design tab.

2. In the Field Explorer, right-click the Formula Fields node and select New.

3. In the Formula Name dialog box, type "AccountTitle" and click OK.

4. In the Formula Workshop - Formula Editor - AccountTitle dialog box, type the
following in the formula text pane:

"Account Number - " + {SalesOrderHeader.AccountNumber}

or

"Account Number - " & {SalesOrderHeader.AccountNumber}

5. Click the Check icon to verify there are no errors and then click OK.
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6. Click Save.

7. In the Formula Workshop tree, right-click the Formula Fields node and select
New.

8. In the Formula Name dialog box, type “LineTotal” and click OK.

9. In the formula text pane, type the following:

{SalesOrderDetail.OrderQty} * {SalesOrderDetail.UnitPrice}

10. Click the Check icon to verify there are no errors and then click OK.

11. Click Save and close.

12. Remove the current group fields from the Group Header.

13. Click and drag the AccountTitle formula field to the far-left side of Group Header
#1. Click the Bold icon.

14. Move the existing fields in the Details section to the left to allow for two more fields
to the right.

15. Click and drag the Line Total formula field to the right of the Unit Price field in
the Details section.

16. Select the Line Total field title and click the Italics icon.

17. Using Crystal Reports 2008: right-click the LineTotal formula field and select
Insert > Running Total.

18. Using Crystal Reports 2011: in the Field Explorer, right-click Running Total
Fields and choose New.

19. In the Edit Running Total Field dialog box, confirm that @LineTotal is filled in
in the Field to summarize field and that "sum" is selected from the Type of
summary drop-down list for Type of summary.
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20. Click OK.

21. Place the Running Total RTotal0 to the right of the LineTotal.

22. Select @LineTotal in the Detail section.

23. In the Insert Summary dialog box, ensure that “Sum” is selected in the Calculate
this summary: drop-down list.
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24. In the Summary location drop-down list, select “Group #1:
SalesOrderHeader.AccountNumber - A” and then click OK.

25. Preview the report. Adjust fields as needed to ensure that all field values and field
titles are completely visible.
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26. Save the report.

Conclusion

In this lesson, you learned:

How to create formulas for various data types.

How to create running totals.

How to create and use conditional formulas.
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LESSON 7
Advanced Formatting

Topics Covered

 Splitting sections into multiple sections.

 Summary reports.

 Formatting with lines and box objects.

The Highlighting Expert.

Introduction

Reports are essentially a collection of strings, numbers, and dates from a data repository.
While good data is important, it’s just as important to present information that is appealing
in a useful way. Because of this, formatting is critical in accomplishing the purpose of a
report.

❋

7.1. Using Multiple Sections

The default report sections or those that get added when groups are created are always
present and may not be deleted. The creation of new sections often helps to improve
formatting.

To alter and add new sections, use the Section Expert:
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Demo - Using Multiple Sections

In the Customer report, the field titles are currently in the Page Header. However, since
we added some groups to the report, the field titles appear to be out of place. We will use
the multiple-section feature to help improve this aspect of the report.

1. Open C;/ClassFiles/cry2011-advanced-formatting/Demos/Customer.rpt or use
the report that you already built C:/ClassFiles/Student/reports/Customers.rpt.
Select the Design tab.

2. On the Experts toolbar, click the Section Expert icon.

3. In the Sections list box, select Details.

4. Select the Color tab on the right side of the dialog box. Uncheck the Background
Color check box.
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5. In the Sections list box, select Group Header #4 and then click Insert. Click OK.

6. Notice that the Group Header #4 section has been split into two sections.
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7. Select all field titles in the Page Header and use the down arrow (press 5 times)
to move them down to Group Header #4b.

8. Right-click Group Footer #4 and select Insert Section Below.

9. Right-click the Page Header and select Suppress (No Drill-Down).

10. Preview and save the report.

138 | LESSON 7: Advanced Formatting

EVALUATION COPY: Not to be used in class.



❋

7.2. Summary Reports

One benefit of report formatting is that we can often reuse a single report to produce what
appears to our users to be multiple reports. A prime example is the presentation of a
summary report along with a detailed report. In Crystal Reports, summary and detailed
reports can be produced from the same physical report file using section suppression.

Demo - Creating a Summary Report

In this demo, we will create a summary report that shows total sales by country and region.

1. Open C;/ClassFiles/cry2011-advanced-formatting/Demos/Customer_1.rpt or
use the report that you already built C:/ClassFiles/Student/reports/Cus
tomers.rpt. Select the Design tab.

2. Click the Section Expert icon. Create a new Group Header #3. Click OK.

3. Move all of the titles from Group Header #4b to Group Header #3b.

4. Click the Group Expert icon.

5. Click the Group Expert icon. Remove the Address.City Group.
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6. Click OK.

7. Click the Section Expert icon.

8. In the Sections list, select Details and uncheck the Hide (Drill-Down OK) check
box on the Common tab.

9. In the Sections list, select Group Header #3b and check the Suppress (No
Drill-Down) check box.
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10. Click OK.

11. Move each of the Count of Customer. AccountNumbers up to the header area
just to the right of the title/description. Delete the Report Footer summary.

12. Select the LineTotal formula field and select Insert > Summary.

13. In the Insert Summary dialog box, ensure “Sum” is selected in the Calculate this
summary drop-down list, check the Add to all group levels check box, and then
click OK.
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14. Move each of the Count of Customer. AccountNumbers up to the header area
just to the right of the title/description. Delete the Report Footer summary.

15. Adjust the text objects to ensure they are completely visible.

16. Click the Section Expert icon. Check the Suppress (No Drill-Down) check box
for the following sections: Group Footer #3, Group Footer #2, Group Footer
#1. Click OK.

142 | LESSON 7: Advanced Formatting

EVALUATION COPY: Not to be used in class.



17. Preview the report.

❋

7.3. Lines and Boxes

Lines and boxes can be used to visually separate data in your report. This helps the data
stand out and can improve readability. Please use as needed because too many lines and
boxes can deter attention away from the data and look unprofessional.

Demo - Using Lines and Boxes in Formatting

In the Customer summary report, we will use a box object to section off the summary
information by Country and Region.

1. Open C;/ClassFiles/cry2011-advanced-formatting/Demos/Customer_2.rpt or
use the report that you already built C:/ClassFiles/Student/reports/Cus
tomers.rpt. Select the Design tab.

2. On the Insert toolbar, click the Insert Box icon. Place the cursor in the top-left
corner of Group Header #2 and then click and drag to the bottom-right corner of
Group Footer #2. Release the mouse button.

3. Right-click the box object and select Format Box.
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4. In the Format Editor, on the Box tab, check the Drop Shadow check box. Verify
that the Always Close Border check box is checked. Click OK.

Right-click the Group Footer #2 section and choose Don’t Suppress.

5. On the Insert toolbar, click the Insert Line icon. Place the cursor under the left
side of the CountryDescription formula field and then click and drag to the right
side of the field. Release the mouse button.

6. Right-click the line object and select Format Line.

7. In the Format Editor, change the Width to 3 pt. Click OK.
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8. Preview the report. Adjust the line object to fit the CountryDescription formula
field if needed.
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9. Save the report.

❋

7.4. The Highlighting Expert

Conditional formulas are used to mark records that satisfied a particular condition. The
Highlighting Expert in Crystal Reports provides another way to accomplish the same
purpose:

Demo - Using the Highlighting Expert

We will use the Highlighting Expert to show countries with revenue greater than
$1,000,000 with special formatting.

1. Open C;/ClassFiles/cry2011-advanced-formatting/Demos/Customer_3.rpt or
use the report that you already built C:/ClassFiles/Student/reports/Cus
tomers.rpt. Select the Design tab.

2. Right-click the Sum of @LineTotal in Group Header #2 and select Highlighting
Expert.
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3. In the Highlighting Expert dialog box, click the New button.

4. In the Item editor section, change the selection in the second Value of drop-down
list to “is greater than or equal to” and change the text box to “1000000”.

5. From the Font Style drop-down list, select “Bold” and form the Border drop-down
list, select “Single Box”. Click OK.

6. Preview the report. Notice that records over $1,000,000 are Bold with a box.
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7. Save the report.
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 Exercise 7: Advanced Formatting
 15 to 30 minutes

We will make some visual enhancements to the Sales Order report.

1. Move the field titles so that they are directly above their corresponding fields.

2. Place the account number and titles in a box object. (Use the Format Editor to
ensure that the box spans the entire Details section when previewed and printed.)

3. Place a line above the Sales Order summary field in the Group Footer #1 section.

4. Highlight the Product Name field for products that had a quantity of 10 or greater.
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Solution

The following describes one possible solution to the exercise.

1. Open C;/ClassFiles/cry2011-advanced-formatting/Exercises/SalesOrder.rpt.
Select the Design tab.

2. Right-click the Group Header#1 section and select Insert Section Below.

3. Select all field titles form the Page Header and move them to Group Header #1b.

4. Click the Insert Box icon. Place the cursor at the upper-left corner of the Group
Header #1a and then click and drag to the lower-right corner of the Group Header
#1b. Release the mouse button.

5. Right-click the box object and select Format Box.

6. Choose Navy from the Color drop-down and then click the Rounding tab.
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7. Type 10 in the Rounding box. Click OK.

8. Increase the height of Group Footer #1 and move the summary fields down to
the lower edge of the section.
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9. Click the Insert Line icon. Place the cursor above and to the left of the Line Total
summary field. Click and drag to the right side of the field. Release the mouse
button. Format to taste.

10. Right-click the Product.Name field and select Highlighting Expert.

11. In the Highlighting Expert dialog box, click New.

12. In the Item editor section, in the first Value of drop-down list, select
“SalesOrderDetail.OrderQty”.

13. In the Item editor section, in the second Value of drop-down list, select “is greater
than or equal to”.

14. In the Item editor section, in the third Value of drop-down list, select “10”.
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15. Change Font style to "Bold".

16. Change Background to a Custom pale yellow (you choose the color). Click OK.

17. Adjust all objects as needed.

18. Preview and save the report.
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Conclusion

In this lesson, you learned:

How to split sections into multiple sections.

How to create and use summary reports.

How to format with lines and box objects.

How to use the Highlighting Expert.
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LESSON 8
Exporting and Distribution

Topics Covered

 Exporting file formats.

The Crystal Reports Viewer.

Introduction

While viewing your report in the Crystal Reports application may be useful to you, not
everyone in your organization will have Crystal Reports. How then, will you distribute your
report? An obvious answer is to print it; however, this may not be the best option for your
users.

Your users may want to take the data from your report and present it using a variety of
applications and file formats. While your users could sit down at their computers and type
in all the values from your report, this is impractical. Crystal Reports provides a better way.
With Crystal Reports, you can export the results of your report in a variety of formats.

❋

8.1. Exporting to Excel

Many reports built with Crystal Reports may be in a tabular format. Given this type of
format, it may be worthwhile to extract the data and look at it using a spreadsheet
application such as Microsoft Excel. Crystal Reports can export report data to an Excel
spreadsheet. For Crystal Reports 2011, reports can be exported in both Excel 2003 and
Excel 2007/2010 formats.

Demo - Export to Excel 2007/2010

We will export data from the Customer report to a Microsoft Excel file.

1. Open C:/ClassFiles/cry2011-export-distribute/Demos/Customer.rpt or you
may use the report that you already built C:/ClassFiles/StudentReports/Cus
tomers.rpt.
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2. On the Standard toolbar, click the Export icon.

3. In the Export dialog box, select Microsoft Excel Workbook Data-only from the
Format drop-down list. Click OK.

4. In the Excel Format Options dialog box, select Custom: Data is exported
according to selected options. Change the Column Width to match Group
Header #3. Click OK.

5. In Select Export File dialog box, navigate to C:/ClassFiles/cry2011-export-
distribute/Demos/. In the File name text box, accept “Customer.xlsx” and click
Save.
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6. After the export finishes, open Microsoft Excel and navigate to the newly created
file and open it. Adjust the column width.
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❋

8.2. Exporting to PDF

Instead of printing your report, you may want to save paper and export it to a common file
type. This is often a PDF file, which Crystal Reports provides as an export option. This
export feature can be very useful, especially when not everyone will have a full version of
Adobe Acrobat readily available to create PDF documents.
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Demo - Export to a PDF File

Using our Customer report, output the results as a PDF file.

1. Open C:/ClassFiles/cry2011-export-distribute/Demos/Customer.rpt or you
may use the report that you already built C:/ClassFiles/StudentReports/Cus
tomers.rpt.

2. Click the Export icon.

3. In the Export dialog box, from the Format drop-down list, select “PDF”. Click OK.

4. In the Export options dialog box, click OK.

5. In the Choose export file dialog box, navigate to C:/ClassFiles/cry2011-export-
distribute/Demos/. In the File name text box, accept “Customer.pdf” and click
Save.
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6. After the export finishes, open Adobe Acrobat Reader and navigate to the newly
created file and open it.

❋
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8.3. Exporting to Word

In your organization, when people talk about reports, they are not necessarily referring to
what Crystal Reports produces. Instead, they may be looking at a full progress report
about some activity within your organization built in a product such as Microsoft Word.
Still, these reports may need to incorporate your output. In these cases, you can export
your data to a file that can be used in Microsoft Word.

Demo - Export to a Rich Text File

Using the Customer report, export the output of the report to a Microsoft Word file.

1. Open C:/ClassFiles/cry2011-export-distribute/Demos/Customer.rpt or you
may use the report that you already built C:/ClassFiles/StudentReports/Cus
tomers.rpt.

2. Click the Export icon.

3. In the Export dialog box, from the Format drop-down list, select “Microsoft Word
(97-2003)”. Click OK.

4. In the Export options dialog box, click OK.
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5. In the Choose export file dialog box, navigate to C:/ClassFiles/cry2011-export-
distribute/Demos/. In the File name text box, accept “Customer.rtf” and click
Save.

6. After the export finishes, open Microsoft Word and navigate to the newly created
file and open it.
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 Exercise 8: Exporting Reports
 10 to 20 minutes

Export the output of the Sales Order report to a Microsoft Excel file and a PDF file.

1. Export the report to a Microsoft Excel file.

2. Export the report to a PDF file.
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Solution

1. To export the report output to a Microsoft Excel file:

A. Open C:/ClassFiles/cry2011-export-distribute/Exercises/SalesRe
port.rpt.

B. Click the Export icon.

C. In the Export dialog box, select Microsoft Excel Workbook Data-only
from the Format drop-down list. Click OK.

D. In the Excel Format Options dialog box, select Typical: Data is exported
with default options applied. Click OK.

E. In Select Export File dialog box, navigate to C:/ClassFiles/cry2011-

export-distribute/Exercises/. In the File name text box, accept
“SalesOrder.xlsx” and click Save.

F. After the export finishes, open Microsoft Excel and navigate to the newly
created file and open it. Adjust the column width if needed.
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2. To export the report output to a PDF:

A. Open C:/ClassFiles/cry2011-export-distribute/Exercises/SalesRe
port.rpt.

B. Click the Export icon.

C. In the Export dialog box, from the Format drop-down list, select “PDF”.
Click OK.

D. In the Export options dialog box, click OK.

E. In the Choose export file dialog box, navigate to C:/ClassFiles/cry2011-

export-distribute/Exercises/. In the File name text box, accept
“SalesReport.pdf” and click Save.

F. After the export finishes, open Adobe Acrobat Reader and navigate to the
newly created file and open it.
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Conclusion

In this lesson, you learned:

How to export to various file formats.

How to use the Crystal Reports Viewer.
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LESSON 9
Section 508 Rules

Topics Covered

 Section 508 rules.

Introduction

In order for your reports to remain Section 508 compliant, please read up and learn more
on the official government website.

❋

9.1. Section 508

Per the official government website2, the following is a brief description of Section 508:

In 1998, Congress amended the Rehabilitation Act of 1973 (29 U.S.C. 794d)
as amended by the Workforce Investment Act of 1998 (P.L. 105 - 220), August
7, 1998 to require Federal agencies to make their electronic and information
technology (EIT) accessible to people with disabilities.

Specifically, Section 508 of that act requires that when Federal agencies
develop, procure, maintain, or use EIT, Federal employees with disabilities

have access to and use of information and data that is comparable to the
access and use by Federal employees who are not individuals with disabilities,
unless an undue burden would be imposed on the agency.

2. https://www.section508.gov/
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 9.1.1. What does this mean for Crystal Report users?

Once you have reviewed the official website, you may be overwhelmed or confused about
what Section 508 means to you. In short, you will find a few basic rules to follow when
building and formatting reports.

Use good contrast: Make sure you have dark text, and light backgrounds.

When calling attention to items, do not solely rely on color alone, change the
“shape” of the item by using bold and such.

Use solid, easy to read fonts.

Keep the layout simple.

These are just a few ideas, please always refer to the official site and comply with all rules
posted.

Conclusion

In this lesson, you have learned

About Section 508 rules.
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