
Adobe Animate
Creative Cloud (CC)

Training

with examples and
hands-on exercises

WEBUCATOR



Copyright © 2021 by Webucator. All rights reserved.

No part of this manual may be reproduced or used in any manner without written permission
of the copyright owner.

Version: 3.1.0

The Authors

Tracy Berry

Tracy has been a senior graphic designer/programmer, instructor, and consultant since
1993 and has developed hundreds of logos, marketing materials, websites, and multimedia
solutions for customers worldwide, including involvement in large corporate software
rollouts. She has helped many organizations optimize and streamline data solutions. She
teaches both onsite and online courses and has her CTT (Certified Technical Trainer)
certification. Tracy specializes in teaching graphics, desktop publishing, web design,
reporting/productivity applications, as well as the creation of online courses with software
from leading vendors.

Ryan Dunn (Editor)

Class Files

Download the class files used in this manual at
https://static.webucator.com/media/public/materials/classfiles/ANICC.1-3.1.0.zip.

Errata

Corrections to errors in the manual can be found at
https://www.webucator.com/books/errata/.

https://static.webucator.com/media/public/materials/classfiles/ANICC.1-3.1.0.zip
https://www.webucator.com/books/errata/


Table of Contents

LESSON 1. Getting Started..............................................................................................1
Reviewing the Welcome Screen...............................................................................................1
Creating a New Document.......................................................................................................3
Getting to Know the Work Area...............................................................................................7
Using Workspaces....................................................................................................................9
Moving Panels........................................................................................................................10
Demo: Changing Workspaces.................................................................................................13
Opening Existing Files.............................................................................................................14
Using the Properties Panel.....................................................................................................15
Undo in Animate....................................................................................................................15
Previewing Your Movie...........................................................................................................16
Publishing Your Movie............................................................................................................17
Some Important Keyboard Shortcuts.....................................................................................19

Exercise 1: Previewing Your Movie..............................................................................20
LESSON 2. Working with Drawing Tools.........................................................................21

Using the Tools Panel .............................................................................................................22
Demo: Using the Drawing Tools.............................................................................................33

Exercise 2: Using the Animate Drawing Tools to Create Shapes....................................40
Using Additional Tools............................................................................................................44

Exercise 3: Use the Drawing Tools to Create a Logo......................................................52
LESSON 3. Graphic Symbols and the Library................................................................55

Working with the Library Panel..............................................................................................55
Working with the CC Libraries Panel......................................................................................56
About Symbols.......................................................................................................................57
Creating Symbols....................................................................................................................58
Editing and Managing Symbols..............................................................................................59
Duplicating Symbols...............................................................................................................62
Swapping Symbols..................................................................................................................63
Changing the Size and Position of Instances..........................................................................63
Changing the Color Effect of Instances...................................................................................64
Demo: Creating Graphic Symbols...........................................................................................65

Exercise 4: Create Graphic Symbols for a Banner Ad....................................................70
Import to Stage / Import to Library........................................................................................72
Open Another Document’s Library / Sharing.........................................................................73
Importing Illustrator Files.......................................................................................................73
Importing Photoshop Files.....................................................................................................75

Exercise 5: Create Graphic Symbols.............................................................................76

Table of Contents | i



LESSON 4. Basic Animation...........................................................................................79
Understanding the Timeline...................................................................................................79
Organizing Layers in a Timeline..............................................................................................80
About Animation....................................................................................................................81
Demo: Frame-by-Frame Animation........................................................................................81
Adding Frames, Keyframes and Blank Keyframes...................................................................82
Animating Position: Frame-by-Frame Animation...................................................................83
Changing the Pacing and Timing............................................................................................84
Animating Transparency.........................................................................................................85
Previewing the Animation......................................................................................................85
Demo: Animation with a Motion Tween................................................................................85

Exercise 6: Use Motion Tween to Animate Airplane.....................................................90
Using Timelines to Create Movie Structure............................................................................95
Understanding Our Project File..............................................................................................96

Exercise 7: Build Site Structure on Timeline.................................................................98
More with Animation...........................................................................................................102

Exercise 8: Improving Motion Tweens with Easing and Motion Presets......................112
LESSON 5. Advanced Animation..................................................................................117

Demo: Copy and Paste Motion.............................................................................................117
Demo: Creating Motion Presets...........................................................................................119

Exercise 9: Create Photo Gallery using Motion Presets..............................................123
Creating Masks.....................................................................................................................126
Animating Masks..................................................................................................................129
Morphing with Shape Tweens..............................................................................................131
Using Shape Hints.................................................................................................................133
Motion with Inverse Kinematics...........................................................................................135
Constraining Joints...............................................................................................................137
Demo: Inverse Kinematics....................................................................................................138
Inverse Kinematics with Shapes...........................................................................................140

LESSON 6. Button Symbols.........................................................................................143
Creating Button Symbols......................................................................................................143
Text-only Buttons (Using the Hit State)................................................................................144
Animated Buttons.................................................................................................................147

Exercise 10: Adding Buttons to the Website...............................................................148
Using Sounds........................................................................................................................154

ii | Table of Contents



LESSON 7. Movie Clip Symbols...................................................................................157
Creating Movie Clip Symbols................................................................................................157
Movie Clip Symbols vs. Graphic Symbols.............................................................................158
Demo: Using a Movie Clip to Store Animation.....................................................................159
Demo: Nesting Symbols........................................................................................................162

Exercise 11: Creating Movie Clips..............................................................................163
Code Snippets in a Movie Clip..............................................................................................166

Exercise 12: Using Code to Stop the Website.............................................................172
LESSON 8. Publishing Animate Documents.................................................................175

Testing an Animate Document.............................................................................................175
Publish Settings....................................................................................................................176

Exercise 13: Publishing..............................................................................................181

Table of Contents | iii





LESSON 1
Getting Started

Topics Covered

 Getting to know the work area.

 Creating a new document.

 Using workspaces.

Working with panels

 Previewing your project.

 Publishing your project.

Introduction

Adobe Animate has an extremely powerful and flexible work environment, which we will
be exploring throughout this lesson.

❋

1.1. Reviewing the Welcome Screen

When you first open Animate, you will be taken to the following welcome screen:
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This screen gives you options to create new files fast, create or open your own files, and
learn how to use basic tools in Animate. Once you begin to use Animate, it will also give
you the option to open recent items. Feel free to experiment with the Learn menu in the
top left. It gives you access to a lot of free hands on learning opportunities:
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Before creating a new Animate file, you will need to know a few things about your audience:

What device will they be using? (A computer or mobile device?)

What size will the document be? (Are you building a 200 x 600 banner ad? Should
it fill the screen?)

In most cases, you will click HTML5 Canvas to create a new document using the default
size and settings. We will examine publish settings and options in later sections.

❋

1.2. Creating a New Document

Unless you expect to publish for an older version, you will likely select HTML5 Canvas in
order to create a new document.

1. Click the Create New button on the left side of the screen. This will open the New
Document pop-up menu.
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2. The New Document menu is laid out so you can choose the file type based on
the type of project you are working on. Since we are looking for a document without
a specific preset, select Advanced in the top right corner:

4 | LESSON 1: Getting Started

EVALUATION COPY: Not to be used in class.



3. Make sure HTML5 Canvas is selected, keep all of the default settings, and then
click Create:
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❋
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1.3. Getting to Know the Work Area

Some of the most important elements in the Animate work area are labeled on the graphic
below:

1. Menu: Main way to access features.

2. Tool Bar: Includes frequently used tools such as selection tools, drawing tools,
and text tools.
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3. Panels: Animate includes more than 20 panels that offer detailed control of objects,
animation, and more. Most are disabled until a document is open. Here are some
of the most important panels:

A. Properties: a context-based panel which that properties of any selected
object.

B. Library: a collection of reusable objects called “Symbols.”

4. Timeline: a set of layers similar to Photoshop plus frames that span time.

5. Workspace: allows for quick changes between different layout options.

6. Stage: Anything placed here will be visible in the final output. Animations might
start off stage and fly in before leaving off the other side of the Stage.

❋
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1.4. Using Workspaces

Animate comes with preset Workspaces that organize the screen automatically. Individual
designers and developers like to customize the Animate screen by moving the panels and
other screen elements to different positions. All of these Workspaces are customizable.
If you would ever like to go back to the default layout for a Workspace, select Reset.

You can even save your own favorite layouts by clicking the Save Workspace button

 under the New Workspace label.

❋
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1.5. Moving Panels

All panels can be docked in several places on the screen or they can float. Floating panels
can be dragged anywhere on the screen and will appear on top of other items. To move
a panel, left-click and drag it by its Title Tab (the name of the panel). As you drag it around
the screen, watch for a blue line that indicates where it will be docked if dropped (release
left-click to drop). When panels are docked to the screen, they can stay open at all times.
This is the case for the Properties panel in the following image:

Also, notice that the Library and the Assets panel names are located next to the
Properties panel name but they are a muted grey color. This means they are hidden.You
can open a hidden panel by clicking its name.

When collapsed, the panels become small icons (as shown below).The icon for the Color
panel is the first icon in the following screenshot:
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Single-click the small icon to temporarily open a panel; it will stay open as long as you are
using it. It will automatically close when you click away.

The following graphic shows the Color panel expanded:
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To avoid making changes to the panel accidentally, you may want to use the Lock/Unlock
feature. When a panel is locked, you cannot move it; however, it can be resized:
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❋

1.6. Demo: Changing Workspaces

Now, it is time for you to adjust your workspace. Make sure you are still in your HTML5
Canvas document. If not, create a new one.

1. Notice which Workspace is selected when you open Animate.

2. Change to any of the other workspace options and notice the location of items on
the screen.

3. Try to move one or more of the panels by dragging the panel name to another
part of the screen.

4. When you are satisfied with the location of the panels, click the top workspace
drop-down menu, name your New Workspace and then press the Save

Workspace button  to save this layout.

5. Change back to the original Workspace you selected. If you would like to go back
to the default layout of that workspace, please choose Reset from the top
workspace drop-down menu.

❋
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1.7. Opening Existing Files

You can open a Animate file by clicking File > Open. A dialog box will allow you to select
a file. The following demo is saved as GettingStarted/Demos/FirstAnimation.fla.

This demo has a simple animation in it so that we can examine a somewhat complicated
timeline.You will find that some of the layers have sections in blue. These are animations
called “Tweens,” which will be covered in a later lesson.

Keyframes are represented by either hollow or solid circles. The solid circle means that
frame has visible content. The hollow circle indicates a blank keyframe.

The red playhead shows one moment in time. By dragging the playhead, you will see what
the animation will look like when it plays. Press the Enter key (on Windows) or Return
(on a Mac) to play the timeline in place. This is called scrubbing the timeline.

❋
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1.8. Using the Properties Panel

The Properties panel shows the properties of any selected object. This includes frames
on the timeline or objects on the stage.

Identify the Properties panel and then single-click different objects to explore properties
of that object.The Properties panel is one of the most utilized and most important pieces
in the Animate interface.

❋

1.9. Undo in Animate

Animate allows you to undo even the smallest of steps. Therefore, some new Animate
users think that undo is not working properly.You might have to undo several steps to go
back far enough.

You also might want to increase the number of steps that can be undone. It is set to 100
by default, but it can be increased to 300. To increase the number of steps, Select
Edit(Windows) or Animate(Mac)  > Preferences > Edit Preferences and change the
number of document-level undo levels.
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❋

1.10. Previewing Your Movie

Sometimes looking at the Animate screen does not properly show you the real-life view
of your animation, because some animations will not play unless you are looking at a
published version.
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You can preview the published version by selecting Control > Test Movie > In Browser
(Command+Return on a Mac or Ctrl+Enter on Windows)

❋

1.11. Publishing Your Movie

When you preview your movie, a set of files is generated in the same folder as the .fla
document. There are also additional publishing options that will be covered in a later
lesson.

Select File > Publish Settings to change options like the version of the Animate player
to be used as well as many other options that will affect the final animation.
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❋
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1.12. Some Important Keyboard Shortcuts

Many Animate developers use keyboard shortcuts to optimize workflow. Keyboard shortcuts
can save you a great deal of time. More shortcuts will be introduced in later sections.

Move to a region of the stage: (Hold the space bar.Then, click and drag the Stage).

Zoom in/zoom out: (Ctrl/+ Ctrl/-).

Test movie (Ctrl+Enter).

Scrub timeline (Enter).

Undo (Control+z).

F5: Insert frames.

F6: Insert keyframe.

F7: Insert blank keyframe.

F8: Convert to symbol.

You can even create your own keyboard shortcuts by choosing Edit > Keyboard
Shortcuts.

Function Keys

Function keys are not always available on every computer. You may need to use
the menu options.
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 Exercise 1: Previewing Your Movie
 10 to 15 minutes

In this exercise, you will learn to preview a completed Animate project. In fact, this is the
project that you will build in following exercises.

In the upcoming sections of this course, you will work on many different files that relate to
a fictitious park website you have been assigned. The decision to use Animate for the site
has been made to allow you to be very creative. Also, a very interactive site for park-goers
of all ages was the desire of the client you are working for.

1. Open the file saved as GettingStarted/Solutions/Website.fla.

2. Test the movie in Animate CC by selecting Control > Test Movie > In Browser
or Ctrl+Enter (on Windows) or Command+-Return (on a Mac).

Note

If you have an HTML editor installed, your preview may load in the Editor,
then from there preview in browser. (For example, Dreamweaver may open
a page named Welcome.html; preview that from Dreamweaver

3. You will see the published file. Watch the animation and click the home button.
We will be working on the different sections of this park website throughout this
course.

Conclusion

In this lesson, you have learned:

How to get to know the work area.

How to create a new document.

How to use workspaces.

How to work with panels.

How to preview your project.

How to publish your project.
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LESSON 2
Working with Drawing Tools

Topics Covered

The Tools panel.

 Switching between drawing modes.

 Drawing tools.

 Editing the shapes.

 Using layers and layer folders to organize.

Introduction

When drawing in Animate, you will be creating vector graphics as opposed to raster
graphics (also known as bitmaps). Vector graphics use math to re-figure curves, lines,
and fills based on the size of the graphic. That means if you zoom in, or resize, it will not
lose quality. If you zoom in on a raster graphic (like a photo saved as a .jpg), it will not
look good.You will see all of the square pixels. Raster graphics do not adjust if you change
the size of the image. Many of the drawing tools in Animate are very similar to tools
popularized in other graphics programs such as Adobe Photoshop or Adobe Illustrator.
However, there are key differences that you will learn.

❋
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2.1. Using the Tools Panel

The Tools panel might be displayed as one or more columns of icons. If you do not see
the Tools panel, either change your Workspace or open the Tools panel by clicking
Window > Tools. The panel will be grayed out if a document is not open.
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In this section, you will have a chance to practice with some of the most important tools.
Of course, as the lessons progress, you will be introduced to other tools as well as the
ones covered in this section.

Relax and feel free to experiment with the drawing tools with no worries about how it looks.
Just focus on getting the feel of the tools.

 2.1.1. Rectangle Tool

With a new blank document open, select the Rectangle tool  by single-clicking it.
To draw a rectangle on the stage, left-click and drag from one corner to another, releasing
the mouse once the desired shape is achieved:
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A rectangle will appear with the two colors shown at the bottom of the Tools panel. The
Stroke Color will be the line on the outside and the Fill Color on the inside. Keep in mind
as we look at the other tools that paint always refers to fills and a pencil always refers to
the stroke.

 2.1.2. Selection Tool

The Selection Tool  is the black arrow. The Selection Tool is the most common
tool used to select any item on the stage or Timeline. Back to our example, once your
rectangle is created, single-click the Selection Tool and then single-click the edge of the
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shape, also known as the Stroke.The whole shape is selected.This is because our current

rectangle does not have a Stroke as shown by this symbol .

Click the this symbol  in the bottom left corner of your screen and select a color from
the pop-up Swatches menu:

This will be the color of your Stroke for any new shapes made. Create a new rectangle
right below the last one:
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Select the Selection Tool and click the left edge of the new rectangle. One side of the
rectangle will be selected as seen in the following graphic:
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Double-click the edge of the shape and the entire stroke will be selected. Press Esc to
deselect the Stroke.

The Selection tool can also be used to alter shapes. Roll your mouse around the edges
of your rectangle.The mouse icon changes as you pass over a corner or a straight section.
With the Rectangle deselected, click a corner and drag it. Now, click a side of the rectangle
and drag it. Did you change the rectangle? Remember, you can always Edit > Undo any
steps you wish to take back as you experiment.

 2.1.3. Strokes and Fills

The Stroke is the line on the outside of your rectangle (if you have one). The Fill (again,
if you have one) is the color on the inside. All Shapes in Animate are made up of strokes
and/or fills.The Rectangle tool can create both strokes and fills. Some tools will only create
one or the other. In order to learn about strokes and fills, you can practice with your own
rectangle drawing or you can open ours saved as DrawingTools/Demos/StrokesFills.fla:
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Try to squish or stretch the shapes by clicking and dragging on the edges. As you can
see, the fill will expand to fill the complete area inside the stroke:
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 2.1.4. Merge Mode vs. Drawing Object Mode

The previous shapes were created in Merge Mode. The name comes from the fact that
all the shapes in merge mode can merge with each other. Try it! Drag one rectangle onto
a second. Then, click a blank part of the stage (to deselect). Now move that rectangle
away. Like colors merged together and different colors chopped holes in each other!

Object Drawing Mode, on the other hand, places the stroke and fill into a special kind of
group called a Drawing Object. With the Rectangle tool selected, you can turn on Object
Drawing Mode by clicking the small circle at the bottom of the Tools panel while you
have the Rectangle tool selected:

The following demo is saved as DrawingTools/Demos/MergeModeDrawMode.fla.

Open the Properties Panel and then single-click the green circle on the left. Notice the
Properties panel shows the fill is a shape:
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Next you will single-click the green circle on the right. The Properties  panel shows the
circle is a Drawing Object. This means it will not merge with another shape. If you drag
it onto the other green circle, it will not create a hole. Notice the blue line that surrounds
it on the stage, this is an indicator of it being a Drawing Object:
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If you double-click a drawing object, everything else on the stage will be grayed out. You
will be editing the shapes that make up the drawing object.

Notice near the top of the screen that the words “Drawing Object” just appeared next to
the name of your Scene. You are now editing this object. To go back to the main stage,
click “Scene 1”.

 2.1.5. Pencil Tool

The Pencil Tool  is used to draw a stroke freehand with your mouse. It can be
difficult to accurately draw with the mouse. But, when the Pencil tool is selected, you will
see an option at the bottom of the Tools panel for straighten, smooth, or ink. These
options change how your line is drawn:
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 2.1.6. Line Tool

The Line tool  also creates a stroke. But, it creates only straight lines. Of course,
after the line is drawn you can adjust it in any way that you can adjust a stroke.

 2.1.7. The Free Transform Tool and Transform Panel

The Free Transform Tool  and the Transform panel (available under Window >
Transform) are both used to stretch, squish, rotate, or otherwise change an object shape
on the stage. With the Free Transform Tool selected, the bounding box around your
selection will have handles to drag and modify the shape.

The Transform panel is used to change dimensions numerically. For example, reduce
the width and height to 50% of the original size:
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❋

2.2. Demo: Using the Drawing Tools

In this demo, you will build a bird by using and stretching common shapes. Make sure to
check the status of your drawing tools to ensure the proper Object Drawing mode is
selected.

1. Create a new HTML5 file.

2. Start by drawing three ovals so that they overlap. One will be the head, one will
be the body, and the last will be the tail feathers. You can rotate them to get the
desired angle using the Free Transform Tool. Any unwanted lines (or strokes)
can simply be deleted by single-clicking to select and pressing the Delete key:
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3. Now, let’s try a wing. Start with a triangle that is close to the shape you would like.
You can create the triangle using the line tool. Once you have the outline, fill in

the shape with the Paint Bucket Tool :

4. To give the impression of feathers on the bottom edge of the wing, we will draw
small lines across the wing as shown below. This segments the line into smaller
pieces that can be easily manipulated:

5. Adjust the curves so that they are even and smooth. Delete any unwanted lines:

The finished version of the file is saved as DrawingTools/Solutions/Bird.fla.
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 2.2.1. Adding a Tool

There are many tools that are not accessible in the default Tool Panel. In order to access
them do the following:

1. Click the elipse  in the Tool Panel.

2. Click and hold on the Pen Tool  and drag it over to the Tool Panel. Place
it right next to the Pencil Tool:
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3. Now it will stay in your Tool Panel until you remove it.

 2.2.2. Pen Tool

Use the Pen Tool to create strokes that are Bezier curves. The Pen Tool allows you to
create complicated shapes with curves that can be modified with a great deal of control.
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Anyone familiar with the Pen Tool from Adobe Illustrator or Photoshop will feel at home.
With the Pen Tool selected, click around the outside of your desired shape everywhere
you would like a point. As you click, hold and drag the mouse. Handlebars will appear that
adjust the curve:

 2.2.3. Sub-selection Tool

The Sub-selection Tool , the white arrow, is used to adjust the points and the
handlebars. Click and hold on the Selection Tool to select the Sub-selection Tool. This
tool can be used on all stokes whether they were created with the Pen Tool or other
drawing tools. All strokes are in reality Bezier curves.

 2.2.4. Paint Bucket Tool

The Paint Bucket  adds a fill to an area enclosed inside a stroke. This stroke can
be created with any tool which creates strokes: line, pencil, pen, etc.

 2.2.5. Brush Tool

The Brush Tool  allows you to draw a fill using the fill color. The fill will not have a
stroke on the outside; you can add one if you like.

You can now choose to have the brush size change according the the zoom level. It is
helpful to draw in proportion.
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 2.2.6. Paint Brush Tool

The Paint Brush Tool , which you will need to add to the Tool Panel, brings the
enhanced capabilities of Art brushes similar to other Adobe products like Illustrator. The
Brush Library (Window > Brush Library) helps you choose a brush style to “paint” with,
using patterns and images:
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 Exercise 2: Using the Animate Drawing
Tools to Create Shapes

 20 to 25 minutes

In this exercise, you will learn to use the drawing tools to create common shapes that can
be molded and stretched to create interesting looking art, even if you are not an artist.
When completed, you will build a tree that might look like ours (shown below). Of course,
yours might turn out very differently, and that is just fine; make sure you focus on the feel
of the tools, not the final outcome.

Feel free to be creative! You may decide to use your tree in a logo you will create later:
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Drawing the Trunk

1. Create a new file by clicking Create New and then selecting Advanced Menu >
HTML5 Canvas > Create.

2. You will use the Brush Tool to draw the left and right sides of the trunk. First,

select the Brush Tool . Set the brush shape to round (  ). Select a fill
color for the trunk.We used #999900. Draw one side and then the other by clicking
and dragging the mouse. (If you do not like your shape, you can “undo” at any
time.)

3. Continue using the Brush Tool to fill in the trunk and add a few branches:
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4. Again using the Brush Tool, you could add a hole to the tree. Change the fill color
to black and draw the hole:
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5. Add additional enhancements until you are satisfied. You can add a vertical line
to show texture on the trunk.

6. One way to draw branches is to just take a green oval and mash it up into an odd
shaped blob, which will be repeated a number of times. Each of the repeated
shapes can be different shades of green, can be stretched differently, and can be
larger or smaller. Draw a green oval (like the following). We used color #006633.
Copy and paste it near the original. Change the shape of the original in any way
you like. Now, copy the new shape and paste 5 to 10 additional copies. Each one
can be changed and positioned as you desire:
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7. When completed, it might look something like this:

 E2.1. If you are done early…

Add additional trees or other objects in other parts of the stage.

Move any additional objects you create to new layers.

❋

2.3. Using Additional Tools

So far we have covered the basic tools. But, there are additional powerful tools as well.
Let’s examine them!
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 2.3.1. Using a Gradient Fill

The fills we have used so far only have solid colors. Click the fill color chip to see the
default set of colors.The bottom row has some special colors that are gradients using two
or more colors blended together to create a smooth appearance.

Select any of the gradient colors and then draw a rectangle and you will see your shape
is filled with the gradient:

These gradients are completely editable. You can even save your new gradient colors in
the Swatches panel. With one of these gradient colors selected, open the Color panel to
adjust the colors that make up the gradient.
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 2.3.2. Gradient Transform Tool

The Gradient Transform Tool  is found in the additional tools section. Add it next
to your Paint Bucket tool:

When a gradient is already present on the stage, select the Gradient Transform Tool
and click the gradient fill. You will see a set of handlebars which can be used to rotate,
squish, or move the gradient (see the following image):

 2.3.3. Using the Ink Bottle Tool

The Ink Bottle Tool  adds a stroke to an existing fill using the color in the selected
stroke area. It is accessed through the Paint Bucket Tool.
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 2.3.4. Using the Eye Dropper Tool

The Eye Dropper Tool  selects a fill or stroke color from one object then instantly
switches to either the Ink Bottle Tool or the Paint Bucket Tool to let you use that color
elsewhere.

 2.3.5. Drawing Ovals

The Oval Tool  is used to draw Ovals and Circles. For a perfect circle, hold the
Shift key while you are drawing the oval.

 2.3.6. Using Layers and Layer Folders

Layers are used to separate content from one another. Shapes can merge together or cut
holes in each other if they overlap when we are not using the Drawing Objects. This does
not happen when the shapes are on different layers, even when they are not Drawing
Objects. When creating certain types of animation, the object will need to be the only item
on a layer. For this reason, it is a good idea to get into the habit of creating many layers.
In some projects, it might make sense to create a new layer for each object. Make sure
you take the time to properly name a layer based on its use or items that make up the
layer. This will make any project much easier to edit in the future.

Layer Folders can be used to keep the timeline organized as well. In the following image,
notice that three cloud layers are grouped together in a layer folder named clouds. Click
the arrow to collapse the folder and the contents will take up less space in the timeline.
They remain individual layers and objects, just compressed in the timeline.You can open
this file in DrawingTools/Demos/LayersFolders.fla
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 2.3.7. Creating Transparencies
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The color of any stroke or fill can be made transparent. In the Colors panel beneath spots
for red, green, and blue, you can set the transparency level. This is also known as
Alpha-transparency, or simply “Alpha”.

If you had an image with a 30% transparency, it would be mostly transparent. The color
shown appears to fade the more lower your Alpha value is.

 2.3.8. Creating and Editing Text

Click the Text Tool  to add text to the stage. If you want the width of the text to be
fixed (this type of text will not grow wider, just taller as the amount of text in the shape
increases), click and drag the size of the box you would like. Otherwise, a single-click puts
the text all on one line.
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 2.3.9. Add Filters to Text

Animate text has the ability to have special effects that retain the ability to edit the text.
To apply an effect, select a text box and then check the Properties panel. Filters can only
be added to Dynamic Text. Near the bottom of the panel find the category called “Filters”.
Here you can add a Glow, Drop Shadow, Blur, Bevel, and others as well. The text now
has an effect added, but you still have the ability to change the basic text properties.
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 Exercise 3: Use the Drawing Tools to
Create a Logo

 15 to 20 minutes

In this section, you will build the logo for our Griffin Park site. Feel free to follow our
example, or create your own design.You will use this logo in later exercises:

Create Shield as Background.

1. Open the file saved as DrawingTools/Exercises/logo.fla.

2. Start by selecting the Rectangle tool. You can select any color you like for the
stroke and fill.We used #009966 for the green fill and #000000 for the black stroke.
Draw a rectangle.

3. Bend the lines or adjust the shape and color in any way you like.

4. Add text for park name.

5. Add Dropped Shadow Filter on text. (Note: Use a Dynamic Text Type.)

6. Add additional shapes or design. Be creative!

 E3.1. If you are done early…

If you like your tree from earlier, you might add it to your logo.

Add additional objects to the logo.
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Conclusion

In this lesson, you have learned:

How to use the Tools panel.

How to switch between drawing modes.

How to use drawing tools.

How to edit the shapes.

How to use layers and layer folders to organize.
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LESSON 3
Graphic Symbols and the Library

Topics Covered

The Library panel.

 Symbols.

 Importing items to the stage or library.

Introduction

In this section, we will work with graphic symbols and introduce the library. The library is
one of the basic elements of Animate movies.

❋

3.1. Working with the Library Panel

The Library Panel is utilized to store objects that can be reused throughout the movie. An
item stored in the library are considered a Symbol. The Library helps Animate keep file
size down by storing the basic information about objects in one place. When an object is
reused, known as an instance, Animate does not need to store the basics again. It only
stores what is different about the new instance of the object. Certain properties of the
instance can be changed, for example, transparency, color, size, and rotation.

Below, notice the Library is open on the right and has one Graphic Symbol, called Logo.
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❋

3.2. Working with the CC Libraries Panel

The Creative Cloud Libraries Panel helps you share assets with other products. Making
it easy to capture, manage, and reuse elements of your designs.
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To use the CC Library:

1. Open the library. Window > CC Libraries.

2. Sign in if needed.

3. Your Library may have the following categories: Color Themes, Brushes, Graphics,
Looks, and Patterns. Note: Not all of these types have a purpose in Animate and
may be gray and dimmed out.

4. Drag an item to stage to use. For example: Try any Graphics you may have.

5. Have a shape selected on stage and click a color from the Color themes to apply.

❋

3.3. About Symbols

There are three types of symbols: graphic symbols, button symbols, and movie clip symbols.
This lesson primarily covers graphic symbols.
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Symbols all have their own timelines. In fact, the timeline is one of the biggest differences
between the types. Buttons have a special timeline that reacts to the user’s mouse (when
the mouse is over, for example, formatting can be applied to create an effect). We will see
more about Buttons later.

Graphic Symbols and Movie Clip Symbols both have a layer structure and timeline that
looks like the main timeline. Movie clip timelines play independently of the main timeline,
while graphic symbols play in sync with the main timeline.That means if the main timeline
stops, any graphic symbols will stop, also.

❋

3.4. Creating Symbols

There are two ways to create symbols:

1. From existing content:You can draw the item first using the drawing tools. Select
the shape (or shapes) and select Modify > Convert Symbol.

2. From scratch: Start with a blank slate by choosing Insert > New Symbol… You
will then see a new blank timeline and set of layers to create the content.

Either way, you will need to set the name and the type. If you are converting existing
content, you can also set the registration point. That is the spot that will be treated as the
0,0 position when counting the number of pixels from the left or the top. The registration
point can help in exact placement during advanced animations. If you create a symbol
from scratch, the registration point will be visible on the stage:
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❋

3.5. Editing and Managing Symbols

There are a number of ways to edit symbols. When editing a symbol, you will see the
symbol’s name in the Edit Bar next to the name of the Scene. The two most common
techniques are:

1. Double-click the instance on the stage (or right-click and choose Edit in Place).
This way you will see the instance in context with the other objects around it. The
logo below is still stretched as it is in the instance. Click Scene 1 in the top left
corner to exit this view:
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2. Double-click the shapes next to Logo in library (or right-click and choose Edit).
The symbol will still open, but you will not see any other items on the stage. It is
the symbol alone.You will not see any effects that are on any instances surrounding
the art you are editing:
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Note

No matter how you edit the symbol. If you make changes to the symbol itself, it will
change all instances of the symbol. It is important to watch the Edit bar to know
if you are editing a symbol or the main timeline.

❋
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3.6. Duplicating Symbols

If you have the need to create a new symbol that is very similar to an existing symbol, you
will save time by duplicating the existing symbol. When you are ready to duplicate an
existing symbol, right-click in the library and select Duplicate:

❋
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3.7. Swapping Symbols

Once an instance has been placed on the stage, you might decide to replace it with another.
For example, if you are making a photo gallery, you might want the first picture to fade in
and then fade out. When the second picture fades in, you will likely want it in the exact
same spot. One way to do this is just swap one for the other.

With the original instance selected, look for the Swap button  in the Properties
panel:

❋

3.8. Changing the Size and Position of Instances

Certain changes can be made to instances on the stage that do not affect the main symbol.
You can change the size, the rotation, the tint, and the transparency level.

Start by dragging multiple instances of a symbol from the library to the stage and then
select the Free Transform Tool

. Move your mouse around the edge of the instance. You will see various mouse icons.
Experiment with the changes you can make to each instance. For example, you can stretch,
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squish, skew, and rotate the instance. None of these changes will change the main symbol.
They will only change the selected instance.The main characteristics of the symbol remain,
even when the original changes, the unique instances retain their own personality:

❋

3.9. Changing the Color Effect of Instances

You can also add a tint that will color in your instance with a solid color. The screenshot
below shows one instance has been completely covered in black at a level of 100%. Notice
the Properties Panel on the right. You can also change Brightness and Alpha
(transparency):
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❋

3.10. Demo: Creating Graphic Symbols

This demo will show how to create graphic symbols and store them in the library. When
you are done, you will have multiple instances of the paw print graphic symbol that you
might use in a later project. It might look something like this:

1. Start by opening GraphicSymbols/Demos/PawPrint.fla. On the screen, you will
find shapes that look like a paw print. (If you would prefer to draw your own paw
print or make changes to the one provided, you can do so now or later. Since it is
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about to become a symbol, it will be easy to make changes to all instances in the
future.)

2. Select all parts of the paw print. (You can do so by (1) using Shift+click to add
objects to your selection, or (2) using the selection tool (the black arrow) to draw
a big box surrounding the whole image.)

3. Select Modify > Convert  to Symbol (or press F8). Name the new symbol “Paw
Print”, select the symbol type Graphic, and set the registration point to the center:
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Function Keys

Function keys are not always available on every computer. You may need
to use the menu options.

4. Look in the library to view your new symbol:
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5. Now, drag several instances from the library to different parts of the stage. You
can change various properties of each instance. For example, Alpha (transparency)
and Tint are adjustable by adding an effect in the Properties window. Also, use
the Free Transform tool to change size, rotation, and skew:
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6. Be sure to save your file.You can decide to use your Paw Print in the next exercise.
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 Exercise 4: Create Graphic Symbols for a
Banner Ad

 20 to 30 minutes

You have been assigned to design a banner ad for the local newspaper website for our
upcoming Pet Parade in the park. The ad we purchased is 120 x 600 px (but you can
change that).

In this exercise, you will use the Paw Print symbol that you made earlier this section. (Or
you can use the one provided.)
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1. Open GraphicSymbols/Exercises/PetParade.fla. It is already sized at 120 x 600
px.

2. Open the library to see the assets your team has already assembled.You will find
the paw print, the park logo, and a number of photos sized appropriately.
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3. Take some time to plan out your ad and draw it on paper or in a Animate document.
(Or use ours as your model.) The following steps will give you some hints about
how we made ours.

4. Create a new layer and name it “Background”. Drag an instance of the paw print
to the stage. Reduce the size and make it transparent. Copy it and paste a number
of instances to make a wandering trail of footprints (or a design you like).

5. Create a new layer and name it “Heading Back”. Draw a rectangle to cover a small
portion of the top of the document. Ours has no stroke and a fill of #663333. Ours
has a width of 121 pixels and a height of 83 pixels.

6. Create a new layer and name it “Heading Text”. Add three text boxes at the top
that will say “Saturday!” and “Pet” and “Parade”. Our text is white.

7. Hint: To easily set each of the text boxes to be the exact same width, select all
three pieces of text and open the Align panel. Click Match Width and Align Left
Edge.

8. Create a new layer and name it “Photos”. Drag photos of your choice to the stage.

9. If you would like to add any effects like transparency to the photos, you must
convert them to symbols first. These effects must be added to the instances of
the symbols on the stage.

10. Create a new layer and name it logo. Add the park logo to the stage. Ours is at
the bottom.

11. Add any additional content to the ad.

12. When you are done, test the movie!

 E4.1. If you are done early…

Find additional photos to import.

Add the additional copies of the logo symbol to the background layer

❋

3.11. Import to Stage / Import to Library

It is easy to import images made in other programs to the stage or the library. Choose File
> Import > Import to Stage or Import to Library.You can import images (jpeg, gif, png),
sounds, videos, and more. All external items you import in from another source will appear
in the library; they are not Symbols automatically. You can, however, convert them to
symbols at any time.
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Animate creates a folder to store all relevant parts of animated gifs, making it easier to
keep the library organized.

❋

3.12. Open Another Document’s Library / Sharing

It is easy to move items from one library to another. When two or more documents are
open, the top of the library will show a drop-down list of document names. Select the library
that holds the items you would like to take.The Library panel will now be available to use.
Drag from the library to the stage of the new document and the item will automatically be
added to the stage and library of the new document. Even if you delete the instance from
the stage of the new document, the library will still retain the item.

You can also open the library of another document by selecting File > Import > Open
External Library.

The symbol will be copied from one file to another, but it will not remain connected to the
original. There are two ways for a symbol to remain connected to the original. Neither is
covered in this course. But, one technique is called runtime sharing. Runtime sharing
means that the symbol is updated every time you run the .swf after it is published. You
can also set the source of a symbol. This method executes before the file is published.
Both of these are set in the symbol’s Advanced Properties window.

In order to find a specific item, you can search by the symbol name.

❋

3.13. Importing Illustrator Files

When a photo is imported into Animate, it is in the form of a bitmap. Bitmaps are not very
editable.You can use the bitmap tools to edit, but the editing options are limited. Importing
an Illustrator file is another story!

All of the layers, paths, and individual objects are available and can be manipulated as
vector art.

Choose File > Import > Import to Stage or File > Import > Import to Library. Locate
the .ai file and you will see the following dialog box:
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❋
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3.14. Importing Photoshop Files

Just like importing from Illustrator, when you import a .psd into Animate, you retain many
of the key features of the .psd document. Again, you can keep all layers. You can also
create a new keyframe for each layer or even convert the .psd into a movie clip.
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 Exercise 5: Create Graphic Symbols
 10 to 15 minutes

In this exercise, you will convert three provided shapes into graphic symbols and import
a baseball from an Illustrator file:

1. Open GraphicSymbols/Exercises/Baseball.fla. Notice the layer structure.

2. Open the library. For now, it is empty. You are to select the three objects on the
stage, individually, and convert each one into a graphic symbol.

3. You are welcome to draw any of your own items and use those instead.

4. Import a baseball drawn in Illustrator. Select File > Import > Import to Library.
Browse to GraphicSymbols/Exercises/Baseball-Illustrator.ai. Leave the
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default settings on the import window and pay attention as the new item will appear
in the library.

 E5.1. If you are done early…

Draw any additional items of your own.

If you have any of your own Illustrator or Photoshop files, import them.

Conclusion

In this lesson, you have learned

How to use the Library panel.

How to create and use symbols.

How to import items to the stage or library.
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LESSON 4
Basic Animation

Topics Covered

Timelines.

 Keyframes.

 Motion Presets.

 Animating filters.

Introduction

So far, much of what we have learned could be applied to graphics programs like
Photoshop. Everything you have learned has been static. We have not yet seen any
animation.

In this lesson, you will learn the key Animate features that make it such a great animation
tool!

It can be a little intimidating to learn Animate. For most people, it is the first time working
with timeline animation. This adds a layer of complexity that still graphics do not have.
Don’t worry, if you take it step by step, you will get it.

❋

4.1. Understanding the Timeline

The timeline is a matrix of frames and layers. Think of it like a spreadsheet where A1 is
the first cell. The letter refers to the column and the number refers to the row. In Animate
it is analogous, but the columns are called frames and the rows are called layers. The
frame numbers appear across the top of the timeline and the layer names go down the
left column. The animation plays from the beginning to the end based on placement of
objects along the timeline. Code, called JavaScript or ActionScript, can alter that timeline;
this would be the trademark of a more complex animation. We will focus on a basic
left-to-right timeline animation.
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The blue playhead selects which part of the timeline is visible on the stage. Open Basi
cAnimation/Demos/FrameByFrame.fla and drag the playhead back and forth.This is called
“scrubbing” the timeline.

Keyframes are the only frames you can edit. All Keyframes have small circles on them.
Keyframes with visible content have solid circles while blank keyframes have hollow circles.

Click the several different keyframes and watch the content on the stage change.You can
hide or lock any layer by clicking the buttons that appear when you hover over the layer
name. If you want to hide, you click the eyeball and to lock you click the lock. Click the
permanently visible eyeball or lock icons directly to hide or lock all layers at once.

In Photoshop, hidden layers are not part of an exported file, but in Animate they are. Even
hidden layers will be included in the exported document (unless you change this in the
publish settings):

❋

4.2. Organizing Layers in a Timeline

When dealing with the timeline and the order of the final animation, the order of layers
matters. The higher the layer in the stack, the higher the content will appear. It is like
stacking several transparencies on an overhead projector.

One important difference between Photoshop and Animate is that in Photoshop if you click
a layer, that layer is active and selected until you select a different layer. In other words,
if you try to click content from a different layer, Photoshop will not change to the other
layer.You would have to select the layer first.
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Animate is different. When you select content on the stage, Animate will change to the
layer the item is on - unless that layer is locked, at which time you would not be able to
select the content.

It is important to minimize the number of items on each layer. Many animation types require
that only one item be on the layer in order to properly animate.

Layers should also be named appropriately as at the moment of creation, your organization
makes sense; however, 6 months from now when you need to edit a .fla file, the process
might not make sense. By taking the time to plan, organize, and name layers, you will
save yourself valuable time in the future.

❋

4.3. About Animation

The idea of timeline animation goes back to flipbooks. If you ever made a flipbook you
were doing frame-by-frame animation. Each frame appears on the screen for a fraction
of a second. Typical frame rates are from 15 to 30 frames per second. By using 15 frames
per second timing, you are making each frame visible for 1/15 of a second. Beyond about
30 frames per second, the computer cannot display more information and your eye stops
being able to see the difference.

❋

4.4. Demo: Frame-by-Frame Animation

The following demo is saved as BasicAnimation/Demos/FrameByFrame.fla. Take a look
at the timeline.You will notice two layers (named number and back) and a timeline which
spans 50 frames. Note the keyframes on the number layer:
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Drag the playhead from the beginning to end. This will give you a sense of how the movie
will play. But, did you drag too fast or too slow? How fast will the movie play? The
Properties panel shows that this movie will play at 24 frames per second. That means it
will last about 2 seconds.

If you press the Enter key (or Return on a Mac) you will see the timeline in action as
Animate moves the playhead for you.

Hide the back layer and the blue box will disappear. Hide the number layer and the numbers
will disappear.

❋

4.5. Adding Frames, Keyframes and Blank Keyframes

As mentioned earlier, only keyframes are editable. That means, when you want to build
an animation, you will need to add keyframes to the timeline at the point in time in which
you need to make an edit. There are two main ways to do this. First, you can right-click

82 | LESSON 4: Basic Animation

EVALUATION COPY: Not to be used in class.



at the junction of the layer, and frame, and then choose Keyframe from the shortcut menu.
Or, you can choose Insert > Timeline from the menus once you have pre-selected the
proper layer and frame. The following are shortcuts you can use to add different types of
frames:

Insert Frame (F5): This adds frames that extend from the previous frame to the
selected frame. It extends content on the stage, but these frames are not editable.

Insert Keyframe (F6): This adds an editable keyframe, but it also copies any
content from the previous keyframe. This is helpful in animating objects since it
gives you another instance of the object to work with.

Insert Blank Keyframe (F7): This also adds an editable keyframe, but it will be
blank.This is useful if you have ended an animation and want to start with nothing
in that frame.

Function Keys

Function keys are not always available on every computer. You may need to use
the menu options.

❋

4.6. Animating Position: Frame-by-Frame Animation

Open the following demo saved as BasicAnimation/Demos/FrameByFrame-car.fla. You
will find that a car is being animated across the screen. Every five frames or so, the car
moves farther down the road. If you scrub the playhead (or just press Enter/Return) you
will find the animation is pretty jumpy.

To make the quality of the animation better, you could add a keyframe to every frame, but
that will mean you will need to position the car in many different positions along the way,
still creating a choppy animation. It would be very difficult to position each one accurately
to create smooth motion. Luckily, Animate can help with these animations using Motion
Tweens. We will look at Motion Tweens in the next demo:
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❋

4.7. Changing the Pacing and Timing

The car takes about one second to get from the beginning to the end. This movie plays
at 12 frames per second (fps). To make the car move more slowly, we need more frames.
You could click and drag the keyframes to a later point on the timeline. This will stretch
out the length of the animation, but it will still be jumpy.

To make it less jumpy, you need not just more frames but more keyframes. This would
allow the car to move less each time, giving the illusion of a smooth transition.

❋
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4.8. Animating Transparency

Many properties can be animated! Above you saw how easy it is to animate position by
placing the object at one place in the first frame and a different place in the next keyframe.

Also, you can animate an object’s transparency, rotation, size, tints, and more. Imagine if
you set the transparency of the car to 10% in the first keyframe and then 10% higher in
each later keyframe. The car will then fade in. By changing the properties of keyframes,
you are animating!

❋

4.9. Previewing the Animation

In addition to scrubbing the timeline, another way to test the movie is to preview the HTML
and JavaScript files. This will actually publish these files to the same folder as the .fla
document.The HTML and JavaScript files are the files that will play in the internet browser.
Preview the these files by pressing Control+Enter (Command+Return on a Mac). Or,
select Control > Test Movie > In Browser.

❋

4.10. Demo: Animation with a Motion Tween

The following demo is saved as BasicAnimation/Demos/Clouds-done.fla. Take a look at
the completed version. It has a Motion Tween on the timeline. Scrub the timeline and
watch how even the cloud animation is. Also, notice the yellowish-gold section of frames
which has been added to the timeline. This yellowish-gold section is a motion tween. In
this demo, you will see how to create that Motion Tween:
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1. Close the completed file and open BasicAnimation/Demos/Clouds.fla. Examine
the existing layer structure and timeline. You will find one (locked) layer named
“ground”.

2. Add a layer and name it “clouds”.

3. Drag an instance of the clouds symbol from the Library onto your new layer in
whatever you would like to designate as the starting position. (Our example will
start on the left and move to the right.)

4. Single-click the clouds instance.

5. Select Insert > Create Motion Tween (or right-click and select Create Motion
Tween) and notice the change to the timeline. Animate just added frames on this
layer.

6. Now, drag the blue playhead to the last frame. This is where the animation ends:
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7. Move the clouds to your desired ending position:

8. This path of the animation will follow the line that appears on the stage. This line
will not appear in your finished product. You can treat this line just as you would
any other stroke.That means you can stretch or bend it in any way and the clouds
will follow that path. Each dot on the line represents a frame.You can start to see
how far your animation will move each frame:
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9. Test the movie by pressing Control+Enter (Command+Return on a Mac). Or,
select Control > Test Movie > In Browser:

10. The ground layer only appears for one frame. So, while your clouds might move,
the ground disappears after one frame. Adding frames to the ground layer will fix
this. Check how many frames were added to the clouds layer. Animate added 24
frames to ours. Since you want the ground layer to be there the whole time, so it
should have the same number of frames as the cloud layer.

11. Select the last frame on the ground layer and press F5 to Add Frames (Insert >
Timeline > Frame):
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 Exercise 6: Use Motion Tween to Animate
Airplane

 20 to 25 minutes

In this exercise, you will animate an airplane with a Motion Tween. There will be two
separate animations. The first shows the plane running along the runway. In the second,
it is taking off.

1. Open the file saved as BasicAnimation/Exercises/Airplane.fla. It is shown
below:

2. Notice that the layer structure matches the Clouds demo.

3. Add a new layer and name it “airplane”.

4. Select the new layer and open the Library. Drag an instance of an airplane onto
the first keyframe of the new layer:
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5. Single-click the airplane instance (to select it) and add a Motion Tween (by
right-clicking or choosing Insert > Motion Tween from the Menu.)

6. Animate just added the default number of frames for a new Tween (about 24).
Drag the playhead to frame 12 (or about half way to the end of the animation).
Now, position the airplane about halfway across the screen (as shown below):
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7. To complete the second part of the animation (taking off), drag the play head to
the last frame and reposition the airplane once again (see below).This time, position
the plane in the air at the end of the timeline:

92 | LESSON 4: Basic Animation

EVALUATION COPY: Not to be used in class.



8. When you run the movie, you might decide that it is moving too quickly. By adding
more frames, the animation will take more time. For layers with tweens, you can
simply drag the end of the last keyframe to some frame in the future (like frame
50). On layers without tweens, use a Control+click and then drag the end of the
last frame to a later frame:
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9. Adjust your animation until you are satisfied! Test the movie to watch your
animation.

 E6.1. If you are done early…

Pull some of the other airplanes from the Library. Practice adding multiple motion
tweens. Remember, each must be on its own layer.
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Adjust the rotation of the plane after it takes off.

❋

4.11. Using Timelines to Create Movie Structure

In the next exercise, you will build the structure of the website that you will use in several
of the upcoming lessons. So far, our movies have been very small, focusing on small
aspects of the final animation. In this section, you will see that if you make an entire website
out of Animate, the timeline will be more complicated. Instead of playing straight through
the timeline, it has certain destination keyframes that hold “pages” of content. JavaScript
will be used to build a navigation system to jump from page to page.

Open the following demo, saved as BasicAnimation/Demos/MovieStructure.fla. Test the
movie by clicking Control+Enter (Windows) or Command+Return (Mac). The project
functions like many other websites - the navigation links are used to take you to different
pages (keyframes in the timeline).

Examine the timeline and you will see four small red flags on the labels layer with the
names of the four pages: intro, home, contact, and about. This timeline works a little
differently than most we have seen so far. It does not play straight through because it has
labels at frames 10, 20, and 30 as well as code that makes the buttons when clicked stop
at these labels.

Please notice that when the movie first begins, it plays the first nine frames then stops at
frame 10. Timeline animations are still used in some sections of this project. But, some
frames act as static pages. Frame 10 is the “home” page. The buttons would have code
to jump to either home, contact, or about:
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❋

4.12. Understanding Our Project File

Now, let’s turn to the exercise file to get an idea of how this project is put together. Open
the solution to the next exercise. It is saved as BasicAnimation/Solutions/Website.fla.

First test the movie to see the final product.You will notice that several pieces of the movie
slide into position as a quick intro.We eventually want the timeline to stop once everything
is in position:
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 Exercise 7: Build Site Structure on Timeline
 20 to 30 minutes

In this exercise, you will put together an entire website for Griffin Park. We will continue
to use this site in later topics. You will have a chance to practice tweening by bringing in
the various parts of the site one at a time. Because there are no actions yet, it will just play
through and repeat. In later topics, we will add actions and buttons to allow users to control
navigation.

1. If you haven’t already done so, open and test the solution so that you can see the
animation in action. It is saved as BasicAnimation/Solutions/Website.fla.

2. Now that you’ve seen the end result, close the completed file and open BasicAni
mation/Exercises/Website.fla. You will find one layer with a simple graphic of
the sky:
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Sky Layer

3. The only layer is currently named “Layer 1”. Rename this layer “sky” since it holds
the sky graphic.

Logo Layer

4. Add a new layer and name it logo.

5. Drag an instance of the logo to the center of the stage on frame 1.

6. Use the Free Transform tool to increase the size. It should be large.

7. Add a Motion Tween (right-click or select Insert > Motion Tween).

8. Drag the end of the motion tween span to frame 39 to extend the motion.

9. Drag the playhead to the end of the motion tween. Reduce the size of the logo
and reposition it to the upper-right corner of the screen.

10. Scrub the timeline> to see your animation. The logo should decrease in size and
move into its final position.

11. If your sky layer has only one frame, it will disappear after frame 1. It will need
additional frames to match the other layer. Single-click frame 39 of the sky layer.
Press F5 to add regular frames.

12. Since the logo is in position and will not move again, we could use a single instance
of the logo in frame 40. This will be a static instance. Click frame 40 and Insert
Blank Keyframe.

13. Click frame 39 (the end of the logo animation). single-click the logo in its ending
position. Press Control+c to copy the logo.

14. Click back on the new blank keyframe in frame 40 and choose Paste in Place
(Control+Shift+v). This will place a new instance in the exact same position as
the previous frame.

15. Add enough frames to the sky layer so that it will be the background throughout
the animation.

Prepare the Text Links Layer

16. Next you will create the text (which will eventually become buttons in a later lesson).
Add a new layer and name it “Text Links”.

17. Add a new Keyframe in frame 40.
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18. Select the Text tool. Set your text properties as desired in the Properties panel.
We chose Arial, white, 21 point.

19. Create a text box and type the text “home” in frame 40 on the Text Links Layer.

20. To create the additional text links, copy and paste the home text and replace the
word “home” with “facilities,” “videos,” “photos,” and “contact”.

21. To line up the text links easily, use Shift+click to select all of the text boxes. Open
the Align panel. Unclick “align to stage” and then click Align Left Edge and
Distribute Vertical Center. This will even out the space between the text links.
(Be sure to unclick “align to stage!”)

Animate the Text Links Layer

22. Now let’s animate the text links by adding a Motion Tween. Select all of the text
links at once (in frame 40) and press F8 (or select Modify > Convert to Symbol).
Select Graphic Symbol and name it “myNavigation”.

23. In frame 40 on the text links layer, create a motion tween.

24. Drag the navigation instance in frame 40 just off the stage. This will position the
instance to slide into the screen.

25. Decide how long it should take for the text to slide in. Place your cursor in that
frame (we chose frame 60) and drag the text into the ending position.

26. Extend the other layers to the end of your animation. Ours ends in frame 60:
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Add Remaining Layers

27. We need a layer with a background for the photos fading in. There will be no
animation on this layer. Add a layer called “content back” and add a new keyframe
in frame 40. Drag an instance of the content back symbol to the new keyframe.

28. Add a layer called “photo”. Add a Keyframe in frame 40 for an instance of the
photo symbol. Add a motion tween and click the instance in frame 40. Using the
Properties panel, set the effect called “Alpha” to 0%. Then, drag the playhead to
frame 55 and change the Alpha to 100%. This will fade the photo layer in over 15
frames.

29. Add a layer called airplane. In frame 55 add a keyframe and an instance of the
airplane (Yellow Airplane with Sign) from the Library. Add a Motion Tween to
position the airplane off stage initially and fly in.

30. Add one final layer named “labels”. Add a keyframe in frame 40. Using the
Properties panel, add labels for frames 1 (logo) and 40 (intro):

31. Save your movie and test it! Does the animation behave the way you intend it to?

32. In later exercises, the website file will be used again. You will have the choice of
using yours or a version provided for you. To make it easy to find this file later,
save it in the ClassFiles folder as ClassFiles/Website.fla.

 E7.1. If you are done early…

Adjust any of your existing animations.
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Add additional objects to animate.

❋

4.13. More with Animation

Animate has added tools that help you animate with even more precision and less work!
In this section, we will look at techniques for automating and taking control of tweens.

 4.13.1. Using Motion Presets

Animate now has some pre-designed animations that can be applied to objects. These
presets were recently added to Animate and allow for quick and easy animation of objects.
Best of all, they are completely editable, so you can use them as a starter, and then modify
the motion to fit your needs.

To see a motion preset in use, open the demo saved as BasicAnimation/Demos/Motion
Presets.fla.You will find a ball bouncing in. Notice the path and timing of the bounce on
the stage. Creating this animation realistically from scratch would be quite time consuming
and difficult to maintain a smooth appearance:
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To create your own animation automatically using motion presets, follow these steps:

1. Place an instance of a Movie Clip symbol in the starting position on the stage.

2. With the Motion Presets panel open, select the instance.

3. Single-click a preset and watch the preview in the panel.

4. When you have found one you would like to try, click Apply.
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Note

Some of the presets, including the 3D presets, require that the object be
Movie Clip Symbols.

It is that easy! Depending on which preset you choose, it will add a certain number of
frames to suit the animation.You can click to add keyframes to change any position, size,
alpha, etc.You can also stretch or shrink the animation to fit your needs.

 4.13.2. Animating Filters

Filters can be added to instances of button and movie clip symbols and dynamic text
instances. The process of adding a filter is as follows: single-click the instance or
double-click the text so you can type, and then look near the bottom of the Properties
panel for the heading “Filters”:
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Click the Add Filter icon to add a filter.You can select Drop Shadow, Blur, Glow, Bevel,
Gradient Glow, Gradient Bevel, or Adjust Color:

Each of these filters has several options which can be manipulated.  And, as a bonus, if
you adjust the filter at the beginning and end of any animation, you can build an illusion
of change.The demo, which has a green pulse in and out, is saved as BasicAnimation/De
mos/Filters.fla.

 4.13.3. Animating Transformations

As you have already seen, if the artwork has different positions at both the beginning and
ending points of a Motion Tween, Animate adds the tween.This is true with transformation,
too. Use either the Free Transform tool or the Transform panel to make changes to an
object.

In the example shown below, saved as BasicAnimation/Demos/Transformation.fla, the
bike is skewed to the left slightly. By the last frame, two changes have taken place: (1) it
has skewed back a bit toward the right and (2) the size has been reduced giving it the
illusion of perspective:
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 4.13.4. Changing the Path of the Motion

Since the path of a tween is just a stroke, it can be manipulated like any other stroke. For
example, you can use the selection tool to bend the path. The following file is saved as
BasicAnimation/Demos/Transformation2.fla:
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 4.13.5. Swapping Tween Targets

If you have a tween on the stage that is already set up, you can easily change the symbol
being tweened. Just click the instance of the symbol and open the Properties panel.Then
click Swap and browse to the new symbol.

 4.13.6. Easing

Our animations so far have looked pretty good, but sometimes they can appear mechanical
and not very natural. This is because the speed of the animation is uniform throughout
the tween.

Imagine a car stopping and starting at a red light. As the car comes to a stop, it gradually
slows down. And, as it starts again, it gradually increases speed. Animate calls this easing,
objects can ease into or out of animations:
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Compare a regular tween (saved as BasicAnimation/Demos/MotionTween-car.fla) to one
with easing (saved as BasicAnimation/Demos/MotionTweenEase-car.fla).Test both.Which
looks more natural?

 4.13.7. Animating 3D Motion

Note

3D objects are only available in the traditional ActionScript 3.0 file type:
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You already know about animating in two dimensions: X and Y. Animate can also animate
the Z axis.There are two tools used specifically for 3D animation both of them are located

in the More Tools Menu. They are the 3D Rotation tool ( ) and the 3D Translation

Tool ( ). The 3D Rotation tool lets you spin the object in all 3 directions. The 3D
Translation tool slides the object to the left and right, and up and down (along the X, Y
axes) and even forward and back (along the Z axis). Translation is the term used to move
objects left, right, and forward and back in 3D.

Open the demo saved as BasicAnimation/Demos/3D-Tween.fla to work with a photo
rotating in 3D.

If you click either tool, you will see a special shape which gives you easy access to the X,
Y, Z, and X Rotation, Y Rotation and Z Rotation properties. Try them all!

Motion Editor

To fine-tune a Motion Tween, you can use the Motion Editor. To open the Motion Editor
which will appear in the timeline, double-click the Motion Tween in the timeline or right-click
it and select Refine Motion Tween:
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The tween can then be altered to fit your needs:
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 Exercise 8: Improving Motion Tweens with
Easing and Motion Presets

 15 to 25 minutes

In this exercise, you will improve the files you used in the last two exercises by adding
Motion Tweens and Easing. Or, as an alternative, create a new blank movie to practice
using the following items:

Motion Presets

Easing

The Motion Editor

Open BasicAnimation/Exercises/Airplane.fla (or the solution version saved as BasicAn
imation/Solutions/Airplane.fla) to add easing.

1. Be sure the Properties panel is open.

2. Click Frame 1 of the airplane layer to select the motion tween.

3. Open the Ease category in the Properties panel.

4. Change the value of Ease to -100.

5. Test the movie and you will see the plane speed up as it starts taking off. It will
pick up speed as it goes along.

Open BasicAnimation/Exercises/Website.fla (or the solution version of the last exercise
saved as BasicAnimation/Solutions/Website.fla) and use a Motion Preset to adjust
the animation.

1. Find the first frame of the airplane animation (frame 56). Right-click it and choose
Refine Motion Tween.

2. Click Add Ease button:
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3. Select the new Ease "Bounce in" for x:
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4. Test the movie. This ease might not be the appropriate one.

5. Change the Tween. This time add the ease called Simple (Fast).

6. Test the movie.

 E8.1. If you are done early…

Practice with additional easings.

Apply one of the Motion Presets to another existing animation.
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Conclusion

In this lesson, you have learned

How to understand and organize a Timeline.

How to animate using keyframes.

How to use Motion Presets.

How to animate filters.
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LESSON 5
Advanced Animation

Topics Covered

 Copying and pasting motion.

 Creating masks.

 Morphing and shaping tweens.

 Inverse Kinematics (IK).

Introduction

If you ask ten Animate designers to build the same file, you will likely get ten different
approaches.This is possible because Animate is very flexible and gives you many options.
Let’s take a look at some of the additional ways of working with animation.

❋

5.1. Demo: Copy and Paste Motion

In Animate movies, it is very common to repeat motion. For example, if you have a series
of text chunks that will all slide in performing the same fade in, there is no need to create
the motion several times. If you create one motion, it is easy to repeat it for the other
objects, therefore making sure they match.

Try it by opening AdvancedAnimation/Demos/Animation1.fla. Scrub the timeline to see
what is provided. Notice that there are a number of words waiting to slide in from the left
side of the screen. The word “run” is already animated. Let’s repeat that motion for the
other words:
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1. Right-click the tween on the timeline (run layer) and select Copy Motion (or select
Edit > Timeline > Copy Motion).

2. Now, select frame 1 on the layer named “with”. Again, right-click the frame and
select Paste Motion (or select Edit > Timeline > Paste Motion).

3. Scrub the timeline. Does it do what you expect?

We will work on this file further in the next section.

❋
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5.2. Demo: Creating Motion Presets

If you want to repeat a motion again and again you can store it as a Motion Preset. These
stay with the application, so you will be able to use your custom presets on other documents
in the future.

1. Either continue with your own file or open AdvancedAnimation/Demos/Anima
tion2.fla.

2. First, let’s replace the animation for the word “run” with a Motion Preset for a more
complicated animation.

3. Open the Motion Presets panel and select the tween on the run layer:

4. Apply the “fly-in blur left” preset. You will be asked whether you want to replace
the existing motion. Choose Yes:
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5. Modify the animation any way you like (for example, adjust the position at the end
of the tween stretch the animation to take more or fewer frames, adjust the path
of the animation, etc.).

6. When you are satisfied with your changes, you are ready to save it as a Motion
Preset. Right-click the timeline in the Motion Tween and select Save as Motion
Preset…:
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7. Name your preset something like “fly in words”:

8. You are now ready to apply your custom preset to the other words. Click the next
word and open the Motion Presets panel. In the Custom Presets folder you will
find your new preset!
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9. Click Apply.
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 Exercise 9: Create Photo Gallery using
Motion Presets

 20 to 30 minutes

In this exercise, you will build a photo gallery that automatically slides photos in and out.
They will also fade in as they enter and fade out as they leave:

Import and Prepare Images

1. Open the file AdvancedAnimation/Exercises/PhotoGallery.fla

2. Import several images to the Library from AdvancedAnimation/Exercis

es/galleryphotos.

3. Create a new layer and name it “Photo1”.

4. Drag an instance of one of the images to the new layer just off the stage to the
left.

5. If desired, use the Transform panel to set the height and width. (335 width works
well.)

6. Convert the image into a graphic symbol.
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7. Drag each of the photos out to the stage make any size adjustments. Convert
them each into symbols named “photo2”, “photo3”, “photo4”, etc. Once you have
created the symbols you can delete the image.1

8. Use a Motion Preset to Slide in Pictures

A. With the first photo positioned off the screen in the starting position,
single-click the photo. Open the Motion Presets panel.

B. Find fly-in-left and click Apply. It will add about 24 frames. Feel free to
adjust the end frame to locate the image where you wish it to be.

C. We want this photo to remain visible for about 1 full second and then fly
out to the right. To do this, add a Blank Keyframe in the very next frame
(frame 25).

D. Copy the photo from frame 24 (on stage) and paste it in place
(Control+Shift+V) on frame 25. The photo will stay in this location until
the next keyframe. Extend to frame 49 in needed:

9. Photo Slide-out

A. Add another keyframe in frame 50.

B. Using another motion preset, add a motion tween to slide the photo out.
This should run from frames 50 to 75.

C. Position the photo off the screen in the ending position. Adjust the Title
layer to extend to frame 75.

D. Test your movie!

1. See AdvancedAnimation/Solutions/PhotoGallery_After ImportPrep.fla for review.
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2

10. Add Additional Photos

A. To add several additional photos, you can repeat the above steps. Or,
follow this shortcut:

B. Add an additional layer. Remove any frames in the new layer.

C. Click the name of the “Photo1” layer. Choose Edit > Timeline > Copy
Frames to copy all the frames of this layer. (Lock layer to prevent
accidental edits.)

D. Click the first frame of the new layer and paste the frames (Edit > Timeline
> Paste Frames).

E. Single-click a photo on the new layer to select it. In the Properties panel,
click the Swap… button:

F. Select the next photo. Repeat for each Keyframe. Name the layer and
lock it.

11. Repeat for each image you wish to add.3

12. Finish the Animation

2. See AdvancedAnimation/Solutions/PhotoGallery_After_MotionInOut.fla for review.
3. See AdvancedAnimation/Solutions/PhotoGallery_After_AddImages.fla for review.
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So far, our photos will all slide in simultaneously. Probably not what we
want!

A.

B. To fix this, drag each of the animations farther down the timeline so that
they do not play one at a time. Remember to extend Title Layer:

C. Test your movie!4

 E9.1. If you are done early…

Add additional photos to the gallery.

Use other motion presets to change some animations

❋

5.3. Creating Masks

A mask creates a hole through which you can see the layers below. Masks in Animate
are very similar to masks in Photoshop or other graphics programs. Imagine looking through
a set of binoculars. You can only see through the lenses. As you move around, you can
see other areas. A mask works the same way.

4. See AdvancedAnimation/Solutions/PhotoGallery.fla for final review.
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Open the following example saved as AdvancedAnimation/Demos/Mask.fla:

Notice that the icons for the layers in the screenshot above are different than most layers.
The circle layer is the mask layer. Also, the masked layer (flowers) appears to be indented
as if it were in a layer folder. Any additional layers can be added to the masked section
by dragging underneath the mask layer. To remove a layer from the mask, just drag it up
or down.

Note

Please be aware that if the layers are not locked in the Animate Timeline, you will
not be able to see the mask on the stage. This phenomenon only occurs in the
Animate program, once the animation is properly previewed, or published, the mask
layers work properly.

Any layer can be turned into a mask layer.

1. Right-click the layer and select Mask.
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2. Or, select the layer and Modify > Timeline > Layer Properties). Choose Mask
then click OK:

❋
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5.4. Animating Masks

Animating a mask is no different than animating any other layer. Any object on a mask
layer can be converted into a symbol and tweened.

Open the example saved as AdvancedAnimation/Demos/Mask-Animated.fla. Scrub the
timeline and you will see the mask moves across the screen. Test the movie to see the
final product. If the animation does not render out the way you expected, please check to
make sure your layers are locked:
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❋
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5.5. Morphing with Shape Tweens

Shape Tweening morphs one shape into another. You have learned by now that Motion
Tweening must be done on instances of symbols. Shape Tweening, on the other hand,
must be done on shapes.

To create a Shape Tween, place a shape in a keyframe. Add a blank keyframe later on
the same layer with a different shape in that keyframe. Hover over the proper frame and
layer and then right-click the timeline between the two keyframes and select Shape Tween.

Open our example, saved as AdvancedAnimation/Demos/ShapeTween.fla:
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❋
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5.6. Using Shape Hints

The closer your two shapes, the easier the transition between them. If you have many
complicated shapes involved in the tween, you may end up with some odd looking shapes
in between. Shape Hints will help! Shape Hints allow you to decide how the shapes will
morph by placing hint markers at the beginning and ending shapes.

Click the first keyframe of a shape tween. Select Modify > Shape > Add Shape Hint. A
small letter will be placed on the stage. The placement of this shape is important. Place
it at a spot you want to control. Then, click the next keyframe and reposition the small
letter at the end where you wish the beginning to morph to. The hints guide the way the
shapes morph. Keep in mind, more is not always better. You will want to test after each
placement as each placement will affect the outcome.

Open our example, it is saved as AdvancedAnimation/demos/ShapeTween-hints.fla. If
your Hints are not visible, please go to View > Show Shape Hints.
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❋
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5.7. Motion with Inverse Kinematics

Animating a ball bouncing or car stopping is one thing, but what if you want to create
animation with a natural looking structure for movement - like a skeleton? Animate has
Inverse Kinematics that allow for lifelike movement of objects. You can literally create a
bone structure that spans between instances on the stage. This allows for different poses
that are animated, much like tweens are animated.

In order to use the Bone tool in this way, your objects must be symbols. (In a later section,
you will see how to use the Bone tool on Shapes.)

Open our example, saved as AdvancedAnimation/Demos/IK-demo-done.fla. Use the
selection tool to drag the pieces and watch how they move.

If you would like to try, open AdvancedAnimation/Demos/IK-demo.fla. Using the Bone tool

, which can be found in the more tools section, click, and drag from the first piece to
the second. Then, click again from the second to the third. The point you click will be the
joint:
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Above, you can see the first bone in place. Below, you can see how they move together
when dragged:
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❋

5.8. Constraining Joints

To ensure your bone structure doesn’t bend in unnatural ways, you will need to contain
the movement of some joints.Think about how an elbow works.You probably cannot bend
your elbow in all directions. It is constrained to a certain range of motion.

You can also assign constraints to any joint in the Properties panel. When you check the
constrain box, you will see a small guide that shows the angles to which motion is
constrained. Change the angle values in the Properties panel.

Click any of the bones and look in the Properties panel. You will find categories related
to the joint. Rotation is enabled by default, but uncheck the box if you do not want the joint
to rotate:
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❋

5.9. Demo: Inverse Kinematics

Let’s get some practice with IK animation!
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1. Open AdvancedAnimation/Demos/IK-runner.fla.

2. Select the Bone tool. To create a natural skeleton, start on the upper torso and
then click and drag to the head.
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3. Go back to your original starting point. Click and drag to one shoulder. Then, click
and drag from the shoulder to the elbow. Repeat for the second arm starting again
at the torso.

4. Continue adding bones. Connect the torso to the pelvis. Connect the pelvis to the
legs.

5. Once your skeleton is built, switch to the selection tool. Drag the bones and watch
the connected bones move!

6. Add additional frames. Click at some point in the future and add a pose by
reposition the figure.

7. Add several different poses and test the movie.

❋

5.10. Inverse Kinematics with Shapes

You can add similar bone structures to simple shapes. Maybe you will want a tree that
blows in the wind or a fire that flickers back and forth. Create any shape and select the
bone tool.You can click and drag within the shape to provide a structure for movement:
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The screenshot above shows a drawing of a fire. Notice that keyframes have been added
and the flames have been repositioned to provide the animation.
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Conclusion

In this lesson, you have learned:

How to copy and paste motion.

How to create masks.

How to morph with shape tweens.

How to animate with Inverse Kinematics (IK).
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LESSON 6
Button Symbols

Topics Covered

 Button symbols.

Text buttons.

 Animated buttons.

 Adding sound to a button.

Introduction

So far we have worked with only one of the three symbol types (the graphic symbol). Now,
let’s examine the Button Symbol.

❋

6.1. Creating Button Symbols

Buttons are created like any symbol.You have two options:

1. Create the content first, select the content, and choose Modify > Convert to
Symbol (F8).

2. Choose Insert > New Symbol. Then create the content.

Function Keys

Function keys are not always available on every computer. You may need to use
the menu options.

When you first create a Button Symbol, you will notice the biggest difference between it
and the Graphic Symbol is the timeline. Button Symbols have timelines, but they are
different in that rather than playing from the beginning to end, they have four special
frames: Up, Over, Down, and Hit.
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These frames allow you to specify what changes will take place as the mouse interacts
with the button. This file is saved as Buttons/Demos/Buttons.fla:

Just like any other timeline, you can only edit keyframes. Add keyframes or blank keyframes
just as you would normally. Any change that occurs between the up and down states will
appear to the user when the mouse rolls over the button. Down is what appears when the
mouse is pressed down.

The hit state is used to designate the trigger area. If you do not specify an area, all the
visible content will serve as the trigger area. You need not use the hit frame unless you
want to specify an alternate area for the trigger area. The hit state is great to use when
dealing with irregular shapes that involve transparency.

As you will see below, the hit state is commonly used with a text button.

❋

6.2. Text-only Buttons (Using the Hit State)

By default, the trigger area for the button is your content. That means, if you have small
narrow text, your user’s mouse will have to be right on the individual letters to trigger the
button.The hit state will fix this problem by allowing you to designate a bigger trigger area.
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Add a keyframe in the hit state and then draw a shape that matches your desired trigger
area. This shape will not be visible in the final product. Fill and stroke color do not matter;
however, any solid area will react as the hit area.

Open the demo saved as Buttons/Demos/TextButtons.fla. Drag the playhead to the hit
frame and you will find the shape setting the trigger area:
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❋
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6.3. Animated Buttons

The frames of a button indicate what will be visible when the mouse is over or presses
down. Any animations placed on a keyframe will run when that frame is called.

Symbols can be placed inside other symbols. Believe it or not, graphic symbols can be
placed in movie clips, which are placed in button symbols, which are placed in another
symbol!
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 Exercise 10: Adding Buttons to the Website
 20 to 30 minutes

We will continue work on the website from the earlier exercises. You can open your file
from earlier (called Website.fla). You can also use the one saved as Buttons/Exercis
es/Website.fla.

We are going to create buttons out of the navigation text. So far, the text has been sliding
in from the left into position. We want the text to be turned into buttons after it’s in position.
To do this, we will duplicate the navigation symbol and place the new duplicate on the
next frame. Follow the steps below to get it done.

Position a New Instance of the Navigation in a New Keyframe

1. In the last frame of the text links layer (frame 61), add a blank keyframe:

2. Click frame 60 in the text links layer. Single-click the navigation text symbol and
copy it (Ctrl+c will work.)

3. Click the new blank keyframe in frame 61 and paste in place (Ctrl+Shift+v). This
will paste the navigation in the exact position as the previous frame.

4. Extend all layers to frame 75:
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Duplicate the Navigation Symbol and Swap Symbol

5. Open the Library and find the navigation symbol.

6. Right-click it to duplicate the symbol. Name the new symbol “navigation buttons”.

7. Since we want the new symbol in the exact same position as the last one, we can
use Swap Symbol to replace one for the other.

8. Single-click the instance of navigation in frame 61 on the text links layer. Open
the Properties window and click the Swap Button:

9. Browse to the newly created navigation buttons. Click OK:
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Convert Text into Buttons

10. Find the new symbol called “navigation buttons” and open it.

11. Right-click the word “home” and select Convert to Symbol (or press F8). Choose
Button for the type and name it “homeBTN”.

12. Double-click the homeBTN symbol to edit. Add a new keyframe into the over
state.

13. Select the text in the over state and add change the character settings using the
Properties Inspector.You choose the options:
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14. Add a Keyframe in the down state and change the fill color to yellow:
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15. Add a Keyframe in the hit state to set the size of the clickable area of the button
by drawing a shape to fill word width and height:
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16. Now, test your movie to see if it is working.

17. Since the new buttons have been placed at the end of the timeline, they will only
appear on the screen for the length of one frame - only a small fraction of a second.

18. Add additional frames to each layer so that they all extend to frame 100:
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19. Test your movie again. If you are satisfied with the home button, repeat the above
steps for the other four buttons. Name them facilitiesBTN, photosBTN,
videosBTN, contactBTN.

 E10.1. If you are done early…

Add additional changes in the Down state.

❋

6.4. Using Sounds

Sounds can be used on the timeline just like visible content, sounds can be added to any
keyframe. These sounds will play in time with the timeline.

 6.4.1. Importing Sounds

Sounds can be imported in the same way as images, Illustrator files and other external
files. Choose File > Import > Import to Library. All imported sounds appear in the library.
You can even play the sounds there for preview purposes using the small play button in
the upper-right corner.

You can now add audio directly to the stage. File > Import > Import to Stage.
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 6.4.2. Adding Sounds to Buttons

Sounds can be added to button timelines. Notice below that a keyframe was added to the
down state and the sound is visible in that frame. For practice, add a sound to the other
two buttons. Open the following demo, saved as Buttons/Demos/Buttons_Sounds.fla:

Conclusion

In this lesson, you have learned:
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How to create button symbols.

How to create text buttons.

How to create animated buttons.

How to add sound to a button.
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LESSON 7
Movie Clip Symbols

Topics Covered

 Movie clip symbol.

 Movie clips vs. graphic symbols.

 Adding code to a movie clip.

Introduction

Movie clip symbols are one of the most important basic elements of Animate movies.
Contrary to the sound of the name, movie clips don’t necessarily have anything to do with
video. Like graphic and button symbols, they are a way to make your movie more modular.
They have their own layer structure and timeline.

Again, like the other two symbol types, you can place multiple instances on the main
timeline. All three symbol types help in keeping file size down since you can store symbols
in the library once and use multiple instances of them.

❋

7.1. Creating Movie Clip Symbols

Just like creating graphic symbols and buttons, there are two basic options for creating
movie clips:

1. From existing content:You can draw the item first using the drawing tools. Select
the shape (or shapes) and select Modify > Convert Symbol:
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2. From scratch: Start with a blank slate by choosing Insert > New Symbol. You
will then see a new blank timeline and set of layers to create the content:

Since movie clips tend to have the most complicated timelines and layer structures, you
might be more likely to create them from scratch.

❋

7.2. Movie Clip Symbols vs. Graphic Symbols

Button symbols are very different than the other symbol types in that the timeline is
simplified to 4 mouse states. Button symbols are used when you want to interact with the
user’s mouse in either an Up, Over, Down, or Hit state. The difference between graphic
symbols and movie clips is not so obvious, at first.

Movie clips have two major advantages over graphic symbols:

1. Movie clip timeline plays independently of the main timeline. This is extremely
important! It means that if the main timeline stops, the movie clip can continue to
play.

2. Movie clip instances can be controlled with code. Instances on the stage can
be given names.These names are used to control the instances with code. *Note:
Buttons also have this ability.
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Since they are more powerful, movie clips do take up a bit more memory than graphic
symbols. If you know an object will be a static, it makes sense to create a graphic symbol.
For more complicated objects, a movie clip might make sense. But even a simple object
which needs to be controlled by Code should be a movie clip.

❋

7.3. Demo: Using a Movie Clip to Store Animation

The following two demos show the difference between placing an animation on the main
timeline as compared to inside a movie clip symbol. They are saved as MovieClips/De
mos/Sun-MainTimeline.fla and MovieClips/Demos/Sun-MovieClip.fla.

Take a look at the timelines. You will find that Sun-MainTimeline.fla has a motion tween
that spans about 24 frames. But Sun-MovieClip.fla only has one frame. If you test these
movies, they appear similar. So how does the movie clip work if it has no frames? Where
is the tween?

Double-click the Sun movie clip and you will see the tween. It is nested inside the movie
clip symbol:
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Even though the main movie only has one frame, the movie clip plays and loops.

The following demo, saved as MovieClips/Demos/Sun-MovieClipVsGraphic.fla, has only
one frame on the main timeline. Compare the two and see that the sun on the left will
rotate as it is a movie clip:
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❋
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7.4. Demo: Nesting Symbols

As you can see, symbols can be nested in one another. For example, if you want animation
on a button when someone clicks, create your animation as a movie clip. Then, place an
instance of that movie clip animation in the buttons down state.

In the following demo of a bicycle, saved as MovieClips/Demos/Bike-MC.fla, you will
explore a movie clip project. Select the artwork by single-clicking the bike on the stage.
Notice that the bicycle is an instance of a graphic symbol named Bicycle. Double-click
the symbol to see its component pieces. It is made up of graphic symbols for two tires and
a frame (just like a real bicycle!).

Double-click the tire animation called Tire rotating in the Library to see the tween of the
Tire graphic. And, finally, the Tire graphic symbol is made up of the Spokes and Rims.

Remember to watch the edit bar to see which object you are editing, as shown below:
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 Exercise 11: Creating Movie Clips
 10 to 15 minutes

In this exercise, you will convert a static graphic symbol into a movie clip so that the runner
can keep running regardless of what is happening on the main stage:

1. Open MovieClips/Exercises/FunRun.fla.

2. Find the keyframe in frame 24 on the runner layer. Single-click the runner symbol
on the stage. It is currently a graphic symbol.

3. Press F8  to convert it into a new symbol. Name it “runnerMVC” and choose Movie
Clip:
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Function Keys

Function keys are not always available on every computer. You may need
to use the menu options.

4. Double-click the new movie clip symbol on the stage to edit it if you are not already
editing the clip.

5. Add a motion tween to the timeline of runner that moves the runner across the
screen toward the logo:
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6. Test the movie!

❋
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7.5. Code Snippets in a Movie Clip

Movie clips can be enhanced by using code snippets to create complimentary code for
your Animate file. Code snippets range from timeline navigation to loading and controlling
objects.You can locate snippets by selecting Window > Code Snippets:

Open the sample file MovieClips/Demos/Bike-MC_code.fla. Open the Actions Panel to
see the code that stops the motion of the bike wheels at frame 53 toward the end of the
animation:

166 | LESSON 7: Movie Clip Symbols

EVALUATION COPY: Not to be used in class.



When this is tested, the following files are generated to create the playback:
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Bike-MC_code.html (created during test: file used by the web browser to load the
movie).

Bike-MC_code.js (created during test: JavaScript code used to create actions used
by the movie).

Bike-MC_code.fla (original file: used to make changes and updates by user, only
opens in Animate).

 7.5.1. Add a Code Snippet to a Movie Clip

1. Open MovieClips/Demos/Bike-MC_code_Start.fla:
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2. Select Window > Code Snippets to open the Code Snippets panel.

3. Select the bike artwork on the stage at frame 53. Select HTML5 Canvas > Actions

> Stop a Movie Clip then Add to current frame :
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4. The code will be added to frame 53:
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5. Test movie Control > Test.

6. The bike wheels stop at the top of the hill:
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 Exercise 12: Using Code to Stop the
Website

 15 to 20 minutes

We will stop the Griffin Park website at the end using code.

Add an action to stop the movie

1. Open your website file from earlier or open the version saved as MovieClips/Ex
ercises/Website.fla.

2. Select frame 100 on the labels layer.

3. Using the code snippets for HTML5 Canvas > Timeline Navigation, place a stop
by double-clicking Stop at this Frame:
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4. A new layer named “Actions” has been added with a keyframe at frame 100:
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5. Test the movie and you will find it stops at frame 100.

Conclusion

In this lesson, you have learned:

How to create a movie clip symbol.

About the differences in movie clips vs. graphic symbols.

How to add code to a movie clip.
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LESSON 8
Publishing Animate Documents

Topics Covered

Testing an Animate document.

 Publishing settings.

Introduction

You might not know it, but you have been publishing Animate documents ever since you
tested your first movie. Publishing means creating the files that will be run by end users.
The .fla file will not be run by users. In most cases, they will be running an HTML document.
But, there are other options.

❋

8.1. Testing an Animate Document

As you know by now, to test a movie select Control > Test  or press Control+Enter (on
Windows) or Command+Return (on a Mac). This will create the .html file and place it in
the same folder as the original .fla. Be aware that if there is already an .html by that name
in the folder, it will be overwritten. For this reason, it is not a good idea to work directly on
the server when editing the .fla file. In fact, the .fla file does not even need to be uploaded
to the server. Open our saved project that is saved as Publishing/Demos/MotionTween-
car.fla:
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❋

8.2. Publish Settings

Open File > Publish Settings to modify the publish settings:
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When you click the Publish button, any format with a check mark will be created. For each
box that is checked, a tab appears with options for that format type across the top of the
window:

LESSON 8: Publishing Animate Documents | 177



By default, the first box is checked. Animate will create a .js file and an HTML document
to act as the container. Both files will be saved in the original folder with the .fla file. Or,
you can click the browse button next to the file name to change the name or location.

Different File Types Have Different Publish Settings

If you start with an ActionScript file type, you will have different Publish settings:
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Aside from the publishing options, you can also export other file formats by going to File
> Export:
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 Exercise 13: Publishing
 10 to 15 minutes

In this exercise, you will work with the publish settings and prepare the file for uploading
to the website:

LESSON 8: Publishing Animate Documents | 181



1. Open your website file from earlier or use our saved as Publishing/Solutions/Web
site.fla.

2. Test the movie.

3. Open the publish settings and create a JavaScript/HTML file.

4. Browse to the folder and view the newly published documents.

 E13.1. If you are done early…

Explore other types of output available.

Conclusion

In this lesson, you have learned:

How to test an Animate document.

How to change the publishing settings.
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