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LESSON 1
Relationships

Topics Covered

 Referential integrity.

 Relationships between tables.

Introduction

In this lesson, you will learn about referential integrity and about how to establish
relationships between tables.

❋

1.1. Review

In the introductory course, we defined a relational database as a collection of data sets
organized in multiple tables. We went on to say that each table in a relational database
has well-defined relationships with one or more other tables in the database.

We showed how to normalize data in preparation for establishing these relationships.
Open Relationships/Demos/Demo - My Music Collection.accdb to begin.

For example, suppose we start with the following unnormalized data:
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To achieve First Normal Form, we eliminate repeating groups of data by creating separate
tables for each related group of data and assigning a primary key field to each table. In
our example, we have no repeating groups, so we simply need to assign a primary key,
Recording_ID, to the Recordings table.

To achieve Second Normal Form, we eliminate redundant data by separating it into new
tables. Notice that in our example, the artist and format data repeats.We need to separate
these tables from the original Recordings table and assign a primary key to each table.

Now that the redundant data is separated out,we replace the data in the Recordings table
with foreign keys (the primary keys from the Artists and Formats).
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To achieve Third Normal Form, we remove columns in tables that don’t depend directly
on the table’s primary key. In our relatively simple data set, we don’t have any such
columns, so we can consider our data normalized to Third Normal Form.

In brief, each table in a database should have a single focus. When you notice that
secondary items in the table are repeating, it’s a signal to break the repeating topic into a
table of its own and assign it its own primary key. This primary key becomes the source
for a foreign key field in the original table. For the sake of good organization, though
optional, the primary key and foreign key should share the same name and must be of
similar data type.

After normalization, we discussed the three relationships possible between tables.

One-to-many. Table A has a one-to-many relationship with Table B if a record in
Table A can match one or more records in Table B but each record in Table B
must match only one record in Table A.

Many-to-many. Table A has a many-to-many relationship with Table B if Table A
can have one or more matches in Table B and Table B can have one or more
matches in Table A.

One-to-one. Table A has a one-to-one relationship with Table B if Table A can
have no more than one matching record in Table B and Table B can have no more
than one matching record in Table A.

To ensure data integrity it is not enough to simply acknowledge the types of relationships
that exist between tables, it is essential that we define the relationships so that they can
be enforced.

❋
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1.2. Referential Integrity

Let’s consider the recording tables again. Suppose I delete a record from the Artists table.

The result is that there are records in the Recordings table that refer to an artist record
that no longer exists. We call this sort of record an orphaned record.

Suppose instead of deleting a record from the Artists table, I change a record:

The result this time is not orphaned records, but incorrect records.
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Referential integrity ensures that orphaned records are not created and that references
are not changed arbitrarily.We can turn on referential integrity when we create relationships
between tables. When referential integrity is turned on, Access refuses to allow actions
that would compromise the integrity of the relationship.

There may be valid reasons for allowing changes to or deletions of primary keys. For these
cases, Access provides Cascade Update Related Fields and Cascade Delete Related
Records options when you enable referential integrity. Cascade Update Related Fields
updates all records that reference the affected primary key. Cascade Delete Related
Records deletes all records that reference the affected primary key.

❋

1.3. Relationships

Access provides a tool for formalizing the relationships among tables. The relationships
themselves are intrinsic to the structure of the database tables. The fact that we have
added a foreign key column to one table with data that matches (or is compatible with)
the data type of the primary key field of another table is sufficient to establish the
relationship. Access, however, provides a tool to formalize this relationship and help us
keep that relationship in mind as we work with the database.

 1.3.1. Data Types and Relationships

When you formalize the relationship by connecting a pair of fields in two tables, you must
ensure that the fields have the same data type or compatible data types. For example, if
one field stores its data as numbers and the other stores its data as text, you cannot use
the fields in a relationship.
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Significantly, autonumber fields and number fields may be compatible provided that the
field size of the number field is “long integer”. For instance, consider the My Music Collection
database. Assuming that the primary key of the Artists table, Artist_ID, is an autonumber
field, we could associate it to the Artist_ID field in the Recordings table as a foreign key
provided that the Artist_ID in the Recordings table is a long integer number field.The same
would be true for the Format_ID fields.

 1.3.2. Formalize the Relationship Between Tables

To formalize the relationship between two tables: Open Relationships/Demos/Demo - My

Music Collection - 3NF.accdb to begin.

1. Open the database. (For this demonstration, we’ll use the Demo - My Music
Collection - 3NF database.)

2. On the Database Tools tab, click Relationships.

3. The Show Table dialog box opens.
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4. On the Tables tab, highlight the tables you want to establish relationships between,
then click Add.

5. Click Close. Representations of the tables are added to the Relationships tab in
the workspace.
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6. To establish a one-to-many relationship, highlight the key field from the “one” side
of the relationship and drag and drop it onto the corresponding field in the table
on the “many” side of the relationship.

The Edit Relationships dialog box opens.

7. Mark the Enforce Referential Integrity check box. We’ll leave the Cascade
Update Related Fields and Cascade Delete Related Records check boxes
cleared.
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8. Click Create. A connector is added between the tables.

9. Repeat steps 5-7 to relate the Format_ID field in the Formats to the Format_ID
field in the Recordings table.

10. Click Save.

❋
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1.4. A Few Words about Naming Conventions

In this course we will not impose a structure on the names of our database objects. This
will make it more natural to refer to database objects in context. However, for larger or
more complex databases you will want to consider using a naming convention to help you
distinguish among objects. Using a naming convention is particularly helpful if other people
may maintain your application.

A commonly used convention for Access databases is the Leszynski/Reddick naming
convention. Briefly, this convention adds a tag in lower case letters before the object name
and omits all spaces.

ExampleTagObject Type

tblRecordingstblTable

tlkpFormatstlkpTable Lookup

qryCDRecordingsqryQuery

qappRecordingsAction Query qapp (append)

qxtb (crosstab)

qdel (delete)

qmak (make table)

qry or qsel (select)

qupd (update)

frmRecordingEntryfrmForm

sfrmCompilationssfrmSubform

rptMusicListrptReport

srptCompilationssrptSubreport

mcrAddRecordingsmcrMacro

cmdOpenRecordingsFormcmdCommand

A variant of the Leszynski/Reddick convention includes an underscore between the tag
name and the object name: tbl_Recordings.

A similar naming convention has the advantage of making it easy to distinguish among
object types like the Leszynski/Reddick convention does, but has the added benefit of
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being easier to search. By this convention we append a tag in upper case letters to the
end of the object name while omitting all spaces.

ExampleTagObject Type

RecordingsTBLTBLTable

FormatsLKUPLKUPTable Lookup

CDRecordingsQRYQRYQuery

APPEND_RecordingsQRYAction Query APPEND_ObjectNameQRY

XTAB_ObjectNameQRY

DELETE_ObjectNameQRY

MAKE_ObjectNameQRY

SELECT_ObjectNameQRY

UPDATE_ObjectNameQRY

RecordingEntryFRMFRMForm

CompilationsSFRMSFRMSubform

MusicListRPTRPTReport

CompilationsSRPTSRPTSubreport

AddRecordingsMCRMCRMacro

OpenRecordingsCMDCMDCommand

Whichever convention you choose, it is important to use it consistently across your
application.
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 Exercise 1: Creating Relationships
 15 to 45 minutes

In this exercise, you will add an Accounts table to the Bank Register database, add a field
for the foreign key to the Transactions table, and formalize the relationship between the
Accounts table and the Transactions table. Open Relationships/Exercises/Bank Regis

ter.accdb to begin.

The Accounts table will store the following information:

AccountNameAccountNumberRoutingNumberAccount_ID

Checking0064003156781125007491

Savings0064002678911125007492

All the transactions entered thus far in the database are for the checking account.
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Solution

To add the table to the database:

1. Open the database.

2. On the Create tab in the Tables group, click Table Design. A new table opens
in Design view.

3. In the Field Name column in the first row, type “Account_ID”.

4. In the Data Type column, select “AutoNumber”.

5. In the Description field, type “Record number automatically assigned by Access.”

6. In the Field Properties area on the General tab, in the Caption field, type
“Account_ID”.

7. From the Indexed drop-down list, select “Yes (No Duplicates)”.

8. In the next row of the field definition area, enter the following information for the
Routing Number field:

Field Name: RoutingNumber

Data Type: Short Text

Description: Enter the routing number for the bank.

9. In the Field Properties area on the General tab, enter values for the following
properties:

Field Size: 9

Caption: Routing Number

Required:Yes

Indexed:Yes (Duplicates OK)

10. In the next row of the field definition area, enter the following information for the
Account Number field:

Field Name: AccountNumber

Data Type: Short Text

Description: Enter the bank account number.

11. In the Field Properties area on the General tab, enter values for the following
properties:

Field Size: 12

Caption: Account Number
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Required:Yes

Indexed:Yes (Duplicates OK)

12. In the next row of the field definition area, enter the following information for the
Account Name field:

Field Name: AccountName

Data Type: Short Text

Description: Enter a name for the bank account.

13. In the Field Properties area on the General tab, enter values for the following
properties:

Field Size: 40

Caption: Account Name

14. In the field definition area, highlight the Account_ID row.

15. On the Table Tools: Design tab in the Tools group, click Primary Key.

16. Click Save. The Save As dialog box opens.

17. In the Table Name field, type “Accounts”.

LESSON 1: Relationships | 15



18. Click OK.

19. Switch to Datasheet view and add the records specified above.

20. When you finish, close the table.

To add a foreign key field to the Transactions table:

1. Open the Transactions table in Design view.

2. In the field definition area, highlight the Code row and on the Table Tools: Design
tab in the Tools group, click Insert Rows.

3. In the row you just inserted in the Field Name field, type “Account_ID”.

4. In the Data Type field, select “Number”.

5. In the Description field, type “Foreign key to Accounts table.”

6. In the Field Properties area on the General tab, enter a value for the following
property:

Caption: Account ID

7. Click Save.
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8. Switch to Datasheet view.

9. In the Account_ID column, fill in each row with “1”.

10. Switch to Design view.

11. With the Account_ID row selected in the field definition area, go to the Field
Properties area on the General tab and change the Required value to “Yes”.
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12. Click Save.You are prompted about data integrity issues.

13. Click Yes.

14. Close the Transactions table.

To formalize the relationship between the Accounts table and the Transactions table:

1. On the Database Tools tab, click Relationships. The Show Table dialog box
opens.
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2. On the Tables tab, highlight the Accounts and Transactions tables, then click Add.

3. Click Close. Representations of the tables are added to the Relationships tab in
the workspace.

4. Highlight the Account_ID field in the Accounts table and drag and drop it onto the
Account_ID field in the Transactions table.
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The Edit Relationships dialog box opens.

5. Mark the Enforce Referential Integrity check box. Also mark the Cascade Update
Related fields and the Cascade Delete Related Records check boxes.

6. Click Create. A connector is added between the tables.
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7. Click Save.

Conclusion

In this lesson, you learned:

About referential integrity.

How to establish relationships between tables.
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LESSON 2
Queries

Topics Covered

 More on Query Design view.

 Select and parameter queries.

 Logical operators.

 Action queries.

Introduction

Recall that queries are the means to describe the data that you want Access to return or
to act on. Queries help us manage data through viewing, adding, updating, and deleting.
Queries can also be used to perform calculations on data, to summarize data, and to
automate common tasks.

❋

2.1. Query Design View

Before we examine the types of queries, let’s take a closer look at the query design
interface. Open Queries/Demos/Demo - My Music Collection - sample.accdb to begin.
We are using Titles Artists Formats Query.
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The Query Design view contains two main sections.The top of the view contains the tables
and queries that you add as data sources for the query. Notice that if we previously
formalized the relationships among the tables, the relationships are indicated here too.
The bottom section is the query design grid where you add fields to the query and specify
how to select and sort the query results.

Tables in Queries

When we refer to “tables” in the context of queries, we are referring to the items
added to the top of the Query Design view. While depicted two different ways, both
the familiar row and column layout and this more compact list of fields represent the
same objects.

To add fields to the query design grid, do one of the following:

Locate the field you want to add and double-click it.

Drag and drop the field onto the query design grid.

Highlight the field and press Enter.

The query design grid has five main rows:

Field - This row shows the names of the fields you have added to the query.

Table - This row shows the names of the tables that contain the fields you have added to
the query.
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Sort - This row indicates which field(s) you are sorting on and whether the sort is
“Ascending” or “Descending”.

Show - This row contains a check box. If the check box is marked, the field appears in
your results. If the check box is cleared, the field will not appear in your results.You might
want to clear the check box if you are using a field to specify selection criteria for the query
but don’t need to see the field in the result set.

Criteria - This row is for specifying selection criteria so that you can filter the result set.
All records that satisfy all your criteria will appear in the results. Criteria can be simple
values or expressions. The operators and expressions that are valid depend on the data
type of the field. Use the or row and the rows below it if you need to specify additional
criteria.

Note

Depending on the type of query you are creating, other rows may appear in the grid.

You can move fields in the query grid to rearrange them.

To move a field:

1. Hover your mouse over the field you want to move until the cursor changes to .

2. Click to select the field.
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3. Click and drag the field to its new location. A bold separator indicates the positions
where you can place the field.

4. When you reach the desired position, release the mouse button.

If you add a field by mistake or find that you don’t need a field that you’ve added to the
query design grid, you can delete the field.

To delete a field from the grid:

1. Select the field you want to delete.

2. Press Delete or click Delete Columns.
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To format a field from the properties:

1. Select the field you want to format. General > Format is based on type of data.
You may not have any choices available in the format area

2. When the results appear, your new format is shown.

Calculated fields may be typed into the Field area. Make sure to use the proper syntax
NAME OF NEW FIELD: formula. See example below:

Formatting in the Properties Sheet will be helpful when the data is stored one way, and
yet, you need to show it with a different number format.
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❋

2.2. Review of Select Queries

At the heart of every kind of query is a select query.

Select queries can return a subset of fields from a single table or can aggregate data from
multiple tables.

To create a simple select query showing data from a single table: Open Queries/Demos/My
New Database - Start.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the table to perform the query on and click Add.

4. Click Close.
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5. In the table, double-click the field names you want to add to the query grid.

6. On the Query Tools: Design tab in the Results group, click Run. The results
display in a datasheet.
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7. Click Save.

8. In the Save As dialog box, type a name for the query and click OK.

To run a query after you’ve saved it:

1. Locate the name of the query in the Navigation pane.

2. Double-click the query name.
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To write a select query to pull together data from multiple tables: Open Queries/Demos/Demo
- My Music Collection - Start.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the tables to add to the query and click Add.

4. Click Close.
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5. In the tables, double-click the field names you want to add to the query grid.

6. On the Query Tools: Design tab in the Results group, click Run. The results
display in a datasheet.
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7. Click Save.

8. In the Save As dialog box, type a name for the query and click OK.

❋

2.3. Review of Select Queries with Criteria

You can select very precise result sets by applying selection criteria to a select query.
Selection criteria let you include or exclude data based on the requirements you specify.

To create a select query with selection criteria: Open Queries/Demos/Demo - My Music

Collection - Simple Select from Multiple Tables.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.
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3. Highlight the tables to add to the query and click Add.

4. Click Close.
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5. In the tables, double-click the field names you want to add to the query design
grid.

6. In a column for a field you want to limit results by, enter a value or expression in
the Criteria row. To enter more criteria for a single field, use the or rows below
the Criteria row. For examples of acceptable criteria, search Access help for
“examples of query criteria” and see the section on logical operators that follows
this section.
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Result Set

The result set will include records that satisfy at least one of the criteria
specified for a field. In our example, the result set will include records where
the artist name starts with “C” OR where the artist name is “Beatles”.

7. Enter criteria for other fields as desired.

Result Set

The result set will include only the records that satisfy all the columns. In our
example, the result set will include records where the artist name starts with
“C” AND the format is “Compact disc” OR records where the artist name is
“Beatles” AND the format is “Compact disc”.

8. On the Query Tools: Design tab in the Results group, click Run. The results
display in a datasheet.
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9. Click Save.

10. In the Save As dialog box, type a name for the query and click OK.

❋

2.4. Logical Operators

When specifying selection criteria, it’s not always convenient (or possible) to list all the
acceptable criteria values. Usually it’s better to write logical expressions to describe the
criteria. This is where logical operators come in. Logical operators describe how we want
our criteria evaluated. In conjunction with operators, we can use wildcard characters,
symbols such as asterisk (*) that substitute for other characters or strings of characters.

The following table lists common logical operators with examples and explains their use.

ReturnsExampleOperator

Items that start with “C”.Like C*Like

Items that end with “C”.Like *C

Items that contain “C”.Like *C*

All items except those that start with “C”.Not Like C*Not Like

All items except those that end with “C”.Not Like *C

All items except those that contain “C”.Not Like *C*

Items that are blank.Is NullIs Null

All items that are not blank.Is Not NullIs Not Null

Items that match one of the values in the
list.

In (Arizona, New Mexico,
Texas, Oklahoma)

In

Items that don’t match one of the values in
the list.

Not In (Arizona, New
Mexico, Texas, Oklahoma)

Not In

Items that fall between 200 and 400.Between 200 and 400Between and

All items that don’t fall between 200 and
400.

Not Between 200 and 400Not Between
and

Items that are less than 200.< 200<

Items that are less than or equal to 200.<= 200<=

Items that are greater than 400.> 400>

Items that are greater than or equal to 400.>= 400>=
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You can create very specific selection criteria by combining logical expressions.

❋

2.5. Parameter Queries

Suppose we want to query the recordings database by format. So, for instance, we might
want to know which recordings are MP3s or which recordings are 33s.We can accomplish
this using a parameter query. A parameter query returns the same type of information
each time, but prompts us for a particular value each time so that it knows exactly which
records to return.

To create a parameter query: Open Queries/Demos/Demo - My Music Collection - Select

Query with Criteria.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the tables to add to the query and click Add.

4. Click Close.

5. In the tables, double-click the field names you want to add to the query grid.
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6. In the Criteria row of the field you want to prompt for, type prompt text enclosed
in brackets ([]).

Note

Periods (.) and exclamation marks (!) cannot be used in prompting text.
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7. On the Query Tools: Design tab in the Show/Hide group, click Parameters. The
Query Parameters dialog box opens.

8. In the Parameter column, type the prompting phrase you used in the query design
grid without the brackets.

9. From the Data Type drop-down list, select the type of data to accept in the
prompting field.
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10. Click OK.

11. If you want to hide the prompting field from the result set, clear the corresponding
Show check box.

12. On the Query Tools: Design tab in the Results group, click Run. You are
prompted to supply a parameter.

13. Enter a valid parameter value.
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14. Click OK. The results display in a datasheet.

15. Click Save.

16. In the Save As dialog box, type a name for the query and click OK.

❋

2.6. Action Queries

Select queries are useful for pulling out subsets of data from one or more tables. Action
queries go a step further. Action queries let us do something with our data: make a new
table from it, append data from one table or query to another, update the data in a table,
or delete data from a table.

It is important to remember that an action query cannot be directly undone. For this reason,
it’s critical that you’re aware of the effects of an action query before you run it. In fact, it’s
a good practice to preview the results of your query in Datasheet view before actually
running your query to ensure that the results are what you intend. Datasheet view shows
the results without committing the action. In the demonstrations that follow, we will not
include the preview step, but anytime you’re instructed to run a query, it’s a good idea to
preview it first.

It’s also important to know that action queries do not warn you if you’ve already run them.
This is especially good to know when you’re running append and update queries. This is
another excellent reason for previewing in Datasheet view until you’re ready to perform
the query action.
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 2.6.1. Make Table Queries

A make table query is useful when you need to make a copy of part of your data or when
you need to archive data. A make table query starts with a select query.

To create a make table query: Open Queries/Demos/Demo - My Music Collection - Pa

rameter Query.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the tables to add to the query and click Add.

4. Click Close.

5. In the tables, double-click the field names you want to add to the query grid.
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6. On the Query Tools: Design tab in the Query Type group, click Make Table.
The Make Table dialog box opens.

7. In the Table Name field, type a name for the table you are creating.

8. Click OK.

9. In the Results group, click Run. Access prompts you to confirm that you want to
create the table.

10. Click Yes. The table is added to the list of tables in the Navigation pane.
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11. Click Save.

12. In the Save As dialog box, type a name for the query and click OK.

 2.6.2. Append Queries

An append query is useful when you need to add records from one table to another table.

Remember that append queries, like other action queries, don’t warn you when you try to
run them a second time. Running an append query twice would append the same data to
a table twice. To avoid the database cleanup this would necessitate, remember that you
can always preview the data in Datasheet view until you are ready to actually perform the
action.
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To create an append query: Open Queries/Demos/My New Database - Append Query -

Start.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the table with the records you want to append to another table and click
Add.

4. Click Close.

5. Double-click the fields you want to add to the query.
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6. On the Query Tools: Design tab in the Results group, click Run.

7. Inspect the results to ensure that the records returned are the records you intend
to append.

8. Click Save.

9. In the Save As dialog box, type a name for the query and click OK.

10. Switch to Design view.

11. On the Query Tools: Design tab in the Query Type group, click Append. The
Append dialog box opens.
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12. From the Table Name drop-down list, select the table to append the records to.

13. Click OK. You are returned to the query window in Design view. Notice that the
Show row has been replaced with the Append To row.

14. In the Append To row for each field, select the field in the destination table that
corresponds to the field in the query. Access tries to match up similarly named
fields for you if it can.
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15. When you finish, click Run. Access prompts you to confirm that you want to append
the rows to the table.

Reminder

This is a good place to preview in Datasheet view until you are confident that
the query will yield the results that you expect.

16. Click Yes. Be careful to run an append query only once. Running the query multiple
times will result in the same records being appended multiple times.

17. Open the table that you appended the records to and view your results.
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18. Switch back to the query and click Save.

Notice that the records we added do not have all the fields that the Contacts table has.
As long as there are no required fields, this does not usually pose a problem.

Notice also the contents of the Cell column did not come through as we would have hoped.
The Contacts table has a mask on the Cell field and a 10-character limit. In general, before
we append records we should ensure the compatibility of the fields we match up.

Find Duplicates Queries

Suppose another user entered data in our database and inadvertently entered several
duplicate records in the TitlesWithArtistsAndFormats table. We can use a find duplicates
query to locate the extra records and clean them up.

To create a find duplicates query: Open Queries/Demos/Demo - My Music Collection -

Find Duplicates Query - Start.accdb to begin.
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1. Open the database.

2. On the Create tab in the Queries group, click Query Wizard. The Query Wizard
starts.

3. In the list box, select “Find Duplicates Query Wizard”.

4. Click OK. The Find Duplicates Query Wizard starts.

5. In the list box, select “Table:Titles-Artists-Formats”.

6. Click Next >.
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7. Click >> to move all fields from the Available fields list box to the Duplicate-value
fields list box.

8. Click Next >.

9. Name the query.

52 | LESSON 2: Queries

EVALUATION COPY: Not to be used in class.



10. Click Finish. The duplicated records load in Datasheet view.

11. Use the information from the table to determine which records need to be deleted
from the original table.

 2.6.3. Update Queries

An update query provides a quick way to change the data in existing records. It’s similar
to the Find and Replace feature except it doesn’t require (or allow) your intervention.

Remember that update queries, like other action queries, don’t warn you when you try to
run them a second time. Running an update query twice could have unintended
consequences. For example, if you’re updating a numeric field to increase all values by
20%, running the update twice would result in an increase of more than 40%. To avoid
the database cleanup this would necessitate, remember that you can always preview the
data in Datasheet view until you are ready to actually perform the action.

To create an update query: Open Queries/Demos/My New Database - Update Query -

Start.accdb to begin.

LESSON 2: Queries | 53



1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the table to add to the query.

4. Click Add.

5. Click Close.
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6. Double-click the field(s) you want to update to add them to the query design grid.

7. On the Query Tools: Design tab in the Query Type group, click Update. Notice
that the Show row is removed and replaced by an Update To row.

LESSON 2: Queries | 55



8. In the Update To row, for each field you need to change, type the new value.

9. Specify criteria for which records to change if you do not want to change all records.
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10. Click Save.

11. In the Save As dialog box, type a name for the query and click OK.

Tip

If you are creating the update query for one-time use only, it is not necessary
to save it.

12. On the Query Tools: Design tab in the Results group, click Run. You are
prompted to confirm that you want to update the records.

13. Click Yes.

14. Open the table you updated records for and confirm the updates.
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 2.6.4. Delete Queries

A delete query lets you remove records from a table. If you have any doubt about the
effects of running a delete query, it’s a good idea to back up your database before
proceeding.

Let’s use a delete query to remove the records we appended to the Contacts table.

To create a delete query: Open Queries/Demos/My New Database - Delete Query -

Start.accdb to begin.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design. The Show Table
dialog box opens.

3. Highlight the table(s) to add to the query.
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4. Click Add.

5. Click Close.

6. In the table, double-click the field(s) you want to use as criteria for choosing the
records to delete.
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7. On the Query Tools: Design tab in the Query Type group, click Delete.

8. In the Criteria row in the query design grid, type the values you want to delete.

9. Click Save.

10. In the Save As dialog box, type a name for the query and click OK.
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Tip

If you are creating the delete query for one-time use only, it is not necessary
to save it.

11. On the Query Tools: Design tab in the Results group, click Run. Access prompts
you to confirm your action and warns you that it cannot be undone.

12. Click Yes.

13. Open the table you deleted records from and confirm the deletion.

 2.6.5. Creating Crosstab Queries

To analyze data, summarizing by column and row in order to make sense of large amounts
of information. Open Queries/Demos/Demo - My Music Collection - Start.accdb to
begin.
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1.

Create Tab > Query Wizard.

2.

Choose Crosstab Query Wizard to start the process. Click OK.
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3.

Choose the Query or Table to use as the source. Click Next.

4.

Choose the row headings field source. Click Next.
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5.

Choose the column headings field source. Click Next.

6.

Choose the calculated field and the function to use. Click Next.
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7.

Name the crosstab query. Choose to view or modify the query. Click Finish.

8.

Your query results will look similar to the above example.

 2.6.6. Delete a Query

Once a query has served its purpose, you may want to delete the query. Do make sure
that you confirm that the query is no longer being used, or you may damage the database.
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1.

Right-click the query that you wish to delete. Choose Delete.

2.

The warning above will need to be confirmed in order to complete the process.
Once you do confirm the message, there will be no way to recover the lost data.

 2.6.7. Rename a Query

Queries may be renamed by right mouse clicking upon an existing query. Be cautious
when renaming the query because objects that had required it may then not respond and
this will cause an error.
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1.

Right-click upon the query you want to rename.

2.

Type the new name. Hit the Enter key.

3.

The new name is now available.
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 Exercise 2: Creating Select and Action
Queries

 15 to 25 minutes

In this exercise, you will create a table of uncleared transactions (using an Action Query)
for the Bank Register database from the ClassFiles\Queries\Exercises folder. Name the
new table “Uncleared Transactions”.
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Solution

First, we will create a select query to select the uncleared transactions and then we’ll
change it to a make table query.

1. Open the database.

2. On the Create tab in the Queries group, click Query Design.

3. In the Show Table dialog box, highlight “Transactions”.

4. Click Add.

5. Click Close.

6. In the table, double-click * to add all fields in the table to the query.
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Hint: Double-clicking * is a quick way to add all the fields in a table to your
query.You can still add a field from the table to use as selection criteria, just
make sure to clear the field’s Show check box so that the field doesn’t appear
twice in your results.

7. In the table, locate and double-click the Cleared field to add it to the query design
grid.
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8. Clear the check box in the Show row for the Cleared field. (We don’t want the
Cleared field to appear twice in our table.)

9. In the Criteria row for the Cleared field, type “False”. (We want the table to show
only transactions that are not cleared.)
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10. On the Query Tools: Design tab in the Results group, click Run.

11. View your results.

12. Switch back to Design view.

13. On the Query Tools: Design tab in the Query Type group, click Make Table.

14. In the Make Table dialog box in the Table Name field, type “Uncleared
Transactions”.
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15. Click OK.

16. On the Query Tools: Design tab in the Results group, click Run. Access prompts
you to confirm your action.

17. Click Yes. The table is added to the list in the Navigation pane.

18. Open the table and view your results.

19. Return to the query and click Save.

20. In the Save As dialog box, type a name for the query and click OK.
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 Exercise 3: Creating a Parameter Query
 20 to 45 minutes

In this exercise, you will create a parameter query on the Transactions table that prompts
for a range of transaction dates. Return all transaction details. Use the Between and logical
operator. Continue using the Bank Register database from the ClassFiles\Queries\Exer
cises folder.
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Solution

To create the parameter query:

1. Open the database.

2. On the Create tab in the Queries group, click Query Design.

3. In the Show Table dialog box, highlight “Transactions”.

4. Click Add.

5. Click Close.

6. In the Transactions table, double-click * to add all fields in the table to the query.
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7. In the Transactions table, locate and double-click the TransDate field to add it to
the query design grid.

8. Clear the Show check box for the TransDate field.
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9. In the Criteria row of the TransDate field, type “Between [What begin date?] and
[What end date?]” (don’t include the quotes).

10. On the Query Tools: Design tab in the Show/Hide group, click Parameters.

11. In the first row in the Parameter field, type “What begin date?”.

12. From the Data Type drop-down list, select “Date With Time”.

13. In the second row in the Parameter field, type “What end date?”.

14. From the Data Type drop-down list, select “Date With Time”.
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15. Click OK.

16. On the Query Tools: Designtab in the Results group, click Run.You are prompted
to supply a parameter.

17. Enter a date.

18. Click OK.You are prompted to supply a second parameter.

19. Enter a date.
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20. Click OK. The results display in a datasheet.

21. Click Save.

22. In the Save As dialog box, type a name for the query and click OK.

Conclusion

In this lesson, you learned:

About select and action queries.

About logical operators.

How to create and run select, parameter, make table, append, update, and delete
queries.
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LESSON 3
Table Functions

Topics Covered

 Importing from Excel.

 Exporting to Excel.

Introduction

In this lesson, you will learn how to import data from an Excel spreadsheet into an Access
database, and how to export data from an Access database to an Excel spreadsheet.

❋

3.1. Importing Data

Suppose you have data in a spreadsheet that you want to add to a table in your database.
How can you add it to your database without re-keying it? Well, as long as you can put
the data into a form that Access can understand, you can import the data into your
database. In particular, you can import data from another Access database, from Excel,
from SQL Server, from a text file, or from XML.

In this lesson, we’ll look at how to import data from an Excel spreadsheet. Files are found
in Tables_Advanced/Demos/ folder.

For this example, we’ll import data from an Excel file called Music Listing.xlsx. The
content of this file looks like this:
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We’ll append the records to the Titles-Artists-Formats table.

Before we import the data, we need to ensure that the table we’re importing from is set
up appropriately. Here are a few things to keep in mind:

1. Access cannot skip rows and columns during import, so we need to eliminate any
rows and columns that we don’t want to import or that don’t exist in the destination
table.
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2. Make sure there are no blank cells in the table, or if there are, that the destination
table accepts null values (missing or unknown values) in the corresponding field(s).
A field can accept null values if it is not a required field and its validation rules do
not prohibit null values.

3. Make sure there are no error values (#NUM and #DIV) in the import table.

4. Ensure that the fields in the import table are compatible with the fields in the
destination table. For example, importing text into a number field is not advised if
there are any non-numeric entries in the import field.

5. The table should be closed before importing it.

Once your source data is ready, you can import the records to the Access table. To do
so: Files are found in Tables_Advanced/Demos/Demo - My Music Collection -

Start.accdb folder.

1. Open the database.

2. On the External Data tab in the Import & Link group, click New Data Source >
From File > Excel. The Get External Data - Excel Spreadsheet wizard starts.
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3. Click Browse and navigate to the location of the file that contains the items you
want to import.

4. Highlight the file name and click Open.

5. At the Specify how and where you want to store the data in the current
database prompt, select Append a copy of the records to the table.

6. From the drop-down list, select the table to append the records to.
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7. Click OK.You may get a warning. Click Open.

8. The Import Spreadsheet Wizard starts.
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9. Click Next >.

10. Click Finish.You are prompted whether to save the import steps for reuse.
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11. Click Close.

12. Open the table you imported the records into to see your results.
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❋

3.2. Linking Tables from External Sources

Using External Data > Import & Link > New Data Source > From Database > Access
you may link tables from an external location making it easy to tie databases together,
saving you the time and possible errors in double entry. The goal should always be enter
the data once, and link/reuse whenever possible. Continue using the existing database,
new files are found in Tables_Advanced/Demos/My New Database - Simple Select.accdb.
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Link table wizard
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Choose the items you wish to link, and click OK.

You will be prompted as to the status, if there were errors, go back and double check you
choices.

Note

When the original table data is updated, your linked copies will also update.

❋

3.3. Import Tables from other Databases

When you need to move an entire copy of the table, and not have it look back and update
from the original, you should choose to Import.
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Import table wizard
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Choose the items you wish to import, and click OK.

You will be prompted as to the status, if there were errors, go back and double check you
choices.

❋

3.4. Tables from Templates and Application Parts

Creation of new tables does not always have to start from scratch, or an import from an
existing Access database. We can use Templates or whole databases, and Application
Parts for form and table objects.Your choices will differ as to what has been made available
to you by your installation. Below are some of the basic choices that are normally available.
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These items may be customized and formatted as per usual. They just give you a head
start.

1. Open the database that needs a new table.

2. Create > Application Parts > Contacts.
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3. The appropriate Tables, Queries, Forms and Reports have now been added.
Saving you the time of creating each one. They may be opened in Design View
and edited individually.

94 | LESSON 3: Table Functions

EVALUATION COPY: Not to be used in class.



 Exercise 4: Importing Data from Excel
 15 to 25 minutes

In this exercise, you will import transactions from a spreadsheet called Checking
Transactions.xlsx into the Transactions table of the Bank Register database found in the
ClassFiles/Tables_Advanced/Exercises folder. Files are found in Tables_Advanced/Exer
cises/Bank Register.accdb.

The spreadsheet contains the following records: Files are found in Tables_Advanced/Exer
cises/Checking Transactions.accdb.
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Solution

1. Ensure that Checking Transactions.xlsx is closed.

2. Open the database.

3. On the Import & Link group, click New Data Source > From File > Excel.

4. Click Browse and navigate to the location of Checking Transactions.xlsx.

5. Highlight the file name and click Open.

6. Select Append a copy of the records to the table and then select “Transactions”
from the drop-down list.

7. Click OK.
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8. Click Next >.
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9. Click Finish.You are prompted whether to save the import steps for reuse.

10. Click Close.

11. Open the Transactions table to see your results.

❋
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3.5. Exporting Data

In the introductory course, we mentioned that an advantage of Excel over Access is Excel’s
rich reporting and charting capabilities. Access’s export feature lets us take advantage of
this feature by making it easy to put our data in Excel format.

To export data from an Access table or query to an Excel worksheet: Files are found in
Tables_Advanced/Demos/Demo - My Music Collection - Exporting Data.accdb folder.

1. Open the database.

2. Open the table or query with the data you want to export.

3. On the External Data tab in the Export group, click Excel. The Export - Excel
Spreadsheet wizard starts.
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4. If you need to change the saving location, click Browse. The File Save dialog
opens.
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5. Navigate to the location where you want to save the file, enter a name in the File
name field, and click Save.

6. If you want to save in a different format than the default, select the format from
the File format drop-down list.

7. Mark the Export data with formatting and layout check box.

8. Mark the Open the destination file after the export operation is complete
check box.
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9. If you choose a name already used, you may receive an additional step. If so ,
click Yes to overwrite file, or No to get a chance to rename.

10. Click OK. The new workbook opens.
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11. Back in Access, you are prompted whether to save the export steps.

12. Click Close.
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 Exercise 5: Exporting Data to Excel
 10 to 20 minutes

In this exercise, you will export the data in the Transactions table of the Bank Register
database found in the ClassFiles/Tables_Advanced/Exercises folder to an Excel file
named Current Transactions.xlsx.
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Solution

1. Open the database.

2. Open the Transactions table in Datasheet view. On the External Data tab in the
Export group, click Excel.

3. Click Browse.

4. Navigate to your ClassFiles/Tables_Advanced/Exercises folder.

5. In the File name field, type “My Current Transactions.xlsx”.
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6. Click Save.

7. In the File format field, ensure that “Excel Workbook (*.xlsx)” is selected.

8. Mark the Export data with formatting and layout check box.

9. Mark the Open the destination file after the export operation is complete
check box.

10. Click OK. The new workbook opens.
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11. Back in Access, you are prompted whether to save the export steps.

12. Click Close.

Conclusion

In this lesson, you learned:

How to import data from Excel.

How to export data to Excel.
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LESSON 4
Forms

Topics Covered

 Parts of a form.

 Adding a logo and title to a form.

 Form fields.

 Form controls.

Introduction

In this lesson, you will learn about the parts of a form, how to add a logo and title to a form,
to work with form fields, and about the different controls that are available for forms.

❋

4.1. Design View

Creating a form in Design view gives you maximum control over your form’s presentation
and behavior. In this lesson, we will start with a blank slate. Start by opening Forms_Ad
vanced/Demos/Demo - My Music Collection - Start.accdb.

To start a form in Design view, go to the Create tab in the Forms group and click Form
Design. A blank form design tab opens on the work surface.
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Name and save the form. For our demo database, we’ll name the form “Music Collection”.

Next, we need to give our form a record source. To do this, we’ll create a query.

1. On the Create tab in the Queries group, click Query Design.

2. In the Show Table dialog box, add the Recording Formats, Artists, and Recordings
and then click Close.

3. In the Recordings table, double-click “Title”.

4. In the Artists table, double-click “Artist”.

5. In the Recording Formats, double-click “Format” and “Description”.
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6. Run the query.

7. Save the query as “Recording Details”.

8. Return to the form in Design view.

9. To associate the query with the form, right-click in the design surface and select
Form Properties from the shortcut menu.

10. On the All tab from the Record Source drop-down list, select “Recording Details”
or you may use a query we created named “Titles-Artist-Formats”.
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11. Close the property sheet.

 4.1.1. Form Sections

Forms have three main sections: header, detail, and footer. Only the detail section is
required to create a form.

Header

If you include the optional header section, it is visible for every record.The header section
is often used to add a logo or title to the form. The header and footer are paired, so when
you add one to the form, you add them both.

Detail

The detail section contains the data entry controls of the form. The values in the detail
section change as you move from record to record.

Footer

If you include the optional footer section, it is visible for every record.
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 4.1.2. Adding a Header and Footer

To add header and footer sections to a form:

1. Display the form in Design view.

2. Right-click the design surface and select Form Header/Footer from the shortcut
menu.

The header and footer sections are added to the design surface.
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 4.1.3. Adding a Logo to the Header

To add a logo to the header of the form:

1. Resize the header section as needed to accommodate the logo. To do so, hover
your mouse over the lower edge of the header section until the cursor changes to

. Click and drag until the header is an appropriate size and then release the
mouse button.
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2. On the Form Design Tools: Design tab in the Header/Footer group, click Logo.
The Insert Picture dialog box opens.

3. Navigate to and select the logo file.

4. Click OK. The logo is added to the header area.
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5. If necessary, click and drag the lower-right corner of the image container to resize
the logo.

6. If you want to move the logo to a different position in the header, hover over the

image until the cursor changes to  and then click and drag the logo to its new
position.

7. To preview the logo, switch to Form view.

 4.1.4. Adding a Title to the Header

To add a title to the header:
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1. In Design view, on the Form Design Tools: Design tab in the Header/Footer
group, click Title. A text box is added to the header section.

2. Type the title for the form.

3. If you want to change the font, font size, font color, etc., of the title, select the Form
Design Tools: Format tab and make your selections.

4. Return to the Form Design Tools: Design tab and then switch to Form view to
preview your results.
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 4.1.5. Adding Fields to a Form

Next, we’ll add fields to the design surface. We will add only the fields that our users need
to interact with or need to view as they input data.

To add fields to the form:

1. Switch to Design view.

2. On the Form Design Tools: Design tab in the Tools group, click Add Existing
Fields. The Field List pane opens.

3. Double-click a field name to add the field to the design surface. Notice that both
a field label and a data entry field are added to the design surface.
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4. Repeat step 3 for all the fields you need to add to the form.
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 4.1.6. Arranging Fields on a Form

As you can tell, Access adds the fields in the order you selected them and stacks them.
Presumably you want your form to have a little more visual appeal, so you’ll want to move
the fields about and resize them.

To move a field and its label together:

1. Click the label and then press Ctrl and click the field. Both the label and field will
be outlined in orange.
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2. Hover your mouse pointer over either of the objects until the cursor changes to 
and then click and drag the objects to their new location and release the mouse
button.
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To move objects separately:

1. Click the object you want to move.

2. Hover over the handle in the object’s upper left corner until the cursor changes to

 and then click and drag the object to its new position.

To resize objects independently:

1. Click the object you want to resize to select it.
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2. Hover over the object at one of the sizing handles until the icon changes to .
There are sizing handles (the squares on the orange outline of the object) on all
four sides and on three of the corners.

3. Click and drag to the desired size.

You can also resize multiple objects simultaneously, either fields and their labels, multiple
fields, multiple labels, or multiple fields and labels.

To resize multiple objects:

1. Select the objects to resize by pressing and holding Ctrl while clicking each object.

2. Hover over a sizing handle on any one of the objects until the icon changes to .

3. Click and drag to the desired size.

 4.1.7. Spacing Objects on a Form

You can control the alignment and spacing between objects on a form to give the form
balance and a professional polish.

To align objects on a form:

1. Select the objects you want to align.You can Ctrl+click to select objects or, if the
objects are contiguous, you can click and drag a rectangle around the objects.
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2. Select the Form Design Tools: Arrange tab.

3. In the Sizing & Ordering group, click Align.

4. From the drop-down menu, select the appropriate alignment.

The fields align according to the orientation you selected.

To space the controls evenly on the form:

1. Select the controls you want to evenly space.
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2. In the Sizing & Ordering group, click Size/Space.

3. From the drop-down menu, select an appropriate option in the Spacing section
of the menu.

The space between the selected objects adjusts according to your selection.

You can also resize the form itself if it is too large or too small for its objects.

To make the form shorter or longer:
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1. Hover over the lower edge of the detail section until the cursor changes to .

2. Click and drag the edge up or down to resize the form vertically.
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To make the form narrower or wider:

1. Hover over the right edge of the form (any section will do) until the cursor changes
to 

2. Click and drag the edge to the left or right to resize the form horizontally.
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You cannot resize the form narrower than the right end of its rightmost object.
If an object is preventing you from resizing to the desired width, resize that
object first.

❋

4.2. Formatting

You can apply formatting such as font styles, background colors, and text justification to
objects on the form. Formatting options are found on the Form Design Tools: Format
tab. To apply formatting, select the objects that you want to apply a particular type of
formatting to and select the formatting from the ribbon.

For example, to make the labels on a form bold:

1. Select the labels.
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2. Click .

Instead of formatting each item individually, you may apply a Theme. A Theme includes
the overall design, colors, and fonts. They may be created, saved and therefore reused.
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❋

4.3. Tab Order and Properties

As a courtesy to your users (and yourself), it’s important to set the tab order on your form
so that users progress through the screen in a logical way. Access does its best to guess
the tab order and also provides an Auto Order feature that sets the order for you.

To set the tab order on a form:

1. On the Form Design Tools: Design tab in the Tools group, click Tab Order. The
Tab Order dialog box opens.

2. In the Section list box, select the section of the form that you need to set the tab
order on.

3. In the Custom Order list box, highlight a field in a position that you need to change.
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4. Click the selector to the left of the selected field and drag the field to its new position
in the tab order.

5. Release the mouse button.
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6. Repeat steps 3-5 until you achieve the desired order.

7. When you finish, click OK.

 4.3.1. Setting Properties on a Form

We’ve barely scratched the surface of the items that can be managed on a form. To see
all the properties that we can work with, we need to refer to the property sheets for the
form, for the sections of the form, and for every object on a form.

The property sheets present all the available properties on one tab and also divide the
properties up by category.

Form Property Sheet

To view the property sheet for the form, right-click anywhere in the form and select Form
Properties from the shortcut menu.
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To set a special order upon the form loading, use the Order By property. Type the field
name then use ASC or DESC to set the order.
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Section Property Sheet

To view the property sheet for a particular section of a form, right-click in that section and
select Properties from the shortcut menu.

Object Property Sheet

To view the property sheet for any object on the form, right-click the object and select
Properties from the shortcut menu.
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 4.3.2. Controls

Access provides a variety of controls that you can use to customize your form. To view
the list of available controls, on the Form Design Tools: Design tab in the Controls
group, click the drop-down arrow to reveal the full list.
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DescriptionControl

Text box

Label

Button

Tab control

Hyperlink

Web browser control

Navigation control

Option group

Insert page break

Combo box

Chart

Line

Toggle button

List box

Rectangle

Check box
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DescriptionControl

Unbound object frame

Attachment

Option button

Subform/subreport

Bound object frame

Image

Chart

Let’s change a text box on our form to a combo box. This will allow users to select an item
from a list of items or to enter a new item.

1. Open the form in Design view.

2. Select the text box you want to change to a combo box.

3. Right-click and select Change To > Combo Box from the shortcut menu.
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4. If the property sheet for the Format field is not showing, right-click in the Format
field and select Properties from the shortcut menu.

5. Select the Data tab on the property sheet.
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6. In the Row Source field, click . The Query Builder starts.
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7. In the Show Table dialog box, select the table that will serve as the source of the
data in the field and click Add.

8. Click Close.

9. Add the field that you want to use to provide the data for the field you are editing
by double-clicking it.

10. Save the query.
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11. Click Close. Notice that a SQL SELECT statement is added to the Row Source
field.

12. In the Limit to List field, select “No”. This will allow users to select from the list
but still be able to enter their own value if they do not find an appropriate value in
the list.

13. In the Allow Value List Edits field, select “No”. This will prevent users from
changing the values already in the list.
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14. Preview your form in Form view. Notice when you click the drop-down list you just
created, that the values appear in the list.
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Creation of new forms does not always have to start from scratch, or an import from an
existing Access database. We can use Application Parts for form objects. Your choices
will differ as to what has been made available to you by your installation. Below are some
of the basic choices that are normally available. These items may be customized and
formatted as per usual. They just give you a head start.

❋

4.4. Create Forms with Application Parts

Application Parts provide quick starts to basic forms. Customization is still available with
no limits.

1.

Create > Application Parts > Choose a part.
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2.

Double-click the new form object to open it.

3.

You may now use the form or edit any aspects.

❋

4.5. Creating a Subform

When you want to show a One-to-Many type of data, you may use a Subform to represent
the Many side of the Main forms topic. Start by working in Design View, and choose
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Design > Controls > Controls > Subform/Subreport. Start by opening Forms_Advanced/De
mos/Demo - My Music Collection - SubForm.accdb.

Draw in the subform and wait for the wizard to appear.
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If you do not get a wizard, you may need to make sure it is active.

If you get a warning, Click Open.

Choose to use an existing object. Click Next.
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Choose the object and the individual fields from that object. Click Next.

Choose the connection to use as the link between records. If you do not have a connection,
note that Access may either have an error, or show all the the subform source for each
record. It is best to have a link on order to maintain the One-to-Many relationship. Click
Next.

148 | LESSON 4: Forms

EVALUATION COPY: Not to be used in class.



Name the subform. Click Finish.

Your subform is now ready to format, edit, adjust upon the main form. They are easy to
customize and adjust as any other form. The main difference is that it pulls related data
into the main form for display.
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This is how your form may look. Notice that we see only the titles related to artist number
1.
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 Exercise 6: Creating Forms
 25 to 60 minutes

In this exercise, you will create a form called “Enter Transactions” from the Transactions
table of the Bank Register database.You can find the database in the ClassFiles\Forms_Ad
vanced\Exercises folder.

1. Create a query with the following fields: Credit, Account_ID, Code, TransDate,
Description, Amount, Memo, Cleared, and AccountNumber. Name the query “Bank
Transactions”.

2. Change the background color of the form.

3. Inasmuch as possible, lay out the form like a check. Resize the fields as needed.

4. Change the font on all objects to Arial 10.

5. Change the labels to bold.

6. Change the label on the Description field to “Payee or Description”. Change the
label on the Code field to “ID”.

7. Replace the Account ID field with the AccountNumber field from the Accounts
table.

8. Change the Account field to a combo box with the account numbers in the
drop-down list. Limit the list to the account numbers already in the list and default
to the checking account number.

9. Change the Code field to a combo box with a lookup.

10. Set the tab order.

LESSON 4: Forms | 151



Solution

To create the query:

1. Open the database.

2. On the Create tab in the Queries group, click Query Design.

3. In the Show Table dialog box, double-click “Transactions” and “Accounts” and
then click Add.

4. Click Close.

5. In the Transactions table, double-click to add the Credit, Account_ID, Code,
TransDate, Description, Amount, Memo, and Cleared fields to the query design
grid.

6. In the Accounts table, double-click to add the AccountNumber field to the query
design grid.
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7. Run the query.

8. Save the query as "Bank Transactions".

9. Close the query.

To create the form:

1. On the Create tab in the Forms group, click Form Design.
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2. Save the form as "Enter Transactions".

3. Right-click the design surface and select Form Properties.

4. From the Record Source drop-down list, select the Bank Transactions query.

5. Close the property sheet.
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6. On the Form Design Tools: Design tab in the Tools group, click Add Existing
Fields.

7. Double-click "Account_ID“, ”Code“, ”Credit“, ”TransDate“, ”Description“,
”Amount“, ”Memo“, and ”Cleared" to add the fields to the form design surface.

8. Close the field list.

9. To change the background color of the detail section, right-click in the Detail section
and select Properties from the drop-down menu.
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10. In the Back Color field, click . The color palette opens.
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11. Select a color for the background.

12. Close the property sheet.
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13. Drag the fields to the desired positions on the form.

14. Consider moving the labels closer to the data entry fields.

15. Lengthen and shorten fields as needed.

16. Use the alignment tools as needed.

17. Preview the form in Form view occasionally to admire your results. (Your results
may vary from the example.)
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18. In Design view, click and drag the bottom and right sides of the form to resize it.
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19. To set the font and font size, select all the objects in the form. (You can use Ctrl+A
to do this.)

20. On the Form Design Tools: Format tab in the Font group, select “Arial” and “10”.

21. Select each of the labels.You will probably need to use Ctrl+click to select them
all.
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22. In the Font group, click .
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23. To change the label on the Description field, right-click the label and select
Properties from the shortcut menu.

24. On the Format tab in the Caption field, type “Payee or Description”.

25. Select the Code label on the design surface. Notice that the property sheet changes
to the sheet for the Code label.

26. In the Caption field, type “ID”.
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27. Close the property sheet.

28. Preview your form in Form view. Notice that the entire “Payee or Description” label
does not show and there’s a bigger gap now between the ID label and its field
object.
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29. Tweak the layout to show the complete labels and to improve spacing.
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30. To remove the Account_ID field, select the label and field objects and press
Delete.

31. To add the AccountNumber field, on the Form Design Tools: Design tab in the
Tools group, click Add Existing Fields.

32. In the Field List, double-click AccountNumber. The field is added on the design
surface.

33. Close the field list.
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34. Move the AccountNumber field to the desired location and tweak as needed. (Don’t
forget to make the label bold.)

35. To change the AccountNumber field to a combo box, in Design view select the
AccountNumber field object, right-click, and select Change To > Combo Box
from the shortcut menu.

36. With the AccountNumber field object still selected, click Property Sheet.

37. Select the Data tab.

38. In the Row Source field, click . The Query Builder opens.
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39. Highlight "Accounts" in the Show Table dialog box and click Add.

40. Click Close.

41. In the table, double-click AccountNumber to add the field to the query.

42. Click Close > Close.

43. In the property sheet, in the Limit to List field, select “Yes”.

44. In the Allow Value List Edits field, select “No”.

45. In the Default Value field, type “006400315678”. (This is not a very robust way
to handle the default value. Account numbers can change, so it would be better
to make the default value depend on the Account ID which should never change.)
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46. Close the property sheet.

47. Right-click the Code field object and select Change To > Combo Box.

48. In the ribbon, click Property Sheet.

49. This time, we’ll create a value list for users to select from. We’ll make the list
available to users, but give them the ability to enter other values. From the Row
Source Type drop-down list, select “Value List”.

50. In the Row Source field, click . The Edit List Items dialog box opens.
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51. Type values in the dialog box, putting each entry on a separate line.

52. When you finish, click OK.
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53. Close the property sheet.

54. On the Form Design Tools: Design tab in the Tools group, click Tab Order.

55. Drag the items in the tab order to the desired positions.
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56. When you finish, click OK.

57. Preview your form in Form view.
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❋

4.6. Alter a Form

Forms may be altered in a variety of ways that can help you to customize any process.

 4.6.1. Delete Forms

Once a form has served its purpose, you will want to delete it in order to keep your database
efficient.
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1.

Right-click the form you want to delete, be aware that if the form is being used by
other objects, the deletion process may cause issues.

2.

Confirm the action.

 4.6.2. Remove Form Controls

Controls may need to be removed from the various sections of the form. When doing this,
the data will not be affected, and the control may be added back at any time.
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1.

Select the control to remove. Tap the Delete key.

2.

The control is removed.
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 4.6.3. Format a Form

There are many options available on the three tabs.

Format Print Layouts

Forms may be printed at anytime. To view and adjust the layout, choose File > Print.

1.

File > Print.
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2.

Print Preview.

3.

The Print Preview Ribbon provides many choices in how the form will be printed.

Change Margins

Margins can affect how much of the form will fit on a single page.
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Insert Backgrounds and Images

Images may help convey a message. By branding a set of forms with a logo or image will
help to categorize and maintain a uniform look.

1.

Format > Background Image >Browse...

2.

Choose the proper image.
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3.

The image is now placed in the center of the form.

Conclusion

In this lesson, you learned:

About the parts of a form.

How to add objects to a form.

How to add, move, format, and order fields on a form.

About the controls available for forms.

To work with form properties, section properties, and object properties.
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LESSON 5
Reports

Topics Covered

 Creating reports in Design view.

 Report sections.

 Report fields.

 Moving, resizing, and formatting report objects.

 Manipulating headers and footers.

 Grouping and sorting report records.

 Property sheets.

Introduction

In this lesson, you will learn to create reports in Design view. In doing so, you will learn
about the sections of a report, to add fields to a report, to move, resize, and format the
objects on a report, to manipulate the page header/footer, the report header/footer, and
group headers/footers, to group and sort records, and to work with report, section, and
object property sheets.

❋

5.1. Design View

Many of the techniques we learned in the forms lesson will apply as we learn to design
reports. In particular, the methods for moving, resizing, and formatting objects are identical.

As with forms, Design view gives you the maximum control over the aesthetics and
performance of your reports. Files are located Reports_Advanced/Demos/Demo - My Music

Collection - Start.accdb.

To start a report in Design view, go to the Create tab in the Reports group and click
Report Design. A blank design tab opens on the work surface.
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Name and save the form. (We’ll name the report “Music List”.)

Next, we need to give our report a record source. To do this we’ll use the “Record Details”
query that we created in the forms lesson.

1. To associate the query with the report, right-click in the design surface and select
Report Properties from the shortcut menu.

2. From the Record Source drop-down list, select “Recording Details”.
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3. Close the property sheet.

Note

You may make a copy of a report that you have made, assuming you like the layout
and formatting and then change the source as a shortcut way to reuse existing
reports. If you have different field names, those will need to be added, modified, or
deleted in the report to match the new source.

❋

5.2. Report Sections

Reports have three standard sections: page header, detail, and page footer. In addition,
you can add group header/footer and report header/footer sections.

 5.2.1. Report Header

If you include the optional report header section, it is visible on the first page of the report
only. You can use it for report information that only needs to appear once on the report
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such as a logo, title, and date. The report header and footer are paired, so when you add
one to the form, you add them both.

 5.2.2. Page Header

The page header section appears at the top of each page of the report. For a tabular
report, the page header is a good place for column headings.

 5.2.3. Group Header

If you group the data in your report, Access adds a group header section that is visible
before each new grouping on the report. You can use it to print the group name for each
grouping on the report. There can be multiple group headers on the report depending on
how many grouping levels you include.

 5.2.4. Detail

The detail section contains one record for each row in the record set. This is the main
section of the report.

 5.2.5. Group Footer

If you include group totals on a report, the group footer section appears at the end of each
grouping on the report. The group footer typically shows summary information for each
group. There can be multiple group footers on a report depending on how many grouping
levels you include.

 5.2.6. Page Footer

The page footer appears at the bottom of each page of a report. The page footer usually
contains page numbers.

 5.2.7. Report Footer

If you include the optional report footer section, it appears once at the end of the report.
The report footer contains summary information for the entire report. For example, the
report footer might be used to show report grand totals.
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 5.2.8. Adding a Report Header/Footer

To add report header/footer sections to a report:

1. Display the report in Design view.

2. Right-click the design surface and select Report Header/Footer from the shortcut
menu.

The report header and footer are added to the design surface.

 5.2.9. Adding a Logo to the Report Header

To add a logo to the report header:

1. Resize the header section as needed to accommodate the logo.
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2. On the Report Design Tools: Design tab in the Header/Footer group, click Logo.

3. Navigate to and select the logo file.

4. Click OK. The logo is added to the report header area.

5. Move and resize the logo as needed.
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6. Switch to Print Preview to preview the logo.

7. When you finish, click Close Print Preview.

 5.2.10. Adding a Title to the Report Header

To add a title to the report header:

1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Title.

2. Type the title for the report.
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3. Go to the Report Design Tools: Format tab and make any formatting changes
you want.

4. Return to the Report Deesign Tools: Design tab, then switch to Print Preview
to preview the report.

5. When you finish previewing the report, click Close Print Preview.

 5.2.11. Adding Fields to a Report

Next, we’ll add some content to the report by adding fields to the design surface.

To add fields to the report:
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1. On the Report Design Tools: Design tab in the Tools group, click Add Existing
Fields.

2. In the Field List pane, double-click the field names you need to add them to the
design surface.

 5.2.12. Add Calculated Fields

When the data you need is not directly available in the field list, then you must create a
calculated field (formula) to display the data wanted. Continue using the file Reports_Ad
vanced/Demos/Demo - My Music Collection - Start.accdb.
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1. Open RPT_Contacts in Design View. Insert a Text Box for the Calculated Field.
Design > Controls > Text Box.

2. Enter the formula into the Data Tab > Control Source area.

3. The finished report may look similar to this.

❋
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5.3. Arranging Fields on a Report

As with forms, Access adds the fields in the order you selected them and stacks them.
For this report, we want a tabular layout, so we’ll adjust the layout accordingly.

The same techniques for moving and resizing fields on a form apply to reports. This time,
however, we’re going to stack the labels on top of their corresponding fields.

If needed, remember to use the Report Design Tools: Arrange tab to apply alignment
and spacing to the report objects.

Use the Report Design Tools: Format tab to apply formatting to the report objects.

Preview your work as necessary to ensure you are achieving the results you want.

❋
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5.4. Resizing the Detail Section

When you previewed the report, you may have noticed that the report is displaying one
record per page. The Detail section needs to be only as tall as the height of one record
plus any spacing you want to allow between records. For this reason, we need to resize
the height of the Detail section.

When we preview the report now, we see that there are multiple records per page.

To create multiple columns in a report, you may choose Page Setup > Page Layout >
Columns. Choose the proper settings, and click OK.
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 5.4.1. Eliminating Repeating Headings

You may have noticed that the labels in our example repeat for every record. That’s
because the labels are included in the Detail section of the report.

We can move the labels to the Page Header if we want them to print just once at the top
of every page of detail.

To do so:

1. In Design view, select all the labels.

2. Press CTRL + X (Cut).
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3. Paste CTRL + V the fields in the Page Header and resize the Detail section to
account for the extra space caused by deleting the labels. Double-Click Title lable
and type “Song Title”.

4. To add a new item - On the Report Design Tools: Design tab in the Controls

group, click . The cursor changes to .

5. In the Page Header, click and drag a rectangle above the first field to create a
label.

6. In the label, type the text you want to appear above the corresponding detail
column.

7. Keep in mind the Cut and Paste method is much faster!.

8. After you add the labels you need, tweak the sizing and placement as needed.
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Some Tips

1. You can move selected objects by small increments by pressing Ctrl
and the arrow on your keyboard that corresponds to the direction
you want to move.

2. You can resize selected objects by small increments by pressing
Shift and the arrow on your keyboard that corresponds to the
direction in which you want to resize.

3. You can use the Size/Space options on the REPORT DESIGN
TOOLS: ARRANGE tab to quickly equalize the size of several
objects. For instance, if you want to make all the labels the same
height as the shortest label, you would select Size/Space > To
Shortest from the menu.

9. Perform any formatting changes you want to make to the labels.

10. When you finish, preview your results.

 5.4.2. Set Margins

Margins will affect the amount of information that will be displayed in the printed page.
Page Setup > Page Size > Margins.

LESSON 5: Reports | 193



❋

5.5. Grouping and Sorting

You can control how the information on the report is grouped and how data within those
groups is sorted.

First, you can sort without grouping. To do so:

1. On the Report Design Tools: Design tab in the Grouping & Totals group, click
Group & Sort. The Group, Sort, and Total pane appears at the bottom of the
window.
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2. Click Add a sort. A list of fields you can sort by displays.

3. Select a field to sort by.

4. Preview the report. Notice that the report is sorted alphabetically by the column
you selected.
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To group and sort the report:

1. In Design view, clear the sorting you just applied by clicking  at the end of the
Sort by line in the Group, Sort, and Total pane.

2. Click Add a group.

3. From the drop-down list, select the field to group by.

4. Preview the report. Notice how the report is grouped.
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5. Back in Design view, notice that Access has added a group header section (called
“Format Header” in our example). This is causing gaps between the groupings in
the report. If we don’t want to include a group heading, we can resize the group
header so that it doesn’t take up any space. However, let’s add a label that shows
the group name instead.

6. On the Report Design Tools: Design tab in the Controls group, click . The

cursor changes to .

7. Click and drag a rectangle in the group header section. This is the text box we will
use to add the group names.
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8. The text box has a label with it that we will not need. Click the left side of the text
box to select it. (It may be a bit difficult to find.)

9. Press Delete.

10. Notice that the text box is labeled “Unbound”. This means there is no data tied to
the text box at this time. For our example, we want to bind the text box to the
Format Description field.

11. Right-click the text box and select Properties from the shortcut menu.The property
sheet for the text box opens.

12. On the Data tab, from the Control Source drop-down list, select the field to bind
to the text box.
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13. Close the property sheet.

14. Preview the report. Notice that each group now starts with a group name.

15. Format the text box and resize the group header section to achieve the look you
desire.
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16. Now, to sort the data within each group, go to the Group, Sort, and Total pane
and click Add a sort.

17. From the drop-down list, select the field to sort by.

18. If you want to sort by a second field, click Add a sort again and select another
field.

19. Preview your report. Notice the grouping and sorting.

200 | LESSON 5: Reports

EVALUATION COPY: Not to be used in class.



❋

5.6. Setting Properties on a Report

As with forms, we’ve hardly made a dent in the number of items that can be managed on
a report. To see all the available properties, we can refer to the property sheets for the
report, the report sections, and the individual objects on the report.

The property sheets for reports are laid out the same as those for forms.

 5.6.1. Report Property Sheet

To view the property sheet for the report, right-click anywhere in the report design surface
and select Report Properties from the shortcut menu.
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 5.6.2. Section Property Sheet

To view the property sheet for a particular section of a report, right-click in that section
and select Properties from the shortcut menu.
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 5.6.3. Object Property Sheet

To view the property sheet for any object on the report, right-click the object and select
Properties from the shortcut menu.
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One property that you may find useful on reports is the Can Grow property. When applied
to a text object that represents a field with values of variable length, Can Grow expands
the vertical space that a value displays in if it would otherwise be cut off.

To demonstrate the Can Grow property, we’ll temporarily shorten the Title field object.

204 | LESSON 5: Reports

EVALUATION COPY: Not to be used in class.



To apply the Can Grow property:

1. In Design view, select the field object you want to apply the Can Grow property
to.

2. If it’s not currently showing, open the property sheet for the field object.

3. Select the Format tab.

4. If necessary, scroll down to find the Can Grow field and select “Yes” from the
drop-down list.

5. Preview the report.
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A helpful characteristic of property sheets is the ability to select multiple objects and then
to view and change the properties that the objects have in common.

To demonstrate how to use the multiple selection property sheets, let’s remove the borders
around the data on the report.

To do so:

1. In Design view, select the objects you want to remove the borders from.
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2. On the Report Design Tools: Design tab in the Tools group, click Property
Sheet.

3. Select the Format tab.

4. From the Border Style drop-down list, select “Transparent”.

5. Preview your report.

While we’re at it, let’s remove the shading too.
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The shading in our example occurs in two places, the group header section and the detail
section.

To remove the shading:

1. Select the group header and open its property sheet.

2. Select the Format tab.

3. From the Alternate Back Color drop-down list, select “No Color”.

4. Repeat this procedure for the Detail section.

5. When you finish, preview the report.
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 5.6.4. Adding Record Counts

Access can show us the number of records in a group and the total number of records on
our report. To accomplish this, we use the Totals feature.

To show record counts on the report:

1. In Design view, on the Report Design Tools: Design tab in the Grouping &
Totals group, click Group & Sort to open the Group, Sort, and Total pane.

2. In the Group on line, click More.

3. Click the with no totals drop-down list.
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4. From the Type drop-down list, select “Count Records”.

5. Mark the Show Grand Total check box.

6. Mark the Show subtotal in group footer check box.

Notice that a group footer is added to the report design and that Count fields have
been added in the group footer and report footer.

7. Preview the report.
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We have totals now, but they look a little stark without labels to identify them. We’ll go
ahead and add labels and tweak the formatting.

To add labels to the Count fields:

1. Right-click the Count field and select Set Caption from the shortcut menu.

2. Resize the label as needed.

3. Change the label text to describe the totals.
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4. Preview the report.

Suppose we want to customize our group total labels to indicate what is in each group.
We can do that using a text box and a simple expression.

To customize the group label:

1. Select the label in the group footer, right-click, and select Change To > Text Box
from the shortcut menu.
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2. In the ribbon, click Property Sheet.

3. In the property sheet, select the Data tab.

4. From the Control Source drop-down list, select the field with the values you want
to build the label around.

5. Move the cursor in front of the field name in the Control Source field and type
“=”, then in quotes type any text you want to precede the field name. If you need
to include a space after, you can enclose that in the same quotes.

6. Type a “+”.
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7. Move the cursor after the field name, type “+” and then type any text you need to
follow the field name. Put quotes around the text you type and include spaces
inside the quotes as needed.

We have created a simple expression that concatenates (combines) text and a
field to make a custom label.

8. Preview your report.

9. Notice that the new labels are enclosed in those pesky borders, so clean those
up if desired and make any other tweaks you want to the formatting.

❋
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5.7. Special Report Fields

Access includes a couple of built-in report fields for standard report formatting: dates and
page numbering.

 5.7.1. Dates

To insert a date in your report to indicate when the report was produced:

1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Date and Time. The Date and Time dialog box opens.

2. Select the date style you want, decide if you want to include the time and, if so,
the style you want, and click OK. The date field is inserted in the header of your
report.
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3. Move, resize, and format the date field and other fields as desired.

4. Preview your report.

 5.7.2. Page Numbering

To insert page numbers in the page header or footer of your report:

1. In Design view, on the Report Design Tools: Design tab in the Header/Footer
group, click Page Numbers. The Page Numbers dialog box opens.
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2. Select the format, position, and alignment of page numbers for your report. If you
don’t want to see the page number on the first page of the report, clear the Show
Number on First Page check box.

3. Click OK. The page number is inserted into the page at the position you selected.

4. Preview the report.
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5. Move, resize, and format the page number as desired.

❋

5.8. Controls

The controls available on a report are the same as those available for forms minus the
Web Browser Control and the Navigation Control.

We’ll demonstrate using a couple of these controls in our report. First, we’ll add a line to
improve the layout of our report, then we’ll insert a page break.

Let’s add a line below the group header to set off each of the groups in the report.

To add a line:

1. In Design view, enlarge the group header section a bit.

2. On the Report Design Tools: Design tab in the Controls group, open the

drop-down list and click . The cursor changes to .
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3. Click and drag a line below the group label from near the left edge of the report
to near the right edge.You can press Shift while you’re drawing the line to ensure
that it is straight.

4. Preview the report.

5. Tweak the size of the group header and the position of the group header label to
achieve the desired effect.
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Suppose we want the report to start a new page each time a new group section starts. To
do that, we can insert a page break in the group footer.

To insert a page break:

1. In Design view, on the Report Design Tools: Design tab in the Controls group,

click . The icon changes to .

2. Click in the group footer below the Count field. A page break marker is added on
the left.

3. Preview the report.

Due to the short length of our report, we’ll remove the page breaks for now. To do so,
return to Design view, highlight the page break marker, and press Delete.
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 5.8.1. Printing a Report

After we’ve got our report with the information we want on it, in the format we want, we
can print it. To prepare for printing, we need to ensure that the printable page is set up to
our satisfaction.

Setting Page Layout

To access page setup options, go to the Report Design Tools: Page Setup tab.

The ribbon presents most of the page setup options individually, but if we click Page Setup,
we’ll find all the options collected in one place.

Margins may be altered to suite your needs.

You can also choose Page Orientation and general paper size. These settings remain
with the report.
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Since these settings should be familiar to you, we’ll not discuss them at length here.

After you have the page set up as desired, preview the report in Print Preview mode, then
on the Print Preview tab, click Print.

Notice on the Print Preview tab that you can also output your report to a variety of other
formats including .xls, .txt, .pdf, .xps, .rtf, .html, and email.

❋

5.9. Subreports

Many times it would be helpful to show a table of data that is either related to or not related
to the main report. Files are located Reports_Advanced/Demos/Demo - My Music Collection

- Grouping and Sorting.accdb. We may use a subreport to achieve this. Design >
Controls > Controls > Subform/Subreport.
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Draw the report object in the proper section. For example, if we want the subreport at the
bottom of each page, use the Page Footer area.

A wizard should present itself, assuming they are activated, to lead you through the
remaining choices. Choose to use an existing object. Click Next.
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Choose the fields from the source you wish to show. Keep in mind if it will be related, you
should be aware of your table relationships such as the Primary and Foreign keys which
connect the data. Click Next.

Choose a connection, if you want to show all of the data, then choose None. Click OK.
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Name your subreport. Click OK.

Your report may look like this.
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❋

5.10. Application Parts

Creation of reports may be started by using any existing reports in the Application Parts.
Many of the reports are bundled with other objects such as tables to store the data, and
forms to enter the data.These may be customized and changed as needed once they are
created.
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❋

5.11. Deleting a Report

When a report is no longer needed, you may delete it by right mouse clicking a report
name and choosing Delete.
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❋

5.12. Formatting a Report

Using the Ribbon, or the Property Sheet, most aspects of the report can be altered.
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 5.12.1. Adding a Background and Images and Applying a Theme

Themes allow an efficient way to develop a consistent color through out the report.

1. Click Design > Themes > Colors.

2. Choose a theme that you wish to use. Click it to apply.

Images create an easy way to brand a set of reports to a corporate identity.

1. Click Format > Background > Background Image > Browse.
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2. Choose the proper picture. Click OK.

3. The picture is now placed behind the report objects as a background.
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 Exercise 7: Creating Reports
 25 to 45 minutes

In this exercise, you will create a report of transactions from the Bank Register database.
Use the database found in the ClassFiles/Reports_Advanced/Exercises folder as a starting
point.

1. Create a query based on the Transactions table that shows uncleared checking
account transactions. Name the query “Uncleared Checking Transactions”.

2. Create a tabular report based on the Uncleared Checking Transactions query.
The report should have the following characteristics:

A. Add the following title to the report: “Uncleared Bank Transactions”. Add
a date field in the report header.

B. Show the following fields: TransDate, Code, Description, and Amount.

C. Group the records on the report by credits and debits and sort them first
by date, then by description.

D. Label the credits group “Credits” and the debits group “Debits”. (This will
require you to build an expression. Hint: Research the “IIf” function.) Put
a line under the group labels.

E. Show a subtotal for each group. Label the subtotals “Total Credits” and
“Total Debits”.

F. Show a report total. Label the total “Grand Total”. Add a line above the
label.

G. Add page numbers at the bottom right.

H. Tweak the formatting as you like.
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Solution

To create the query:

1. On the Create tab in the Queries group, click Query Design.

2. In the Show Table dialog box, select “Transactions” and click Add.

3. Click Close.

4. In the Transactions table, double-click to add the Account_ID, TransDate, Code,
Description, Amount, Credit, and Cleared fields to the query design grid.
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5. In the Account_ID column in the Criteria row, type “1”. (The checking account’s
record ID is “1”.)

6. In the Cleared column in the Criteria row, type “False”.

7. Run the query.

8. Save the query as “Uncleared Checking Transactions”.

9. Close the query.

To create the report:
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1. On the Create tab in the Reports group, click Blank Report.

2. Switch to Design view.

3. Right-click in the design surface and select Report Properties.

4. Select the Data tab.

5. From the Record Source drop-down list, select the Uncleared Checking
Transactions query.

6. Close the property sheet.

7. On the Report Design Tools: Design tab in the Header/Footer group, click Title.

8. Type the title for the report: “Uncleared Bank Transactions”.

9. In the Header/Footer group, click Date and Time.

10. In the Date and Time dialog box, select options for the date and time, then click
OK.

11. Format the title and date as desired.

12. On the Report Design Tools: Design tab in the Tools group, click Add Existing
Fields.
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13. In the Field List pane, in the Transactions list, double-click “TransDate”, “Code”,
“Description”, and “Amount”.
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14. Select all the field labels and press Delete. Note:You may also use the shortcut
of Cut and Paste.

15. Arrange the fields across the top of the detail section. Resize the fields relative to
the data that each contains.

16. Reduce the height of the detail section.
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17. Add labels for each of the fields in the Page Header section using the label control.

18. Resize, align, and format the labels.

19. While we’re tweaking the formatting, remove the field borders and the alternate
row shading. To do so:

A. Select the labels in the page header and the fields in the detail section.

B. Open the property sheet.

C. Select the Format tab.

D. From the Border Style drop-down list, select “Transparent”.

E. Click in the Credit Header section.

F. In the property sheet, on the Format tab, from the Alternate Back Color
drop-down list, select “No Color”.

G. Click in the Detail section (but not on a field object).

H. From the Alternate Back Color drop-down list, select “No Color”.

I. Close the property sheet.

20. On the Report Design Tools: Design tab in the Grouping & Totals group, click
Group & Sort.

21. In the Group, Sort, and Total pane, click Add a group.

22. From the select field drop-down list, select “Credit”.
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23. Click Add a sort and select “TransDate” from the drop-down list.

24. Click Add a sort again and select “Description”.

25. In the Credit Header section, add a text box to show the group header label.

26. Delete the label from the text box you just added.
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27. Select the text box, open the property sheet, and select the Data tab.

28. On the Control Source field, click . The Expression Builder opens.

29. In the Expression Elements list box, expand the Functions list and select Built-In
Functions.

30. In the Expression Categories list box, select “Program Flow”.

31. In the Expression Values list box, double-click “IIf”. The expression you’ve built
displays in the expression window.

32. Replace the <<expression>> placeholder with “[Credit]=True”.
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33. Replace the <<truepart>> placeholder with “Credits” (enclosed in quotes).

34. Replace the <<falsepart>> placeholder with “Debits” (enclosed in quotes).

35. Click OK.

36. In the property sheet, remove the borders from the label by selecting “Transparent”
from the Border Style drop-down list.

37. Format the group header label as desired.

38. Close the property sheet.

39. Enlarge the Credit Header to make room to add a line below the label.

40. On the Report Design Tools: Design tab in the Controls group, click .

41. Click and drag to draw a line from near the left edge of the Credit Header to near
the right edge of the Credit Header.
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42. In the Group, Sort, and Total pane in the Group on row, click More.

43. From the with no totals drop-down list, select “Totals”.

44. From the Total On drop-down list, select “Amount”.

45. From the Type drop-down list, select “Sum”.

46. Mark the Show Grand Total check box.

47. Mark the Show subtotal in group footer check box.

48. In the Credit Header, select the label, right-click, and select Copy.
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49. In the Credit Footer, right-click and select Paste.

50. Open the property sheet for the Credit Footer text box and select the Data tab.

51. In the Control Source field, place your cursor immediately after the “=” sign and
type “Total ” followed by “+”.

52. Move and format the label as desired.

53. Remove the alternate formatting on the group footer.

54. In the Report Footer, add a label for the report totals.

55. In the label, type “Grand Total”.

56. Above the label, add a line from near the left edge to near the right edge.

57. On the Report Design Tools: Design tab in the Header/Footer group, click Page
Numbers.

58. In the Page Numbers dialog box, in the Format field, select “Page N”.

59. In the Position field, select “Bottom of Page [Footer]”.
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60. In the Alignment field, select “Right”.

61. Mark or clear the Show Number on First Page check box as you prefer.

62. Click OK.

63. Format the page number as desired.

64. Preview the report.
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65. Notice that the grand total is incorrect. That’s because we treated credits and
debits both as positive numbers and simply added them up. To fix this, first select
the total field in the report footer.

66. Open the property sheet and select the Data tab.

67. In the Control Source field, click .
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68. In the expression pane, we need to replace the expression with an expression
that will add the credits and add the negative of the debits. To do this, type
“=Sum(IIf([Credit]=True,[Amount],-[Amount]))”.

69. Click OK.

70. Preview the report.

71. Tweak the report as desired.

72. Save the report and name it “Uncleared Bank Transactions”.

Conclusion

In this lesson, you learned:

To create and format Access reports.

To work with the various sections of a report.

To group, sort, and add totals for records on a report.
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To work with the Expression Builder.

To work with property sheets.
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LESSON 6
Macros

Topics Covered

 Creating macros.

 Running macros.

Introduction

In this lesson, you will learn how to create some simple macros and several ways to run
a macro.

❋

6.1. Macro Basics

Macros allow you to automate actions for your database.You can perform simple actions
such as opening a form or printing a report. You can also string together actions to build
macros that perform complex automation operations. In this lesson, we’ll focus on some
simple macros.

Access makes it relatively easy to create macros. For the simplest macros, you simply
select an action and specify parameter values. In Design view, Access provides two ways
to select the actions for your macros.You can select from an alphabetized drop-down list.

Open /Macros/Demo/Demo - My Music Collection - Start.accdb
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You can also select from a searchable grouping of actions called the Action Catalog.

248 | LESSON 6: Macros

EVALUATION COPY: Not to be used in class.



After you select an action, you are prompted for any necessary parameter values.

 6.1.1. Open a Table, Form, and Report

To create a macro that opens a table:

1. On the Create tab in the Macros & Code group, click Macro. A blank macro tab
is added on the work surface along with the Action Catalog.
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2. From the Add New Action drop-down list, select “OpenTable”. The OpenTable
prompts load in the macro tab.

3. From the Table Name drop-down list, select the table you want to open.

4. From the View drop-down list, select the view you want the table to open in.

5. From the Data Mode drop-down list, select the mode you want the table to open
in.Your options are “Add”, “Edit”, and “Read Only”.
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6. Click Save. The Save As dialog box opens.

7. In the Macro Name field, type a name for the macro.

8. Click OK.

To create a macro that opens a form:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenForm”.

3. From the Form Name drop-down list, select the form you want to open.

4. From the View drop-down list, select the view to open the form in.
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5. From the Data Mode drop-down list, select the mode to open the form in. Your
options are “Add”, “Edit”, and “Read Only”.

6. From the Window Mode drop-down list, select the type of window you want the
form to open in.Your options are “Normal”, “Hidden”, “Icon”, and “Dialog”.

7. Save the macro.

To create a macro to open a report:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenReport”.

3. From the Report Name drop-down list, select the report you want to open.

4. From the View drop-down list, select the view to open the report in.

5. From the Window Mode drop-down list, select the type of window you want the
report to open in.Your options are “Normal”, “Hidden”, “Icon”, and “Dialog”.
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6. Save the macro.

 6.1.2. Run a Query

To create a macro that runs a query:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenQuery”.

3. From the Query Name drop-down list, select the query you want to run.

4. In the View drop-down list, ensure that “Datasheet” is selected.

5. From the Data Mode drop-down list, select “Edit”.
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6. Save and name the macro.

7. On the Macro Tools: Design tab in the Tools group, click Run.

 6.1.3. Print a Report

To create a macro that prints a report:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenReport”.

254 | LESSON 6: Macros

EVALUATION COPY: Not to be used in class.



3. From the Report Name drop-down list, select the report to print.

4. From the View drop-down list, select “Print Preview”.

5. From the Add New Action drop-down list, select “PrintObject”.

6. Save and name the macro.

7. On the Macro Tools: Design tab in the Tools group, click Run. Notice that the
requested report opens in the background and the Print prompt opens so that you
can print the report.
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❋

6.2. Running a Macro

As we’ve shown, we can run a macro from Design view by clicking Run on the Macro
Tools: Design tab. Once we’ve saved a macro, we can run it from the Navigation Pane,
from the Database Tools tab, or we can bind the macro to a control and use the control
to launch the macro.

To run a macro from the Navigation Pane:

1. Locate the macro in the Navigation Pane.
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2. Double-click the macro name or right-click and select Run from the shortcut menu.
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To run the macro from the Database Tools tab:

1. On the Database Tools tab in the Macro group, click Run Macro.The Run Macro
dialog box opens.

2. From the Macro Name drop-down list, select the macro to run.

3. Click OK.

To demonstrate how to bind a macro to a control, we’ll create a simple form and add a
button that opens another form.
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To bind a macro to a control and run it:

1. On the Create tab in the Forms group, click Form Design.

2. On the Form Design Tools: Design tab in the Controls group, click , then
click and drag on the form design surface to draw a button. When you release the
mouse button, the Command Button Wizard starts.

3. In the Categories list box, select the type of action you want the button to perform.

4. In the Actions list box, select the action you want the button to perform.

5. Click Next >. In this example, you are prompted for the form to open.
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6. Select a form and click Next >.You are prompted for which information to display.

7. Make a selection and click Next >.You are prompted whether to have a text label
or picture on the button.
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8. Provide a text label or select a picture for the button and then click Next >. You
are prompted to name the button.

9. Type a name for the button “cmdOpenMusic” and click Finish.The button is added
to the form design surface.
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10. Right-click the button and select Properties from the shortcut menu.

11. In the property sheet, select the Event tab. Notice that the On Click field indicates
“[Embedded Macro]”.

12. In the On Click field, click . The macro opens on the macro design surface.
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13. Click inside the macro. Set additional options for the macro as desired.

14. Save and close the macro.

15. Save and name the form.

16. Switch to Form view.
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17. Click the macro button to execute its function.
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 Exercise 8: Creating Simple Macros
 20 to 45 minutes

In this exercise, you will create the following macros in the .../ClassFiles/Macros/Exer
cises/Bank Register.accdb database:

1. A macro that opens the Enter Transactions form in add mode so that you can
enter new transactions in the database. Name the macro “Add Transactions”.

2. A macro that opens the Enter Transactions form in edit mode so that you can
review transactions. Name the macro “Review Transactions”.

3. A macro that opens the Uncleared Checking Transactions query in Datasheet
view so that you can mark cleared transactions. Name the macro “Mark Cleared
Transactions”.

4. A macro that closes the database. Name the macro “Close Database”.

LESSON 6: Macros | 265



Solution

To create a macro that opens the Enter Transactions form in add mode:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenForm”.

3. From the Form Name drop-down list, select “Enter Transactions”.

4. In the View drop-down list, accept “Form”.

5. From the Data Mode drop-down list, select “Add”.

6. From the Window Mode drop-down list, select “Dialog” or “Normal”.

7. Click Save.

8. In the Save As dialog box in the Macro Name field, type “Add Transactions”.

9. Click OK.

To create a macro that opens the Enter Transactions form in edit mode:

1. From the Add New Action drop-down list, select “OpenForm”.

2. From the Form Name drop-down list, select “Enter Transactions”.

3. In the View drop-down list, accept “Form”.

4. From the Data Mode drop-down list, select “Edit”.
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5. From the Window Mode drop-down list, select “Dialog” or “Normal”.

6. Click Save.

7. In the Save As dialog box in the Macro Name field, type “Edit Transactions”.

8. Click OK.

To create a macro that opens the Uncleared Checking Transactions query in Datasheet
view:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “OpenQuery”.

3. From the Query Name drop-down list, select “Uncleared Checking Transactions”.

4. In the View drop-down list, accept “Datasheet”.

5. In the Data Mode drop-down list, accept “Edit”.
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6. Click Save.

7. In the Save As dialog box in the Macro Name field, type “Mark Cleared
Transactions”.

8. Click OK.

To create a macro that closes the database:

1. On the Create tab in the Macros & Code group, click Macro.

2. From the Add New Action drop-down list, select “CloseDatabase”.

3. Click Save.

4. In the Save As dialog box in the Macro Name field, type “Close Database”.

5. Click OK.

Conclusion

In this lesson, you learned:

To create several simple macros.

To run macros.
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LESSON 7
Completing the Desktop Application

Topics Covered

 Creating and implementing a navigation form.

 User access to your database application.

Introduction

In this course and in the introductory course, we learned to create the main components
of a database. In this lesson, we’ll learn how to tie the components together in a cohesive
package and distribute it to your end users.

❋

7.1. The Navigation Form

We want to make our users’ experience with our application as streamlined as possible.
For this reason, we’ll create a navigation form that presents the main functions of our
database in a straightforward and logical way.

To create a navigation form:

1. Open the database.

2. On the Create tab in the Forms group, click Navigation.

LESSON 7: Completing the Desktop Application | 269



3. Select the layout you prefer from the drop-down list. For this example, we’ll select
“Vertical Tabs, Left”. The form is added to the work surface in Layout view.

4. Staying in Layout mode, drag and drop a form or report from the Navigation Pane
onto the [Add New] button. A navigation button is added and the report or form
loads in the view area of the form.

5. Repeat the last step for each form or report you want to access from the navigation
form.
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6. Change the caption at the top of the form by double-clicking in the text area,
selecting the current text, and overwriting it.

7. Change the caption on the form tab by right-clicking in the heading area and
selecting Form Properties from the shortcut menu. On the Property Sheet in the
Caption field, type a new caption.
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8. Preview the form in Form view. Notice how clicking the buttons changes the
contents of the view area.

❋

7.2. Running Macros from a Navigation Form

You’re not limited to running forms and reports from the navigation form. You can use
navigation buttons to run macros as well, thus opening the range of functionality to any
process you can write a macro or module for.
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To run a macro from a navigation button:

1. Open the navigation form in Layout view.

2. In the button area, right-click and select Insert Navigation Button from the shortcut
menu. A new navigation button is added.

3. With the new navigation button selected, go to the Property Sheet and on the
Format tab in the Caption field, type a label for the button.
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4. Select the Event tab.

5. In the On Click field, select the macro you want to run from the drop-down list or
click  to build a macro.

6. Preview the navigation form in Form view and click the new button to test the
macro.

❋
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7.3. Setting the Navigation Form as the Default Form

You can set the navigation form as the default form that displays when a user opens your
application. In addition, we can give our application an official name and an icon to display
for forms and reports.

To do so:

1. Open the database.

2. Select the File tab.

3. Click Options. The Access Options dialog box opens.

4. Select the Current Database tab.

5. In the Application Title field, type the name of your application.

6. In the Application Icon field, click Browse and navigate to and select the icon
file to use.
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7. If you want to use the icon as both the form and report icon, mark the Use as
Form and Report Icon check box.

8. From the Display Form drop-down list, select the navigation form to use as the
default display form.

9. Click OK. You are notified that you must close and reopen the database for the
change to take effect.

10. Click OK.
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 Exercise 9: Creating a Navigation Form
 15 to 35 minutes

In this exercise, you will create a navigation form for the Bank Register database using
the database in the ClassFiles\CompletingDesktopApp\Exercises folder. Include buttons
to launch the Add Transactions macro, the Edit Transactions macro, the Mark Cleared
Transactions macro, the Uncleared Bank Transactions report, and the Close Database
macro. Make the navigation form the default form for your application and assign the icon
“Piggy Bank.ico” to the application.

LESSON 7: Completing the Desktop Application | 277



Solution

To create the navigation form:

1. Open the database.

2. On the Create tab in the Forms group, click Navigation and select a layout for
the navigation form from the drop-down list.

3. Right-click in the button area and select Insert Navigation Button from the shortcut
menu.

4. Open the Property Sheet for the new button.

5. On the Format tab in the Caption field, type “Add Transactions”.

278 | LESSON 7: Completing the Desktop Application

EVALUATION COPY: Not to be used in class.



6. On the Event tab in the On Click field, select “Add Transactions” from the
drop-down list.

7. Repeat steps 3-6 for the Edit Transactions macro, typing “Edit Transactions” in
the Caption field and selecting “Edit Transactions” from the On Click drop-down
list.

8. Repeat steps 3-6 for the Mark Cleared Transactions macro, typing “Mark Cleared”
in the Caption field and selecting “Mark Cleared Transactions” from the On Click
drop-down list.

9. Drag and drop the Uncleared Bank Transactions report from the Navigation Pane
to the [Add New] button.

10. Repeat steps 3-6 for the Close Database macro, typing “Close” in the Caption
field and selecting “Close Database” from the On Click drop-down list.

11. Double-click in the heading and replace “Navigation Form” with “Bank Transaction
Maintenance”.

12. Preview the navigation form in Form view.
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13. Close the navigation form.You are prompted for a name.

14. Type a name for the form (we’ll use “Bank Transactions”) and click OK.

To set the form as the default and assign an icon to it:

1. With the database open, select the File tab.

2. Click Options.

3. Select the Current Database tab.

4. In the Application Title field, type “Bank Register”.

5. In the Application Icon field, click Browse and navigate to and select the “Piggy
Bank.ico” file.

6. Mark the Use as Form and Report Icon check box.

7. From the Display Form drop-down list, select the navigation form name.
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8. Click OK. Access advises you that you’ll need to close and reopen the application
to see the changes.

9. Click OK.

❋

7.4. Splitting the Database

If you will share your database over a network, you will want to consider splitting the
database. Splitting the database means separating the database objects such as forms,
reports, and queries from the data tables. The database objects comprise the front-end
database and the data tables comprise the back-end database.You distribute the front-end
to your users so that they can interact with the database.The back-end database is stored
at a location on your network. End users access the data through linked tables.

LESSON 7: Completing the Desktop Application | 281



Splitting the database improves performance and lessens the chance of data corruption.
It also allows individual users to add their own queries, forms, and reports without affecting
other users.

Users sharing a split database must all have versions of Access that are compatible with
the back-end database. So, for example, if the back-end database is .accdb format, users
with Access 2003 or earlier will not be able to use the database.

Before You Split

Before you split a database, always create a backup copy so that if you later have
regrets you can restore the database from the copy.

To split a database:

1. Make a copy of the database on your local hard drive.

2. Open the database from your local drive.

3. Close any open database objects.

4. On the Database Tools tab in the Move Data group, click Access Database.
The Database Splitter wizard starts.

5. Click Split Database. You are prompted for a saving location and name for the
back-end database.
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6. In the Create Back-end Database dialog box, navigate to and select the location
where you want to save the back-end database. This needs to be a location that
every user has access to, typically on a network.

7. Click Split. When the process finishes, Access notifies you that the database has
been split.

8. Click OK.

The database that remains open is the front-end database. Notice in the Navigation Pane
that the table icons have changed to indicate that the tables are linked tables.
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 7.4.1. Encrypt with a Password

Many times you may want to password protect your database in order to protect it form
unwanted changes.

You may get an error if you do not have the database open in exclusive mode.
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File > Open > Open Exclusive

Enter the password, you will be prompted to reenter the password. The next time you
open the database, the password will be required.

❋
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7.5. Distributing the Front-End Database

Before Distributing

Before distributing the front-end database, you may want to hide the Navigation
Pane.To do so, open the Access Options dialog box, select the Current Database
tab, clear the Display Navigation Pane check box, and click OK.

To distribute the front-end database, do one of the following:

Attach the front-end database to an email and send it to your users.

Save the front-end database to a network location and notify your users where to
find it.

Save the front-end database to removable media (CD-ROM or USB thumb drive)
and distribute to your users.

❋

7.6. Database Maintenance

As a database is used, it may benefit from general maintenance.

 7.6.1. Compact and Repair

When you share your files with others, or alter it’s structure, it may become corrupt. Often
a Compact and Repair can fix the issues by recompiling the database and removing unused
space. If objects and data are unable to be fixed, a log of sorts will be kept in a table for
your review.
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 7.6.2. Backup a database

Backing up your data is very important as files can become so corrupt that they cannot
be repaired. Having a recent back up is helpful for restoration. If you need your backup
file, simply open it and work with any data you need. Try to set a schedule and backup
often. By default, the date will be added at the end of your backup file name.

 7.6.3. Recover a database

When and if a database has an issue, you should have a recent backup for restoration. If
you need your entire database, simply open the backup file and work with any data you
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need.You may also just need a few objects such as a table. If that is the case, use External
Data > Import & Link > Access in the original database to import in any missing objects.

 7.6.4. Maintain Backward Compatibility

In order to maintain backward compatibility with other users, you may save your database
as 2000 or 2002-2003.

Be warned that features special to .accdb will not be available in the .mdb file type. As
well a few features form the .mdb file type are not available in the newer .accdb file type.

Conclusion

In this lesson, you learned:

To create navigation forms.

To split an Access database into front-end and back-end databases.

How to distribute an Access database front end to your users.
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